GameOfMir历史更新记录

GameOfMir官方网站(www.gameofmir.com)

【2019-12-25更新:】
需要同时更新 GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe DBServer.exe

增加Give脚本命令可以使用SetThrowItemLy脚本命令设置该物品来源
修改脚本命令PickUpItems
修改UI编辑器可以调整首饰盒单个物品的位置
修复引擎关闭报错的问题
修复已知BUG

[@test]
#IF
#ACT
SetThrowItemLy 5 <$MAP> <$KILLMONNAME> <$USERNAME> DATE TIME
Give 木剑 1

自动一键捡取物品 PICKUPITEMS X Y 范围(不能超过20) 是否按照(M2-查看-列表信息二-内挂捡取)设置的捡取(1按照设置的捡取 0捡取所有物品)

可以在杀怪触发里使用，或者做个自定义技能，使用该自定义技能来触发这个命令

[@KillMon]
#ACT
PICKUPITEMS <$KILLMONX> <$KILLMONY> 3 1

【2019-12-20更新:】
需要同时更新 GameLogin.exe M2Server.exe

增加弹出验证码窗口时触发
增加脚本自动一键捡取物品脚本命令PickUpItems
增加衣服武器简装外观自定义设置(M2-选项-客户端设置-内挂控制（二）)
修复已知BUG

QFunction-0

;弹出验证码窗口时触发

[@ShowGameValidateDlg]
#IF
#ACT
SENDMSG 6 开始验证
BREAK

------------------------------------------------------------

自动一键捡取物品 PICKUPITEMS X Y 范围(不能超过20)

可以在杀怪触发里使用，或者做个自定义技能，使用该自定义技能来触发这个命令

[@KillMon]
#ACT
PICKUPITEMS <$KILLMONX> <$KILLMONY> 3

【2019-12-12更新:】
需要同时更新 GameLogin.exe M2Server.exe

修复窗口放大鼠标点不了的问题
修复SetSuckDamage几率无效的问题
修复脚本命令SENDMOVEHINTMSG微调坐标为负数时显示位置不正确
增加脚本命令SENDVERTICALMOVEMSG

功能说明：在屏幕上显示向上滚动信息

格式：SENDVERTICALMOVEMSG 文字信息 文字颜色 背景颜色 坐标Y 滚动次数 发送模式(0=全服 1=个人)

文字换行：\

[@main]
#ACT
SENDVERTICALMOVEMSGG 提示信息1\提示信息2 249 0 100 3 0

【2019-12-05更新:】
需要同时更新 GameLogin.exe M2Server.exe

增加脚本命令SENDMOVEHINTMSG GetDBItemFieldValue GetItemsNumber(具体使用说明看说明书)
增加脚本常量<$KILLMONNAME_MAXHP> 当前杀死的怪物的最大血量
扩展NPC脚本点击触发带参数

扩展NPC脚本点击触发带参数

-----------------------------------扩展NPC脚本点击触发带参数------------------------------

///////////////////////////////////////////////////////////新增触发带参数

<@测试1/@测试(1,2,3)> <@测试2/@测试(2,3,4)>

[@测试]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 1,2,3
CHECKSCRIPTPARAM 2,3,4
#ACT
SENDMSG 6 <$SCRIPTPARAM1>,<$SCRIPTPARAM2>,<$SCRIPTPARAM3>
break
#ELSEACT
SENDMSG 6 非法的参数
break

[@main]
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\
[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------有人用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break

#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!

【2019-12-02更新:】
需要同时更新 GameLogin.exe

修复登录器开启微端后偶尔登录器关不掉进程中有残留的问题
优化微端更新速度

【2019-11-26更新:】
需要同时更新 M2Server.exe

修复上一版引擎关闭报错的问题

【2019-11-25更新:】
需要同时更新 GameLogin.exe WIL编辑器

修复登录提示不配套的问题
修复64位wil编辑器处理wil格式的数据会多一块的问题

【2019-11-24更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe RunGate

增加攻击不卡，也就是无限刀功能(M2-选项-参数设置-游戏速度-攻击的速度调整为0 就是攻击不卡)
游戏网关(RunGate.exe)-选项-安全过滤-攻击保护-数量限制也要适当增加
增加自定义OK框支持到18个
增加脚本命令ScatterBagItems
修复已知问题

[@main]
#ACT
;可以指定怪物直接爆物品，如果没有攻击目标，就以自己的坐标爆物品，如果有攻击的目标，就会以攻击的目标的坐标爆物品
;ScatterBagItems 怪物名称 爆率倍数(实际倍率=当前设置的值除以100)
ScatterBagItems 红野猪 100

【2019-11-13更新:】
需要同时更新 GameLogin.exe M2Server.exe

增加杀怪或杀人爆物品QF触发(需要在M2-查看-列表信息二-物品规则里添加允许爆物品触发的)
增加[@TakeOffX]也可以使用LINKPICKUPITEM进行关联，关联后可以使用命令对该物品检测或操作
增加常量当前攻击伤害<$PKPOWER> <$H.PKPOWER>
增加宝宝杀怪同步主人的选项(M2-选项-功能设置-其他控制(1))
修改登录假人脚本命令支持乱序登录，格式:DUMMYLOGON 地图 X Y 数量 是否乱序登录(0=顺序登录 1=乱序登录)
修复禁止私聊命令无效的问题
修复SHOWGAMEVALIDATEDLG脚本命令

;QF触发 杀怪或杀人爆物品触发，不是死亡的角色触发，是杀人的角色触发，每爆一个物品，触发一次，如果爆十个物品就会触发十次
[@ScatterBagItems]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你杀人了:【<$CURRRTARGETNAME>】，这个人包裹里爆出物品
#ELSEACT
SENDMSG 6 你杀怪了:【<$CURRRTARGETNAME>】，这个怪物爆出物品

#IF
#ACT
LINKPICKUPITEM
;支持用命令链接命令，用脚本命令对当前爆出的物品操作或检测

【2019-11-07更新:】
需要同时更新 GameLogin.exe

修复上一次更新导致自动行走功能失效的问题

【2019-10-31更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe 必备补丁(NewopUI.Pak)

修复M2一个报错信息
修复SortVarToList SortHumVarToList SortHumVarToListEx这三个脚本命令不支持绝对路径
增加[@DropItemX]也可以使用LINKPICKUPITEM进行关联，关联后可以使用命令对该物品检测或操作
增加麻痹后勾选允许使用魔法的控制(M2-选项-参数设置-状态控制)
增加脚本命令REFRESHBAG SetThrowItemLy MonItems 详细看说明书
增加摆摊价格的控制(M2-查看-查看列表信息二-摆摊价格控制)
增加交易挑战选项控制(M2-选项-功能设置-其他设置(2))
增加装备对比(M2-选项-功能设置-其他设置(2))
增加UI编辑器可以对任意UI恢复默认设置

【2019-10-18 20:30更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe

修复韩国地图可能读取失败的问题
修复登录器配置器删除配置可能会导致无法保存的问题
没有到期的每个月可以免费更改一次绑定，当月没有更改的次数不会累计到下个月
自己在引擎操作上可以自己更改绑定，点击“帮助-注册-更换绑定”

【2019-10-18 更新:】
需要同时更新 GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe

修复GameOfMir引擎控制器的问题
修复pak补丁命令不能修改的问题

【2019-10-17 更新:】
需要同时更新 GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe

修复playdice报错的问题
修复必备补丁密码修改后登录器无法读取的问题
增加脚本命令ChangeAccountInfo（修改账号密码密保信息）
增加脚本命令高等级杀怪经验不变HighLevelKillMonFixExp
增加启动控制器可以清理文件

格式:HighLevelKillMonFixExp 时间(秒) 是否保存（1保存，空或0不保存）

[@main]
#ACT
HighLevelKillMonFixExp 720 1

脚本命令修改账号密码信息

[@修改账号密码信息]
#ACT
;ChangeAccountInfo 账号 密码 用户名 生日 提问1 回答2 提问2 回答2 邮箱(可以空) 手机(可以空)
ChangeAccountInfo qqqq 1234 1234 2019/01/01 1 2 3 4 1234@qq.com 1234567890

QF脚本相关触发

[@ChangeAccountInfoOK]
账号信息修改成功！

[@ChangeAccountInfo_Error_Account]
账号长度不正确或存在非法字符！

[@ChangeAccountInfoing]
正在修改中，请稍后！

[@ChangeAccountInfo_Error_Password]
密码长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_UserName]
用户名长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_BirthDay]
生日格式错误！

[@ChangeAccountInfo_Error_Quiz1]
提问1长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Answer1]
回答1长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Quiz2]
提问2长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Answer2]
回答2长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_EMail]
邮件地址长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_MobilePhone]
手机号长度不正确或存在非法字符！

[@ChangeAccountInfoError]
账号信息修改失败！

[@ChangeAccountInfoPasswordSame]
账号不能和密码相同！

[@ChangeAccountInfoUnSimplePassword]
不能使用简单的密码！

[@ChangeAccountInfoWriteError]
账号修改失败！

[@ChangeAccountInfoNotExists]
账号不存在！

【2019-10-08 更新:】
需要同时更新 GameLogin.exe M2Server.exe RunGate.exe

修复摆摊可能导致物品丢失的问题
修复元素合击威力、怒气增加无效的问题
修复续费后有几率掉线
修改首饰盒内观素材读取StateItem
物品来源显示上面增加一个空行

【2019-09-29 更新:】
需要同时更新 GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe

修复必备补丁密码修改后登录器配置器无法读取的问题
修复十步一杀可以穿越障碍物的问题
修复首饰盒内观特效错误的问题（原来的内观特效是显示的包裹里的特效）
修复列表信息二窗口重复打开，物品会重复的问题
自定义按钮增加支持到100

【2019-09-18 更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe

修复登录器UI一些问题
修复登录器配置器UI编辑一个问题
修复时装发型隐藏选项无效的问题

增加包裹上面显示元宝、泡点、金刚石、灵符(UI默认是隐藏不显示的，需要配置登录器的时候，修改UI才能显示)
使用方法：
首先启动登陆器配置器

点击界面UI编辑-界面编辑-OK

然后找到包裹的窗口，鼠标点一下包裹窗口，右边的窗口会有名称，DItemBag_，在这个下面找到
LabelBagGameGold LabelBagGamePoint LabelBagGameDiamond LabelBagGameGird
在左边的窗口基本属性里-是否可见设置成True，保存修改，保存到配置文件，重新配置登录器即可显示
(M2-选项-客户端设置-内挂控制二-包裹上显示元宝信息，该选项将无效)

【2019-09-11 更新:】
需要同时更新 M2Server.exe

修复引擎一个问题

【2019-09-10 更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe RunGate.exe WIL编辑器.exe 必备补丁(NewopUI.Pak)

修复ChangeHumNewValue脚本命令对体力魔法无效的问题
修复64位引擎获取分辨率失效的问题
修复WIL编辑器一个问题
修复登录器已知问题
增加技能提示信息是否在聊天框显示的选项(M2-功能设置-技能魔法-技能参数)
增加所有界面支持播放动画特效，可以编辑登录界面、开门动作、角色选面等所有界面的动画特效，可以在UI编辑器里编辑
如果登录器是修改过UI的更新后有些UI还需要重新编辑一下
如果没有修改UI直接使用原始的配置登录器的，
在登录器配置器，编辑游戏界面UI-恢复默认-保存配置到文件-然后配置登录器

【2019-09-05 更新:】
需要同时更新 GameOfMir引擎控制器.exe GameLogin.exe M2Server.exe RunGate.exe

扩展变量
完善NPC标签<TEXT:文字内容:X:Y/@触发>(详细看说明书)
增加INI文件读写脚本命令(详细看说明书)
增加延时小退(M2-选项-功能设置-其他设置2)
修复重新加载NPC后，NPC脚本创建的NPC消失的问题
修复其他一些问题

P0-P999 (私人变量，数字型) 关闭对话框重置为0。
D0-D999 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M999 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N999 (私人变量，数字型) 下线不保存.小退归0.
S0-S999 (私人变量，字符型) 下线不保存.小退归0.
I0-I999 (全局变量，数字型) 不可保存，服务器重启自动重置为0。
G0-G999 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A999 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）

【2019-09-02 更新:】
需要同时更新 GameOfMir引擎控制器.exe GameLogin.exe LoginSrv.exe M2Server.exe

修复控制器定时启动的问题
修复右键小地图传送会掉线的问题
修复禁止创建账号失效的问题
增加NPC标签<TEXT:文字内容:X:Y/@触发>
增加NPC命令：loopgoto endloop中止

=====================================================设置NPC文字坐标===================================

<Text:文字内容:X:Y/@触发>
<Text:测试下这段文字的显示|提示信息:10:20/@测试>
<Text:<$STR(S87)>|提示信息:10:20{FCOLOR=250}/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{FCOLOR=254}/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{AUTOCOLOR=250,251,252,253,254}/@测试>

说明：循环脚本运行次数设置

格式：Loopgoto @脚本 脚本运行次数（为空或0时，运行1次）

示范脚本：
[@循环]
#ACT
mov N1 0
mov N2 1
Loopgoto @运算 100
sendmsg 6 1加到100的结果为：<$STR(N1)>

[@运算]
#ACT
Inc <$STR(N1)> <$STR(N2)>
Inc N2 1

增加NPC命令：endloop中止Loopgoto

[@随机取数]
#act
mov p1 0
Loopgoto @取数 100
sendmsg 6 循环<$str(p1)>次，才取到>=50的数：<$str(p10)>

[@取数]
#act
inc p1 1
;此例仅做说明，实际只用取一次，取50以内的取机数+49即可
movr p10 100

#if
large p10 49
#act
endloop

【2019-09-01 更新:】
需要同时更新 GameOfMir引擎控制器.exe GameLogin.exe DBServer.exe LoginSrv.exe M2Server.exe

修复游戏界面淡入淡出一个问题
修复SetMapRoute命令无效的问题
修复INPUTTEXT一个问题
修复DBServer和LoginSrv一个问题
优化登录器内存占用
引擎控制器增加定时关区功能

【2019-08-26 更新:】
需要同时更新 GameOfMir登录器生成器.exe 列表服务器.exe GameLogin.exe M2Server.exe

优化游戏界面淡入淡出
修复叠加物品被刷的问题
修复补丁更新的问题
修复UI编辑器方向键调整坐标失效的问题

【2019-08-20 更新:】
需要同时更新 GameLogin.exe

修复游戏界面淡入淡出一个问题

【2019-08-18 更新:】
需要同时更新 GameLogin.exe M2Server.exe WIL编辑器.exe

修复WIL编辑器一个问题
增加NPC对话框内创建输入框功能
增加游戏界面淡入淡出功能

【2019-08-13 更新:】
需要同时更新 GameOfMir登录器生成器.exe M2Server.exe WIL编辑器.exe

修复WIL编辑器一个问题
修复个别登录器启动显示的图片报错的问题
修复AddButtonEx坐标错误的问题
WIL编辑器增加密码一键修改
自定义装备属性文本长度扩展60个字符或30个汉字

【2019-08-01 更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe WIL编辑器.exe 必备补丁(NewopUI.Pak)

增加仿HeroM2摆摊支持所有货币
WIL编辑器增加密码管理功能
增加地图参数：SECRET(31|固定名字|2|21) //浑水摸鱼模式

[+] 增加地图参数：SECRET(31|固定名字|2|21) //浑水摸鱼模式

01 禁止说话
02 禁止名字变色
04 禁止看对方装备
08 统一名字 //第2参数就是指定显示的名字
16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观
32 是否百分比显血 //是否人物、英雄HP以百分比显示
如果要多个功能起作用，相加对应的数字即可，
例如：禁止名字变色(02) + 禁止看对方装备(04) + 统一装备外观(16)，等于：22，既是第1参数=22

SECRET(31|固定名字|2|21)

特别解说: 第一参数 31 为控制总参数

总参数分为

01 禁止说话
02 禁止名字变色
04 禁止看对方装备
08 统一名字 //第2参数就是指定显示的名字
16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观
32 是否百分比显血 //是否人物、影响HP以百分比显示

假如第一参数为01时 SECRET(1|固定名字|2|21) 那么后面的 |固定名字|2|21 的几个参数也必须写上但是不生效

举列: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止查看对方装备

那么第一参数就是 01+08+04=13 第2参数写 神秘人 第3参数和第4参数由于未用到可以随便写不起效

[盟重省 3] SECRET(13|神秘人|2|21)

举列2: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止名字变色 禁止查看对方装备 统一装备外观为倚天衣=物品库的倚天衣SHAPE=35 统一武器外观为倚天武器=物品库的SHAPE=68

那么第一参数就是 1+2+4+8+16=31 第2参数写 神秘人 第3参数写35 第4参数写68

[盟重省 3] SECRET(31|神秘人|35|68)

举列2: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止名字变色 禁止查看对方装备 统一装备外观为倚天衣=物品库的倚天衣SHAPE=35 统一武器外观为倚天武器=物品库的SHAPE=68 .比例显血

那么第一参数就是 1+2+4+8+16+32=63 第2参数写 神秘人 第3参数写35 第4参数写68

[盟重省 3] SECRET(63|神秘人|35|68)

【2019-07-21 更新:】
需要同时更新 GameLogin.exe DBServer.exe M2Server.exe

修复一个可能导致掉线问题
修复引擎提示日期错误的问题

如何把20151108的UI替换到新登录器配置器里

旧的登录器配置器UI目录“UI_0”“UI_1”“UI_2”“UI_3”，有几个修改几个

UI_0\UI.db文件名称改成“Mir.db”
UI_0\ConfigUI.db文件名称改成“MirConfigDlg.db”
UI_0\StateUI.db文件名称改成“StateWin.db”

UI_1\UI.db文件名称改成“Mirs.db”
UI_1\ConfigUI.db改成“MirsConfigDlg.db”
UI_1\StateUI.db改成“StateWin.db”

UI_2\UI.db文件名称改成“MirReturn.db”
UI_2\ConfigUI.db文件名称改成“MirReturnConfigDlg.db”
UI_2\StateUI.db文件名称改成“StateWin.db”

UI_3\UI.db文件名称改成“Mir2013.db”
UI_3\ConfigUI.db文件名称改成“MirConfigDlg2013.db”
UI_3\StateUI.db文件名称改成“StateWin.db”

新的登录器配置器是要账号的，假设你的账号是“gameofmir”，登录器参数名称是“我的登录器”UI的位置就在

当前登录器配置目录下的“登录器参数\gameofmir\我的登录器\游戏界面UI”

把上面修改的UI文件替换进去，重启登录器配置器

【2019-07-15 更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe DBServer.exe M2Server.exe GameOfMir引擎控制器.exe

修复个人商店一个问题
增加首饰盒相关变量
增加脚本命令SETUSERSHOPBUSINESS设置个人商店营业状态

;SETUSERSHOPBUSINESS 角色名称 禁止或开启(0,1)
[@main]
#if
CHECKMYSHOP
#act
SETUSERSHOPBUSINESS <$USERNAME> 0
SENDMSG 6 你的个人商店已经禁止营业
SENDMSG 6 禁止营业后在个人商店里无法搜索到你的商店
SENDMSG 6 无法搜索到你出售的物品，无法在个人商店里摆摊
#elseact
SENDMSG 6 你还没有个人商店

;——————————————————首饰盒人物变量
<$GODBLESSITEM1> ---- <$GODBLESSITEM12>

<$G_GODBLESSITEM1> ---- <$G_GODBLESSITEM12>

;——————————————————首饰盒英雄变量
<$H.GODBLESSITEM1> ---- <$H.GODBLESSITEM12>

<$H.G_GODBLESSITEM1> ---- <$H.G_GODBLESSITEM12

【2019-07-01 更新:】
需要同时更新 全套程序

修复物品来源会显示NPC路径的问题
修复使用烟花提示非法使用命令的问题
增加窗口嵌入功能(需要更新全套程序)
增加小退前触发QF脚本[@SoftClose]
增加脚本命令禁止小退“DIABLESOFTCLOSE”该命令只能在[@SoftClose]下使用，其他地方无效
增加脚本字符串分割脚本命令EXTRACTSTRING

;QF脚本触发
[@SoftClose]
#act
DIABLESOFTCLOSE
SENDMSG 6 当前无法小退

[@main]
#act
;EXTRACTSTRING 分割符 需要分割的字符串 保存变量1 保存变量2 保存变量3 保存变量4 保存变量5 保存变量6 保存变量7 保存变量8
MOV s1
MOV s2
MOV s3
MOV s4
MOV s5
MOV s6
MOV s7
MOV s8
GetRandomText ..\QuestDiary\装备列表.txt S0 0
EXTRACTSTRING : <$STR(S0)> s1 s2 s3 s4 s5 s6 s7 s8
GIVE <$STR(S1)> 1
GIVE <$STR(S2)> 1
GIVE <$STR(S3)> 1
GIVE <$STR(S4)> 1
GIVE <$STR(S5)> 1
GIVE <$STR(S6)> 1
GIVE <$STR(S7)> 1
GIVE <$STR(S8)> 1
TakeOn <$STR(S1)> 0
TakeOn <$STR(S2)> 1
TakeOn <$STR(S3)> 3
TakeOn <$STR(S4)> 4
TakeOn <$STR(S5)> 5
TakeOn <$STR(S6)> 6
TakeOn <$STR(S7)> 7
TakeOn <$STR(S8)> 8
BREAK
;======================================================
;装备列表.txt 内容

;战神盔甲(男):裁决之杖:绿色项链:黑铁头盔:骑士手镯:骑士手镯:力量戒指:力量戒指
;战神盔甲(女):裁决之杖:绿色项链:黑铁头盔:骑士手镯:骑士手镯:力量戒指:力量戒指
;魔法长袍(男):血饮:恶魔铃铛:道士头盔:龙之手镯:龙之手镯:紫碧螺:紫碧螺
;魔法长袍(女):血饮:恶魔铃铛:道士头盔:龙之手镯:龙之手镯:紫碧螺:紫碧螺
;灵魂战衣(男):无极棍:灵魂项链:道士头盔:三眼手镯:三眼手镯:泰坦戒指:泰坦戒指
;灵魂战衣(女):无极棍:灵魂项链:道士头盔:三眼手镯:三眼手镯:泰坦戒指:泰坦戒指

如果提示以下脚本错误

CALL的脚本要这样写

正确的:
[@法魔皇元神]
{

}

[@道魔皇元神]
{

}

错误的:
{
[@法魔皇元神]

[@道魔皇元神]

}

【2019-06-18 更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe

修复微端密码无法修改的问题
修复元素名称改不过来的问题
修复OpenItemBoxEx的问题

【2019-06-10 更新:】
需要同时更新 GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe

修复ChangeModeEx模式11之后无效的问题
修复物品来源地图显示错误
增加假人乱序登录的选项
增加英雄包裹支持装备比较

如果登录器配置器的参数无法保存或其他问题，请把登录器配置器目录里的“LoginConfig.db”删除，重新启动配置器，重新配置参数

【2019-06-06 更新:】
需要同时更新 LoginGate.exe LoginSrv.exe GameOfMir登录器生成器.exe GameLogin.exe M2Server.exe、日记查询.exe

修复登录网关提示非法获取验证码的问题
修复个人商店页数显示错误的问题
修复其他一些问题

【2019-06-01 更新:】
需要同时更新 GameLogin.exe M2Server.exe LogDataServer.exe

修复个人商店一些问题
修复引擎一个报错信息
修复其他一些细节
内挂勾选“隐藏其他效果”的时候也会隐藏地面物品特效

【2019-05-26 更新:】
需要同时更新 GameLogin.exe M2Server.exe

修复摆摊的问题

【2019-05-25 更新:】
需要同时更新 登录器生成器.exe GameLogin.exe M2Server.exe

增加元素名称自定义
增加CALL爆率支持

====================================以下是采用#call设置怪物爆率==========================================

》》》》》》》》》》》》》白野猪.txt

#CALL [\\爆率系统\基础爆率.txt] @药水

----------------------------------以上是怪物爆率文件中白野猪设置-----------------------------------------

》》》》》》》》》》》》》

D:\MirServer\Mir200\Envir\QuestDiary\爆率系统\基础爆率.txt

[@药水]
{
#CHILD 1/1 RANDOM
(
1/1 超强金创药
1/1 超强魔法药
1/1 太阳水
)
}

--------------------------以上是CALL路径的基础爆率设置-----------------------------------------------------

【2019-05-20 更新:】
需要同时更新 GameLogin.exe、M2Server.exe、LogDataServer.exe

修复日记乱码的问题
增加血量魔法百分比脚本命令

--------------------------------------------------------------------
检测自身血量百分比
格式：CheckHpPer 操作符(>/=/<) 百分比
例子：
#IF
CheckHpPer > 30
#ACT
#SAY
你的血量在总血量的30%以上
--------------------------------------------------------------------

按最大HP值的百分比来加减HP

格式：AddHpPer 操作符(+/-/=) 百分比 例：
#IF
#ACT
AddhpPer + 30
GuildNoticeMsg 250 0 你的血增加了30% self
===================================================================
检测自身MP百分比
格式：CheckMpPer 操作符(>/=/<) 百分比
例子：
#IF
CheckMpPer > 30
#ACT
#SAY
你当前的MP在总mp量的30%以上
--------------------------------------------------------------------

按最大MP值的百分比来加减MP

格式：AddmpPer 操作符(+/-/=) 百分比 例：
#IF
#ACT
AddMpPer + 30
GuildNoticeMsg 250 0 你的MP增加了30% self

======================================================================
检测或给英雄增加命令同上，只需将命令前加h. 即可
例：
#IF
#ACT
h.AddMpPer + 30 1
GuildNoticeMsg 250 0 你的英雄MP增加了30% self #IF
h.CheckHpPer > 30 1
#ACT
#SAY
你的英雄血量在总血量的30%以上

【2019-05-16 更新:】
需要同时更新登录器(“GameOfMir登录器生成器.exe”“GameLogin.exe”)、M2Server.exe、Rungate.exe

修复集成的补丁释放在根目录的问题
修复多机负载失效
修复免蜡失效
增加地图参数禁止使用仓库NOUSESTORAGE
增加地图参数禁止购买商铺物品NOUSESNDASHOP

【2019-05-13 更新:】
需要同时更新登录器(“GameOfMir登录器生成器.exe”“GameLogin.exe”)和引擎

修复无法保存UI
修复无法查看别人装备

【2019-05-08 更新:】

20151108老版本升级说明，需要使用压缩包里的数据扩展工具对人物数据扩展后才能正常使用。

修复封包导致引擎重启卡死的问题
修复摆摊自定义OK框刷叠加物品的问题
优化内存占用
优化微端
优化数据通讯
开放所有定制功能，全部免费使用(详细看说明书)
修改一些GM命令，必须在GM列表(AdminList.txt)里的GM才可以使用(比如刷装备，刷元宝等等命令)，如果不在列表里，就算权限是10也无法使用
修改找回密码和修改密码都会弹出验证码
增加自定义验证码功能
增加英雄支持首饰盒和时装
增加按钮特效(UI编辑器可以编辑按钮的特效)
增加脚本命令，ADDBUTTONEX该命令支持特效(详细看说明书)
增加登录器游戏列表字体支持多彩(在列表文件里设置，看登录器配置器的列表格式)
增加武器简装
增加怪物简装
增加自定义怪物血条图片的自定义
增加登录器支持PNG图片的半透明效果皮肤
增加触发字段动态加密，防止封包触发脚本刷元宝等等
增加地面物品自定义特效(M2-查看-列表信息二-特效列表)
增加物品来源
增加HeroM2引擎的人物账号等等数据转换(在启动控制器里)
增加只要是读写文件的脚本命令都支持绝对路径
(只要路径那个参数是绝对路径，就会自动检测到。例: CHECKNAMELIST E:\数据文件\100元卡号.txt
不要使用前面加点的方式去读写否则可能产生“I/O error”错误)
增加列表服务器获取列表
暂时去除插件功能

【2015-11-04 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe DBServer.exe”

1. 修复提示读取数据失败的问题

如果登陆器打不开，是运行过其他登陆器，被其他登陆器劫持了，重新到我们官方网站下载最新的配置器，配置登陆器.
以后随时关注我们的官方网站，发现登陆器打不开，先看我们网站，可能会有更新
或者使用360急救箱，勾选强力模式，全盘杀毒

【2015-11-02 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”

1. 修复脚本命令GETHUMCUSTOMITEMVALUE的问题

【2015-11-01 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”

如果登陆器打不开，是运行过其他登陆器，被其他登陆器劫持了，重新到我们官方网站下载最新的配置器，配置登陆器.
以后随时关注我们的官方网站，发现登陆器打不开，先看我们网站，可能会有更新
或者使用360急救箱，勾选强力模式，全盘杀毒

【2015-10-28 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”

1. 修复追心刺在安全区能攻击掉血的问题
2. 修复可能会导致人物登陆M2会提示读取数据失败的问题
3. 修复灭天火掉蓝的问题

如果登陆器打不开，是运行过其他登陆器，被其他登陆器劫持了，重新到我们官方网站下载最新的配置器，配置登陆器.
以后随时关注我们的官方网站，发现登陆器打不开，先看我们网站，可能会有更新
或者使用360急救箱，勾选强力模式，全盘杀毒

【2015-10-25 更新:】
本次更新文件
全套程序，需要同时更新

1. 增加支持恶魔盾(详细看列表格式)
2. 修复英雄一些问题
3. 修复打开技能界面，鼠标无法滚动的问题

如果登陆器打不开，是运行过其他登陆器，被其他登陆器劫持了，重新到我们官方网站下载最新的配置器，配置登陆器.
以后随时关注我们的官方网站，发现登陆器打不开，先看我们网站，可能会有更新
或者使用360急救箱，勾选强力模式，全盘杀毒

【2015-09-18 更新:】
本次更新文件
全套程序，需要同时更新

1. 增加日记查询工具
2. 增加自定义装备特效的外观特效，普通绘制模式选项
3. 增加手动使用物品后，内挂自动吃药是否暂停的选项(在登陆器配置器里设置)

【2015-09-10 更新:】
本次更新文件“GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe M2Server.exe 数据管理.exe LogDataServer.exe”
需要同时更新

1. 鼠标点击拿起物品时,显示该物品的ID序列号(M2-选项-客户端设置-装备信息显示-鼠标点击拿起物品时,显示该物品的ID序列号)
2. 增加人物说话过滤信息时触发QF脚本的[@FilterSayMsg]。过滤信息写入S0变量中
3. 增加PlayMusic命令调整为关闭游戏音效时依然声音有效.
4. 增加新行会系统支持取消行会战
5 增加日记服务器数据TCP协议(使用启动器配置)
5. 增加数据管理工具增加物品制造IDX和物品所在DB的IDX查询功能
6. 增加M2玩家技能强化几重查询,增加玩家U T变量信息查询

【2015-09-02 更新:】
本次更新文件“M2Server.exe”

1. 修复自定义OK框一个漏洞

【2015-09-01 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
登陆器和M2需要同时更新

1. 修复获取随机数脚本的问题
2. 修复自定义NPC图层问题
3. 增加一个新的NPC使用图片功能

新增加 格式: <ImgEx:F:U:H:D:X:Y/@Label>
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
U=默认显示的图片序号
H=鼠标放上去时显示的图片序号
D=鼠标点下去时显示的图片序号
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

【2015-08-20 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe”
登陆器和M2需要同时更新

1. 修复引擎一个报错
2. 修改验证码算法

【2015-08-08 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe UpdateServer.exe”
登陆器和M2需要同时更新

1. 修复微端密码明明是正确的，加载时还是会提示错误的问题
2. 修复英雄人形怪假人砍怪，会砍歪的问题
3. 修复英雄KILLMONEXPRATE命令无效的问题
4. 修复骑马自动开盾的问题
5. 修复假人不支持捡取触发的相关常量
6. 增加人物说话过滤信息时触发QF脚本的[@FilterSayMsg]
7. 增加魔法道士技能攻击的麻痹戒指代码189
8. 增加禁止骑马脚本命令HORSERIDINGBAN。在骑马触发里使用

【2015-07-25 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe RunGate.exe”
登陆器和M2需要同时更新

1. 修复自定义技能火墙，最长时间设置无效的问题
2. 修复网关无法检测自定义技能的使用间隔的问题
3. 修复其他已知BUG
4. 增加一些新的常量
5. 增加一个物品规则，禁止人物使用

【2015-07-17 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”

1. 修复骑马一些问题
2. 修复登陆器人物坐标显示不正确，导致卡位问题
3. 增加脚本命令清除所有经络等级。ClearAllPulse

【2015-07-15 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe NewopUI.Pak”
登陆器和M2需要同时更新

1. 增加骑马功能(详细使用说明，搜索说明书)

【2015-07-09 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
登陆器和M2需要同时更新

1. 修复重新加载沙巴克的一些问题
2. 修复捡取触发一个我改名常量问题
3. 修复地面假物品问题
4. 修复新行会列表里少行会的问题
5. 增加聚灵珠DB的Source字段等于1提取经验时不触发@GetExp

【2015-07-05 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe LoginGate.exe SelGate.exe”

1. 修复英雄连击的问题
2. 修复初始化行会时触发无效的问题
3. 修复大退或小退触发无法使用传送命令的问题
4. 修复RandomKillMon脚本命令问题
5. 修复沙巴克城门开启关闭的GM命令无效的问题
6. 修复启动器在开启Access数据库时，有的机器无法保存配置文件
7. 增加M2重新加载沙巴克配置功能
8. 增加内挂中的物品，可以选择隐藏控制
9. 增加新行会列表的排序方式选项

【2015-06-30 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe DBServer.exe LoginSrv.exe”

1. 修复FIGHT3的问题
2. 修复人物麻痹小退不能回城的问题
3. 修复经络触发错误
4. 修复自定义包裹按钮，鼠标放上去提示信息不显示的问题
5. 修复武器带星号时禁止升级 ，必须砍一下去掉星号后才可以升级
6. 增加捡取物品触发一个新的常量

【2015-06-26 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
登陆器和M2需要同时更新

1. 完善自定义技能火墙效果
2. 增加初始化行会时触发字段。在登陆脚本里[@LoadGuild]。只能用于行会自定义变量的申请
3. 增加脚本命令过滤全服提示信息。如SENDMSG、GuildNoticeMsg等等脚本命令发送的全服提示信息。
4. 增加包裹窗口上5个自定义按钮，点击触发QF脚本的[@ItemBagButtonClickX],如何使用看说明书
5. 增加行会战地图标识 FIGHT3(是否掉装备)

功能：过滤全服提示信息
FILTERGLOBALMSG 是否过滤(0不过滤，1过滤)
[@main]
#IF
#ACT
FILTERGLOBALMSG 1
SENDMSG 6 开启过滤全服提示信息，你不在接受如SENDMSG、GuildNoticeMsg等等脚本命令发送的全服提示信息。

在登陆脚本QManage.txt里触发
[@LoadGuild]
#IF
#ACT
VAR Integer GUILD QQQQ

【2015-06-18 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
登陆器和M2需要同时更新

1. 修复英雄锁定的问题
2. 修复物品自定义特效的衣服、武器、头盔内观的普通绘制模式无效的问题
3. 增加自定义技能支持魔法盾和火墙效果

【2015-06-10 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
登陆器和M2需要同时更新

1. 增加技能心灵召唤(把自己所有不在自己身边的宝宝召唤到身边，技能DB在程序包里的数据库目录里)
2. 增加物品自定义特效的，普通绘制的模式选项
3. 增加脚本命令GOTOLABELEX(详细看说明书)
4. 增加脚本命令MAPKILLMONEXPRATE(详细看说明书)
5. 修改脚本命令SENDTOPCHATBOARDMSG(详细看说明书)
6. 修改脚本命令PLAYEFFECT(详细看说明书)
7. 修复默认内挂减血吃药的问题
8. 修复英雄锁定目标的问题

【2015-06-06 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
登陆器和M2需要同时更新

1. 增加捡取触发物品的一些常量(详细看说明书)
2. 增加自定义NPC(M2-查看-列表信息二-自定义NPC)

【2015-06-01 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe 数据管理.exe”
登陆器和M2需要同时更新

1. 修复公告信息自定义颜色无效的问题
2. 修复数据管理工具不支持Access数据库
3. 修复修复神水的次数，样式2显示错误
4. 修复英雄蜡烛不掉持久的问题
5. 增加账号信息的常量

密码:<$PASSWORD>
生日:<$BIRTHDAT>
问题1:<$QUIZ1>
答案1:<$ANSWER1>
问题2:<$QUIZ2>
答案2:<$ANSWER2>
邮箱:<$EMAIL>
电话:<$PHONE>
手机:<$MOBILEPHONE>

【2015-05-28 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”

1. 修复新行会系统一个问题
2. 修复集成物品备注和套装备注登陆器闪退的问题
3. 增加一个新的捡取触发不需要序号的,在QF脚本里触发[@PickUpItemEx]
4. 增加一个脚本命令SENDUPGRADEITEM。用于刷新捡取触发修改后的物品

【2015-05-26 更新:】
本次更新文件“M2Server.exe”

1. 修复镖车怪物报错的问题(如果没有使用这个怪物的可以不更新)

【2015-05-25 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe”
需要同时更新

1. 修复一个恶意封包导致引擎卡死不响应的问题(建议更新，所有引擎都存在这个问题)
2. 修复默认内挂英雄吃药的问题
3. 修复强化无极真气无效的问题
4. 修复称号备注的问题
5. 修改删除NPC的脚本命令DELNPC
6. 修改登陆验证码验证顺序，防止盗号的。先输入验证码，然后才能输入账号密码，如果密码输入错误，还需要重新输入验证码(在账号服务器开启验证码，才支持验证码功能)
7. 增加脚本命令LINKPICKUPITEM。用于关联捡取的物品
8. 增加脚本CheckContainsTextListEx。该命令和CheckContainsTextList命令使用方式差不多(具体看说明书)
9. 配置器增加一个全屏绘制地图的选项

---------------------------------------------------------------
删除一个NPC

格式: DELNPC NPC名字 地图文件名称(该参数可以为空，为空表示所有地图的)

[@删除所有地图的]
#IF
#ACT
DelNpc 测试

[@删除某个地图的]
#IF
#ACT
DelNpc 测试 3

---------------------------------------------------------------
LINKPICKUPITEM脚本命令
功能：可以对捡取的物品进行关联，该命令只能在捡取触发里[@PickUpItemX]使用

[@PickUpItem0]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作

;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253

;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1

;修改后的参数，刷新到客户端
SENDUPGRADEITEM

【2015-05-20 更新:】
本次更新文件“GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe M2Server.exe DBServer.exe LoginSrv.exe”

1. 修复报毒问题
2. 修复服务端启动后无法备份数据的问题
3. 修复脚本命令CheckContainsTextList无效的问题

【2015-05-18 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe DBServer.exe LoginSrv.exe”
需要同时更新

1. 修复脚本命令SETSHOWITEMMSG无效的问题
2. 修复人物名称有特殊封号可能导致内挂参数无法保存的问题
3. 修复英雄一些问题
4. 修复技能一个问题
5. 修复引擎有几率卡死无响应的问题,64位引擎没有这个问题(卡死症状：网关全部断开连接，必须要强制结束M2的进程才能关闭M2,如果遇到过的就赶紧更新吧)
6. 修改自定义属性，如果名称设置为空时，装备属性框不显示该属性(自定义属性名称设置：M2-选项-客户端设置-自定义属性)
7. 增加商铺购买物品的时间间隔控制
8. 增加首饰盒支持套装

【2015-05-10 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
需要同时更新

1. 修复报毒问题(登陆器配置器必须要勾选有签名的配置登陆器)
2. 修复英雄锁定的问题
3. 修复备注<LOOKS:L:T:X:Y:Z>Looks 大于 10000以上不显示的问题

【2015-05-06 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”
需要同时更新

1. 修复挑战，如果双方同时死亡时，胜利的回城会掉装备的问题
2. 修改SetItemState命令。设置后直接就生效了，不需要在使用SetItemBind命令绑定，才会生效
3. 修改NPC对话框里，播放动态图片的PlayImg。增加支持次数限制
4. 增加一个假人命令，锁定目标命令，可以用于砍猪
5. 增加物品备注和套装备注支持图片显示

[@假人自动锁定目标]
#ACT
DUMMYAUTOTARGET 1
;假人使用这个命令后，搜索到攻击目标后，会自动锁定该目标
;DUMMYAUTOTARGET 参数(0关闭自动锁定,1开启自动锁定)

----------------------NPC对话框播放动态图片---------------------------
NPC对话框里，播放动态图片
格式: <PlayImg:F:N:C:T:X:Y:M:L/@Label>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制
L表示播放次数，如果为空或为0时，表示无限次数。设置大于0时，表示播放的次数，次数到了就会自动消失

F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.

--------------------------物品备注和套装备注支持显示图片----------------------------
物品图片显示:
格式：<LOOKS:L:T:X:Y:Z>
L表示物品DB的Looks值
T0表示包裹物品图片 1表示地面物品图片
XY 表示微调坐标
Z0表示不显示背景 1表示显示背景

任意图片显示:
格式：<Img:N:F:X:Y>
N表示播放开始图片
F表示WIL文件序号
X,Y表示微调坐标

动态图片播放:
格式: <PlayImg:F:N:C:T:X:Y:M>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制

【2015-05-01 更新:】
本次更新全套程序，需要同时更新

1. 修复英雄一些问题
2. 修复M2在有的机器会卡死的问题
3. 修复人物死亡掉落物品提示信息，会删除人物名称后面数字的问题
4. 修改KICK命令，人物直接掉线
5. 增加人物小退的脚本命令LOGOUT
6. 增加登陆器是否允许在虚拟机运行的选项(登陆器配置器中选择)

7. 升级授权Key，更新2015-05-01或者之后的程序，必须使用新的授权Key，如果你的Key是在销售(QQ718846686)购买的，可以把你的授权Key离线发给销售，免费更换新的授权
新的授权Key使用方法和以前的一样。如果不更新新程序的，可以不更换，以前的Key还可以正常使用。

【2015-04-21 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”

1. 修复64位引擎一些问题
2. 修复64位微端一个问题
3. 修复登陆器一个问题

【2015-04-20 更新:】
本次更新文件“M2Server.exe”

1. 修复引擎一个内存报错

【2015-04-18 更新:】
本次更新全套程序，需要同时更新。

1. 修复64位引擎一些问题
2. 修复英雄在安全区可以锁定别人的宝宝
3. 修复物品规则里的禁止英雄使用无效的问题
4. 修改脚本命令KillCallMob。详细查看说明书
5. 修改不勾选 验证时禁止攻击和使用物品。人物可以使用物品(功能设置-其他控制(2)-验证码基本设置)
6. 增加验证时间限制，超过设置时间没有验证成功的踢下线(功能设置-其他控制(2)-验证码基本设置)

【2015-04-12 更新:】
本次更新文件“M2Server.exe”

1. 修复自定义属性导致属性错乱的问题(目前就64位引擎有问题)
2. 增加防脱机验证码时间控制
3. 增加脚本命令TakeWEx。该命令和TakeW的唯一区别，就是分左右戒指和手镯

[@收左戒指]
#ACT
TakeWEx [RINGL]

[@收右戒指]
#ACT
TakeWEx [RINGR]

[@收左手镯]
#ACT
TakeWEx [ARMRINGL]

[@收右手镯]
#ACT
TakeWEx [ARMRINGR]

【2015-04-10 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe”，需要同时更新。

1. 修复装备框显示一个问题
2. 修复叠加物品一个问题
3. 修复13周年界面一个问题
4. 修复Access数据库重读不生效的问题
5. 修改登陆验证码加密方式(如果有开启的用户，需要同时更新LoginSrv.exe和登陆器，否则无法登陆)
6. 扩展GiveStateItem命令，支持丢弃消失
7. 增加群体施毒术的间隔控制
8. 增加脚本命令获取人物穿戴装备的自定义属性值GetHumCustomItemValue
9. 增加脚本MOVEX这个命令和MOV使用一样，不过在多级脚本使用中不一样
10. 增加脚本SETSHOWITEMMSG用来关闭或显示，有的脚本命令会提示“你身上没有戴指定物品！！！”
11. 增加脚本SHOWGAMEVALIDATEDLG。可以显示验证码输入窗口
12. 增加脚本CHANGEGAMEVALIDATESTRING。修改验证码
13. 增加防脱机验证码功能(M2-选项-功能设置-防脱机设置里开启)
14. 增加64位引擎(建议开大服的使用)
15. 增加64位微端

-----------------------------------------------------------------------------------------------------------------
SHOWGAMEVALIDATEDLG 模式(0自己 1当前地图 2全服人物) 自定义验证码(该参数可以为空，如果为空时，会自动生成验证码)
-----------------------------------------------------------------------------------------------------------------
CHANGEGAMEVALIDATESTRING 修改的验证码(不超过6个字符)
;这个命令是在玩家输入错误，或点击换一张时使用。在QF触发 [@ValidateFail]和[@ChangeValidateString]2个触发下面使用
-----------------------------------------------------------------------------------------------------------------
获取人物所穿装备的自定义属性值：
GETHUMCUSTOMITEMVALUE 属性位置(-1表示10个属性全部获取,0~9 装备自定义10个属性） 绑定的属性类型(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的) 变量1(保存属性值) 变量2(如果属性是百分比的，保存在这个变量)
-----------------------------------------------------------------------------------------------------------------
SETSHOWITEMMSG (0关闭，1显示)
-----------------------------------------------------------------------------------------------------------------
GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6 项目7(0为正常,1为绑定) 数量

;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备,项目7--丢弃消失
-----------------------------------------------------------------------------------------------------------------

[@显示随机验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0

[@显示自定义验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0 123456
SENGMSG 6 验证码窗口会显示123456，不超过6个字符

;验证码QF触发相关
;输入正确触发
[@ValidateOK]
#ACT
SENDMSG 6 输入的验证码正确

;输入错误触发
[@ValidateFail]
#ACT
CHANGEGAMEVALIDATESTRING 123456
SENDMSG 6 输入的验证码错误,把验证码修改成123456

;点击换一张时触发
[@ChangeValidateString]
#ACT
SENDMSG 6 用户点击换一张
-----------------------------------------------------------------------------------------------------------------
[@main]
#ACT
MOV S1 神话
S1.MOVEX S2 <$USERNAME>
SENDMSG 6 S2使用的是神话这个人物的，<$USERNAME>这个使用的是，谁点击这个脚本，就调用的谁的
SENDMSG 6 这个脚本存在2个人，执行脚本的人物S1和点击触发脚本的人物

【2015-03-25 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”，需要同时更新。

1. 修复GiveStateItem命令

【2015-03-24 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”，需要同时更新。

1. 修复对进度条等级操作时报错的问题
2. 增加进度条名称支持显示进度条值、进度条百分比、进度条等级(详细看说明书)
3. 增加10个无属性的自定义属性(详细看说明书)
4. 增加检测自定义装备属性绑定类型的脚本命令(详细看说明书)
5. 扩展GiveStateItem命令，增加一个数量参数

【2015-03-23 更新:】
本次更新文件“GameOfMir登录器生成器.exe NewopUI.Pak”，需要同时更新。

1. 修复上一版出现的问题
2. 修改装备宝石加星为图片模式(NewopUI.Pak 530开始)

【2015-03-22 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe NewopUI.Pak”，需要同时更新。

1. 修复上一版出现的问题
2. 修改装备自定义进度条图片静态和动态的图片素材位置(详细看说明书)
3. 自定义进度条增加一个等级参数(详细看说明书)
4. 更新后，上一版进度条数据会错乱

【2015-03-21 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe NewopUI.Pak”，需要同时更新。

1. 修复自定义属性魔法值的百分比计算错误
2. 修复行会过多导致引擎会几分钟卡一次的问题
3. 修复英雄一些问题
4. 增加2种新的装备悬浮框的显示样式(M2-选项-客户端设置-装备信息显示-装备悬浮框显示样式)
5. 增加装备自定义进度条功能(类似刀魂功能)

【2015-03-18 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”，需要同时更新。

1. 修复战士自定义技能，别人看不见技能效果的问题
2. 修复不勾上显示分隔线自定义装备文本不显示的问题
3. 修复改名装备卖到商店后，无法买回的问题

【2015-03-17 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”，需要同时更新。

1. 修复包裹物品多，数据会错乱的问题
2. 修复CHECKCUSTOMITEMVALUE命令无效的问题
3. 增加自定义装备属性的名称控制(M2-选项-客户端设置-自定义属性)

【2015-03-16 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe”，需要同时更新。

1. 修复装备改名，卖到商店，会恢复原名称的问题
2. 增加自定义装备文本和自定义装备属性功能。详细搜索说明书

【2015-03-08 更新:】
本次更新文件 M2Server.exe DBServer.exe 需要同时更新。

1. 修复会造成首饰盒装备和人物装备丢失的问题(如果更新过2015-03-06或2015-03-07的请立即更新以上2个程序)

【2015-03-07 更新:】
本次更新文件“人物数据扩展工具5.exe”

1. 修复转换工具没有转换个人商店数据的问题(如果转换发现没有个人商店的，重新使用新的转换工具转换一下就可以)

【2015-03-06 更新:】
本次更新文件“GameOfMir登录器生成器.exe M2Server.exe RunGate.exe DBServer.exe 合区工具.exe 数据管理.exe”，需要同时更新。

1. 封最新外挂
2. 装备改名不在保存在Envir\ItemNameList.txt里，直接保存在人物数据“Mir.DB”“HeroMir.DB”(使用转换工具，会自动处理在ItemNameList.txt的改名数据)

升级步骤：
1.首先关闭服务端
2.扩展人物数据前先备份数据“Mir.DB”“HeroMir.DB”“Mir200\Envir\UserData”的数据
3.更新程序“GameOfMir登录器生成器.exe M2Server.exe RunGate.exe DBServer.exe”
4.然后使用启动器清除NPC缓存和武器升级数据(启动器-数据清理-勾选武器升级，商店缓存，其他选项不要勾，然后点开始清理)
5.使用“人物数据扩展工具5.exe”扩展人物数据(在程序包里的，工具目录里)
6.登陆几个角色试试，看看扩展的数据有没有问题
7.如果使用过插件的，请联系插件制作商，重新使用新的API更新插件，才可以使用最新程序

【2015-02-08 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 加强OK框的检测，增加OK框里是否有物品的检测命令CheckBoxItemCount
2. 扩展删除OK框物品命令DELBOXITEM

CheckBoxItemCount OK框编号(0~7) 物品数量(该参数只有是叠加物品时才会有效)
检测OK框中是否有物品

DELBOXITEM OK框编号(0~7) 删除数量(该参数只有是叠加物品时才会有效，如果没有全部删除掉，需要使用UpDateBoxItem命令进行刷新，否则客户端不能立即显示删除掉的数量。如果该参数为空时，表示该OK框里的叠加物品不管有多少数量，都全部删除)
删除OK框物品

【2015-01-28 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复任务NPC不显示

【2015-01-26 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 增加人物的元素的属性值的常量<$VALUE1>..<$VALUE11>。英雄的<$H.VALUE1>..<$H.VALUE11>
2. 修复勾选优化流量后人形怪刷出来看不见衣服外观的问题
3. 修复使用刷封包工具可以刷自定义输入的 @@InPutInteger @@InPutString 变量值的问题
4. 修复十步一杀鼠标指向目标时，技能不使用的问题
5. 封最新外挂

【2015-01-20 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复勾选优化流量产生的问题
2. 修复叠加物品的问题
3. 修复登陆器双开的问题

【2015-01-18 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe RunGate.exe

1. 优化降低M2流量占用(M2-选项-性能设置-勾选优化发送到网关的数据。必须更新最新2015-01-18的RunGate才能支持)
2. 修复叠加物品的问题
3. 修复归来界面内挂一些问题
4. 修复管家报毒的问题
5. 修复登陆器一些问题

【2015-01-12 更新:】
本次更新文件 M2Server.exe LoginGate.exe SelGate.exe

1. 过滤人物发送自定义颜色的聊天框信息,防止玩家冒充GM红字发信息(比如人物喊话，私聊信息，禁止使用,如:{GOM引擎官方网站：http://www.gameofmir.com|255:249})
2. 修复登陆、角色网关掉线问题

【2015-01-08 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe 合区工具.exe
需要同时更新

1. 修复战士连击的问题
2. 修复十步一杀的问题
3. 修复合区工具偶尔会丢失角色的问题
4. 修改发送屏幕滚动信息脚本命令，支持多彩色信息(使用方式和NPC的文字颜色类似)

[@main]
#ACT
MOV S1 这个是屏幕滚动信息坐标在100
SENDMOVEMSG 1 253 255 100 3 <这个是屏幕滚动信息坐标在100/FCOLOR=250>{<$STR(S1)>/FCOLOR=253}{<$USERNAME>/FCOLOR=254}<这个是屏幕滚动信息坐标在100/FCOLOR=69>

【2015-01-06 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复登陆器一个问题
2. 修复OK框一个问题

【2015-01-03 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe LoginGate.exe SelGate.exe
需要同时更新

1. 修复登陆、角色网关一处误封
2. 修复登陆器自动刷新列表的问题
3. 修复M2一个BUG
4. 增加登陆器游戏音量控制(在M2-选项-客户端控制-内挂控制(二)开启或打开)
5. 封最新外挂

【2014-12-16 更新:】
本次更新文件 M2Server.exe

1. 优化英雄，人形怪、假人

【2014-12-15 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe RunGate.exe

1. 修复摆摊时，M2会有几率产生一个错误
2. 修复登陆器多开的问题

【2014-12-12 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe LoginGate.exe SelGate.exe
需要同时更新

1. 优化登陆角色网关
2. 增加包裹物品自动放入自定义OK框的脚本命令(详见说明书)

【2014-12-10 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe LoginGate.exe SelGate.exe LoginSrv.exe DBServer.exe

1. 修复网关被攻击会卡死的问题
2. 修复分身在安全区不主动攻击的问题
3. 修复自定义技能飞行技能的声效错误

【2014-12-02 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复ChangeHumAbility不加时间参数失效的问题
2. 修复月灵安全区还会攻击人物的问题
3. 内挂里增加一个禁止交易的选项

【2014-12-01 更新:】
本次更新全套程序

1. 修复引擎一个错误，会导致装备备注、套装备注、查看别人装备等等信息会不显示或引擎卡死的问题
2. 降低引擎CPU占用
3. 增加野蛮冲撞是否可以麻痹目标的选项

【2014-11-28 更新:】
本次更新全套程序，必须同时更新才可以(包括各种网关，M2，登陆器等等，如果使用微端的也要更新)

1. 修复月灵会攻击尸体的问题
2. 修复自定义OK框一个问题
3. 修改API插件的消息号等等代码，如果使用了插件，先要更新插件才能更新程序，否则插件会有问题
4. 增加支持MDB格式Access数据库(Magic.DB,Monster.DB,StdItems.DB)，
程序工具目录里有BDE数据库转换成MDB格式Access数据库的工具，
转换后就不需要DBC2000了，可以卸载了，启动器里勾选使用Access数据库配置一下就可以
5. 封最新外挂

【2014-11-15 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 增加非沙巴克成员小退是否回城的选项(M2-选项-功能设置-其他控制2)
2. 修复已知BUG

【2014-11-08 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe 合区工具.exe

1. 修改自定义技能，辅助技能中增减属性的计算方式
2. 增加合区工具可以自动清除数据
3. 优化英雄，人形怪、假人

【2014-11-06 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复掷斧骷髅不显示血条的问题
2. 修复摆摊还是会出现假物品的问题
3. 修复内功怪获取经验不正常
4. 修复合击有几率失效的问题
5. 修改英雄在没有攻击目标情况下也会使用魔法盾和召唤宝宝
6. 增加使用Alt + R刷新人物包裹时，如果英雄在线也会同时刷新英雄包裹
7. 优化英雄，人形怪、假人
8. 封最新外挂

【2014-11-03 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复镜像地图释放时M2会报错
2. 优化英雄，人形怪、假人
3. 增加英雄，人形怪、假人支持新技能 纵横剑术、十步一杀、冰镰术、冰霜群雨、裂神符、死亡之眼
4. 增加假人支持连击

【2014-10-24 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复M2运行几天后会造成怪物无敌的问题
2. 目前就360提示报毒，其他杀毒软件检测正常，具体还不知道怎么回事。(登陆器支持自主签名，有条件的用户，可以自己签名免杀。)

【2014-10-21 更新:】
本次更新文件 GameOfMir登录器生成器.exe

1. 修复xp sp3之前的系统登陆会出错
2. 修复pak不读取的问题

【2014-10-20 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复一些老的登陆器皮肤导入看不到的问题
2. 修复ADDMAPGATE在镜像地图使用的问题
3. 封最新外挂

【2014-10-18 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复有的登陆器皮肤显示错误的问题
2. 修复机器码会重复的问题
3. 修复ADDMAPGATE失效的问题
4. 修复摆摊会刷物品的问题
5. 修复刷属性的问题
6. 修复宝宝攻击的封顶伤害无效的问题
7. 封十彩外挂

【2014-10-14 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复BUG
2. 封十彩外挂

【2014-10-12 更新:】
本次更新文件 GameOfMir登录器生成器.exe Dbserver.exe

1. 修复不能创建人物的问题
2. 修复pak会读取不了的问题

【2014-10-11 更新:】
本次更新文件 全套程序

1. 修复上一版出现的BUG

【2014-10-10 更新:】
本次更新文件 全套程序

1. 修复BUG
2. 修复不读取pak补丁的问题
3. 修复WIL编辑器导入导出PNG格式的问题
4. 封十彩外挂
5. 增加动态创建镜像地图
6. 修改CreateNpc脚本命令

--------------------------------------------------------------------------------
动态地图相关
ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建
--------------------------------------------------------------------------------
CreateNPC NPC名字 地图 坐标X(-1时随机坐标) 坐标Y(-1时随机坐标) 外观 脚本文件 脚本文件是否要加上地图名称(例如.设置为0时脚本文件必须带“-3”如:“传送员-3.txt” 设置为1时脚本文件不需要带“-3”如:“传送员.txt”)
--------------------------------------------------------------------------------

【2014-09-27 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe WIL编辑器.exe

1. 修复GiveStateItem命令一个问题
2. 修复上一版更新导致wzl格式的素材微端不更新的问题
3. 修复WIL编辑器转换13周年新界面素材有黑边的问题(可以转换成pak或导出PNG格式，就不会有黑边)

【2014-09-24 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复绑定和非绑定的物品不能叠加
2. 修复技能防御百分比没效果
3. 修改TakeBagItem脚本命令
4. 封十彩外挂

一键回收包裹物品的脚本命令
格式：
TakeBagItem 物品名称(支持多个物品) 收取数量 每个物品增加元宝值 每个物品增加金币值 每个物品增加泡点值 每个物品增加泡点经验值 变量(保存实际回收的物品数量) 聚灵珠经验(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)

[@main]
#ACT
TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0
SENDMSG 6 成功回收<$STR(N1)>个木剑，布衣(男)，布衣(女)，价格为10000经验

【2014-09-19 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复13周年界面编辑后不能保存的问题
2. 修复其他BUG
3. 封十彩外挂

【2014-09-08 更新:】
本次更新文件 M2Server.exe

1. 修复集成自定义技能数据的问题，需要使用新的M2重新生成集成的数据，然后使用登陆器配置器集成

【2014-09-07 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复内功怪一个问题
2. 修复风盾采集问题

【2014-09-05 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe

1. 修复新的行会管理一个问题
2. 修复其他BUG
3. 增加登陆器闪退修复工具(需要更新最新登陆器，修复后才能生效)

【2014-09-03 更新:】
本次更新文件 M2Server.exe

1. 修复M2一个问题

【2014-09-02 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe 数据管理.exe

1. 修复新的行会管理一个问题
2. 数据管理工具，在增加一个等级排行查看
3. 账号服务器增加一个是否开启远程账号管理工具的选项

【2014-09-01 更新:】
本次更新文件 全套程序
需要同时更新

1. 修改登录器补丁自动(如果是压缩文件登录器每次启动都会解压，防止补丁被破坏。非压缩文件，每次启动登录器也会比对文件的MD5值，检测是否需要更新)
2. 修复多机负载配置工具一个问题
3. 修复合区工具一个问题
4. 修复偶尔有杀不死怪物，人物登陆不了的问题
5. 修复有时候BOSS怪物会不停的刷的问题
6. 修复装备技能威力对人物无效的问题
7. 修复其他BUG
8. 增加脚本命令修理城墙，攻城结束才能使用，攻击期间无效。RepairWall
9. 增加数据管理工具，人物金币元宝等各种数据大小的排行
10. 增加远程账号管理工具
11. 增加盛大新的行会管理系统(M2-功能设置-其他控制(2)。登陆器配置器不能勾选归来版或外传版，这2个界面不支持新行会界面)
12. 增加禁止传送捡取装备的选项(M2-功能设置-其他控制(2))
13. 增加野蛮冲撞、擒拿手同等级禁止使用的选项
14. 封已知外挂

RepairWall 城墙(1左 2中 3右)

[@main]
#act
RepairWall 1
RepairWall 2
RepairWall 3

【2014-08-15 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe DBServer.exe

1. 修复在线改名系统一个问题

【2014-08-14 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe DBServer.exe

1. 增加在线改名系统
2. 修改风盾验证方式(如何使用，到风盾客服那问)
3. 封十彩外挂

-----------------------------------人物在线改名------------------------------
[@Main]
<查询名称是否可以使用/@@InputString1(请输入新的名称：)>\
<我要改名/@@InputString2(请输入新的名称：)>>\

[@InputString1]
#IF
Equal S1
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S1 > 20
CheckStringlength S1 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
QUERYHUMNAMEEXIST S1

[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S2 > 20
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
CHANGEHUMNAME S2

QFunction-0.txt脚本相关触发

[@QueryingHumName]
正在查询请稍后。。。\ \
<关闭/@exit>\

[@QueryHumNameOK]
查询成功，该名称可以使用\ \
<关闭/@exit>\

[@ChangeingHumName]
正在修改请稍后。。。\ \
<关闭/@exit>\

[@ChangeHumNameOK]
#ACT
;这个命令是用来修改，你的变量保存文件和人物名称列表文件里面的人物名称的，如果没有这些可以不使用这个命令
;这个命令也只能放在这个地方，放其他地方无效
CHANGEHUMNAMEFILE ..\QuestDiary\变量文件\HQCQASave.txt
CHANGEHUMNAMEFILE ..\QuestDiary\会员名称.txt
#SAY
你的名字修改成功，旧名称：<$USERNAME> 新名称：<$USERNEWNAME>！\ \
<关闭/@exit>\

[@NameLengthFail]
名字长度不允许超过30个字符！\ \
<关闭/@exit>\

[@HumNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HumNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\

[@ChangeHumNameFail]
改名失败！\ \
<关闭/@exit>\

【2014-08-11 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe

1. 增加全局变量管理(M2-管理-全局变量)
2. 修改挖矿触发，不管有没有挖到矿都会触发
3. 修复毒素武器，使目标中毒后，还会回血的问题
4. 修复延迟暗杀的问题

【2014-08-08 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复自定义怪物半月攻击无效的问题
2. 修改免Shift键砍人时的问题(经测试盛大免Shift键砍人，是鼠标点击松开后才开始攻击。M2-选项-客户端设置-仿盛大免Shift键勾上就可以)
3. 增加宝宝可以升级到最高等级的限制(M2-功能设置-宝宝升级)
4. 增加可以发送国家信息的最低等级控制
5. 封十彩外挂

【2014-08-05 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 封十彩外挂

【2014-08-02 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修改装备加星，每行10个星星，超过10个星星自动换行。
2. 内挂增加一些选项
3. 修复人物外观无补丁时候点击不了的问题
4. 修复其他问题
5. 封十彩外挂

【2014-07-29 更新:】
本次更新文件 M2Server.exe

1. 修复人形怪攻击力不正常的问题

【2014-07-28 更新:】
本次更新文件 GameOfMir登录器生成器.exe

1. 修复报毒的问题
2. 修复如果使用UI编辑器修改聊天框组高时，文字背景绘制的问题

【2014-07-26 更新:】
本次更新文件 M2Server.exe

1. 修复怪物秒人的问题

【2014-07-25 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe

1. 修复顶戴花翎的问题
2. 修复怪物说话的问题
3. 修复出售或修理装备时没有金币数量改变没有声音

【2014-07-24 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe Rungate.exe 多机负载配置工具.exe

注意：不能只更新登录器或网关或引擎，这三个程序必须同时更新，否则登录会黑屏

1. 修复地图读取问题
2. 修复行会编辑有机率会乱码的问题
3. 修复双击英雄包袱的手镯或者戒指有一边穿不上的问题
4. 修复多机负载配置工具一个问题
5. 修改顶戴花翎脚本命令SetIcon.增加一个参数，是否仅自己可以看见
6. 扩展收费功能首饰盒和宝石镶嵌

----------------------------------------------------------------------
首饰盒改动:

首饰盒支持CheckItemW TakeW AutoTakeOnItem AutoTakeOffItem

AutoTakeOnItem 装备名称 装备位置(30~41 是首饰盒的位置代码)
AutoTakeOffItem 装备位置(30~41 是首饰盒的位置代码)

[@TakeOnX]
首饰盒穿装备触发 X值=30~41

[@TakeOffX]
首饰盒脱装备触发 X值=30~41

首饰盒装备，人物死亡掉落设置在(M2-选项-参数设置-人物死亡-首饰盒)
首饰盒装备是否掉持久设置(M2-选项-功能设置-其他控制(1))

首饰盒装备的修理，在NPC文件头增加以下代码
(@buy @sell @repair @s_repair)
%100
+100
+101
+102
+103
+104
+105
+106
+107
+108
+109
+110
+111

----------------------------------------------------------------------
宝石镶嵌改动:
宝石的Shape值(0~4)显示出5个不同颜色的镶嵌宝石。在必备补丁NewopUI.PAK的301~305
宝石的Shape值如果设置为255，镶嵌后会显示宝石DB的Looks的。也就是DnItems里面的素材

宝石DB库的字段Reserved=0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值是增加的对应的7个基本属性的值
宝石DB库的字段Reserved>0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值除以100，为人物各属性的倍数，例如Ac2设置为110，人物的防御为200。人物实际防御=110/100*200=220

【2014-07-20 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe 合区工具.exe
需要同时更新

1. 增加一个新的脚本关键字“#OR” 使用和“#IF”类似
2. 增加合区工具合区完成后，新数据自动保存到主区
3. 修复脚本命令ChangeHumAbility ChangeModeEx一个问题
4. 修复帐号服务器点帐号管理窗口看不见的问题
5. 封十彩外挂

#IF 下面的检测命令，所有检测命令都必须检测成功时才会执行#SAY或#ACT
#OR 下面的检测命令，只要有一个检测命令检测成功时就会执行#SAY或#ACT

[@main]
#IF
CHECKLEVELEX > 10
CHECKLEVELEX < 100
#SAY
您的等级在10-100级之间。
#ELSESAY
您的等级不在10-100级之间。

[@main]
#OR
CHECKMAPNAME 0
CHECKMAPNAME 3
#SAY
你在地图0或在地图3
#ELSESAY
你不在地图0，也不在地图3

【2014-07-16 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe

1. 修复合区工具合不了行会成员的问题
2. 扩展脚本命令ChangeHumAbility ChangeModeEx MakePosion(详细看说明书)
3. 封十彩外挂

【2014-07-12 更新:】
本次更新文件 M2Server.exe

1. 修复M2长时间运行后卡死

【2014-07-11 更新:】
本次更新文件 GameOfMir登录器生成器.exe

1. 修复误报

【2014-07-10 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe

1. 封十彩外挂
2. 增加装备比较功能(可以内挂里开启或关闭)
3. 修复点击登录器公告的链接会报毒的问题
4. 修复使用施毒术时攻击人物时，人物名称会不变色
5. 修复自定义OK框一个问题
6. 修复其他BUG

【2014-06-30 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe

1. 封十彩外挂
2. 优化登录器获取列表
3. 扩展GIVE脚本命令,兼容以前的格式，新的加的2个参数可以为空(商业支持)

GIVE 物品名称 数量 极品属性(13个参数，可以参考UPGRADEITEMEX命令 属性位置的介绍，或自己实际测试看效果) 元素属性(11个参数,从暴击机率开始)

例：

GIVE 布衣(男) 1 100|100|100|100|100|100|100|100|100|100|100|100|100 100|100|100|100|100|100|100|100|100|100|100|100|100

【2014-06-23 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复登录器一个错误
2. 修复称号触发一个问题

【2014-06-21 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe

1. 修复会卡技能问题
2. 封十彩外挂

【2014-06-20 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe RunGate.exe

1. 修复自动生成挂机点的问题
2. 修复网关一个的问题
3. 修复使用技能的问题

【2014-06-18 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe 合区工具.exe UpdateServer.exe

1. 修复13周年新界面一些错误
2. 修复不能过地图的问题
3. 登录器配置器增加2个新的选项，自己启动登录器配置器查看

【2014-06-17 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe

1. 修复一个会导致无法使用技能的错误

【2014-06-16 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复13周年新界面一些错误
2. 修复盾牌外观特效无效的问题
3. 修复自定义技能一个选项不保存的问题
4. 修复毒符互换一个问题
5. 增加一个从自定义OK框里的物品拿到包裹时触发[@ItemOutBoxX] X表示OK框的序号
6. 加快游戏启动速度

【2014-06-11 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe

1. 修复13周年新界面一些错误

【2014-06-10 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe GuiEditDll.dll M2Server.exe

1. 修复行会战时间提示错误
2. 修复SCREENEFFECT命令的问题
3. 修复自定义怪物太多会失效的问题
4. 增加支持13周年新界面(商业支持)
5. 封十彩外挂

【2014-05-31 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe

1. 修复爆金币的问题

【2014-05-30 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe

1. 修复一个会导致人物掉线的问题
2. 修复SETITEMEFFECT脚本命令不能实时显示效果的问题

【2014-05-29 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复登录器误报的问题
2. 修复爆金币的问题

【2014-05-28 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修改THROWITEM命令
2. 修复141、182装备的经验倍数计算错误
3. 修复内挂挂机一个问题
4. 增加麻痹或冰冻后是否允许传送的选项(M2-功能设置-其他设置(2))
5. 增加复活后多长时间才可以使用传送的选项(M2-功能设置-其他设置(2))
6. 封最新十彩外挂

THROWITEM 地图名称 X坐标 Y坐标 范围 物品名称 数量|时间 是否掉落提示(0不提示,1提示)

【2014-05-22 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复称号的问题
2. 修复清理怪物的问题
3. 修复鼠标指向目标，偶尔会乱图的问题

【2014-05-21 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe DBServer.exe
需要同时更新

1. 修复登录器一个微端更新的问题
2. 修复时装DB里设置翅膀不显示的问题
3. 修复苹果和无极真气冲突的问题
4. 优化登录器内存占用
5. 增加时装生效时是否显示发型外观(M2-功能设置-其他设置)
6. 增加归来版登录器也支持称号

【2014-05-20 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复有个特效特效会闪的问题
2. 修复雷霆剑法的问题
3. 修复反弹伤害威力和爆击威力倍数计算错误的问题
4. 优化登录器内存占用
5. 增加灵魂火符攻击威力设置

【2014-05-18 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe
需要同时更新

1. 重新购买的新的数字证书，解决商业登录器报毒问题
商业登录器分成2种：
1：有数字签名的可以防止杀毒软件误报(不支持登录器插件，不支持捆绑补丁)
2：无数字签名的(支持登录器插件，支持捆绑补丁)
2. 增加多机负载配置工具
3. 封最新十彩外挂

【2014-05-15 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe RunGate.exe
需要同时更新

1. 修复无极真气有些情况下会加0点的问题
2. 修复重新加载NPC一个问题
3. 修复叠加物品价格计算错误
4. 修复报毒的问题

【2014-05-12 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe LoginSrv.exe
需要同时更新

1. 修复无极真气会叠加属性的问题
2. 修复一个叠加物品的问题
3. 修复聚灵珠超过设置等级时，还可以释放经验的问题

【2014-05-08 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe GuiEditDll.dll M2Server.exe LogDataServer.exe LoginSrv.exe
需要同时更新

1. 修复摆摊有假物品的问题
2. 修复合击，引擎的报错导致没有攻击威力
3. 修复战士使用连击技能时会少使用一个技能的问题
4. 修复行会公告编辑框不能移动的问题(公告编辑和封号编辑窗口做了修改，如果使用过UI编辑器编辑过这个的，需要对封号编辑窗口编辑一下)
5. 修复一些脚本命令调整极品属性不支持21亿的问题
6. 修复其他问题
7. 加强封挂能力
8. 增加商品购买叠加物品时可以输入购买数量(商业版支持)
9. 增加冰咆哮、灭天火的威力倍数控制
10. 增加登录器打开自动选择哪个区的功能(详见列表格式)
11. 修改解包配置文件支持解包数量设置(Envir\UnbindList.txt)

-------------------------------------------------------------------------------------------
列表格式:

[Server]
; 标题|服务器标题|服务器名称|服务器IP|服务器端口|是否自动展开(0不展开，1自动展开)|微端IP|微端端口(0表示不使用微端)|安全盾防火墙端口(0表示不使用防火墙)|防火墙类型，0=安全盾防火墙 1=风盾
0=电信服务器|热血传奇7008|传奇归来7008|127.0.0.1|7008|1|127.0.0.1|0|0
1=电信服务器|传奇归来7000|传奇归来7000|127.0.0.1|7000|1|127.0.0.1|0|0
[Setup]
公告地址=http://www.gameofmir.com
官方首页=http://www.gameofmir.com
客户服务=http://www.gameofmir.com
刷新速度=360
自动刷新=0

自动选择游戏区=电信服务器|传奇归来7000|传奇归来7000

;增加这里的输入前面三个名称，登录器打开就会自动选择这个区，如果只输入“电信服务器”就会自动展开“电信服务器”这一项
;例如：自动选择游戏区=电信服务器 就会自动展开“电信服务器” 输入完整的前面三个名称就会自动选择这个区
;为空时，当然就不会自动选择任何区。

-------------------------------------------------------------------------------------------

新的解包配置文件 Envir\UnbindList.txt 格式，兼容旧格式，升级新M2如果不需要修改解包数量的，可以不修改Envir\UnbindList.txt：

;物品DB字段Anicount的值 物品名称 解包数量 物品类型(0其他,1加红,2加蓝,3加红蓝,4卷轴)

100 强效金创药 6 1
101 强效魔法药 6 2
119 强效太阳水 6 3
120 万年雪霜 6 3
102 金创药(小量) 6 1
103 魔法药(小量) 6 2
104 金创药(中量) 6 1
105 魔法药(中量) 6 2
106 地牢逃脱卷 6 4
107 随机传送卷 6 4
108 回城卷 6 4
109 行会回城卷 6 4

-----------------------------------------------------------------------------------------------
很多人说，不能解包，或者乱吃包裹里的物品
这是由于捆绑DB设置错误或者Envir\UnbindList.txt这个文件配置错误导致的，
设置错误，会导致无法正常吃药、解包，及时雨内挂里保护里看不到吃药的物品
特别是其他版本转换过来的会出现这样的问题。

如果出现以上问题，可以使用启动器捆绑DB转换一下。如果还不能正常，就手动按照以下
规则修改你的DB。
-----------------------------------------------------------------------------------------------

捆绑物品的DB格式：

客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

-----------------------------------------------------------------------------------------------

【2014-04-30 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe GuiEditDll.dll M2Server.exe

1. 修复人形怪不爆物品的问题
2. 增加UI编辑器支持ui_common.wzl ui_n.wzl nselect.wzl(解决黑边的问题)
3. 增加添加行会成员时自动输入对面人物的名称
4. 增加非行会战区区范围设置(M2-功能设置-其他设置)

【2014-04-29 更新:】
本次更新文件 GameOfMir登录器生成器.exe 插件API代码

1. 更新客户端插件API代码，使用客户端插件需要使用新代码编译后才能支持新登录器

【2014-04-28 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复祈祷失效的问题
2. 修复183攻击计算错误
3. 修复物品修理价格计算错误
4. 修复@LeaveGroup触发失效的问题

【2014-04-23 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复自动解包的问题
2. 修复一些物品的价格计算错误

【2014-04-22 更新:】
本次更新文件 GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复TakeOnitem穿装备命令英雄使用时包裹还有残留
2. 修复CHANGEITEMADDVALUE命令的问题
3. 修复人物数据扩展工具4.exe转换后称号和可保存变量没有转换
4. 修复极品属性不能超过255的问题(M2-参数设置-游戏选项(1) 然后物品装备里的极品才可以支持255以上)
5. 修复攻杀剑术攻击超过21亿会出现负数的问题

【2014-04-21 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复属性的问题

【2014-04-20 更新:】
全套程序全部更新，需要同时更新。需要“人物数据扩展工具4.exe”扩展人物数据
先备份数据“Mir.DB”“HeroMir.DB”“Mir200\Envir\UserData”的数据
然后清除NPC缓存和武器升级数据，然后更新全套程序

1. 增加支持盾牌支持外观和盾牌外观特效(商业版支持,盾牌和武器不一样，不分男女，每一个盾牌需要600张图片就可以，补丁在程序包里)
2. 增加属性AC Mac DC MC SC支持21亿，支持人物、怪物、装备，装备极品属性(商业版支持)
3. 增加自定义特效是否分男女，也就补丁需要1200一组，还是600一组的特效图片(商业版支持)
4. 增加元素属性的暴击威力倍数和反弹威力倍数的控制(M2-选项-物品装备-新增属性)(商业版支持)
5. 增加自定义等级属性(商业版支持)
6. 增加网关日记记录
7. 修复一个使用物品的错误
8. 修复二次捆绑物品不能自动解包的问题
9. 修复使用封包触发脚本刷物品的问题
10. 修复套装防毒无效的问题
11. 修复其他BUG
12. 修改183攻击威力倍数物品的算法
13 修改定制功能绑定授权文件Key.db，在我这买过定制功能的，如果要使用新引擎，可以过来免费更换授权文件Key.db

【2014-03-28 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复无极真气不能升级的问题。
2. 修复内挂里的战士自动使用烈火、开天斩等有时候会失效的问题
3. 修复内挂挂机时，战士攻击速度会变慢的问题
4. 修复声望装备，声望不够时，不显示红色
5. 修复自定义技能一个问题
6. 修复人物加后缀封号后，内挂配置无法保存
7. 修复内功怪的问题
8. 加强商业登录器封挂能力
9. 增加一个禁止交易的地图参数NODEAL

【2014-03-19 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe

1. 修复上一版脚本命令DelayGoto失效的问题，只需更新M2，其他不需要更新。

【2014-03-18 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir引擎控制器.exe GameOfMir登录器生成器.exe GuiEditDll.dll M2Server.exe
需要同时更新

1. 修复诅咒术的问题
2. 修复人形怪挖物品的问题
3. 修复物品规则里禁止英雄使用的规则无效的问题
4. 修复<$DATETIME>显示错误
5. 修复武器特效，在使用连击时的问题
6. 修改无极真气的计算方式
7. 优化引擎可以长时间不重启，会导致宝宝叛变
8. 加快连击技能之间的停顿时间

【2014-03-12 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe GuiEditDll.dll M2Server.exe
需要同时更新

1. 修复一个复制装备的问题
2. 修复UI编辑一个问题
3. 修复噬魂沼泽的问题
4. 修复元素一个问题
5. 修复宝箱叠加物品的问题
6. 修复裂神符的问题
7. 修复怪物不走直线的问题
8. 修复自定义OK框，显示装备信息，只能是悬浮式显示(关闭悬浮可以在包裹下面显示)。
9. 修改CONFERTITLE命令
10. 加强商业登录器封挂能力
11. 增加自定义技能的强化技能的威力倍数设置
12. 增加行会成员的职位信息过滤
13. 增加一个多线程发送数据的选项(M2-选项-性能设置。以前引擎默认就是多线程发送的，多线程发送效率会高一些，但是CPU占用会高一些，在线人物不多想多开区的，可以关闭该选项)

新格式:
CONFERTITLE 巅峰战神 1 为1激活为当前使用的称号

【2014-02-22 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复元素的问题
2. 修复一些外挂封不了的问题，加强商业登录器封挂能力
3. 增加人物移动是否自动绕障碍物的选项(M2-选项-客户端设置-内挂控制)
4. 增加破防御是否开启的选项
5. 增加称号无需激活，属性也可以生效，详细查看说明书(原来的只有设置成当前的称号的那个称号的属性才会叠加到人物)。

【2014-02-18 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm 必备补丁(NewopUI.Pak) 合区工具.exe 数据管理.exe GameOfMir登录器生成器.exe M2Server.exe
需要同时更新

1. 修复怪物不爆物品(商业版引擎没有这个问题)
2. 修复全体模式不能攻击自己的宝宝
3. 修复称号一些问题
4. 修复聚灵珠加经验不触发@GetExp的问题
5. 修复AddAttacksabukAll攻城命令的问题
6. 修复合区工具一个问题
7. 修复登录器自动生成挂机点的问题
8. 增加数据管理可以对T变量和U变量值查看修改功能
9. 增加SCENEVIBRATION屏幕震动脚本命令(商业版支持)
10. 包裹增加整理包裹的按钮(如果不需要或者位置不对，可以在登录器配置的UI编辑里，对这个按钮坐标调整或隐藏)

屏幕震动命令格式:
SCENEVIBRATION 模式(0~4，0仅自己，1在线所有人，2屏幕范围内人物，3.当前地图上所有人 4.指定地图上所有人) 震级(1~3) 次数 地图ID(模式等于4时，需要该参数)

【2014-02-16 更新:】
全套程序全部更新，需要同时更新。需要“人物数据扩展工具3.exe”扩展人物数据
先备份数据“Mir.DB”“HeroMir.DB”“Mir200\Envir\UserData”的数据
然后清除NPC缓存和武器升级数据，然后更新全套程序

1. 修复动态IP的问题
2. 修复自定义OK框删除后不能立即消失的问题
3. 增加NPC远程脚本支持怪物爆率，支持脚本中的CALL的脚本远程(商业版支持)
4. 增加可以保存在人物数据库的字符变量T(0~49) 字符串长度最大1000(商业版支持,免费版可以使用，但是不能保存)
5. 增加可以保存在人物数据库的可保存数字变量U(0~49) 值的范围正负21亿(商业版支持,免费版可以使用，但是不能保存)
6. 增加称号功能(商业版支持，详见说明书)
7. 增加技能破防百分比(商业版支持)

【2014-01-18 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir引擎控制器.exe M2Server.exe GameOfMir登录器生成器.exe DBServer.exe
需要同时更新

1. 修复SETAUTOGETEXP脚本命令的问题
2. 修复SetSuckDamage脚本命令的问题
3. 修复ChangeModeEx脚本命令无法冰冻目标的问题
4. 修复会提示[RunDB] 保存人物数据超时...(需测试)
5. 修复M2查看在线人物，排序会报错的问题
6. 修复其他BUG

【2014-01-08 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm GameOfMir引擎控制器.exe M2Server.exe GameOfMir登录器生成器.exe GuiEditDll.dll
需要同时更新

1. 修复刷怪不准确的问题
2. 修复自定义技能一个问题
3. 修复UI编辑器读取自定义素材一个错误
4. 修复可以抗拒安全区的宝宝
5. 修复护身显示蓝血的选项不保存的问题
6. 修复其他BUG
7. 修改MonGenEx刷怪命令
8. 增加脚本命令OpenShopDlg打开个人商店窗口和打开商铺脚本命令OpenSndaShopDlg(商业版支持)

打开商铺脚本命令
[@main]
#ACT
OpenSndaShopDlg

----------------------------------------------------------
打开个人商店脚本命令

OpenShopDlg 类型(0所有商店列表 1我的商店列表)

[@main]
#ACT
OpenShopDlg 0

----------------------------------------------------------
脚本命令刷怪
格式:
MonGenEx 地图文件名称 X Y 怪物名称 范围 数量 是否内功怪物(0否,1是) 名称颜色(0~255) 国家名称(属于哪个国家的怪物，没有可以为空) 同一个国家玩家是否可攻击怪怪物(0不可以,1可以)
最后2个参数是国家怪物设置，如果没有可以留空

[@main]
#if
#act
MonGenEx 3 330 330 白野猪 12 10 0 255

【2014-01-03 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm 必备补丁(NewopUI.Pak) M2Server.exe GameOfMir登录器生成器.exe LogDataServer.exe
需要同时更新

1. 修复物品寄售时，金刚石不减的问题
2. 修改套装属性增加百分比的计算方式
3. 增加护身生效时，蓝血条显示(蓝血条在必备补丁里00177，商业版支持)
4. 增加走路和跑步触发
5. 日记服务器，增加一个日记查询

走路和跑步触发
QFunction-0

[@Run]
#SAT
你在跑步

[@Walk]
#SAT
你在走路

【2013-12-26 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe GameOfMir登录器生成器.exe
需要同时更新

1. 修复顶戴花翎的问题
2. 修复元素属性一个问题
3. 修复神秘人摆摊无法点击，无法打开自己的个人商店
4. 增加支持Hair3.wzl的斗笠
5. 增加支持Npc3.wzl Npc4.wzl。代码226~272,查看说明书
6. 增加登录器是否读取本地列表的选项

斗笠相关数据
StdMode = 16
Anicount 0戴上后显示头盔的内观 1戴上后不显示头盔的内观
Shape 0~7 Hair2
Shape 8~9 Hair3 目前Hair3只有2个斗笠，如果增加，Shape值依次增加就可以支持
Source 0时显示神秘人,Source=1时不显示神秘人 带斗笠后的"神秘人"效果对管理员无效.

神秘人显示可以在M2中设置-功能设置-其他设置

563;斗笠一;16;0;1;0;0;0;1188;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
564;斗笠二;16;1;1;0;0;0;1587;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
565;斗笠三;16;2;1;0;0;0;2080;6000;0;0;0;0;0;1;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
566;斗笠四;16;3;1;0;0;0;2081;6000;0;0;0;0;0;0;0;1;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
567;斗笠五;16;4;1;0;0;0;2422;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
568;斗笠六;16;5;1;0;0;0;2522;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
569;斗笠七;16;6;1;0;0;0;2768;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
570;斗笠八;16;7;1;0;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
571;斗笠九;16;8;1;0;0;0;3890;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
572;斗笠十;16;9;1;0;0;0;4266;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;

【2013-12-24 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm WIL编辑器.exe RunGate.exe M2Server.exe GameOfMir登录器生成器.exe
需要同时更新

1. 修复毒素武器的问题
2. 修复登录器一个误报问题
3. 修复登录器不释放插件的问题
4. 修复物理伤害减少无效的问题
5. 修复自动穿装备一个问题
6. 修复英雄一个问题
7. 重新编写物品寄售交易系统
寄售数据已经修改，更新M2后会自动升级老的数据，更新M2前先备份寄售数据，防止更新后的数据出现问题
寄售数据D:\MirServer\Mir200\Envir\UserData\UserData.dat
8. 修改顶戴花翎命令，增加一个速度参数，NPC和怪物的顶戴花翎同样增加一个速度参数
9. 增加套装属性支持上限和下限分别控制
10. 增加占领沙巴克触发

功能: 占领沙巴克触发

QFunction-0

[@GetCastleX] X表示城堡编号

[@GetCastle0]
#IF
#SAY
沙巴克已经被占领

SetIcon 位置(0-9) WIL文件序号 图片序号(0-65535) X(为空时默认X=0) Y(为空时默认Y=0) 播放张数(为空时默认张数=1) 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒)

【2013-12-16 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm WIL编辑器.exe M2Server.exe GameOfMir登录器生成器.exe
需要同时更新

1. 修复M2勾选麻痹允许使用魔法的选项无效的问题
2. 修复开通元宝交易时不提示的问题
3. 修复脚本命令MessageBox的问题
4. 修复内挂挂机捡物的问题
5. 修复千里传音信息不能有空格的问题
6. 修复WIL读取的问题
7. 修复其他BUG
8. 修改行会名称和沙巴克名称的长度限制60个字符
9. 优化登录器启动速度
10. 增加支持最新安全盾防火墙(旧的不在支持)
11. 增加个人商店和仿HeroM2摆摊的交易货币控制
12. 增加M2是否发送物品备注，套装备注，自定义怪物配置，自定义技能配置等
不发送时可以集成到登录器，可以减少登录游戏时的流量

【2013-12-04 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe

1. 修复火龙神的问题
2. 修复英雄，假人，人形怪不召唤宝宝的问题
3. 修改ChangeModeEx命令(12冰冻 13蛛网攻击 18麻痹攻击)
4. 增加聊天框上面一排按钮的整体坐标微调和聊天框微调

[@Main]
#ACT
ChangeModeEx 12 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标冰冻，冰冻机率5(数字越大机率越低)，冰冻时长3秒

ChangeModeEx 13 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标中蛛网，中蛛网机率5(数字越大机率越低)，中蛛网时长3秒

ChangeModeEx 18 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标麻痹，麻痹机率5(数字越大机率越低)，麻痹时长3秒

【2013-12-03 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe GameOfMir登录器生成器.exe GameOfMir引擎控制器.exe
需要同时更新

1. 修复一个怪物内存错误
2. 修复M2一个内存泄漏
3. 修复挑战一个问题
4. 修复登录器一个内存错误
5. 修复祖玛雕像类怪物苏醒缓慢的问题
6. 修复使用毒素或麻痹武器，攻击非敌对关系目标可以中毒或麻痹的问题
7. 修复内挂吃药提示超速
8. 修复自动回复的问题
9. 优化M2启动速度
10. 重新编写的内挂挂机(商业版支持保存挂机参数设置)
11. 增加182和183经验翻倍和攻击翻倍装备计算持久使用DB库的持久计算的选项
12. 增加爆物品数量的保存功能(M2-查看-列表信息一-怪物爆物品，商业版支持)
13. 增加DB库里的元素属性。使用最新启动器会自动检测并且创建元素需要的字段(商业版支持,Value1~Value20 字段分别对应元素)
14. 增加PASSWORDLCOKSYSTEM脚本命令。(M2-选项-功能设置-密码保护)
15. 修改ChangeModeEx命令(11~19新模式，商业版支持)

//格式: ChangeModeEx 模式(1-10) 时间(1-65535) 附加值(1-21亿)
//说明: 1=无敌 2=隐身 3=HP 4=MP 5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定
//第三个参数无敌,隐身,禁止攻击时没有使用.
//如果是禁锢时，第三个参数表示禁锢范围
//11 禁锢(释放一个类似困魔咒的光圈，敌对人物或怪物只能在这个圈子里移动，无法走出圈子外面，所有传送失效，不能小退)
//12 冰冻
//13 蛛网
//14 防麻痹
//15 防禁锢
//16 防冰冻
//17 防蛛网
//18 麻痹
//19 护身

[@Main]
#ACT
ChangeModeEx 11 10 3
SENDMSG 6 你被禁锢10秒

ChangeModeEx 12 10
ChangeModeEx 13 10

ChangeModeEx 14 10
SENDMSG 6 10秒内可以防麻痹

ChangeModeEx 15 10
SENDMSG 6 10秒内可以防禁锢

ChangeModeEx 16 10
SENDMSG 6 10秒内可以防冰冻

ChangeModeEx 17 10
SENDMSG 6 10秒内可以防蛛网

ChangeModeEx 18 10
SENDMSG 6 你被麻痹了

ChangeModeEx 19 10
SENDMSG 6 护身，有效10秒

【2013-11-18 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe GameOfMir登录器生成器.exe LoginSrv.exe
需要同时更新

1. 修复会提示超速创建帐号的问题
2. 修复会自定义怪物无视防御对怪物无效的问题
3. 修复CheckItemDura脚本命令错误
4. 修复地图参数Safe Fight 客户端不显示安全和战斗的图标
5. 修复自定义技能一些问题
6. 修复连击一个问题
7. 修复爆物品一个问题
8. 修复几处内存错误
9. 修复其他问题
10. 修改脚本命令StartAutoPlayGame，支持自动生成挂机点(商业版支持自动生成挂机点)
11. 修改其他细节
12. 增加Tab键获取角色名称的控制选项(选项-客户端设置-内挂控制)

内挂自动挂机使用说明：
使用快捷键CTRL+ALT+X或点击挂机按钮会触发QF里的[@StartAutoPlayGame]
停止挂机触发QF里的[@StopAutoPlayGame]

格式:
StartAutoPlayGame 参数1 参数2 参数3

参数1:挂机范围(挂机点以人物当前坐标生成范围)
参数2:2个挂机点之间的距离(登录器会根据该参数自动生成挂机点,该值可以控制挂机点的密度)
参数3:模式(0=需要用户设置挂机点，否则无法挂机，1=如果用户没有设置挂机点，会自动生成挂机点, 2=不管有没有用户有没有设置挂机点都会清空所有挂机点，然后自动生成挂机点)

[@StartAutoPlayGame]
#IF
CHECKMAPNAME 0
#ACT
SENDMSG 6 当前地图禁止挂机
break

#IF
#ACT
StartAutoPlayGame 100 60 1
SENDMSG 6 开始挂机，使用快捷键“CTRL+ALT+X”停止挂机

[@StopAutoPlayGame]
#ACT
SENDMSG 6 挂机结束，使用快捷键“CTRL+ALT+X”开始挂机

【2013-11-08 更新:】
本次更新文件 GameOfMir引擎帮助文档.chm M2Server.exe GameOfMir登录器生成器.exe DBServer.exe LoginSrv.exe NewopUI.Pak
需要同时更新

1. 修复聚灵珠杀怪不增加经验的问题
2. 修复SendCenterMsg命令替换模式无效的问题
3. 修复物品会爆到NPC脚下的问题
4. 修复会提示数据库服务器有时候会异常重启的问题
5. 修复@Reconnection命令的问题
6. 修复登录器一处内存泄漏
7. 修复内挂挂机的一个问题
8. 修复交易一个问题
9. 修复限时物品一个问题
10. 修复使用命令@ForcedWallconquestWar攻城的问题
11. 修复其他BUG
12. 增加捡取物品速度控制(选项-客户端设置-内挂控制)
13. 增加UI可以编辑交易人物名称和金币、包裹金币的坐标
14. 增加英雄包裹也可以使用聚灵珠
15. 增加自定义特效增加一个新的选项。用于一些特效图片大小不一样，导致绘制的效果走动的问题(例如：StateEffect.wzl 开始图片：720 张数：26)
16. 增加自定义召唤技能，重复召唤回到人物身边的选项
17. 增加分身术召唤间隔
18. 修改自定义怪物声音
19. 修改setautogetexp脚本命令(详见说明书)
20. 优化一些可能会导致出错的代码

【2013-10-30 更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
需要同时更新

1. 修复自定义技能一些问题
2. 修复内挂挂机登录器还是卡死的问题
3. 修复天使翼翅膀设置不保存的问题
4. 修复NPC商店的问题
5. 修复@KillSlave触发失效的问题
6. 修改CHANGEEXP命令

调整用户经验
CHANGEEXP 参数1(=,+,-) 参数2(经验值) 参数3(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)

【2013-10-26 更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe

1. 优化英雄、假人、人形怪智能
2. 完善自定义技能
3. 增加天使翼翅膀设置(M2-功能设置-其他控制)
4. 增加彻地钉攻击范围控制
5. 修复圣兽攻击效果错误
6. 修复内挂挂机登录器偶尔会卡死的问题
7. 修复IsHigh命令失效的问题
8. 修复其他BUG

圣兽一;140;54;270;48;1;0;1;350;0;25;20;25;30;0;0;20;30;0;1;0;0;
圣兽一1;141;55;271;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽二;142;54;272;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽二1;143;55;273;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽三;144;54;274;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽三1;145;55;275;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;

【2013-10-21 更新:】
本次更新文件 全套程序全部更新
必须同时更新，否则无法正常游戏

1. 修复自定义技能一个问题
2. 修复自定义OK框一个问题
3. 修复takecheckitem 命令无效

【2013-10-20 更新:】
本次更新文件 全套程序全部更新
必须同时更新，否则无法正常游戏

1. 增加动态IP功能
2. 增加龙影剑法和逐日剑法是否按键立即释放的选项
3. 增加自定义技能(M2-查看-列表二-自定义技能。免费版不能保存配置信息)
4. 优化脚本加载速度
5. 修改自动刷新列表时，不重复验证安全盾
6. 修复双IP多机负载的问题
7. 修复英雄的问题
8. 修复挑战一个问题
9. 修复启动器一个问题
10. 修复怪物血量的问题

【2013-10-12 更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe RunGate.exe GameOfMir引擎控制器.exe
必须同时更新，否则无法正常游戏

1. 优化脚本加载速度
2. 修复英雄连击的一个错误
3. 修复挑战一个问题
4. 修复启动器一个问题

【2013-10-08 更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe WIL编辑器.exe RunGate.exe GameOfMir引擎控制器.exe

1. 修复脚本加血的问题
2. 修复PNG格式加亮的问题
3. 修复WIL编辑器一个问题
4. 修复其他问题
5. 增加MMX类型支持绘制PNG格式图片
6. 增加聊天框、输入框、快捷物品框坐标微调控制(商业版)

【2013-09-28 更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
需要同时更新

1. 修复默认内挂卷轴小退保护失效的问题
2. 修复创建快捷方式方式的问题
3. 修复行会封号的问题
4. 修复自定义怪物一些问题
5. 修复速度的问题
6. 修复有时候会没有声音
7. 修复加亮太亮的问题
8. 修复英雄灭天火魔法数据库错误
9. 优化加载套装列表的速度
10. 修改自定义OK框，没有放入装备时，鼠标移动显示信息
11. 增加自定义怪物血条微调坐标
12. 增加自定义怪物攻击威力计算可以指定字段DC、MC、SC
13. 增加物品规则禁止捡取、下线必掉、丢弃消失
14. 增加分身术是否显示主人名称的后缀
15. 增加支持42亿血(商业版)
16. 增加装备属性悬浮框显示位置跟随鼠标(商业版)

-----------------------------------------------------------
自定义OK框

<ITEMBOX:N:F:M:X:Y:W:H:S:T>\
N=编号(0~7)
F=OK框的背景的WIL序号，-1时不绘制背景
M=OK框的背景的图片序号
X Y = 微调坐标
W=宽度
H=高度
S=允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品
T=未放入装备时，鼠标移动显示信息

[@main]
请放入需要升级的装备\
ITEMBOX:0:2:117:20:10:76:76:10,11:254#只允许放入衣服^251#www.gameofmir.com>\ \ \
<ITEMBOX:1:2:117:96:10:76:76:*:254#所有物品都允许放入^251#www.gameofmir.com>\

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

ReturnBoxItem (0~7)
OK框物品返回到包裹

自定义OK框放入物品后在当前NPC脚本中触发，X值为0~7
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

例:
[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \ \ \

<开始升级/@开始升级>\

[@开始升级]
#IF
;检测名称不等于空时OK框中有物品,也可以检测其他参数
NOT Equal <$BOXITEM[0].NAME>
#ACT
;关联到OK框物品 才可以使用脚本命令修改自定义OK框中的物品
SetUpgradeItem 0

;修改该OK框物品的名称颜色 -1表示是OK框
CHANGEITEMNAMECOLOR -1 253

;修改OK框物品星星数量 -1表示是OK框
CHANGEITEMUPGRADECOUNT -1 + 1

;刷新到客户端
UpDateBoxItem 0

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备

【2013-09-22 更新:】
本次更新文件 NewopUI.Pak M2Server.exe GameOfMir登录器生成器.exe 合区工具.exe
需要同时更新

1. 修复UI保存保存修改按钮失效的问题
2. 修复使用900 X 600分辨率的问题
3. 修复强化技能威力的问题
4. 修复纵横剑术的问题
5. 修复自定义OK框的一些问题
6. 修复合区工具合文本的问题
7. 修复英雄一些问题
8. 修复有的版本不读写的商店和武器升级数据的问题
9. 修复其他已知BUG
10. 修改龙影剑法按键即释放
11. 修改裂神符可以循环分裂
12. 修改属性点调整界面放到NewopUI.Pak 194
13. 修改仿HeroM2摆摊时，可以增减摆摊的物品，不需要停止摆摊在操作
14. M2-选项客户端设置-内挂控制-游戏速度做了修改，可以微调速度。以前会出现+1又太快-1又太慢的问题
15. 增加一些技能选项
16. 增加自定义OK框显示改名的常量<$BOXITEM[X].NAME_G>
17. 增加控制器是否允许登录器最大化的选项
18. 增加摆摊时头顶的信息，增加一个背景。放到NewopUI.Pak 103
19. 增加怪物等级显示(商业版)
20. 增加对M2中加速外挂检测做了修改(商业版)
21. 优化大型攻城时PK流畅性
22. 优化一些不稳定代码

【2013-09-17 更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
1. 修复上一版重新UI不保存的问题
2. 完善自定义OK框，增加2个命令。

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

ReturnBoxItem (0~7)
OK框物品返回到包裹

-----------------------------------------------------------
自定义OK框放入物品后在当前NPC脚本中触发，X值为0~7
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

例:
[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \ \ \

<开始升级/@开始升级>\

[@开始升级]
#IF
;检测名称不等于空时OK框中有物品,也可以检测其他参数
NOT Equal <$BOXITEM[0].NAME>
#ACT
;关联到OK框物品 才可以使用脚本命令修改自定义OK框中的物品
SetUpgradeItem 0

;修改该OK框物品的名称颜色 -1表示是OK框
CHANGEITEMNAMECOLOR -1 253

;修改OK框物品星星数量 -1表示是OK框
CHANGEITEMUPGRADECOUNT -1 + 1

;刷新到客户端
UpDateBoxItem 0

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备

【2013-09-16更新:】

本次更新文件 M2Server.exe GameOfMir登录器生成器.exe 合区工具.exe UpdateServer.exe
需要同时更新

1. D3D和MMX两种登录器代码完美合并在一起做成一个登录器
2. 增加施毒术和毒素武器威力叠加
3. 增加一键回收包裹物品的脚本命令
4. 增加脚本加密功能，M2内置无需插件(商业版)
5. 增加自定义OK框功能(免费版支持2个，商业版支持8个)
6. 增加常量当前组队人数<$GROUPMEMBERCOUNT>
7. 增加聊天框文字背景长度是否根据文字的长度绘制(M2-选项-客户端控制)
8. 增加NPC对话框文字坐标微调(M2-选项-客户端控制)
9. 增加NPC购买物品框文字坐标微调(M2-选项-客户端控制)
10. 增加个人商店一个返回按钮
11. 增加内挂挂机道士不躲避的选项
12. 增加微端客户端路径选项
13. 增加登录器上是否显示版本信息的选项
14. 修复几处可能会导致M2卡死的错误
15. 修复施毒术的问题
16. 修复合区工具，合英雄数据的问题
17. 修复登录器进度条有时候会消失的问题
18. 修复分身的问题
19. 修复英雄不使用灭天火的问题
20. 修复登录器绑定大补丁启动慢的问题
21. 修改冰咆哮的冰冻机率1000以上肯定不出
22. 为了兼容盛大新的mmap。修改Data\minimap\小地图从5001开始
23. 修改其他细节

【2013-09-10更新:】

本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
1. 修复登录器一个错误导致所有窗口打不开
2. 增加新技能声效

【2013-09-09更新:】

本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
1. 修复上一版界面荣誉控制失效的问题
2. 修复强化技能的错误

【2013-09-08更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe

1. 修复聚灵珠爆出来有经验
2. 修复开天斩的问题
3. 修复其他技能一些问题
4. 修复登录器不更新Pak的问题
5. 修复怒气不足时使用合击人物会卡住的问题
6. 修复备用列表失效的问题
7. 修复恢复人物界面看不见人物名称的问题
8. 修复界面荣誉不显示的问题
9. 增加Ctrl + 方向键 可以微调UI坐标
10. 增加新技能 纵横剑术、十步一杀、冰镰术、冰霜群雨、裂神符、死亡之眼(商业版)
11. 增加英雄支持连击(商业版)
12. 增加界面荣誉是否显示由M2控制

【2013-09-03更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe UpdateServer.exe
需要同时更新

1. 增加支持163微博远程列表，列表首尾需要$BEGIN $END关键字(商业版)
2. 增加聊天框背景颜色自定义(商业版)
3. 增加支持风盾防火墙
4. 修复英雄不掉装备的问题
5. 修复微端一个问题
6. 修复上一版出现的问题

【2013-09-01更新:】
本次更新文件 NewopUI.Pak DBserver.exe M2Server.exe GameOfMir登录器生成器.exe UpdateServer.exe 合区工具.exe 数据管理.exe 人物数据扩展工具.exe
需要同时更新

老用户需要使用人物数据扩展工具,扩展Mir.DB

1. 增加商业版登录器
目前免费版登录器和商业版登录器的区别是：1商业版自定义界面功能可以保存配置
2商业版登录器支持读取二次加密的Pak。需要购买Pak二次加密工具。
3商业版增加数字证书，防止杀毒软件误报
4免费版还和以前一样，无限制。商业版目前只多了上面三项功能，需要的可以购买商业版，不需要的可以使用免费版开区。
5以后会添加更多商业版功能

2. 增加Pak二次加密工具(收费工具，需要对素材要加密保护的用户使用)
3. 增加自定义界面功能(免费版登录器也支持，但不能保存配置)
4. 增加英雄升级经验控制选项
5. 增加魔法盾防御力威力倍数控制
6. 增加爆物品面积控制选项
7. 增加脚本死循环数控制选项
8. 增加行会初始人物上限控制选项
9. 增加登录器和微端支持自定义Resources目录名称
10. 修复获取远程列表时登录器有机率会出现假死
11. 修复微端一些问题
12. 修复CHECKITEMW的问题
13. 修复检测幸运脚本命令的问题
14. 修复烈火逐日攻击力的问题
15. 修复一些技能问题
16. 修复宝石升级一个问题
17. 修复自定义怪物物理攻击无视防御的问题
18. 修复其他BUG
19. 修改装备属性显示使用的分隔线.使用NewopUI.Pak中00046
20. 修改其他细节

【2013-07-30更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
需要同时更新

1. 增加召唤骷髅、召唤神兽、召唤月灵召唤间隔控制
2. 增加自定义怪物飞行魔法，16组和8组飞行魔法的选择。可以兼容Mon40里只有8组飞行魔法的怪物
3. 增加新爆率格式
4. 修复MMX登录器不能全屏登录的问题
5. 修复改变屏幕分辨率会修改屏幕刷新率的问题

【2013-07-26更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe

1 增加脚本命令CHECKTRANPOINT检测技能修炼点数 CHANGETRANPOINT调整技能修炼点数
2. 修复登录器强制16位色，有的机器改不了的问题
3. 修复双开时关闭一个游戏，会导致另外一个游戏出现问题
4. 修复机器码会重复的问题
5. 修复假人自动练功脚本命令失效的问题
6. 修复龙影剑法、雷霆剑法攻击力倍数不保存的问题
7. 修复装备刻名的选项不保存的问题
8. 修复英雄一些问题
9. 修复其他BUG
10. 优化登录器搜索传奇客户端规则

【2013-07-21更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe

1 增加非Direct3D技术的登录器，使用汇编MMX指令优化，简称MMX登录器，
可以在配置里选择配置。两种登录器功能完全一样。
Direct3D简称D3D，D3D登录器显卡越好速度越快，MMX登录器兼容性好。
2. 修复自动刷新列表，登录器出错的问题

【2013-07-13更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe
需要同时更新
1 增加登录器搜索到客户端时选择提示
2. 修复吃药不显示加血的问题

【2013-07-12更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe UpdateServer.exe
需要同时更新

1. 改进内挂自动挂机打怪功能
2. 修改自定义怪物动作不再固定10张图片
3. 修复聊天框信息颜色自定义一个问题
4. 修复个人商店一些问题
5. 修复微端时间长了会假死的问题

【2013-07-10更新:】
本次更新文件 M2Server.exe GameOfMir登录器生成器.exe

1. 增加脚本命令StopAutoPlayGame停止挂机
2. 改进内挂自动挂机打怪功能
3. 改进PLAYMAGICBALLEFFECT脚本命令

【2013-07-08更新:】
本次更新文件 NewopUI.Pak DBserver.exe M2Server.exe GameOfMir登录器生成器.exe UpdateServer.exe

1. 增加内挂自动挂机打怪功能
2. 增加法师道士物理攻击威力倍数
3. 增加脚本命令PLAYMAGICBALLEFFECT。播放界面的魔法球效果。
4. 自定义怪物增加半月攻击范围
5. 修复小地图雷达中自己显示错误
6. 修复微端的网关地址不保存
7. 修复怪物伤害封顶，中毒攻击不受控制
8. 修复DBserver.exe一个问题
9. 修复配置归来登录器，不能吃药的问题
10. 修复其他BUG

【2013-07-03更新:】
本次更新程序 M2Server.exe GameOfMir登录器生成器.exe 合区工具.exe UpdateServer.exe UpdateGate.exe

1. 增加微端支持多机负载
2. 增加地面改过名的物品消失后，从物品改名列表中删除该物品
3. 修复AddTextListEx命令错误
4. 修复假人在安全区来回走动的问题
5. 修复合区工具的问题
6. 修复机器意外断电后!Setup.txt文件被还原的问题
7. 修复没有学习刺杀，内挂开启走位刺杀也会砍出刺杀的效果
8. 修改CheckMapSameMonCount命令

【2013-06-28更新:】
本次更新程序 DBserver.exe M2Server.exe GameOfMir登录器生成器.exe 合区工具.exe 数据管理.exe

1. 重新编写了合区工具和数据管理工具，速度比以前快几倍
2. 增加支持QQ长微博远程列表，列表首尾需要$BEGIN $END关键字
3. 优化DBserver.exe
4. 优化个人商店
5. 优化英雄、人形怪、假人的CPU占用。AUTOGOTOXY假人使用这个命令很占CPU，尽量少用，行走距离短一点。
6. 修复会诱惑别人的分身的问题
7. 修复54~58的NPC只能跑步穿不能走路穿的问题
8. 修复非英文输入法时按“~”键，无法捡取物品。
9. 修复多处内存泄漏
10. 修复脚本死循环的问题
11. 修复看不到别人转向

【2013-06-16更新:】
本次更新文件 NewopUI.Pak RunGate.exe M2Server.exe GameOfMir登录器生成器.exe GameOfMir引擎控制器.exe
需要同时更新

1. 优化脚本执行速度
2. 增加自定义采集命令
3. 增加网关封机器码功能
4. 增加气血石按照最大持久的百分比的加血方式
5. 修改机器码读取CPU序列号
6. 修改血条可以自定义，在NewopUI.Pak文件中修改
7. 修改雷达颜色可以自定义，在NewopUI.Pak文件中修改
8. 修改1.76和1.85登录界面集成到NewopUI.Pak
9. 修复自定义怪物在安全区打人不掉血
10. 修复商铺刷元宝的问题
11. 修复<PlayImg>不读取WIL资源里的坐标
12. 修复斗笠不计算极品属性的问题
13. 修复狮子吼使用间隔时间不保存的问题

【2013-06-12更新:】
本次更新程序 DBserver.exe M2Server.exe GameOfMir登录器生成器.exe 合区工具.exe 数据管理.exe 人物数据扩展工具.exe

老用户需要使用人物数据扩展工具,扩展Mir.DB HeroMir.DB ShopItem.dat
启动前需要清理NPC物品缓存，武器升级记录

1. 修复自动开盾的问题
2. 修复连击的问题
3. 修复自定义怪物不攻击人物的问题
4. 增加护体神盾几个选项
5. M2--参数设置-游戏速度里增加2个新选项，如果发现卡，调整那2个参数

【2013-06-08更新:】
本次更新程序 DBserver.exe M2Server.exe GameOfMir登录器生成器.exe

1. 修复在@ItemDamage触发里获取不到该装备的名称
2. 修复M2乱报超速的问题
3. 修复只能是9点幸运才是最佳攻击状态
4. 修复及时雨内挂BOSS提示选项无效的问题
5. 修复登录器的背景图有的不能正常显示
6. 修复IsHigh脚本命令错误
7. 修复57类宝石属性显示不正确的问题
8. 修复战士转职后不小退，还能砍出刺杀的问题
9. 修复PLAYIMG播放特效会影响到IMG播放效果
10. 修复军鼓升星和附加属性不显示的问题
11. 修复其他BUG

【2013-06-04更新:】
本次更新程序 M2Server.exe GameOfMir登录器生成器.exe GameOfMir引擎控制器.exe UpdateServer.exe

1. 修复微端更新数据超过2G后出现负数的问题
2. 修复烈火等技能会不停的刷失败的信息
3. 修复修正GM管理模式在皇宫不提示攻城结束的问题
4. 增加纹理压缩文件配置
5. 增加及时雨内挂BOSS提示功能(玩家没有BOSS提示配置文件时，默认读取Data\BossHint.dat。一行一个怪物名称)
6. 增加启动其定时启动功能
7. 增加聊天信息监控(M2-选项-参数设置-信息控制)
8. 增加<$POWERRATE> 当前攻击力倍数 <$POWERRATETIME> 当前攻击力倍数剩余时间

改进脚本中使用图标功能

【2013-06-02更新:】
本次更新程序 DBserver.exe M2Server.exe GameOfMir登录器生成器.exe

1. 修复触发的问题
2. 修复排行榜问题
3. 修改蜡烛天气图层
4. 优化登录器内存占用

【2013-06-01更新:】
本次更新程序 DBserver.exe LoginSrv.exe M2Server.exe GameOfMir登录器生成器.exe WIL编辑器.exe UpdateServer.exe
需要同时更新

1. 帐号服务器增加注册帐号时的几个选项
2. 增加施毒人下线后，中毒人的毒是否失效的选项
3. 增加自定义怪物使用人物魔法可以使用强化技能效果
4. 增加CheckTakeOnItem、CheckTakeOffItem脚本命令，检测正在穿或脱下的装备，在穿脱装备触发里使用
5. 修复目标在移动时，魔法不容易攻击到目标的问题
6. 修复使用某些加密WIL会花屏的问题
7. 修复刺杀烈火，在高攻击力时计算错误的问题
8. 修复使用脚本命令学习刺杀，内挂开启刀刀刺杀需要小退才能生效的问题
9. 修复怪物破火墙攻击无效的问题
10. 修复人物在安全区会被宝宝挤出去
11. 修复宝石升级武器的问题
12. 修复有的机器设置技能快捷键失败的问题
13. 修复一些触发死循环导致引擎崩溃的问题(获取经验触发里调整经验，或者升级触发里调整等级等等会导致引擎崩溃)
14. 修复其他BUG
15. 修改红毒和绿毒提示信息进行分类
16. 修改CHECKCASTLEWAR支持检测城堡编号
17. 修改NPC标签备注支持自定义颜色，颜色和备注之间使用#号隔开
18. 优化微端

【2013-05-22更新:】
本次更新程序 M2Server.exe Rungate.exe DBserver.exe GameOfMir登录器生成器.exe
需要同时更新

1. 增加NPC标签备注功能
2. 增加中毒信息支持时间和伤害点显示
3. 修复聊天框信息自定义颜色的一个问题
4. 修复GM调整他人转生等级信息显示错误
5. 修复修复破护身属性失效的问题
6. 修复技能备注支持换行
7. 修复登录器一个报错信息
8. 修复关系系统的问题
9. 修复其他BUG
10. 优化M2启动速度

【2013-05-19更新:】
1. 修复升级的问题

【2013-05-18更新:】
1. 修复组队框和人物找回框显示不正常的问题
2. 修复由于检测程序是否被破解的错误，导致人物掉线的问题(长时间不更新的程序会出现)
3. 修改控制器清理全局变量的路径

【2013-05-16更新:】
1. 修复怪物自定义一些问题
2. 修复双击穿装备不会左右交替的更换的问题
3. 修复USEBONUSPOINT加点不准确的问题
4. 修复使用祝福油需要脱下来在戴上才能看到的问题
5. 修复合区工具一个问题
6. 修复斗酒的问题
7. 优化装备技能威力、套装技能威力、怪物自定义的配置文件的读取和保存速度
8. 优化内挂捡取物品过多，M2列表打开会卡一下的问题
9. 修改经验配置保存到Exps.ini，全局变量保存到GlobalVal.ini(升级M2前需要手动把!Setup.txt数据到新文件中)
10. 增加聊天框信息可以自定义颜色，只要信息是在聊天框中显示的都支持

【2013-05-12更新:】
1. 修复聊天框字体偶尔会出现乱码的问题
2. 重新编写了怪物自定义功能，以后盛大增加新怪物无需程序更新支持，可以直接在M2上编辑增加
可以参考程序包中的自定义怪物例子，已经编辑好的Mon36里面的全部怪物配置文件

【2013-05-09更新:】
1. 修复全屏切换后聊天框信息消失的问题
2. 修复最小化后左上角信息提示消失的问题

【2013-05-08更新:】
本次更新需要更新全套程序，否则无法正常游戏。

1. 增加怪物自定义特效和攻击。(M2-选项-怪物设置)
2. 增加人物复活QF脚本触发[@Revival]复活间隔变量<$REVIVALTIME>
3. 优化M2流量占用
4. 修复读取人物数据失败的问题
5. 修复获取经验值不正确的问题
6. 修复登录器报错的问题
7. 修复其他BUG

【2013-05-01更新:】
本次更新需要更新全套程序，否则无法正常游戏。
老用户需要使用人物数据扩展工具,扩展Mir.DB HeroMir.DB ShopItem.dat
启动前需要清理NPC物品缓存，武器升级记录

1. 增加53类宝石的气血石功能 Anicount=1,2,3 分别对应三种石头
2. 增加马牌和盾牌(不支持外观).马牌StdMode=28 位置代码=15 变量<$HORSE> 盾牌StdMode=48 位置代码=16 变量<$SHIELD>
3. 增加装备显示框，是否显示分割的线选项
4. 增加人形怪、英雄、假人可以使用逐日剑法和倚天辟地
5. 增加新的穿人穿NPC控制
6. 优化登录器
7. 修复清理尸体会把城墙尸体也清理了
8. 修复如果NPC物品缓存目录不存在，会不保存物品缓存的问题
9. 修复Shift+右键不会跑的问题
10. 修复百度空间远程列表问题
11. 修复跑步自动绕障碍物反应慢的问题
12. 修复其他BUG

【2013-04-27更新:】
1. 修复读取规则错误

【2013-04-26更新:】
1. 修复转向不灵活的问题(M2-参数设置-游戏速度-转向 控制)
2. 修复某些技能网关会提示加速的问题
3. 修复其他BUG

【2013-04-24更新:】
1. 修复攻击动作时间不能调整的问题
2. 修复中毒时间最大只能调到100秒的问题
3. 修复左手镯戴传送符无效的问题
4. 修改ISDUPMODE命令 格式:ISDUPMODE (0或空时检测所有对象，1只检测人物)

【2013-04-23更新:】
1. 增加体力魔法恢复，人物怪物分开控制
2. 增加保存人物复活间隔的选项(M2-功能设置-其他控制)
3. 增加扔物品触发@DropItemX和拣物品触发@PickUpItemX。X是物品数据库中对应的IDX.
4. 增加假人自动练功命令 格式:AutoUseMagic 技能ID 间隔秒。(必须是学过的技能，在非挂机状态，没有攻击目标的情况下才能正常练功)
5. 增加新的Wil、Wzl、Pak读取规则控制
6. 增加攻击动作时间控制
M2-选项-客户端设置-内挂控制，如果觉得攻击速度太快，M2报超速，可以调整该参数，参数设置为0时，和2013-04-23之前的版本速度一样
如果不想改动版本的速度，把攻击动作时间参数调整为0既可。
7. 修复WIL编辑器的问题
8. 修复下雪和花瓣画面变暗的问题
9. 修复ThrowItem命令范围错误
10. 修复假人速度会突然加速的问题

【2013-04-21更新:】
1. 增加盛大Npc2.wzl中最后15个NPC。代码:211~225
2. 增加检测组队人数的脚本命令 CHECKGROUPMEMBERCOUNT (<,>,=) 数量
3. 增加7200网关，是否开启检测登录器密码的选项
4. 增加连击登录器显示旧连击的界面的选项(旧连击界面暂时不支持内功连击)
5. 修改CHECKITEMADDVALUEEX命令，只检测附加属性AC MAC DC MC SC这5个属性
6. 修复GOTOLABEL范围触发的问题
7. 修复月灵报错的问题

【2013-04-18更新:】
1. 增加点击小地图自动寻路功能(可以在M2关闭或开启该功能，使用小地图按键或M键打开)
2. 增加怪物名称颜色自定义功能
3. 增加改名后的装备变量.例如衣服名称变量<$DRESS> 改名变量<$G_DRESS> 英雄的<$H.G_DRESS>
4. 修改装备属性框的文字描边
5. 修改断岳斩攻击为线性攻击
6. 修复杀怪后英雄获取不到内功经验的问题
7. 修复攻击后仰的问题

【2013-04-16更新:】
请同时更新全套程序，否则无法正常游戏

1. 兼容HeroM2命令ChangeHeroJob
2. 兼容HeroM2变量，扩展D和P变量。支持P0~P99 D0~D99
3. 登录器注册帐号，每次打开自动输入一个随机的生日
4. 增加装备升级触发,执行脚本功能.升级成功时执行@UpgradeOKX,升级失败时执行@UpgradeFailX,
属性被清除时执行@UpgradeClearX,其中X代表装备位置,例如:衣服=0,武器=1
5. 增加支持更换网关的命令@Reconnection
6. 增加包裹刷新速度控制(M2-功能设置-其他控制)
7. 修复野蛮的问题
8. 修复其他BUG

【2013-04-14更新:】
1. 修复及时雨内挂喝蓝药的问题
2. 修复英雄和人形怪刺杀会麻痹的问题
3. 修复卡魔法的问题
4. 攻击速度恢复以前的

【2013-04-13更新:】
1. 修复及时雨内挂自动解包的问题
2. 修复剔除离线挂机人物有机率会踢掉在线人物的问题
3. 修复月灵和英雄攻击分身的问题
4. 修复技能一些问题
5. 增加人形怪支持强化技能

【2013-04-11更新:】
1. 修复使用野蛮后地图名称消失的问题
2. 修复武器升级不破碎的选项勾上后，还有个可能会破碎的问题
3. 修复自动解包的一个问题
4. 修复顶号不提示的问题
5. 增加网关2个选项，用于加速检测
6. 增加调整装备升级次数的脚本命令(ChangeItemUpgradeCount 位置(0~15,-1时为OK框物品) (+,-,=) 次数(0~255))

【2013-04-10更新:】
1. 修复升级经验的问题
2. 修复分身术不计算装备属性的问题
4. 增加NPC常量杀怪经验倍数<$KILLMONEXPRATE> 时长<$KILLMONEXPRATETIME>
5. 增加毒素武器的2个控制(M2-功能设置-其他设置)
6. 增加包裹上是否可以直接显示元宝信息的选项

【2013-04-09更新:】
请同时更新全套程序，否则无法正常游戏

1. 修复登录器荣誉和国战荣誉的问题
2. 修复魔法锁定控制的问题
3. 修复分身术召唤的宝宝会攻击主体的问题
4. 修复帐号服务器的密码找回控制无效的问题
5. 修复equal命令的一个问题
6. 修复自动半月开启后，不会自动关闭的问题
7. 增加中毒后是否提示人物中毒的信息的选项
8. 增加检测装备的附加属性总和(武器的诅咒不在计算范围之内) 格式: CheckItemAddValueEx 位置(0-15) 操作符(> = <) 附加值(0-65000) 新属性(0,1)
9. 增加吃药恢复时间间隔控制
10. 增加体力恢复和魔法恢复间隔控制
11. 增加蜡烛是否随着持久的改变而改变亮度的选项
12. 增加物品规则增加 禁止商铺打折
13. 增加一个经验百分比控制,和经验够可连续升级控制。
14. 增加怪物说话支持%m 地图名称 %x=X坐标 %yY坐标
15. 增加人物英雄、升级、获取经验、获得物品的显示位置和文字颜色控制
16. 增加元素属性可以显示在人物属性框中(只可以在连击版登录器显示)
17. 增加可以控制连击版登录器中的，时装、称号、出战是否显示
18. 增加MapQuest.txt文件中怪物类,支持变量操作 例:F008 [089] 0 <$STR(S$4)> * Q004
19. 增加怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶
20. 增加怪物属性扩展：Envir\MonSpAbilList.txt，
格式：怪物名 忽视防御(0~100) 增加伤害(0~255) 伤害反弹(0~100) 物伤减少(0~100) 魔伤减少(0~100) 麻痹-几率-时间(0~1 0~10 0~10) 防麻痹(0~1) 防全毒(0~1) 防火墙(0~1) 防诱惑(0~1) 破复活(0~1) 破护身(0~1)
21. 增加毒素武器(兼容HeroM2) 使用方法:\Envir\UserData\PoisonWeapon.txt
格式: 武器名称 成功几率 减HP值 基本时间 扩展时间
成功率100以下时设置多少就是多少的成功率例如:80就是80%的成功率50就是50%的成功率
扩展时间是一个随即值,假如设置为10那么它的值就是1-10之间的值. 持续时间=基本时间+扩展时间所产生的随机值
例如:木剑 90 10 10 5

【2013-04-03更新:】
请同时更新全套程序，否则无法正常游戏

1. 修复野蛮后不能立即攻击的问题
2. 修复道士毒抢物品的问题
3. 修复CheckItemUpgradeCount命令无效的问题
4. 修复GetUserItemName命令无效的问题
5. 修复微端偶尔会卡死的问题(需测试)
6. 修复启动控制器无法清理帐号和人物数据的问题
7. 修改SendCenterMsg字体大小
8. 修改注册帐号长度限制在10
9. 增加野蛮不能使用时的提示信息的选项
10. 增加黄字信息的前缀控制
11. 增加扔叠加物品时，全部扔掉。不显示输入数量的对话框(功能设置-其他设置)
12. 增加物品的技能伤害和防御威力百分比功能，支持装备和套装
13. 优化假人和英雄
14. 更新插件API

【2013-03-29更新:】
1. 修复人物说话不显示名称的问题
2. 修复假人AUTOGOTOXY自动行走的问题

【2013-03-28更新:】
1. 增加军鼓变量<$DRUM>
2. 增加假人支持AUTOGOTOXY自动行走命令，目的地不能太远否则会失败
3. 增加跑步时可以自动绕障碍物
4. 增加人物死亡控制暴物品数量
5. 增加登录器分辨率控制
6. 修改点击游戏区，不在刷新公告
7. 修改可以启动多个不同的登录器
8. 修改人物下线后关闭个人商店，无法搜索到该商店的物品
9. 修改开启助跑,被攻击后仰后需要重新助跑
10. 修改蜡烛、火把的持久值为亮度，10000持久亮度为1最高亮度5，会根据持久的降低,降低亮度。
11. 修复诅咒术信息提错误
12. 修复购买商城物品失败时提示信息错误
13. 修复M2一个报错
14. 修复龙影剑法使用间隔不保存
15. 修复宝宝会被挤出安全区的问题
16. 修复传送符无效的问题
17. 修复安全区砍宝宝灰名的问题
18. 修复内挂被攻击开盾无效的问题
19. 修复地图参数NOTALLOWUSEMAGIC和NOALLOWUSEITEMS物品或魔法名称有括号时会失效
20. 修复神秘人说话和杀人时会出现真实名字
21. 修复其他一些问题
22. 优化英雄人形怪

【2013-03-18更新:】
1. 优化客户端微端更新速度
2. 改进KICK命令自动小退
3. 改进MAPEFFECT命令，后面在增加一个灯光亮度的参数(该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效)
4. 修复外挂检测误封的问题
5. 修复SCREENEFFECT命令失效的问题
6. 修复M2龙影剑法威力倍数无效的问题
7. 修复其他一些问题

【2013-03-13更新:】
1. 修复刺杀的问题
2. 增加千里传音的文字过滤

【2013-03-12更新:】
1. 修复使用THROWITEM命令，掉落物品提示错误的问题
2. 修复登录器登录偶尔会提示连接失败的问题
3. 修复套装系统先增加属性点再增加百分比的选项失效
4. 修复GM命令，增加技能报错的问题
5. 修复及时雨内挂吃蓝药不正常
6. 修复魔法盾技能等级越高防御反而越低
7. 修改套装物品只能输入50个汉字的问题
8. 修复技能使用的问题
9. 修复NPC商店购买物品不删除的问题
10. 增加所有GM命令支持英雄
11. 增加逐日剑法信息提示
12. 增加流星火雨使用间隔控制
13. 增加复活血量百分比控制
14. 增加获取用户自定义命令输入参数<$PARAM(0)> <$PARAM(1)> <$PARAM(2)> <$PARAM(3)> <$PARAM(4)> <$PARAM(5)> <$PARAM(6)>

【2013-03-08更新:】
1. 增加远程列表支持百度空间
2. 增加麻痹装备麻痹机率控制，护身装备掉蓝控制，复活装备复活间隔控制，
启动M2后在Envir目录，会生成3个文件ParalysisItemList.txt MagicShieldItemList.txt RevivalItemList.txt
3. 特效编号增加到65535个
4. 修改点击小地图透明切换
5. 修复WIN7~8使用CTRL+ALT+DEL，登录器会卡死的问题
6. 修复其他已知BUG
7. 修改远程列表加密格式

【2013-03-05更新:】
1. 修复宝宝或施毒术杀死怪物不触发[@KillMon]的问题
2. 修复购买NPC商店物品子项翻页无效的问题

【2013-03-03更新:】
1. 增加仿HeroM2国战系统
2. 修复地图参数FIGHT2不掉装备的问题
3. 修复地图参数NORANDOMMOVE随机石还可以使用的问题

【2013-02-28更新:】
请同时更新M2和登录器，否则游戏会出错
1. 增加狮子吼的使用间隔控制
2. 增加内挂开天斩自动使用控制
3. 增加千里传音、传音筒的使用间隔
4. 增加武器升级失败不破碎的选项
5. 修复保存杀怪经验倍数的选项无效的问题
6. 修复英雄刷装备的问题
7. 对内挂吃药做了修改

【2013-02-26更新:】
1. 野蛮和抗拒火环，目标位置不动的问题
2. 升级经验最高设置超过21亿报错的问题
3. 修复别人看不到自己吃药加血
4. 增加双击取回宝箱

【2013-02-20更新:】
1. 优化M2的CPU占用
2. 优化M2的流量占用(修复大型PK时会大卡的问题，流量只占原来的三分之一)
3. 增加内挂物品捡取、物品备注、套装备注直接在M2中配置
4. 改进变量使用规则。在脚本命令中使用变量时，有没有括号都可以正常使用。(注:自定义变量必须要括号 脚本命令:Mov Inc Dec Sum Equal如果第二个参数使用变量，也必须要括号)。
5. 增加物品掉落提示信息可以修改，在String.ini文件DropItemHint=物品[%Item]从[%Name]身上掉落在地图%Map(%X,%Y)处
6. 增加杀怪经验倍数可以保存
7. 修复反弹卡位的问题
8. 修复其他一些问题

【2013-01-03更新:】
1. 修复上版出现的所有问题
2. 增加一个脚本命令GOTOLABEL

【2013-01-02 更新:】

1. 对引擎核心做了大量优化改进
2. 仿HeroM2摆摊功能集成到引擎中，不再使用插件。摆摊QF触发也兼容HeroM2(M2-功能设置-个人商店)
3. 对游戏速度功能做了调整
M2-游戏参数-游戏速度中间隔控制。控制的是人物动作的频率，也就是二次动作之间的间隔。如果出现卡顿，需要调整这里的间隔参数
选项-客户端设置-内挂控制中的速度控制。控制的是人物动作开始到结束的速度。

4. M2-列表信息二中的数据不在保存到MDB数据库中(商铺、套装、特效等等要重新设置)
5. 改进套装系统
6. 改进物品特效
7. 改进变量使用规则。在脚本命令中使用变量时，有没有括号都可以正常使用。(注:自定义变量必须要括号)。

旧：
[@Main]
#ACT
GetListString ..\QuestDiary\数据文件\通缉名单.txt 1 <$STR(S$1)>
#SAY
<$STR(S$1)>

新：
[@Main]
#ACT
GetListString ..\QuestDiary\数据文件\通缉名单.txt 1 S1
#SAY
<$STR(S$1)>

7. 改进扩展字符变量S和数字变量N。需要在S或者N后面加符号$
8. 兼容HeroM2(详见说明书)
9. 修复若干BUG

【2012-11-30更新:】

功能增加：
1. 增加掉落物品提示文字颜色控制
2. 增加FIGHT2地图标志PK不加PK值
3. 增加脚本命令CHECKMAPDUMMYCOUNT检测地图假人数量

问题修复：
1. 修复了人物会被挤出安全区的问题
2. 修复了人物无弯腰动作打钩，PK看不见对方掉血

【2012-11-28更新:】

功能增加：
1. 增加套装可以直接增加属性点(兼容以前的百分比)

问题修复：
1. 修复了重新加载NPC后，M2会报发现非本地图角色的错误
2. 修复了仿HeroM2摆摊插件导致不能拆分叠加物品的问题(需要同时更新登录器和插件)
3. 修复了道士技能自动练功时不能自动毒符互换的问题
4. 修复了宝石升级的一些问题
5. 修复了CHECKMONMAP命令不支持变量的问题
6. 修复了仿及时雨内挂中英雄退出保护选项不受控制的问题
7. 修复了其他已知BUG

【2012-11-22更新:】

问题修复：
1. 修复了经验百分百显示不正确的问题
2. 修复了装备改名后套装备注不显示的问题
3. 修复了WIL编辑器图片花的问题
4. 修复了准确和敏捷超过255会变成1的问题
5. 修复了包裹刷新失败的问题
6. 修复了只显人名的情况下选择自己会看见别人的封号。

功能改进：
1. 优化引擎内存占用

【2012-11-19更新:】 需要在论坛单独下载

问题修复：
1. 多线程网关登录黑屏的问题

【2012-11-18更新:】

新增功能：
1. 增加同一坐标允许爆出物品数量的选项(功能设置-其他控制)
2. 增加NPC对话框字体黑色描边

问题修复：
1. 修复了宝石升级失败无提示的问题

功能改进：
1. 优化引擎CPU占用

【2012-11-16更新:】

新增功能：
1. 增加扩展Npc10.wil。Npc代码从1000

问题修复：
1. 修复了微端有时候会更新不了的问题
2. 修复了宝石升级失败，清除属性点机率低的问题
3. 修复了CheckSlaveInRange命令失效的问题

功能改进：
1. 修改摆摊名称太长的问题，并对名称进行过滤
2. 改进小地图扩展mmap10.wil从10001开始
3. 改进WIL编辑器和微端
4. 优化引擎CPU占用

【2012-11-13更新:】

问题修复：
1. 修复了登录器启动不了的问题
2. 修复了WIL编辑器导出Pak文件时空白图片导不出来的问题
3. 修复了大刀和弓箭手会攻击镖车的问题

功能改进：
1. 修改ThrowItem命令

【2012-11-12更新:】

新增功能：
1. 增加幸运发挥最高威力的选项
2. 增加Pak文件也支持微端更新(原来只支持Wzl文件，必须是2012-09-13以后更新的WIL编辑器创建的Pak文件才支持微端)
3. 增加Pak文件密码绑定登录器，需要配置登录器的时候设置Pak文件的密码否则登录器不能正常读取
4. 增加Wil Wzl Pak文件读取规则
5. 增加清除SendCenterMsg倒计时命令CLEARDELAYGOTO
6. 增加检测人物的吸收伤害

问题修复：
1. 修复了灵魂火符强化技能威力不正常的问题
2. 修复了聚灵珠释放经验不消失的问题
3. 修复了GiveMine默认权限为0的问题
4. 修复了技能一些问题
5. 修复了金刚石的名称在!Setup.txt文件中不保存的问题
6. 修复了宝石升级装备的一些问题
7. 修复了镖车无敌的问题

功能改进：
1. 升级宝石和军鼓冲突，军鼓的StdMode已由55改为65
2. 修改一些脚本命令不支持变量
3. 修改CheckPKPointEx检测PK点(原来检测的是PK等级)

【2012-11-06更新:】

新增功能：
1. 增加登录器数字签名解决报毒问题
1. 增加反外挂黑名单功能
2. 增加噬血术攻击威力倍数控制
3. 增加抗拒火环和气功波可以推动同等级的选项
4. 增加摆摊可以自定义名称

问题修复：
1. 修复了无极真气威力倍数无效的问题
2. 修复了寒冰掌不推动目标的问题
3. 修复了物品规则对摆摊插件的摆摊物品无效的问题
4. 修复了技能一些问题
5. 修复了上左下右4个方向鼠标点击范围偏窄

功能改进：
1. 改进DELTEXTLIST和ADDTEXTLIST命令支持双变量用法和CHECKTEXTLIST一样

【2012-10-31更新:】

新增功能：
1. 增加开启关闭客户端反外挂功能(管理-客户端模块白名单)
2. 增加自动上传白名单功能(管理-客户端模块白名单)

问题修复：
1. 修复了个别机器杀不死怪的问题

功能改进：
1. 优化英雄智能
2. 优化WIL编辑器批量导入的速度
3. 改进CHECKTEXTLIST命令，兼容旧的格式

【2012-10-28更新:】

新增功能：
1. 增加仿HeroM2摆摊功能插件(配置登录器需要使用最新的NewopUI.Pak)

问题修复：
1. 修复了英雄刺杀无威力的问题
2. 修复了英雄守护时不走向守护目的地问题
3. 修复了一处翅膀会变色的问题

功能改进：
1. 优化英雄智能

【2012-10-22更新:】

问题修复：
1. 修复了界面上多了个白点

功能改进：
1. 改进误报率高的问题

【2012-10-20更新:】

问题修复：
1. 修复了WIN764位系统误报

【2012-10-19更新:】

新增功能：
1. 增加客户端模块白名单功能(防止外挂误报。M2-管理-客户端模块白名单，把模块MD5值加入即可)
2. 增加易语言客户端插件API

问题修复：
1. 修复了M2文字过滤失效的问题
2. 修复了英雄的穿脱装备触发失效问题

功能改进：
1. 修改PLAYEFFECT、MAPEFFECT、SCREENEFFECT可以播放图片资源超过65535的WIL
2. 修改SCREENEFFECT

格式: SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 模式(0=自己，1=所有人) 播放效果(0=普通，1=魔法效果)

【2012-10-15更新:】

新增功能：
1. 增加施毒术和无极真气的参数控制
2. 增加客户端插件API

问题修复：
1. 修复了已知外挂误报的问题
2. 修复了挖肉时引擎一个报错

功能改进：
1. 降低M2的CPU占用

【2012-09-30更新:】

问题修复：
1. 修复了PlayEffect跑动时播放速度变慢的问题
2. 修复了M2启动时的一个错误
3. 修复了0血不死的问题
4. 修复了中毒翅膀变色的问题

功能改进：
1. 修改军鼓HP和MP的显示位置
2. 降低M2的CPU占用
3. 加强反外挂系统检测能力

【2012-09-18更新:】

新增功能：
1. 增加支持军鼓，需要在StdItems.DB中增加新的字段HP和MP，可以使用最新的游戏启动控制器自动增加这2个字段。
除了军鼓支持这2个字段，其他装备也支持

问题修复：
1. 修复了合区工具的一个问题
2. 修复了组队杀怪会重复触发的问题

【2012-09-13更新:】

新增功能：
1. 增加合区后的人物第一次登录的检测命令,该命令和检测是否是新人命令一样，只有第一次登录有效
2. 增加支持PNG通道

问题修复：
1. 修复了组队刷经验的问题
2. 修复了合区后有的人物无法登录的问题
3. 修复了归来国际新地图的问题
4. 修复了英雄不守护的问题
5. 修复了Mon19的问题

功能改进：
1. 去掉吃药超速的提示

[@Login]
#IF
ISNEWSERVER 1
#SAY
合区后主区人物登录
break
#IF
ISNEWSERVER 2
#SAY
合区后从区人物登录
break

【2012-09-07更新:】

问题修复：
1. 修复了由于增加新地图导致全屏切换卡死的问题
2. 修复了新地图瀑布不动的问题

【2012-09-05更新(优化测试版):】

新增功能：
1. 增加支持归来国际的新地图。
2. 增加徒弟出师后师父触发.Q-Function中@MasterOK
3. 增加引擎参数设置-游戏速度中增加几个新的选项，防止加速外挂控制失效。
4. 增加免助跑功能，内挂中无此选项，在M2中控制
5. 增加假人优先捡物列表

问题修复：
1. 修复了挖肉难的问题
2. 修复了毒死的怪物偶尔不爆的问题

【2012-08-31更新(优化测试版):】

新增功能：
1. 增加单个装备的爆率设置。

问题修复：
1. 修复了人物中毒翅膀不变色的问题
2. 修复了战士偶尔不攻击的问题

功能改进：
1. 放开登录器检测，可以给登录器加数字证书

【2012-08-30更新(优化测试版):】

问题修复：
1. 修复了挑战地图吃药引擎报错的问题
2. 修复了会出现假怪的问题

功能改进：
1. 优化通讯流量和内存

【2012-08-29更新(优化测试版):】

新增功能：
1. 增加禁止双烈火的选项。
2. 增加支持登录器补丁集成功能。
3. 增加治愈术恢复点数控制
4. 增加治金创药和魔法药恢复点数控制
5. 增加宝宝叛变时立即死亡的选项

问题修复：
1. 修复了合区工具的问题
2. 修复了登录器一个内存错误
3. 修复了刺杀的问题
4. 修复了<$SCATTERITEMNAME>捡取物品时不正确的问题
5. 修复了复活戒指偶尔不复活的问题

功能改进：
1. 优化通讯流量和内存

【2012-08-23更新:】

问题修复：
1. 修复了Race=108的怪物引擎会报错的问题
2. 修复了无法自动登录脱机人物的问题
3. 修复了登录器禁止多开失效的问题
4. 修复了安全区重叠人物不弹开的问题

【2012-08-18更新:】

新增功能：
1. 增加脚本检测命令取反NOT

问题修复：
1. 修复了商铺购买叠加物品不扣元宝的问题
2. 修复了远程脚本读取插件会加载失败的问题
3. 修复了M2中有个参数不保存的问题
4. 修复了由于下线触发挂机导致人物无法踢下线
5. 修复了远程列表显示乱序的问题

功能改进：
1. 修改刺杀攻击威力
2. 修改若干细节

【2012-08-13更新:】

新增功能：
1. 增加支持输入框标题自定义
2. 增加支持IP加速器
3. 增加易语言格式API
4. 增加人物下线关闭个人商店的选项(关闭后无法购买该商店的物品)

问题修复：
1. 修复了登录器透明皮肤在16位色有些花屏的问题
2. 修复了备用列表无效的问题

[@main]
输入框标题自定义\
<输入/@@InputInteger1(请输入元宝数量：)>\

[@InputInteger1]

【2012-08-08更新:】

新增功能：
1. 增加远程脚本读取插件
2. 增加一些脚本命令支持变量
3. 增加和修改引擎一些API

问题修复：
1. 修复了吃药后客户端不实时显示的问题
2. 修复了限制装备开始计时后，时间没有变化的问题
3. 修复了ADDTEXTLIST不能增加相同名称的问题
4. 修复了多线程网关导致CPU高的问题
5. 修复了人物死亡先出背景音乐才倒地
6. 修复了铸造物品里的机率不保存的问题

【2012-08-05更新:】

新增功能：
1. 公布引擎脚本加密插件和功能插件代码
2. 增加新的反外挂系统

问题修复：
1. 修复了一个怪物引起引擎报错的问题
2. 修复了SortVarToList“人物名称:变量值”这样保存
3. 修复了商铺购买叠加物品会给一个叠加满的物品
4. 修复了荣誉的问题
5. 修复了假人可以捡钱
6. 修复了装备改颜色后扔地上颜色不变的问题
7. 修复了21E血人物会死亡的问题

【2012-07-29更新:】

新增功能：
1. 增加重复召唤道士宝宝自动回到主人身边
2. 增加脚本命令SortVarToList
3. 增加师徒名称变量<$STNAME>

问题修复：
1. 修复了商铺物品重启后乱序的问题
2. 修复了离线挂机在上线包裹中有机率会出现属性乱套的装备
3. 修复了120类型怪物会走动的问题

功能改进：
1. 优化M2内存占用

【2012-07-27更新:】

新增功能：
1. 增加脚本命令删除内功DELETESKILLNG
2. 增加登录器配置文件名称自定义

问题修复：
1. 修复了捡取物品后延时一会才会消失的问题
2. 修复了特效坐标的问题
3. 修复了GETLISTSTRING的问题
4. 修复了假人的一些问题
5. 修复了人物走路检测格数太大的问题
6. 修复了红绿毒互换的问题
7. 修复了分辨率的问题

功能改进：
1. 优化M2通讯流量
2. 优化M2内存占用

【2012-07-23更新:】

新增功能：
1. 增加内挂中红绿毒互换的选项

问题修复：
1. 修复了套装属性HP超过256%会不正常的问题
2. 修复了看见别人杀死的怪物还是站着的问题
3. 修复了GETLISTSTRING第二个变量获取不到值
4. 修复了DELNPC不会立刻消失的问题

【2012-07-22更新:】

新增功能：
1. 增加脚本变量人物登录使用的分辨率。宽:<$SCREENWIDTH> 高:<$SCREENHEIGHT>

问题修复：
1. 修复了英雄血条不正常的问题
2. 修复了不能连续买物品的问题
3. 修复了人物视觉范围的问题
4. 修复了内挂默认设置有几个选项不正确的问题

功能改进：
1. 优化NPC脚本执行

【2012-07-20更新:】

新增功能：
1. 增加登录器支持显卡所有分辨率。
2. 增加登录器内挂默认设置。

问题修复：
1. 修复了套装备注显示的问题
2. 修复了叠加物品的问题

【2012-07-18更新:】

新增功能：
1. 增加合区工具支持合并文本功能。

问题修复：
1. 修复了播放怪物声音的错误。
2. 修复了Shape=154的衣服会有护身属性的问题
3. 修复了登录器默认拒绝接受行会喊话信息的问题
4. 修复了地图参数HITMON(@XXX)无效的问题
5. 修复了商店物品不翻页的问题。
6. 修复了MonGen.txt不能超过7个汉字的怪物
7. 修复了不能看到被攻击的人物等级
8. 修复了装备改名后套装备注不显示的问题
9. 修复了装备改名后地面物品捡取提示名称显示无效的问题
10. 修复了自动寻路一卡一卡的问题
11. 修复了英雄H.TAKE无效的问题
12. 修复了英雄或分身被弓箭手攻击不还击的问题
13. 修复了宝石升级的问题
14. 修复了人物走路检测格数太大的问题
15. 修复了内挂魔法加速太慢的问题

功能改进：
1. 人物死亡触发无需延时命令，可以直接使用复活命令复活
2. 改进套装显示方式和套装的男女识别
3. 捡到叠加物品自动叠加
4. 解包后的叠加物品自动叠加

例1. 223/套装名称|2|116/木剑|116/青铜头盔:253/攻魔道提升
例2. 223/套装名称=0|2|116/木剑|116/龙天魔甲:253/攻魔道提升
例3. 223/套装名称=1|2|116/木剑|116/凤天魔衣:253/攻魔道提升
例4. 223/套装名称|2|116/木剑|116/(龙天魔甲,凤天魔衣):253/攻魔道提升

例1 不检测性别
例2 男性套装
例3 女性套装
例4 根据鼠标选择的装备自动显示男女

【2012-07-10更新:】

新增功能：
1. 增加物品特效支持坐标。
2. 增加支持安全盾防火墙采集功能(需要配套防火墙)。
3. 增加支持登录密码功能，登录器和游戏网关密码相同才能正常登录。

4. 增加LineNotice.txt公告文件 字体颜色设置

5. 增加以下变量
<$KILLMONNAME>杀死怪物名
<$KILLMONX> 杀死怪物X坐标
<$KILLMONY> 杀死怪物X坐标
<$STATSERVERTIME> 显示M2启动时间
<$RUNDATETIME> 开区间隔时间

6. 更新反外挂特征码列表
7. 增加野蛮冲撞使用间隔控制
8. 增加装备掉持久倍率控制(选项-功能设置-其他控制)
9. 增加计时物品
限时物品带到身上开始计时,到期后必须在身上时才会自动消失.(每分钟检测一次)
物品Need=101时限时物品,NeedLevel=时间(分钟)
问题修复：
1. 修复了地图会出现假怪的问题(需测试)。
2. 修复了M2一个参数不保存的问题

功能改进：
1. 内挂中NPC名称显示控制,改由人物的名称显示控制
2. 登陆器顶部绿字信息，增加当前等级，升级经验，当前经验，元宝数量

【2012-07-02更新:】

问题修复：
1.修复了英雄不主动攻击的问题。

【2012-07-01更新:】

问题修复：
1. 修复了半月攻击力小的问题。
2. 修复了隔位刺杀会麻痹的问题。
3. 修复了地图怪物或尸体过多，杀怪不爆的问题。
4. 修复了地图连接有机率进不去的问题。
5. 修复了列表信息二-铸造物品无效的问题
6. 修复了英雄的一些问题
7. 修复了GetRandomText命令的一个问题
8. 修复了神秘装备的一个问题
9. 修复了WIL编辑器转换WZL格式的问题

【2012-06-25更新:】

新增功能：
1. 增加以下变量
<$HIT> 准确
<$SPD> 敏捷
<$HITSPD> 攻速
<$MapTitle> 取地图名称
<$USERID> 人物登录帐号
<$KILLER> 杀人者名字

2. 增加倚天辟地技能
3. 增加登录器皮肤支持导入png文件

问题修复：
1. 修复了使用连击M2有机率会产生一个报错的问题。
2. 修复了会员检测命令CHECKNAMEDATETIMELIST失效的问题。
3. 修复了顶戴花翎设置一张图片时不显示的问题。
4. 修复了地面物品名称有机率会产生乱码的问题。
5. 修复了QMapEvent触发中使用SENDMSG %s显示错误
6. 修复了人形怪的一些问题
7. 修复了多机负载的一个问题

功能改进：
1. 功能: 打开一个自定义NPC对话框

【2012-06-18更新:】

需要更新全部程序否则不能正常登录

新增功能：
1. 增加兼容HeroM2脚本命令 CheckItemBind SetItemBind CheckItemState SetItemState GiveStateItem
2. 增加玩家机器码变量 <$MACHINEID> <$USERMACHINEID>

问题修复：
1. 修复了荣誉值不保存的问题。
2. 修复了英雄的一些问题。
3. 修复了假人的一些问题。
4. 修复了数字飘血的问题。

功能改进：
1. DEC对字符型变量操作命令。
2. MOV命令做了一些改进。

<$MACHINEID> 机器码，和登录的角色无关，只要是该机器登录的角色，这个机器码就一样。
<$USERMACHINEID> 该机器当前登录的角色的机器码。不同的角色名称或不同的机器登录生成的机器码不一样。

配合以下命令可以限制角色登录游戏

CheckTextList 文件位置 字符串
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串

增加脚本命令
CheckItemBind,检测物品是否已经绑定
格式:CheckItemBind 装备位置(-1~13,-1时为OK框中物品)
增加脚本命令
SetItemBind,设置物品和人物绑定 绑定后物品属性会显示“已绑定”
格式:SetItemBind 装备位置(-1~13,-1时为OK框中物品) 绑定(0-1)
说明:参数2 0=取消 1=绑定

增加:CheckItemState SetItemState GiveStateItem命令,
功能:给予带绑定状态装备。主要方便设置不能配带的装备绑定状态
格式:GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6(0为正常,1为绑定)

;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备

功能：设置装备绑定状态。
格式：SetItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-5) 属性(0为正常,1为绑定)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出
功能：检查装备绑定状态
格式：CheckItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-5)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出

【2012-06-16更新:】

新增功能：
1. 增加兼容HeroM2脚本命令 CheckHeroJob CheckHeroOnline CheckInWarArea TakeOn TakeOff ChangeHeroLevel ChangeHeroPkPoint

问题修复：
1. 修复了NPC名称使用变量的问题。
2. 修复了仿及时雨内挂免负重没有效果的问题。
3. 修复了鼠标左键点起英雄装备,再点右键,装备就假消失的问题。
4. 修复了英雄的一些问题。
5. 修复了CHANGEPULSELEVEL报错的问题。
6. 修复了登录器皮肤是否透明控制无效的问题。
7. 修复了登录器界面使用大图片显示不全的问题。

【2012-06-11更新:】

问题修复：
1. 修复了一个轻客户端更新的问题。

【2012-06-09更新:】

新增功能：
1. 增加WIL编辑器PAK、WIL、WZL相互转换的功能
2. 增加轻客户端更新密码功能

问题修复：
1. 修复了内挂页面控制错误的问题。
2. 修复了输入框粘贴的问题。
3. 修复了经络打通的问题
4. 修复了<%Item>无效的问题
5. 修复了WIL编辑器导入BMP文件失真的问题

【2012-06-06更新:】

新增功能：
1. 增加边下边玩轻客户端功能
2. 增加登录器搜索客户端条件设置
3. 增加WIL编辑器支持WZL编辑功能
4. 增加转生等级变量:<$RELEVEL>

问题修复：
1. 修复了新界面有个地方会挡住大装备的问题。
2. 修复了声望不保存的问题。
3. 修复了ThroughHum命令无效的问题
4. 修复了偶尔会卡位问题
5. 修复了戴上蒙面面巾头盔不显示的问题

功能改进:
Weapon.wzl Shape 1~99

【2012-05-26更新:】

新增功能：
1. 增加备用远程列表地址

问题修复：
1. 修复了刺杀的问题。
2. 修复了连击的问题。
3. 修复了ThroughHum命令无效的问题

【2012-05-22更新:】

新增功能：
1. 完善内挂中自定义快捷键功能

问题修复：
1. 修复了连击的一些问题。
2. 修复了心灵启示不能看血条的问题。
3. 修复了杀怪不能获取经验的问题。
4. 修复了高等级负重会出现负数的问题。
5. 修复了英雄会攻击弓箭手和大刀的问题。
6. 修复了1000以后经验设置不正确的问题。
7. 修复了装备属性越高价格越低的问题。
8. 修复了关闭隔位刺杀还会隔位刺杀的问题。
9. 修复了ChangeHumAbility 减属性无效的问题。

【2012-05-21更新:】

新增功能：
1. 增加开启第四个连击技能的命令

问题修复：
1. 修复了客户端一个内存错误。
2. 修复了英雄数据不保存的问题。
3. 修复了其他已知BUG。

【2012-05-20更新:】

更新后请先使用人物数据扩展工具进行数据扩展后才可以正常运行

新增功能：
1. 增加盛大新人物属性界面(配置的时候选择连击版才会显示)，酒馆、双英雄、内功、连击。
2. 增加新怪物支持Mon23~35。

问题修复：
1. 修复了一个不能解包的错误。
2. 修复了多线程网关一个内存错误。
3. 修复了其他已知BUG。

【2012-04-07更新:】

新增功能：
1. 增加宝箱功能。

问题修复：
1. 修复了查看别人时斗笠显示错误。
2. 修复了多线程网关一个错误。
3. 修复了M2一些参数不保存的问题。
4. 修复了学习背包里面的技能书，点确定，会向前走一步。
5. 修复了登录网关和角色网关一个错误。
6. 修复了NPC显示变量过多显示不出来的问题。
7. 修复了传奇归来不显示物品的问题。
8. 修复了其他已知BUG。

功能改进：
1. 地图参数NORANDOMMOVE可以使用瞬息移动

【2012-03-31更新:】

问题修复：
1. 修复了多线程网关一个错误。

【2012-03-30更新:】

新增功能：
1. 增加斗笠。

问题修复：
1. 修复了套装属性包裹不显示的问题。
2. 修复了黑夜功能无效的问题。
3. 修复了ChangeModeEx命令中的隐身无效的问题。
4. 修复了多线程网关会自动关闭的问题(需测试)。
5. 修复了其他已知BUG。

功能改进：
1. 改进个人商店(需要使用新的NewopUI.Pak 配置登录器)

【2012-03-28更新:】

新增功能：
1. 增加多线程网关测试版(启动器里需要重新配置一下，在启动器里选择多线程网关)。

问题修复：
1. 修复了会卡住的问题。
2. 修复了神秘装备在包裹中也可以看到属性的问题。
3. 修复了排行榜只能显示第一页的问题。
4. 修复了物品掉落会提示怪物名称显示数字的问题。
5. 修复了其他已知BUG。

【2012-03-22更新:】

新增功能：
1. 增加编辑器支持WZL格式。

问题修复：
1. 修复了会卡住的问题。
2. 修复了RepairALL命令无效的问题。
3. 修复了抗拒火环可以推开同等级的玩家的问题。
4. 修复了刺杀强化空砍没有强化的效果。
5. 修复了登录器自动更新的问题。
6. 修复了叠加物品出售价格的问题。
7. 修复了其他已知BUG。

【2012-03-18更新:】

问题修复：
1. 修复了M2一个错误。
2. 修复了新建组按钮无效的问题。
3. 修复了176版包裹物品显示有些错位的问题。
4. 修复了NPC名字调用变量的问题。

【2012-03-15更新:】

问题修复：
1. 修复了飓风破的问题。
2. 修复了宝石升级的问题。
3. 修复了怪物名称显示错乱的问题。
4. 修复了TAKE命令收回叠加的问题。
5. 修复了个人商铺中Looks大于10000的物品不显示属性的问题。

【2012-03-14更新:】

新增功能：
1. 增加飓风破。

问题修复：
1. 修复了食人花绘制错误的问题。
2. 修复了僵尸Race;95 从地下钻出来后留下的洞显现缓慢的问题。
3. 修复了装备等显示有点错位的问题。
4. 修复了TAKE命令收回叠加的问题。
5. 修复了其他已知BUG。

【2012-03-04更新:】

新增功能：
1. 增加登录验证码功能，在LoginSrv.exe中控制关闭。
2. 增加月灵与召唤圣兽是否可以同时召唤的选项。
3. 增加脚本命令GetOppositeHumName。
4. 增加脚本命令CheckNationCredit
5. 增加一个新游戏点<$GAMEGOLDEX>。

问题修复：
1. 修复了解毒术锁定怪物的问题。
2. 修复了ESC键会关闭英雄左上角窗口问题。
3. 修复了噬血术强化4-6重会卡一下的问题。
4. 修复了逐日剑法技能点不增长的问题。
5. 修复了其他已知BUG。

功能改进：
1. 修改使用宝石装备升级提示方式
2. 修改人型怪属性根据DB数据库中设置防御 魔防 攻击 道术 魔法。
3. 修改checkitem命令支持检测叠加物品
4. 修改加载安全区挂机人物,安全区随机坐标登录

【2012-02-26更新:】

问题修复：
1. 修复了怪物偶尔会有错乱的顶戴花翎。
2. 修复了人形怪不会读取顶戴花翎的问题。
3. 修复了及时雨内挂重复音乐控制无效的问题。
4. 修复了一处内存泄漏

【2012-02-22更新:】
问题修复：
1. 修复了自动脱装备AutoTakeOffItem 装备位置 无效的问题。
2. 修复了查看别人装备时不看不见头盔发光效果。
3. 修复了地图参数中播放音乐，内挂的重复音乐控制无效的问题

功能改进：
1. RepairAll 操作命令改为检测命令修理全身装备时，检测修理需要的金币

【2012-02-18更新:】
问题修复：
1. 修复了套装失效触发[@GroupItemOffX]不触发的问题。
2. 修复了内挂不显示保护的物品。

【2012-02-16更新:】

新增功能：
1. 增加诱惑之光的设置。
2. 增加烈火剑法设置。
3. 增加及时雨内挂中玩家自己输入药名。
4. 增加杀死人物宝宝时触发[@KillSlave]
5. 增加脚本命令检测杀死的宝宝的名称CheckKillSlaveName
5. 增加脚本命令检测是否是指定行会的成员CheckGuildMember
6. 增加脚本命令改变人物宝宝名字颜色.ChangeSlaveNameColor 格式: ChangeSlaveNameColor 宝宝名字 颜色(0-255)
7. 增加脚本命令增加限次使用物品的次数.AddFunItemDura
8. 增加GM命令给定指定纯度的矿石.@GiveMine
9. 增加地图参数 REVIVALREVIVAL(X:N) 当前地图人物可复活的次数,
X表示复活次数,N表示人物在当前地图已经复活次数的自动清零间隔(最小30秒).具体表示:每经过指定秒人物在当前地图复活过的次数自动减1.
10. 增加地图参数 NODROPUSEITEMS 当前地图人物死亡不掉落身上的物品
11. 增加地图参数 NOSAFEPOSITIONMOVE 禁止在当前地图安全区中使用传送戒指
12. 增加GM命令给定指定纯度的矿石.@GiveMine 数量 纯度

功能改进：
1. playsound和playmusic命令修改 文件位置 循环次数 播放模式(0播放给自己,1播放给全服,2播放给同一地图,3播放给同一行会,4播放给同屏人物)
2. ChangeSpeed 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间)
3. 套装生效触发[@GroupItemOnX],套装失效触发[@GroupItemOffX],英雄对应[@HeroGroupItemOnX],[@HeroGroupItemOffX] X表示套装序号
4. 人型怪HP和MP按DB中数据设置

问题修复：
1. 修复了装备攻击速度无变化的问题。
2. 修复了雷霆剑法的问题。
3. 修复了内挂背景音乐重复播放的问题。
4. 修复了移行换位会锁定怪物的问题。
5. 修复了转换性别发型的问题。
6. 修复了除法、乘法、百分比脚本命令的问题。
7. 修复了传奇续章界面药框界面错位的问题。

【2012-02-08更新:】
修正交易完成后负重不变的问题
修正ChangeNationCredit脚本命令
修正毒死怪物，物品不会掉落
增加TakeOnItem和TakeOffItem脚本命令支持变量
TakeOnItem <$STR(S$3)> 12
TakeOffItem <$STR(S$3)> 12

增加地图参数SAYLEVEL(等级),可限制当前地图人物说话等级.
增加地图参数DELDROPITEM,人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).

【2012-02-08更新:】
修正交易完成后负重不变的问题
修正ChangeNationCredit脚本命令
修正毒死怪物，物品不会掉落
增加TakeOnItem和TakeOffItem脚本命令支持变量
TakeOnItem <$STR(S$3)> 12
TakeOffItem <$STR(S$3)> 12

增加地图参数SAYLEVEL(等级),可限制当前地图人物说话等级.
增加地图参数DELDROPITEM,人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).

【2012-02-05更新:】
修正群毒消耗计算错误
修正宝石升级的问题,支持装备加星
修正CHECKVAR和CALCVAR脚本命令
修改GROUPMOVE和GROUPMAPMOVE脚本命令
修正其他已知BUG
增加变量清除功能(管理-文件管理)

;只有组长，才可以使用
GROUPMOVE 地图号 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)
GROUPMAPMOVE 地图号 X Y 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)

增加脚本命令

命令 ClearItemMap
功能:清理地图上指定名字的物品.
格式:ClearItemMap 地图 坐标X 坐标Y 范围 物品名字
说明:物品名字等于*时表示指定范围内的所有物品.

ChangeNationCredit
调整人物的荣誉值

AddGuildMemberCount
功能: 调整当前行会的人数上限.说明: 只能由行会老大使用.
每个行会会自动读取!Setup.txt中的行会人数限制,
之后可以用此命令重新调整行会人数限制,也就是说调整后不受!Setup.txt中行会人数限制参数的限制.
格式: AddGuildMemberCount 操作符(+ - = ) 数量(0--1000)

格式：Gotonow X坐标 y坐标 [地图名]自动寻路
注：地图名可省略，加上后引擎自动判断人物当前地图是否相同。

【2012-01-15更新:】
出现问题时：
(1)请首先检查你出现问题的全套程序和登录器是不是我们最后更新的。
(2)检查是不是脚本写错了或引擎没设置好，可以搜索说明书和更新记录。
(3)还没有解决问题，可以到论坛或找技术求助。
修正挖不到高品质肉
修正登录器公告不显示的问题
修正宝石升级问题(需测试)
修正有机率卡住的问题(需测试)
修正英雄装备绘制遮盖的问题
修正其他已知BUG
增加以下功能
点击界面帮助按钮触发

功能: 改变人物公聊时的文字信息颜色.

功能: 杀死怪物时触发

【2012-01-10更新:】
修正血条绘制错误
修改人物死亡可以点击NPC
修改人物命令@TestStatus增加第三个参数,1时提示,0不提示.例如:Gmexecute TestStatus 5 1
增加私聊等级显示控制(选项-参数-信息控制)
增加以下脚本命令

增加技能检测

功能: 改变当前人物的穿人,穿怪模式.

功能: 组队相关触发.

功能: 装备持久消失时触发,位置0-12

【2012-01-07更新:】
修正火墙时间计算错误
修正掉落物品提示的问题
修正降级导致血条绘制错误

【2012-01-05更新:】
此次更新程序 IPLocal.dll HeroM2Convert.exe M2Server.exe GameOfMir登录器生成器.exe 请同时更新否则不能正常游戏

修正滚动命令无效
修正点住自定义NPC对话框会闪的问题
修正IP插件无效的问题
修正ChangeItemName脚本命令的问题
修正全屏登录没有声音的问题
修改若干细节
增加ESC关闭所有打开的窗口

【2011-12-30更新:】
此次更新程序 M2Server.exe GameOfMir登录器生成器.exe 请同时更新否则不能正常游戏

修正使用NORANDOMMOVE地图参数，还可以使用瞬息移动的问题
修正登录会闪一下的问题
修正MMAP1.WIL调用小地图无效
修正极品提示只有一个方向
修正其他已知BUG
修改自动放药方式

增加装备持久为0时是否消失选项
增加火墙的时间和威力倍数控制
增加掉落物品提示规则
增加脚本命令(兼容HeroM2)
OFFLINEPLAY
GETSTRINGPOS
SENDCENTERMSG
ChangeItemName

功能: 新的装备改名

功能: 在专用登录器屏幕的中间显示公告.

【2011-12-26更新:】
此次更新程序 M2Server.exe GameOfMir登录器生成器.exe 请同时更新否则不能正常游戏

修正一个卡的问题
修正机器人使用THROWITEM命令M2报错的问题
修正流星火雨秒怪的问题
修正内挂不显示地上的勋章和四格物品的名字
修正HeroM2Convert转换工具的一个错误(转换Hum3.wil错误)
修正其他一些细节
增加小地图mmap1.wil(800~999)
增加支持读取Graphics放在Resources目录里
增加火墙换地图消失
增加脚本命令(兼容HeroM2)
ForbidMyShop
CheckMine
TakeMine
CheckHeroCount
SetSuckDamage
SetHeroSuckDamage

CheckMine
功能: 检测背包中物品的纯度(持久,品质).
格式: CheckMine 物品名称 数量(1-45) 纯度(1-65)

例子: 检测背包中是否有5个纯度20的黑铁矿石,并且回收.
[@main]
#IF
CheckMine 黑铁矿石 5 20
#ACT
TakeMine 黑铁矿石 5 20
#SAY
背包中有5个纯度20的黑铁矿石.
#ELSESAY
没有.

检查人物当前召唤了几个分身

SetSuckDamage

说明:设置人物可吸收收到的攻击伤害.
格式: SetSuckDamage 操作符(+ - =) 总吸收直(1-2000000000) 吸收比例(1-1000) 成功率(1-100)
吸收比例 1=0.1% 500=50% 1000=100%
例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%

SetHeroSuckDamage
说明:设置英雄可吸收收到的攻击伤害.
格式: SetHeroSuckDamage 操作符(+ - =) 总吸收直(1-2000000) 吸收比例(1-1000) 成功率(1-100)
吸收比例 1=0.1% 500=50% 1000=100%

【2011-12-24更新:】
此次更新程序 M2Server.exe GameOfMir登录器生成器.exe 请同时更新否则不能正常游戏

修正一个黑屏问题
修正挑战传送的问题
修正SENDMSG发送的信息不能包含空格的问题
修正CheckLuckPoint检测幸运不正确的问题
修正M2在64位系统不能运行的问题
修正内挂部分按钮不能控制的问题
增加脚本命令清除附加属性ClearStoneUpgrade

【2011-12-23更新:】
此次更新程序 M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏
修正已知BUG
增加HeroM2版本转换工具
增加挑战功能(兼容HeroM2)
增加宝石升级系统(兼容HeroM2)

增加支持
武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在传奇目录的\Graphics\Weapon\
衣服放在\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil

兼容HeroM2脚本命令，增加或以下脚本命令
CHECKKILLMONNAME
CHECKHITMONNAME
CHECKOFFLINE
CHECKITEMNAMECOLOR
KILLBYHUM
CHECKRANDOMNO
CHECKFOUNDRYITEM
CHECKGUILDMEMBERCOUNT
CheckUpgradeItemName

OFFLINE
SENDTOPMSG
CHANGESLAVELEVEL
SETHUMATTACKMODE
GETLISTSTRING
GETUSERITEMNAME
GETCALLMOB
KILLCALLMOB
ADDATTACKSABUKALL
CHANGEITEMNAMECOLOR
SETRANDOMNO
GIVEFOUNDRYITEM
SHOWFOUNDRYITEM
CHALLENGMAPMOVE
GETCHALLENGEBAKITEM
CREATENPC
DELNPC
PLAYMUSIC
OpenUpgradeDialog
SetUpgradeFail

【2011-12-20更新:】
此次更新程序 RunGate.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏
增加仿及时雨内挂
增加登录器支持盛大wzl新格式读取
修正登录器会卡死的问题

新格式读取说明:
以读取Prguse.wil为例，
先读取Resources\Data\Prguse.pak,如果Resources\Data\Prguse.pak不存在,读取Data\Prguse.wil,如果Data\Prguse.wil不存在,读取Data\Prguse.wzl。

【2011-11-18更新:】
此次更新程序 DBServer.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正套装列表错乱的问题
修正GETITEMADDVALUE和CHANGEITEMADDVALUE命令不能使用变量的问题
增加脚本命令RecallSelf召唤自己的分身

【2011-11-16更新:】
此次更新程序 RunGate.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正矿石纯度越低价格越高,纯度越高价格越低
修正GIVE命令给叠加物品的问题
修正其他已知BUG
增加白天黑夜时间点控制
增加人形怪可以挖物品选项
补丁规律查看
动态地图连接查看
脚本使用图标功能查看
检查当前地图中的人物是否属于同一行会

【2011-11-12更新:】
此次更新程序 GameOfMir专用WIL编辑器.exe RunGate.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正WIL编辑器转换大WIL文件时出错的问题
修正使用CHANGEMODEEX锁定后还可以走的问题
修正NPC对话框中所有包含“<>”或者“{}”的总会比原本的字符稍微长一点点
修改网关封加速，误封率下降
增加登录器配置可以自定义客户端核心文件名称
增加IP所在地禁止登录列表D:\MirServer\Mir200\Envir\DenyIPLocalList.txt
增加支持“<>”里再次使用变量

例:

[@main]
<调整颜色{FCOLOR=<$STR(G0)>}/@调整颜色>\

变量S<$STR(G0)>值:<$STR(S$<$STR(G0)>)>\

[@调整颜色]
#IF
large G0 255
#ACT
MOV G0 0
GOTO @MAIN
#ELSEACT
INC G0 1
GOTO @MAIN

【2011-11-09更新:】
此次更新程序 LoginSrv.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正登录器显示天气效果时内存占用高的问题
修正聚灵珠的问题
修正收取重叠物品的错误
修正NPC彩色字体
增加数据管理工具
增加支持个人商店数据合区
增加假人配置文件中自动捡物的参数

【2011-11-03更新:】
此次更新程序 DBServer.exe LoginSrv.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正英雄穿装备的问题
修正物品"死亡必爆"规则无效的问题
修正穿脱装备不触发的问题
修正176登录器的一个错误
修正其他已知BUG
M2增加一个新的反加速外挂功能,使用外挂触发QFunction-0脚本里[@UsePlugin]字段
增加禁止免蜡功能天气效果(免费版不支持)
增加假人功能(免费版限制登录10个假人)
修改SETICON脚本命令，增加播放效果参数。人物设置NPC和怪物的顶戴花翎也相应的修改NPC和怪物设置
外挂触发字段外挂触发
更新NewopUI.Pak补丁

NewopUI.Pak 说明：
如果不使用个人商店功能，可以清空NewopUI.Pak中104~163的图片
如果不使用禁止免蜡功能，可以清空NewopUI.Pak中210~215的图片
这样可以减小登录器的大小

【2011-10-24更新:】
修正使用16位色登录游戏时，个别机器会出现白块的问题
修正M2关闭内挂，人物说话不显示的问题
修正其他已知BUG
修改PLAYSOUND命令支持循环次数 PLAYSOUND 文件路径(不能有空格) 循环次数
优化资源读取速度
增加NPC和怪物支持顶戴花翎功能NPC和怪物设置

【2011-10-18更新:】
此次更新程序 游戏启动控制器.exe LoginGate.exe SelGate.exe LoginSrv.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正读取Weapon2.wis的问题
修正使用大NPC对话框调用PAK文件的问题
修正内挂保存配置文件的问题
修正人物死亡地图不是灰色的问题
修正双线一区配置的问题

修改GETRANDOMLINETEXT命令
修改MAPEFFECT命令
格式: MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0普通 1特效)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

【2011-10-13更新:】
此次更新程序 游戏启动控制器.exe LoginGate.exe SelGate.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正不能双开游戏的问题
修正全屏切换后物品显示不正常

【2011-10-12更新:】
此次更新程序 游戏启动控制器.exe LoginGate.exe SelGate.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正使用NPC彩色字体时排列不正确的问题
修正地图触发时脚本命令无法对人物进行操作的问题
修正战士使用技能的问题
修正小退会出现无法认证的问题(小退速度过快导致的)
修正英雄召唤神兽的问题
修正其他已知BUG
增加双线一区配置功能
增加聊天记录过滤按钮的控制
增加特殊命令的控制
增加反外挂特征码功能
使用外挂触发QFunction-0脚本里[@UsePlugin]字段

【2011-10-04更新:】
此次更新程序M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正月灵的问题
修正技能护体神盾施放后不加点问题
修正群体施毒术不自动换毒符
的问题
修正CheckRangeHumCount命令报错
增加登录器获取列表失败时，提醒用户是否重新获取
增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始
增加补丁读取

【2011-10-01更新:】
此次更新程序DBServer.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正M2强化技能的一个报错信息
修正CheckHumInRange命令报错
修正英雄技能书的问题
修改若干细节
修正一些其他问题
优化客户端，CPU占用下降，流畅性提高

【2011-09-25更新:】
此次更新程序LogDataServer.exe DBServer.exe M2Server.exe GameOfMir真彩登录器生成器.exe 请同时更新否则不能正常游戏

修正M2一个报错信息
修正英雄一些问题增加忠诚度
修正群毒无效的问题(需要更换我们提供的技能数据库)
优化引擎数据传输速度
增加极品装备属性点数更加详细的控制
增加日记服务器日记查询功能
增加人物找回功能
加快小退的速度
修改若干细节
修正一些其他问题

【2011-09-18更新:】
修正地图禁止使用物品和魔法无效的问题
修正挖肉的一个问题
修正会秒杀人物的问题
修正偶尔死亡不触发的问题
修改176版交易物品属性显示样式
加快人物的后仰速度
增加魔法锁定范围的选项，在技能魔法选项里，可以提高锁定精度，防止人物跑动时，打不到人物
修正一些其他问题

【2011-09-08更新:】
修正有的机器登录器自动更新完成后不能自动打开新登录器的问题
修正获取最高等级可能产生的内存错误
修正英雄打怪的时候，不跟着人物回城
修正英雄包裹的问题
修正一个卡技能的问题
修正读取WIS文件一个错误
修正挖肉时会导致包裹里肉的品质下降的问题
修改176仓库物品属性显示样式
加快小退的速度
限制输入框输入文字的长度
修正其他一些问题

【2011-09-05更新:】
修正角色名有拖尾的问题
修正魔法锁定神兽，神兽变身后，解锁的问题
修正地图事件触发的一些问题
修正176版本戴不上传音筒
修正英雄升级不能正确显示等级
修正CHECKNAMEDATETIMELIST命令过期记录自动删除的问题
OPENUPGRADEDLG做了一些改进
输入框做了一些改进
增加个人商店出售物品和仓库数量限制
增加地图参数ALLOWUSEMYSHOP允许使用个人商店，没有该参数的地图只能搜索查看，无法出售购买存仓操作
增加个人商店物品规则设置
增加人形怪爆物品机率的设置
增加使用魔法触发QFunction脚本 [@MagicX] X表示魔法ID
增加最高等级限制

【2011-09-02更新:】
修正一个会产生地图产生白块的问题
修正英雄增加魔法命令的问题
修正内挂的一些问题
修正CheckStringlength的问题
修改ADDTOCASTLEWARLIST脚本命令
修改攻击触发兼容HEROM2
增加爆物品触发
更新说明书

格式：CheckStringlength 字符串 检测符(<,>,=) 位数

;============================================================

格式: ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为空时所有行会加入到攻城列表) 天数(几天后开始攻城，该参数可以为空，为空时按照引擎设置的天数)

[@main]
#ACT
ADDTOCASTLEWARLIST 沙巴克 1

魔法和物理攻击触发

地图事件配置详解 必须在M2-选项-功能设置-基本设置-启用地图事件触发勾上才有效

【2011-08-29更新:】
修正装备特效造成地图产生白块的问题
修正人形怪不爆包裹装备
修改M2内挂的一些控制方式

【2011-08-23更新:】
修正交易看不到对方名称
修正死亡复活后关闭背景音乐
修正脚本命令SENDMOVEMSG无效的问题
修正脚本命令SENDTOPCHATBOARDMSG无效的问题
修正脚本命令OPENUPGRADEDLG可能会产生复制装备
修正删除不了物品特效的问题
修正客户端一些绘图错误。
修正开门会闪的问题
修正读取某些资源会产生CPU高的问题
修正内挂自动吃药的一个问题
修正包裹物品偶尔刷新不正常的问题
修正仓库偶尔存取不正常的问题
修正隐身翅膀也隐藏了
修正其他若干BUG
修改一些细节

【2011-08-11更新:】
修正登录器有开门动作时，角色选择界面不显示职业等级
更新说明书

【2011-08-10更新:】
修正地图连接的一个问题
修正定时器的问题
内挂中增加怪物名称显示的选项
登录器配置器增加是否显示开门效果的选项

修正新属性的设置没有保存，导致无法爆出有新属性的装备
修正个别机器全屏登录失败的问题
修正战士没有强化技能效果
修正野蛮冲撞，会触发反外挂系统
修正一些老地图会花屏的问题
修正连续玩几个小时后，由于程序释放内存太慢，造成卡的问题
修正脚本命令CHECKNAMEDATETIMELIST和ADDNAMEDATETIMELIST
修改若干细节
修正其他已知BUG

【2011-08-04更新:】
修正看不见弓箭手射的箭，包括弓箭手和祖玛弓箭手等等怪物。
修正可以同时召唤骷髅和神兽。M2增加一个选项，可以选择是否可以同时召唤
修正移动加速无效的问题
修改装备显示的一些细节
增加WIL编辑器支持PNG和TGA文件的导出和导入
-------------------------------------------------------------
新增兼容HERO的命令或功能
QManage.txt中增加一个新的脚本段[@Startup],此脚本段只在服务器开启后执行一次.

-------------------------------------------------------------
增加脚本命令ChangeModeEx
-------------------------------------------------------------
增加脚本命令MoveMapPlay 原地图 新地图 X Y
把某个地图中的玩家全部移动到另外一个地图.
#IF
#ACT
MoveMapPlay 0 3 333 333
#SAY
地图0中的人物已经全部移动到地图3中.

-------------------------------------------------------------
应用户要求重新修改以下素材读取

【2011-08-02更新:】
开放登录器的必备补丁修改的。提供专用的WIL编辑器，支持设置密码功能
增加各职业一些技能的细节控制
增加暴击的魔法效果
增加护体神盾、乾坤大挪移、擒龙手、召唤圣兽、召唤月灵等技能
扩展物品数据库物品名称支持到30个字符
扩展怪物数据库怪物名称支持到30个字符，扩展HP和MP字段支持到21亿
优化客户端数据处理
修改装备备注支持颜色设置
修正人物死亡屏幕效果
修正套装显示的错误
修正装备加速无效的问题
修正登录器在有的情况下会初始化失败
修正流星火雨和噬血术效果错误
修正其他已经BUG
装备及套装备注说明

【2011-07-28更新:】
优化登录器核心
增加道士可以直接使用包裹中毒符选项
增加千里传音和传音筒文字颜色控制
增加浏览器地址可以在M2自定义
增加内挂中自动吃药的物品可以在M2上控制
增加各职业强化技能
增加套装显示备注
修正技能幽灵盾和神圣战甲术没有符飞行的效果
修正重新加载NPC后，QFunction-0 字段触发引擎会报错的问题
修正脚本命令CHANGEEXP,调整的经验值不正确的问题
修正内挂中物品过滤框向下滚动按钮点不了的问题
修正关闭背景音乐，登录的时候会响一秒的问题
修正读取Wis文件会花屏的问题
修正反外挂误封的问题
修正一些技能没有声效的问题
修正人形怪和英雄装备攻击翻倍没有效果的问题
修正PlaySound脚本命令无效的问题.例: PlaySound Wav\1.wav
修正叠加物品会暴出很多个
修正自动行走有人挡着无法行走的问题
修改内挂中隐藏尸体只隐藏怪物的尸体
修改以下素材读取

强化技能说明:

CHECKSKILL 魔法名称 检测符(+,-,=) 等级 是否检测强化技能(0或为空时为技能等级,1为强化技能等级)
SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)
例：
[@main]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

【2011-07-15更新:】
更换老版的网关，多线程网关会造成卡的问题。
修正脚本命令MAPEFFECT。在地图上播放特效，不能控制播放次数的问题
修正脚本命令CHANGEITEMADDVALUE，修改成功后不能立即显示的问题
修正客户端背景音乐 MUSIC(Wav\music1.mp3)，放到地图参数中。(目录名称和音乐文件名称不能有空格)
修正自动练功速度快了，会触发反外挂系统
修正装备显示的BUG

【2011-07-12更新:】
修正人物属性下限不正常的问题
修正抓屏会卡一下的问题
优化素材载入速度
优化播放音效造成CPU过高的问题
增加装备显示附加属性,可以在M2上控制是否显示
增加脚本命令CHECKITEMADDVALUE,检测物品的附加属性值
增加脚本命令CHANGEITEMADDVALUE,修改物品的附加属性值
增加脚本命令GETITEMADDVALUE, 获取物品的附加属性值

CHECKITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 < > =) 值
CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 + - =) 值
GETITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) 保存变量

【2011-07-09更新:】
修正英雄血量不正常的问题
修正没有魔法时还在自动使用技能
修正创建人物界面显示的一些问题
修正一些图片显示不正常的问题
修正个别机器对纹理压缩支持不好的问题（会造成有的按钮不能点的问题）
修正右键不能开关组的问题
修正命令GuildNoticeMsg无效的问题
修改登录器搜索客户端算法,提高搜索客户端的速度
增加登录器自动记录最后一个游戏区，下次打开的时候，自动选择上次最后登录的区
增加登录器自动记录最近登录的游戏区
增加登录器自动刷新远程列表功能
增加脚本命令ChangeHumAbility
增加脚本命令SetStringBlank

调整人物属性.
格式: ChangeHumAbility 属性(1-12) 操作符(+ = -) 效果(1-65535) 时间秒
说明: 属性1-10分别对应人物 防御下限 防御上限 魔御下限 魔御上限 攻击下限 攻击上限 魔法下限 魔法上限 道术下限 道术上限 MaxHP MaxMP
注意:调整后的属性效果只在人物在线时有效.
不带时间为在线一直有效

例子:
#IF
#ACT
ChangeHumAbility 2 + 10 60
#SAY
你的防御上限增加10点.60秒后恢复

功能: 给字符串在前面或者后面增加指定个数的空格.
格式: SetStringBlank 变量(S,A) 长度(1-100) 格式(0, 1)
说明: 可支持人物S变量或者全局A变量,格式0=前面,1=后面
注意: 第二个参数长度是指增加空格后整个字符串的长度,例如字符串GameOfMir引擎长度是9,
如果第二个参数设置1 那么实际增加6个空格.
注意: 英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

例子:
[@main]
#IF
#ACT
MOV S10 GameOfMir引擎
SetStringBlank <$STR(S$10)> 15 0
SendMsg 5 <$STR(S$10)>

MOV S10 GameOfMir引擎
SetStringBlank <$STR(S$10)> 15 1
SendMsg 5 <$STR(S$10)>

【2011-07-07更新:】
更新引擎帮助文件
增加自动登录离线挂机人物
使用DBServer导出数据，导出的文件保存到X:\MirServer\Mir200\Envir\AutoLoadOffline.txt
然后在M2操作-控制-加载脱机人物
增加装备旧的显示模式
修正5600端口不能修改的问题
修正SENDCENTERMSG 命令无效的问题
完善WebBroser命令，使用客户端内置浏览器打开网站

【2011-07-03更新:】
增加脚本命令SetIcon，在人物头顶显示一个头像。
增加摆摊控制命令[@ShopStall]

【2011-07-01更新:】
增加客户端装备显示框可以在M2上控制
增加免费版可以增加5个WIL文件(用于装备特效)
增加支持900 * 600宽屏分辨率
重新制作的内挂，M2可以详细控制,支持隔位刺杀，走位刺杀等等
增加脚本命令 CHECKNEWITEMVALUE 检测装备新增属性
增加登录器上分辨率选择和窗口模式选项
增加吃药间隔控制(选项-参数设置-游戏速度)
修正快捷键退出游戏时会弹出2次对话框
修正纹理压缩模式时，按钮有时候无法点击的问题
修正人物属性框中，某些衣服会挡着项链戒指等装备

例：
CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 检测符(>,<,=) 值(1-100)
属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

【2011-06-20更新:】
增加脚本命令改变人体颜色支持0~255中颜色
SETBODYCOLOR 颜色(0~255)255时清除颜色 改变时长(秒)

增加脚本命令改变人物状态
MAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 其他无效) 时间(秒) 威力

例：
#ACT
MAKEPOSION 5 10 10
#SAY
你被麻痹了

【2011-06-19更新:】
增加界面按钮的显示控制，可以在M2设置是否显示
增加人物或怪物的等级，HP,MP最高支持到21亿,在M2参数设置-游戏选项(1)
修改装备发光特效，可以使用脚本命令SETITEMEFFECT控制

增加装备以下新属性

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

增加脚本命令：

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

;设置装备发光特效
SETITEMEFFECT 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 特效编号(0-255,0为清除特效)

【2011-06-09更新:】
修正延时公告坐标不正确的问题
修改176版的登录背景音乐
修改装备显示方式
修改个人商店的一些细节
增加启动控制器数据备份功能
增加新沙巴克的资料
增加Alt + R 刷新包裹
增加每个行会限制最高成员的功能

;检测行会最高成员
CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示检测自己所在的行会) 检测符(<,>,=) 数量
;调整行会最高成员
CHANGEGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示调整自己所在的行会) 调整符(+,-,=) 数量

<$GUILDMEMBERMAXLIMIT> 显示你的行会最高成员数

【2011-06-05更新:】
修正CHECKUSERDATE报错的问题
修正个人商店的问题（程序包有详细脚本）
修正客户端内存一个错误
修正客户端播放声音的内存泄漏
修正1.76版，双击戴不了毒符的问题
修正右手镯偶尔戴不上的问题
修正内挂隐藏尸体无效的问题
增加毒符的持久比例(功能设置-技能魔法)

【2011-06-02更新:】
修正数字飘血关闭不了的问题
修正仓库物品取不了的问题
修正行会窗口错误
修正交易信息文字错位
修正装备持久信息显示错误
修正数据库服务器刷新排行榜的错误
修正其他已知BUG
增加窗口模式下，可任意拖动窗口，改变窗口大小

【2011-05-26更新:】
完善所有NPC
兼容HeroM2增加脚本命令

格式: GuildNoticeMsg 255 233 发送自定义颜色的文字信息. Self

参数一是前景颜色,参数二是背景颜色,参数三是要发送的文字信息,参数四等于'Self'时只发送给自己, 等于'Group'时发送给组队,
等于'Map'时发送到当前地图中的人物.如果省略参数四表示全服发送.

支持的参数: %s(玩家名字) %d(NPC名字) %m(地图名字) %x%y(坐标)

;MESSAGEBOX支持确定和取消触发
MESSAGEBOX 是否确认要删除 @确定 @取消

[@确定]
点击的确定

[@取消]
点击的取消

;指定人物触发字段
HCALL 人物名称 触发字段

;自动穿装备
AutoTakeOnItem 装备名称 装备位置

;自动脱装备
AutoTakeOffItem 装备位置

;获取文本字符
GetRandomText 文件路径 变量

;定时触发
DelayCall 时间毫秒 触发字段

;检查是否在某地图
ISONMAP 地图名称

;打开自定义NPC对话框
OpenBigDialogBox WIL文件编号 图片编号

;关闭自定义NPC对话框
CloseBigDialogBox

;复活
Relive

;检测宝宝是否在指定范围
CheckSlaveInRange 宝宝名称 范围

;检测指定范围内的人物数量
CheckRangeHumCount 地图名称 X Y 范围 (<,>,=) 数量

;检测人物是否处在地图的某个范围之内
CheckHumInRange 地图 坐标X 坐标Y 范围(0 -- 500)

;检测城堡是否正在攻城
CHECKCASTLEWAR 沙巴克

【2011-05-23更新:】
增加数字飘血功能
美化装备显示框
增加个人商店功能.拍卖，无限仓库，摆摊功能的合并
修正已知BUG

【2011-05-08更新:】
登录器采用新的优化算法，CPU占用率大幅度下降，整体性能比以前提高几倍。
修正全屏切换会出错的问题
修正登录器有的机器无法关闭的问题

【2011-04-29更新:】
修正有的机器会调整系统音量的问题
增加支持盛大新的土城地图(地图花屏问题)

;检测是否进入攻城的范围

CHECKCASTLEWARAREA 城堡名称

;检测是否正在攻城

CHECKUNDERWAR 城堡名称

;检测地图相同怪物数

CheckMapSameMonCount 地图名称 怪物名称 控制符(<,>,=) 数量

【2011-04-26更新:】
修正骰子不显示的问题
增加游戏的整体登录速度
增加以下脚本命令

;修理所有装备
REPAIRALL

;回城
GOHOME

;复活
REALIVE

;把人物加入行会
ADDGUILDMEMBER 行会名词 人物名称(人物名称为空时把自己加入到行会)

;把行会加入攻城列表
ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为空时所有行会加入到攻城列表)

;在地图上放物品
THROWITEM 地图名称 X坐标 Y坐标 范围 数量 物品名称
THROWITEM 3 336 336 12 2000 金币

;检测地图怪物数量
CHECKRANGEMONCOUNTEX 地图名称 怪物名称 X坐标 Y坐标 范围 控制符(=,>,<) 数量

增加攻击触发 QFunction-0

【2011-04-21更新:】
修正人物捡物品和扔物品负重不变的问题
修正使用某些技能会原地走路的问题
修正登录器浏览器的尺寸修改不了的问题
修正右键会停止自动追杀
修正在商店购买的物品会产生多个叠加(老版本升级重新启动前，需要删除 Market_prices和Market_saved目录下的文件)
修正1.76毒符的位置放到左手镯上
DBServer增加可创建角色数量的选项(用于传奇外传创建三角色)
增加游戏速度功能

ChangeSpeed 速度类型 速度值
速度类型 1为 移动速度 2为攻击速度 3为魔法速度
速度值(-10和10之间 小于0为减速 等于0不变速)

CHANGESPEED 1 5

【2011-04-13更新:】
增加支持传奇外传。
增加登录器皮肤自定义编辑
去掉登录时的开门动画
修正客户端一些图片错误
修正其他已知BUG

【2011-04-03更新:】
增加1.76、1.85、英雄版本、传奇续章。传奇外传正在制作中。
目前引擎支持1.76、1.85、英雄版本、传奇续章、传奇归来。

增加商铺支持元宝，金币，泡点三种货币购买。
增加任务对话框的页面可以在引擎自由设置。详见引擎：工具-任务NPC配置
增加人形怪配置。详见引擎：选项-怪物设置-人形怪设置
增加装备的发光特效，可以设置读取任意WIL资源的效果图片,可以设置装备的外观、内观，包裹中的效果。详见引擎：查看-列表信息(二)-物品特效
增加物品在地面颜色的显示设置，在物品数据库中增加字段Color
增加物品叠加功能，在物品数据库中增加字段OverLap
增加控制器自动配置数据库功能，有些用户不会配置数据库和增加数据库字段。启动控制台就可以自动配置。
增加好友功能
增加脚本命令：

金刚石
CHECKGAMEDIAMOND (<,>,=) 值
GAMEDIAMOND (+,-,=) 值
<$GAMEDIAMOND>

灵符
CHECKGAMEGIRD (<,>,=) 值
GAMEGIRD (+,-,=) 值
<$GAMEGIRD>

荣誉
CHECKGAMEGLORY (<,>,=) 值
GAMEGLORY (+,-,=) 值
<$GAMEGLORY>

检测字符串长度
CHECKSTRINGLENGTH (<,>,=) 值

检测是否有英雄
HAVHERO

创建文件
CREATEFILE ..\QuestDiary\名称列表.txt

PLAYEFFECT 人物效果 所有人可见 可以制作凤天魔甲的光环等效果
MAPEFFECT 地图效果 所有人可见 可以制作泉水喷溅、地图魔法等效果
SCREENEFFECT 屏幕效果 自己可见

PLAYEFFECT WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒)
MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒)
SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 模式(0=自己，1=所有人)

播放声音
PLAYSOUND 1.wav

打开NPC大对话框
OPENMERCHANTBIGDLG WIL文件序号 图片序号 是否可以移动(0,1)

关闭NPC大对话框
CLOSEMERCHANTBIGDLG

英雄脚本命令使用在原来人物的脚本命令前面加“H.”
例:
检测英雄等级
H.CHECKLEVELEX > 0

【2011-02-16更新:】
增加魔法修炼等级，最高可以修炼到15级，需要更换最新的魔法数据库，
否则M2无法启动。MaxTrainLv字段为可以修炼的最高等级

修改魔法等级显示方式和盛大一样

跑步卡的用户，需要修改M2参数。选项-参数设置-游戏速度-间隔控制
数字越大越容易卡，如果发现跑步卡，把数值调小点就可以。

修正其他已知BUG

【2011-01-28更新:】
修改纹理压缩模式，默认使用最高压缩模式，进一步降低内存占用
修正不能自动换毒的问题
修正传音筒看到的是自己的名字
修正小地图雷达点小的问题
修正组队快捷键 组第一个人物，组不上的问题
修正其他已知BUG
修改登录器皮肤
修改客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

【2011-01-24更新:】
修正红屏的问题
修正滚动信息出错导致卡屏的问题
修正其他已知BUG
进一步降低内存占用

【2011-01-22更新:】
修正黑屏的问题
修正看不到别人头盔的属性
修正组队看不到队员
修正其他已知BUG
增加聊天框可以鼠标拖动调整高度

【2011-01-10更新:】
使用D3D绘图引擎重新编写客户端内核，支持硬件加速渲染模式，
执行效率高，游戏更加流畅，CPU占用更低

修正其他已知BUG

【2010-09-25更新:】
修正人物跑动慢的问题
增加新魔法数据库

【2010-09-22更新:】
重新编写了客户端内核，支持16位和32位真彩，游戏更加流畅，CPU占用更低
增加聊天框可拉伸高度
增加噬血术，逐日剑法，流星火雨
修改物品说明现改为随鼠标悬浮说明
修改物品备注信息不在写入登录器，直接读取Data\ItemDesc.dat
增加魔法备注信息显示，读取Data\SkillDesc.dat
修正没有声卡的机器无法启动客户端的问题
修正计次物品显示错误

【2010-09-18更新:】
增加KILLERRACE命令，检测杀人者是人物还是怪物
增加<$KILLER>杀人者名称变量
增加会员命令
增加记忆石功能
增加千里传音和传音筒功能

扩展字符变量S和数字变量N，除了支持0~499以外，可以在S变量或N变量后面增加任意字符，使用如下：

【2010-09-08更新:】
增加脚本加密插件和脚本加解密工具
重新编写了登录器配置
优化客户端更加流程
修正杀毒软件误报
修正其他已知BUG
---------------------------------------------------------------------------------------------
【2010-07-05更新:】
1:发送聊天框固顶信息

2:增加1024*768大界面模式

3:修正若干BUG

【2010-01-01更新：】 请同步更新
=========================================================================================================
自动行走 地图名称 X坐标 Y坐标
AUTOGOTOXY 3 330 330
=========================================================================================================
延时跳转 跳转字段 延时时间(毫秒)
DELAYGOTO @跳转 1000
=========================================================================================================
设置定时器 定时器序号(0-9) 触发时间(毫秒)
在登陆脚本里触发[@OnTimerX]X是定时器序号
SETONTIMER 0 1000
=========================================================================================================
关闭定时器 定时器序号(0-9)
SETOFFTIMER 0
=========================================================================================================
发送屏幕滚动信息 信息类型代码(0-1)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容
SENDMOVEMSG 1 253 255 350 1 这个是屏幕滚动信息坐标在350
=========================================================================================================
发送延时触发信息 信息内容 时间(秒) 字体颜色 换地图是否删除 跳转字段
SENDDELAYMSG 你的礼物在%s后到达 10000 255 0 @给礼物
[@给礼物]
#ACT
GIVE 回城卷 1
=========================================================================================================
改进SENDMSG
SENDMSG 信息类型代码 %s信息内容%d 字体颜色 背景颜色
=========================================================================================================
穿装备 装备名称 装备位置(0-12)
TAKEONITEM 布衣(男) 0
=========================================================================================================
脱装备 装备名称 装备位置(0-12)
TAKEOFFITEM 布衣(男) 0
=========================================================================================================
获取随机字符 文件名 保存变量
GETRANDOMLINETEXT ..\QuestDiary\文件.txt S1
=========================================================================================================
创建文件命令
CREATEFILE ..\QuestDiary\文件.txt
=========================================================================================================
增加地图参数不允许使用技能 NOTALLOWUSEMAGIC(雷电术,火墙)
增加地图参数不允许使用物品 NOALLOWUSEITEMS(回城卷,随机传送卷)
扩展G变量为G0-G499
扩展A变量为A0-A499
变量运算
除法 格式: DIV N1 N2 N3 即N1=N2/N3
乘法 格式: MUL N1 N2 N3 即N1=N2*N3
百分比 格式: PERCENT N1 N2 N3 即N1=(N2/N3)*100
[@MAIN]
#IF
#ACT
Mov M2 10
MUL N1 M2 <$LEVEL>
SENDMSG 1 恭喜∶<$STR(N1)>，获得金刚<$STR(M2)>石锻造附赠品∶<$LEVEL>
=========================================================================================================
自动穿装备命令
穿装备 TakeOnItem 装备名称 位置(0-12)
脱装备 TakeOffItem 装备名称 位置(0-12)
=========================================================================================================
检查字符长度
格式：CheckStringlength 字符串 操作符(<,>,=) 位数
=========================================================================================================
气血石 幻魔石 魔血石 回城石 随机传送石 修复神水，数据库如下
StdMode = 7
Shape = 1 //+HP
Shape = 2 //+MP
Shape = 3 //+HMP
StdMode = 2
Shape = 2 随机传送石
Shape = 3 回城石
Shape = 9 修复神水
=========================================================================================================
金刚石和灵符
GAMEDIAMOND +/-/= 数字 //金刚石(0-65535) 操作(支持变量，如同GAMEGOLD命令)，保存到DB数据，支持新登陆器刷新显示
GAMEGIRD +/-/= 数字 //灵符(0-65535) 操作(支持变量，如同GAMEGOLD命令)，保存到DB数据，支持新登陆器刷新显示
<$GAMEDIAMOND> <$GAMEGIRD> //金刚石,灵符变量
CHECKGAMEDIAMOND >/=/< 数字 //检测金刚石，数字支持变量
CHECKGAMEGIRD >/=/< 数字 //检测灵符，数字支持变量
所有NPC命令支持运用变量，如GIVE $STR(S0) $STR(N8) //$STR(S0)、$STR(N8)
可以选择是否带<>，如：GIVE <$STR(S$0)> $STR(N8)
=========================================================================================================
改进SENDMSG命令
改进：SENDMSG 类型 发送信息 字体颜色(0..255) 背景颜色(0..255) //字体颜色 背景颜色 不为空，则发送自定义颜色文字
实例:
#IF
#ACT
SENDMSG 1 祝贺大家新年快乐！ 249 47
=========================================================================================================
说明:
聚灵珠在人物背包中杀怪时获得经验时自动聚集经验,当经验聚满时双击可获得经验.
人物英雄在线时也可获得经验.
设置:
1.物品数据库中聚灵珠StdMode=49.
2.DuraMax表示聚灵珠可聚集的最大经验值,1点表示1W经验值,例如DuraMax设置20那么实际
可聚集20W经验.DuraMax设置100那么最大可聚集100W经验值.
3.AniCount=0时使用元宝提取经验,=1时使用金币提取经验.
4.Reserved表示聚灵珠最多可使用的天数,当超过使用天数后不再聚集经验,没有聚集经验时不计算天数.
5.Need=提取经验时所需的元宝数量或者金币数量.
6.AC等于0时表示不限制人物等级,大于0时人物等级超过AC设定的等级时无法使用.
7.使用GM命令@Make制造聚灵珠时第三个参数代表聚灵珠的经验,第四个参数代表最多可使用的天数.例如:@Make 聚灵珠 1 10 365 ;10表示10W经验.365表示可以使用365天
如果第四个参数为空时，默认使用DB数据库里Reserved设置的天数


NPC代码

 | 代码：0
 | 代码：1
 | 代码：2
 | 代码：3
 | 代码：4
 | 代码：5
 | 代码：6
 | 代码：7
 | 代码：8
 | 代码：9
 | 代码：10
 | 代码：11
 | 代码：12
 | 代码：13
 | 代码：14
 | 代码：15
 | 代码：16
 | 代码：17
 | 代码：18
 | 代码：19
 | 代码：20
 | 代码：21
 | 代码：22
 | 代码：23
 | 代码：24
 | 代码：25
 | 代码：26
 | 代码：27
 | 代码：28
 | 代码：29
 | 代码：30
 | 代码：31
 | 代码：32
 | 代码：33
 | 代码：34
 | 代码：35
 | 代码：36
 | 代码：37
 | 代码：38
 | 代码：39
 | 代码：40
 | 代码：41
 | 代码：42
 | 代码：43
 | 代码：48
 | 代码：49
 | 代码：50
 | 代码：51
 | 代码：52
 | 代码：54 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：55 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：56 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：57 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：58 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：59
 | 代码：60
 | 代码：61
 | 代码：62
 | 代码：63
 | 代码：64
 | 代码：65
 | 代码：66
 | 代码：67
 | 代码：68
 | 代码：70
 | 代码：71
 | 代码：72
 | 代码：73
 | 代码：74
 | 代码：75
 | 代码：76
 | 代码：77
 | 代码：78
 | 代码：79
 | 代码：80
 | 代码：81
 | 代码：82
 | 代码：83
 | 代码：84
 | 代码：90
 | 代码：91
 | 代码：92
 | 代码：94 传送门，可以点击。
 | 代码：95 传送门，可以点击。
 | 代码：96 传送门，可以点击。
 | 代码：97 传送门，可以点击。
 | 代码：98 传送门，可以点击。
0 | 代码：99
1 | 代码：100
1 | 代码：101
1 | 代码：102
1 | 代码：200
1 | 代码：201
1 | 代码：202
1 | 代码：203
1 | 代码：204
1 | 代码：205
1 | 代码：206
1 | 代码：207
1 | 代码：208
 | 代码：209
 | 代码：210
 | 代码：211
 | 代码：212
 | 代码：213
 | 代码：214
 | 代码：215
 | 代码：216
 | 代码：217
 | 代码：218
 | 代码：219
 | 代码：220
 | 代码：221
 | 代码：222
 | 代码：223
 | 代码：224
 | 代码：225
 | 代码：226
 | 代码：227
 | 代码：228
 | 代码：229
 | 代码：230
 | 代码：231
 | 代码：232
 | 代码：233
 | 代码：234
 | 代码：235
 | 代码：236
 | 代码：237
 | 代码：238
 | 代码：239
 | 代码：240
 | 代码：241
 | 代码：242
 | 代码：243
 | 代码：244
 | 代码：245
 | 代码：246
 | 代码：247
 | 代码：248
 | 代码：249
 | 代码：250
 | 代码：251
 | 代码：252
 | 代码：253
 | 代码：254
 | 代码：255
 | 代码：256
 | 代码：257
 | 代码：258
 | 代码：259
 | 代码：260
 | 代码：261
 | 代码：262
 | 代码：263
 | 代码：264
 | 代码：265
 | 代码：266
 | 代码：267
 | 代码：268
 | 代码：269
 | 代码：270
 | 代码：271
 | 代码：272


官方主页

概 述

本M2游戏主程序汇编代码全新编写，在保持原来的所有功能前提下，修正大量原程序中的BUG，优化数据引擎，内置防外挂系统，彻底防止恶性外挂，增加大量新功能...

GameOfMir反外挂系统简介:

 本反外挂系统，采用全新智能行为侦察技术，在服务器端对客户端发送来的的操作行为在进入数据处理引擎之前进行智能判别，重新对操作行为数据重组，以消除网络延迟造成的数据重叠现象，从而有效的控制游戏速度，将非法操作行为拦截于数据引擎之外，对于堆集数据攻击将直接踢除连接，以保护服务器不受攻击影响。
完善的脚本引擎，完全杜绝因脚本编写问题出现漏洞而刷物品问题。

客户端的行为数据控制完全于服务器端控制，反外挂系统控制的相关数据绝对不可能有被绕过的现象，与客户端没有任何关系
现已有效控制以下各外挂功能：

1、加速控制
有效防止加速攻击、魔法、跑、走等，包括双倍、三倍、四倍加速，组合操作控制，各种暗杀（延迟），游戏装备速度控制。
防加速基本达到完美程度，完全杜绝反弹、卡位、掉线问题。

2、麻痹穿人
麻痹攻击、麻痹魔法、麻痹跑、麻痹走控制。
穿人控制(可选择穿人、穿怪、穿NPC、攻城区域穿人控制)。

3、脚本控制
完善脚本处理机制，杜绝利用脚本跳转绕过命令控制刷物品。包括通买，通卖，通存，通取，特修等。
本反外挂系统，结合全新游戏数据处理引擎，实现大量的游戏新功能，并不断的在增加大量的新游戏功能创意，大大的丰富了游戏的内容，提高了游戏的可玩性。

一、实现数据格式革命性突破，扩展不再有原来老游戏中数据储存大小的限制。

 人物属性由原来 255 扩展到高达65535（包括人物等级，攻击力，魔法、道术、防御、魔法防御等，最高限制数字由版本不同而不同，详细数字参照版本功能定义）。

二、怪物说话功能，支持更丰富的说话内容

三、完美的游戏密码

四、游戏新规则

 支持PK升级，得经验规则

五、人物饥饿系统

六、完善的脚本系统

新增加大量的脚本命令，通过这些脚本命令可更多的对游戏进行控制，实现大量丰富的游戏任务。

七、游戏机器人引擎

新增机器人引擎，通过机器人以实现大量的自动化游戏内容，这些机器人通过脚本控制宝时执行脚本等任务。
（简单实例：通过定时执行脚本控制，定时开展怪物攻城活动，整个过各完全有脚本控制，不需人工参与。）

八、实现数据引擎内核参数外部参数化，大量游戏内核参数可以自行设置，并支持动态修改设置加载参数，以打造各种风格的游戏。

数据动态加载，游戏魔法、怪物、物品数据库运行动态加载，调试游戏变得特别轻松容易，不必多次重新启动程序来检查数据的正确性，运行中的游戏增加怪物、物品不再需要重新启动。所有的配置设置信息全部支持动态加载，不需要重启程序立即生效。

游戏命令配置，所有游戏命令全部由配置文件设置，里面的命令可根据自己的要求改成自己风格的命令。修改后通过动态加载功能立即就可以生效而不必重启程序。

游戏内容提示方案信息，大部份游戏中提示的文字可通过配置文件设置，文字内容可以根据要求改成自己风格的提示信息。

九、可用脚本实现显示在线人物的各种排名（最高等级、最高攻击、最高魔法、最高道术、最高PK值等等）

数据处理引擎内核参数，大量的引擎内核参数可通过配置文件来控制，这些参数可以根据自己的要求进入更改。
以下为可设置参数列表：

红名村位置
红名死亡回城点
PK加PK点数
PK减幸运点数
照明物减持久间隔

安全区大小
新人出生点控制

升级武器点数机率控制
升级武器取回时间
清除过期升级武器时间
升级武器费用

炼药费用
建行会费用
申请行会战费用
申请攻城天数
攻城开始时间
攻城结束提示时间

沙城雇用卫士费用
修理城门费用
修理城墙费用
沙城金币上限
沙城一天收入上限
沙城位置
攻城区域大小
NPC税收率

人物身上金币数上限
人物数据保存间隔时间
显示公告间隔时间
公告文字颜色
GM发红字广播控制
人物退出清除时间
清理尸体时间
清除地面物品时间
怪物爆物品可捡时间

发送文字长度控制

人物登录权限控制，支持1 - 10级GM控制

刷怪倍率
杀怪经验倍率
高等级杀怪控制

各等级升级经验设置

客户端程序版本号日期
控制台上显示在线人数时间

召唤魔法控制，运行10级控制，不同等级召唤不同等级数量的怪物。


颜色值列表

0 | 1 | 2 | 3 | 4 | 5
6 | 7 | 8 | 9 | 10 | 11
12 | 13 | 14 | 15 | 16 | 17
18 | 19 | 20 | 21 | 22 | 23
24 | 25 | 26 | 27 | 28 | 29
30 | 31 | 33 | 34 | 35 | 36
37 | 38 | 39 | 40 | 41 | 42
43 | 44 | 45 | 46 | 47 | 48
49 | 50 | 51 | 52 | 53 | 54
55 | 56 | 57 | 58 | 59 | 60
61 | 62 | 63 | 64 | 65 | 66
67 | 68 | 69 | 70 | 71 | 72
73 | 74 | 75 | 76 | 77 | 78
79 | 80 | 81 | 82 | 83 | 84
85 | 86 | 87 | 88 | 89 | 90
91 | 92 | 93 | 94 | 95 | 96
97 | 98 | 99 | 100 | 101 | 102
103 | 104 | 105 | 106 | 107 | 108
109 | 110 | 111 | 112 | 113 | 114
115 | 116 | 117 | 118 | 119 | 120
121 | 122 | 123 | 124 | 125 | 126
127 | 128 | 129 | 130 | 131 | 132
133 | 134 | 135 | 136 | 137 | 138
139 | 140 | 141 | 142 | 143 | 144
145 | 146 | 147 | 148 | 149 | 150
151 | 152 | 153 | 154 | 155 | 156
157 | 158 | 159 | 160 | 161 | 162
163 | 164 | 165 | 166 | 167 | 168
169 | 170 | 171 | 172 | 173 | 174
175 | 176 | 177 | 178 | 179 | 180
181 | 182 | 183 | 184 | 185 | 186
187 | 188 | 189 | 190 | 191 | 192
193 | 194 | 195 | 196 | 197 | 198
199 | 200 | 201 | 202 | 203 | 204
205 | 206 | 207 | 208 | 209 | 210
211 | 212 | 213 | 214 | 215 | 216
217 | 218 | 219 | 220 | 221 | 222
223 | 224 | 225 | 226 | 227 | 228
229 | 230 | 231 | 232 | 233 | 234
235 | 236 | 237 | 238 | 239 | 240
241 | 242 | 243 | 244 | 245 | 246
247 | 248 | 249 | 250 | 251 | 252
253 | 254 | 255 |  |  |


Magic详解

magicdb:是你所修炼的法术和各种技能.
序号 字段 说明

(1)MagID 技能序号
(2)MagName 技能名字
(3)EffectType 使用技能时角色的动作效果
(4)Effect 技能产生的动画效果
(5)Spell 每次使用技能使用的魔法值
(6)Power 技能的伤害值下限
(7)MaxPower 技能的伤害值上限
(8)DefSpell 每次技能升级后增加使用的魔法值
(9)DefPower 每次技能升级后增加的伤害值下限
(10)DefMaxPower 每次技能升级后增加的伤害值上限
(11)job 可以学习技能的职业（0-战士，1-法师，2-道士）
(12)NeedL1 技能升到1级 需要玩家达到的人物等级（默认数据到15级别）
(13)L1Train 技能升到1级 需要的熟练度（默认数据到15级别）
(14)Delay 使用完当前技能后再次使用其他任意技能之间的延时（单位：毫秒）
(15)descr 简单备注
(16)MaxTrainLv 可以修炼的最高等级


Monster详解

monsterdb: 是关于怪物的攻击,经验,还有等级方面的东西
怪物CoolEye 调到100 ，再用隐身戒指也没用了

(1)sid 怪物代号
(2)name 怪物名称
(3)race 行动模式及死亡时的效果代码
race代码---81 对象进入范围自动攻击
82 2x2范围内毒液攻击-弱
90 贴身麻痹石化攻击-弱
92 遇到攻击对象在范围外时会瞬移
93 边攻击边躲避
95 对象进入攻击范围内会从地下爬出来
100 召唤的骷髅
101 进入范围会从石像状态激活
102 在攻击的同时召唤mir200\!setup.txt文件里的zuma1~4里特定的怪
103 自身不移动，通过释放mir200\!setup.txt文件里的bee特定的怪来攻击对象
105 麻痹石化攻击-强
106 麻痹石化攻击-弱
107 全屏攻击+麻痹+中毒
113 召唤的神兽-小
114 召唤的神兽-大
115 自身不移动，通过地刺来攻击对象
116 自身不移动，通过释放mir200\!setup.txt文件里的spider特定的怪来攻击对象
117 自身没有攻击力，通过自暴来攻击对象
(4)racelmg 攻击模式代码
racelmg代码---15 抛斧头
16 贴身喷毒
21 电火花
22 喷针
40 击电
45 射箭
52 高空喷毒效果
53 低空喷毒效果
49 丢火球 祖玛教主攻击动作
33 大范围喷毒 触龙神攻击动作
触龙神外形编号 140 攻击动作编号 33
祖玛教主外形编号 63 攻击动作编号 49
火焰沃玛外形编号 31 攻击动作编号 20
沃玛教主外形编号 34 攻击动作编号 21
(5)appr 怪物外观形象代码
(6)lvl 怪物等级
(7)undead 是否属不死系 0-否，1-是[不死系不可招，死系可召]
(8)cooleye 是否主动攻击(反隐形范围,并和等级有关)
(9)exp 怪物的经验值
(10)hp 怪物生命
(11)mp 怪物魔法
(12)ac 怪物防御力
(13)ac2 防御力上限
(14)mac 魔法防御力
(15)dc 物理攻击力
(16)dcmax 最大物理攻击力
(17)mc 魔法攻击力
(18)sc 道士精神力
(19)speed 速度
(20)hit 攻击命中率
(21)walk-spd 行走速度间隔
(22)walkstep 行走步伐
(23)walkwait 行走等待时间
(24)attacr-spd 攻击速度间


Stditem详解

stditemdb：物品属性修改
1.选中最底下的那个装备名，然后点图中所示1的位置那个+号，这样就会在你所选中的装备前面插入一列横向表单，点了+号后，在右边就会出现一个“对号”标记的按钮，按一下这个“对号”就表示确定插入这一横列。
(1)idx属性表示数据库的序列号(记住序号不要重复)
(2)name属性表示：
物件的名称
(3)stdmode装备属性：
10-男衣
11-女衣
5-单手
6-双手
30-蜡烛类
22-毒药，符类
42-制作原料
=======================================================
(4)shape这个属性(衣服显示穿上得样子,首饰代表其特殊功能)
“5”表示“灵魂战衣”的样子。
“4”表示“魔法长袍”的样子。
“3”表示“重盔甲”的样子。
19~21 ：项链
为19时，ac2和mac2代表魔法躲避和幸运
为20时，ac2为准确，mac2为敏捷
为21时，ac2为体力恢复，mac2为魔法恢复
24~26 ：手镯
为24时，ac2代表准确，mac2代表敏捷
为26时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
22~23 ：戒指
为22时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
为23时，ac代表攻击速度+ ， mac代表中毒躲避+ ， mac2代表中毒恢复+
shape值：
记忆头盔125
记忆戒指122
记忆手镯124 天地合一
记忆项链123
魔血戒指133 虹魔戒指136
魔血项链134 mp转hp 虹魔手镯137 吸hp
魔血手镯135 虹魔项链138
神秘戒指130 祈祷戒指128
神秘腰带131 随机属性 祈祷手镯126
神秘头盔132 祈祷头盔129
隐身戒指111 传送戒指112
麻痹戒指113 复活戒指114
火焰戒指115 治愈戒指116
幸运戒指117 护身戒指118
负载戒指119
技巧项链120
探测项链121
恢复hp/mp113
对于武器来说： 当shape值和reserved值分别为 30 和 12 时，武器一旦拿上就不能取下，只到死后消失 (血剑)
当仅reserved值为 8 时，武器拿上可以取下，但是一旦战斗死亡，就会消失
=====================================================================================
(5)weight属性是物件重量.

(6)looks属性(显示衣服物品栏里样子和在装备栏里的样子)
"重盔甲(男)"or"战神盔甲(男)"or"钢盔甲(男)" 62
"魔法长袍(男)"or"恶魔长袍(男)"or"圣龙魔袍(男)" 63
"灵魂战衣(男)"or"幽灵战衣(男)"or"泰坦战衣(男)" 64
"重盔甲(女)"or"战神盔甲(女)"or"钢盔甲(女)" 82
"魔法长袍(女)"or"恶魔长袍(女)"or"圣龙魔袍(女)" 83
"灵魂战衣(女)"or"幽灵战衣(女)"or"泰坦战衣(女)" 84
(7)duramax物件持久的属性：这里的变量中"1000"表示1个持久度,那么"40000"就表示40个持久度了!
(8)衣服和武器的属性:
"ac" 防御力下限
"ac2" 防御力上限
"mac" 魔防下限
"mac2" 魔防上限
"dc" 物理攻击力下限
"dc2" 物理攻击力上限 超过了255带在身上攻击是会减成0
"mc" 魔法攻击力下限
"mc2" 魔法攻击力上限
"sc" 道术下限
"sc2" 道术上限
"needlevel" 需要等级
"price" 价格
(9)物品是首饰时：
"ac2" 表示准确
"mac2" 表示敏捷
"ac" 表示防御下限
"ac2" 表示防御上限
"mac" 表示魔御下限
"mac2" 表示魔御上限
药剂的属性：
强效金疮药：hp +90
数据库体现：
ac 90
强效太阳水：hp +50 mp +80
数据库体现：
ac 50
mac 80
这样看来，这里的
ac 表示 hp前值（注 hp：200/300，200为前值，300为后值。）
mac 表示 mp前值
特殊的:
一些不常见的特殊药剂：
生命强化水：生命力暂时提升120秒（120秒内hp后值+50）
数据库体现：
ac 50
mac2 120
魔法强化水：魔法力暂时提升120秒（120秒内mp后值+50）
mac 50
mac2 120
那么这里的
ac 表示hp后值
mac 表示mp后值
mac2 表示时间了
大家知道 苹果 是每项属性都暂时增加240秒，他的ac2中是2，那么应该和武器一样，ac2表示准确了！
(10)stock 是否为库存品
(11)need表示限制种类：
0 为等级限制
1 为攻击限制
2 为魔法限制
3 为道术限制
(12)needlevel表示了(need)限制的具体数量.
另外上面的 stock处网上有说不是库存的意思是是否容易暴出后物品比较极品的意思,大家可以自己测试

字段Color 物品在地面颜色的显示设置
字段OverLap 物品叠加功能

60:在DB库增加新装备新怪的方法和技巧:
传奇4F在DB库增加新装备新怪的方法和技巧
大家一定玩腻了盛大所定的那些装备了把，一定也想在自己的4F里增加一些独创的装备把。
告诉大家一个技巧多利用COPY而让创建的装备100%成功，又不会出错！
具体操作：
比如我想要一件[狂神布衣（男）]
用DB Commander Shortcut打开StdItems.DB后首先找到原来的布衣（男）的数据单击成兰色后，选择DB Commander Shortcut上面的EDIT出现下拉菜单，点里面的COPY RECORD后下拉菜单消失。再点EDIT这时出现的下拉菜单里面原来是灰色不能选择的2个选项成了可选项，选择PASTE RECORD APPEND后他会自动在库的最下面拷贝了一份布衣的资料。IDX是物品编号改成上面物品的编号的后一位就可。NAME是名称呀改成[狂神布衣（男）]因为是COPY布衣（男）同样都是男用衣服所以装备属性和外观属性等都不用修改，现在要修改的只是：
DURAMAX：这是持久，注意这里的1000=游戏中的1点持久，如要40的持久那么就是40000。
AC和AC2就不用我多说了把是 防御和防御上限。
MAC和MAC2是魔防和魔防上限。
DC和DC2是攻击和攻击上限。
MC和MC2是魔法力和魔法力上限。
SC和SC2是道术和道术上限。
这里就自己看着改吧，都改成225的话呵呵。。。。。自己试试。
注意最高只能改到225！！！！！！！！！！！


特殊物品设置[!]

物品名称(Name) | StdMode | Shape | Anicount | Source | 说明
气血石 | 7 | 1 | 0 | 0 | 自动增加HP,增加数量为 持久*10
幻魔石 | 7 | 2 | 0 | 0 | 自动增加MP,增加数量为 持久*10
魔血石 | 7 | 3 | 0 | 0 | 自动增加HP和MP,增加数量为 持久*10
例如： 气血石(小);7;1;1;0;0;0;991;4000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
气血石(中);7;1;2;0;0;0;992;9000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
气血石(大);7;1;3;0;0;0;993;20000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(小);7;2;1;0;0;0;995;6000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(中);7;2;2;0;0;0;996;14000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(大);7;2;3;0;0;0;997;32000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(小);7;3;3;0;0;0;1028;10000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(中);7;3;3;0;0;0;1027;15000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(大);7;3;3;0;0;0;1026;20000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;

物品名称(Name) | StdMode | Shape | Anicount | Source | 说明
随机传送石 | 2 | 2 | 0 | 0 | 随机在当前地图上移动，使用次数为 持久/1000
修复神水 | 2 | 9 | 0 | 0 | 修复身上所穿装备持久，修复点数为 持久/100
千里传音 | 7 | 0 | 1 | 0 | 可以使用 @传 向全服喊话，使用次数为 持久/1000
火龙之心 | 25 | 9 | 0 | 0 | 英雄配带，合击物品.
召唤强化卷 | 2 | 1 | 0 | 0 | 装自己的宝宝升级为七级宝宝(适用于道士)，使用次数为 持久/1000
斗笠 | 16 | 0 | 0 | 0 | 配带后可以隐藏人物名称，支持双头盔配带，并支持人物属性增加 Shap 0~7
聚灵珠 49 0 0时使用元宝提取经验,=1时使用金币提取经验.

0提取经验时触发@GetExp

1提取经验时不触发@GetExp

 说明:聚灵珠在人物背包中杀怪时获得经验时自动聚集经验,当经验聚满时双击可获得经验.
人物英雄在线时也可获得经验.

设置:1.物品数据库中聚灵珠StdMode=49.
2.获取当前经验的倍数Shape/100
3.DuraMax表示聚灵珠可聚集的最大经验值,1点表示1W经验值,例如DuraMax设置20那么实际
可聚集20W经验.DuraMax设置100那么最大可聚集100W经验值.
4.AniCount=0时使用元宝提取经验,=1时使用金币提取经验.
5.Reserved表示聚灵珠最多可使用的天数,当超过使用天数后不再聚集经验,没有聚集经验时不计算天数,值为0时不限制天数
6.Need=提取经验时所需的元宝数量或者金币数量.
7.AC等于0时表示不限制人物等级,大于0时人物等级超过AC设定的等级时无法使用.
8.使用GM命令@Make制造聚灵珠时第三个参数代表聚灵珠的经验,第四个参数代表最多可使用的天数.例如:@Make 聚灵珠 1 10 365 ;10表示10W经验.365表示可以使用365天
如果第四个参数为空时，默认使用DB数据库里Reserved设置的天数
传送符 | 25 | 6 | 0 | 0 | 类似于传送戒指，使用一次减100点持久
自定义记次物品 | 2 | 1 | X | 0 | 自定义物品，使用次数为 持久/1000 ，使用成功后调用 QFunction-0脚本中的 [@StdModeFuncX] 其中X为Anicount
例如： 随机传送石;2;2;1;0;0;0;1025;50000;0;0;0;0;0;0;0;0;0;0;0;0;50000;1;255;0;99;
修复神水;2;9;1;9;0;0;120;10000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;
千里传音(小);7;0;1;1;0;0;1000;5000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
千里传音(大);7;0;1;1;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
传音筒;7;0;1;2;0;0;1000;5000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
超级传音筒;7;0;1;2;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
火龙之心;25;9;1;0;0;0;1148;30000;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;
召唤强化卷;2;1;1;7;0;0;998;5000;0;0;0;0;0;0;0;0;0;0;0;0;6000;5;
斗笠;16;0;2;0;0;0;1188;30000;0;0;0;0;0;0;0;0;0;0;0;7;20000;5;
回城石;2;3;1;30;0;0;1024;60000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;255;0;99;
聚灵珠(小);49;100;1;0;0;0;820;25;0;0;0;0;0;0;0;0;0;0;5;0;25000;5;255;0;0;0;
聚灵珠(大);49;100;1;0;0;0;820;50;0;0;0;0;0;0;0;0;0;0;10;0;50000;5;255;0;0;0;
计时物品 限时物品带到身上开始计时,到期后必须在身上时才会自动消失.(每分钟检测一次)
物品Need=101时限时物品,NeedLevel=时间(分钟)
配合死亡之眼技能使用 | 蓝色药粉(大量);25;3;3;0;0;0;257;15000;0;0;0;0;0;0;0;0;0;0;0;1;15000;50;255;0;0;;


物品代码表

物品代码(Stdmode) | 物品类型 | 相关说明
0 | 药品 |
1 | 食物 |
2 |  |
3 | 卷类 |
4 | 技能书 |
5 | 武器 |
6 | 武器 |
7 | 技能书 |
8 |  |
9 |  |
10 | 衣服(男) |
11 | 衣服(女) |
15 | 头盔 |
16 | 斗笠 |
19 | 项链 |
20 | 项链 |
21 | 项链 |
22 | 戒指 |
23 | 戒指 |
24 | 手镯 |
25 | 符、毒药 |
26 | 手镯 |
28 | 马牌 | 位置代码=15 变量<$HORSE> Anicount=0 不能骑马 大于0时比如1,2,3等等可以使用“Ctrl + J”骑马 马的素材调用L-Horse
29 | 天使 | 物品数据库字段Shape设置天使的类型，1 -10 代表不同的天使。51-100 为不同的同的马， 可以使用“Ctrl + J”骑马 马的素材调用L-Horse
30 | 照明物 | 物品数据内Source字段为1时不随时间掉持久，为0随时间掉持久 51-100 为不同的同的马， 可以使用“Ctrl + J”骑马 马的素材调用L-Horse
31 | 捆装物品 |
48 | 盾牌 | 位置代码=16 变量<$SHIELD>
49 | 聚灵珠 |
53 | 宝石 | 有气血石功能 Anicount=1,2,3 分别对应三种石头
62，52 | 鞋子 |
63 | 宝石 |
64，54 | 腰带 |
65 | 军鼓 |
51 | 符 |
66,67 | 时装衣服 |
68,69 | 时装武器 |
100 | 首饰盒装备 |
101 | 首饰盒装备 |
102 | 首饰盒装备 |
103 | 首饰盒装备 |
104 | 首饰盒装备 |
105 | 首饰盒装备 |
106 | 首饰盒装备 |
107 | 首饰盒装备 |
108 | 首饰盒装备 |
109 | 首饰盒装备 |
110 | 首饰盒装备 |
111 | 首饰盒装备 |

物品特殊属性设置:
武器 蜡烛 类型物品 使用物品数据库字段 AniCount
首饰 头盔 类型物品 使用物品数据库字段 Shape

属性代码 | 属性功能 | 功能介绍
111 | 隐身 | 人物进入隐身状态，普通怪物看不到人物，破隐身的怪物可以看到人物
112 | 传送 | 人物可以使用命令在传送到指定座标上(@UserMove)
113 | 麻痹 | 人物物理攻击时可以将对方麻痹
114 | 复活 | 人物具备复活功能，人物在死亡时起作用，生效一次掉一个持久
115 | 火焰 |
116 | 治愈 |
117,170 | 不掉物品 | 人物死亡时不会掉任何物品，包括背包里的及身上戴的
118 | 护身 | 人物在被攻击时，先降MP，MP为0时才降HP
119 | 超负载 | 人物可以戴上超过自己负重的物品
120 | 技巧 | 人物在练技能时，得到双倍的练习点
121 | 探测 | 可以查找指定人物当前位置
122 | 记忆戒指 |
124 | 记忆手镯 |
125 | 记忆头盔 |
126 | 祈祷手镯 |
127 | 祈祷项链 |
128 | 祈祷戒指 |
129 | 祈祷头盔 |
130 | 神秘戒指 |
131 | 神秘腰带 |
132 | 神秘头盔 |
133 | 魔血戒指 |
134 | 魔血手镯 |
135 | 魔血项链 |
136 | 虹魔戒指 |
137 | 虹魔戒指 |
138 | 虹魔项链 |
139 | 防麻 | 防麻痹功能，可以使被攻击方的麻痹功能失效(不防怪物麻痹）
140 | 无敌(未完全) |
141 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，如果物品持久太小，所得经验将比正常还低
142 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，如果物品持久太小，所得攻击力将比正常还低
182 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，不受物品持久太小影响
183 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，不受物品持久太小影响
143 | 防护身 |
144 | 防复活 |
145 | 行会召唤 |
150 | 麻痹护身 |
151 | 麻痹火球 |
152 | 麻痹防御 |
153 | 麻痹负载 |
154 | 护身火焰 |
155 | 护身防御 |
156 | 护身负载 |
157 | 传送麻痹 |
158 | 传送护身 |
159 | 传送探测 |
160 | 传送复活 |
161 | 复活麻痹 |
162 | 护身复活 |
171 | 不掉背包物品 |
172 | 不掉身上装备 |
189 | 麻痹 | 人物魔法技能攻击时可以将对方麻痹


物品极口属性详解

物品极品属性详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 SHAPE 值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当SHAPE值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当SHAPE值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当SHAPE值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当SHAPE值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当SHAPE值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当SHAPE值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当SHAPE值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久


物品所需条件设置

使用物品所需条件设置:

物品数据库字段:（字段包括二个参数的需要用字段计算器算出具体数字）

Need | NeedLevel
0 | 需要指定等级以上才可以戴上
1 | 需要指定攻击力以上才可以戴上
10 | 需要指定职业及指定等级以上才可以戴上
11 | 需要指定职业及指定攻击力以上才可以戴上
12 | 需要指定职业及指定魔法力以上才可以戴上
13 | 需要指定职业及指定道术以上才可以戴上
2 | 需要指定魔法力以上才可以戴上
3 | 需要指定道术以上才可以戴上
4 | 需要指定转生等级以上才可以戴上
40 | 需要指定转生等级及指定等级以上才可以戴上
41 | 需要指定转生等级及指定攻击力以上才可以戴上
42 | 需要指定转生等级及指定魔法力以上才可以戴上
43 | 需要指定转生等级及指定道术以上才可以戴上
44 | 需要指定转生等级及指定声望点以上才可以戴上
5 | 需要指定声望点以上才可以戴上
6 | 加入了行会的人才可以戴上
60 | 行会掌门才可以戴上
7 | 沙城成员才可以戴上
70 | 沙城城主才可以戴上
8 | 会员才可以戴上
81 | 指定类型会员，及大于或等于指定会员等级，字段设置
82 | 指定或大于类型会员，及大于或等于指定会员等级 字段设置


LineNotice.txt彩色滚动公告[!]

例：
[253,0]自定义字体颜色公告！
<252,255>窗口顶部滚动公告！

格式1：[253,0]聊天框公告 0为背景色 253前景色
格式2：<252,255> 窗口顶部滚动公告,255为背景色 252前景色


达到多少人在线不允许离线挂机脚本[!]

[@离线挂机]
{
#IF
checklevelex < 35
#act
MessageBox 等级35级以上才能使用离线挂机功能!
break

#if
ISONMAP 0
#act
goto @HumanCount0
break

#if
ISONMAP 3
#act
goto @HumanCount3
break

#if
ISONMAP 5
#act
goto @HumanCount5
break

#elseact
MessageBox 此地图无法使用离线挂机功能!
break

[@HumanCount0]
#IF
checkhum 0 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@HumanCount3]
#IF
checkhum 3 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@HumanCount5]
#IF
checkhum 5 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@开始离线挂机]
目前您只需要花费30万金币即可享受挂机涨经验,泡点的服务\
点击下面的挂机功能后即可回家睡觉了,人物自动挂在安全区泡\
经验.能量及泡红名,还可设置自动回复信息,给好友留言！ \
<注意:>在游戏中输入指令[@挂机].同样可以享受挂机服务!\
原则上本区不发展挂机，不希望活死人现象，开区一定成形后\
将逐渐销减离线挂机成分，努力做到让大家聊天有个伴，PK有对象！\
<我要挂机/@@offlinemsg>　<--点击后输入留言给好友留言.>\ \
<关闭/@exit>

[@@offlinemsg]
#if
checkgold 300000
#act
take 金币 300000
OFFLINE 60 2000 ;60 2000 说说60秒钟可以获得2000经验
#elseACT
MessageBox 对不起您的金币不够30万，无法启用离线挂机功能!
break

}


动态地图连接[!]

增加动态地图连接命令
ADDMAPGATE 连接名称(为了区别其他连接) 地图号 X(小于0时随机坐标) Y(小于0时随机坐标) 范围 到达地图号 到达地图坐标X(小于0时随机坐标) 到达地图坐标Y(小于0时随机坐标) 有效时间秒(时间到了自动删除该连接,该参数为空时不限时间)

删除动态地图连接命令
DELMAPGATE 连接名称 地图号

获取动态地图连接坐标
GETMAPGATE 连接名称 地图号 变量1(保存X坐标) 变量2(保存Y坐标) 变量3(保存到达地图号) 变量4(保存到达地X坐标) 变量5((保存到达地Y坐标))

[@AddMapGate]
#ACT
AddMapGate 连接 3 335 330 1 0 335 268 30
GetMapGate 连接 3 <$STR(G10)> <$STR(G11)> <$STR(S$10)> <$STR(G12)> <$STR(G13)>
SENDMSG 6 增加地图新连接30秒后删除:[<$STR(G10)>:<$STR(G11)>]到达地图:<$STR(S$10)>到达坐标[<$STR(G12)>:<$STR(G13)>]

[@DelMapGate]
#ACT
DelMapGate 连接 3


发送聊天框固顶信息

SENDTOPCHATBOARDMSG 发送模式(0发送给所有人,1发送给自己) 字体颜色 背景颜色 时间(秒) 信息 是否显示人物名称(0显示，1不显示)

[@Main]
SENDTOPCHATBOARDMSG 0 149 235 30 %s:聊天框固顶信息


会员系统详解

会员系统主要用来对一些加盟玩家的特殊控制。可以用IP地址，登录帐号，角色名，之类的为标志控制。

相关脚本命令

设置会员类型：SETMEMBERTYPE
设置会员等级： SETMEMBERLEVEL

检查会员类型：CHECKMEMBERTYPE
检查会员等级：CHECKMEMBERLEVEL

相关脚本会员物品

物品使用条件：8、81、82

增加会员时间 文件名称 天 时 分
[@main]
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 2 3
#ACT
SENDMSG 6 增加30天2小时3分 255 253

检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)
[@main]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 S$1 N$1 N$2 N$3
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253

删除会员还是使用原来的老命令DELNAMEDATELIST

[@main]
<输入需要充值的人物名称/@@InputString1>\ \ \
<关闭/@EXIT>\

[@InputString1]
#IF
S$1.CHECKONLINE
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 2 3
SENDMSG 6 <$STR(S$1)>充值成功，增加30天2小时3分！ 255 253
#ELSEACT
SENDMSG 6 <$STR(S$1)>不在线！ 255 253


机器人脚本

功能：
系统机器人，可以定时做一些指定操作
相关配置目录:
\Envir\Robot_def\

相关文件:
\Envir\Robot.txt 机器人配置文件
\Envir\Robot_def\RobotManage.txt 机器人运行脚本文件

机器人配置文件格式:
;Robot.txt
;机器人名称 脚本名称
系统控制 AutoRunRobot

脚本格式:
;AutoRunRobot.txt
#AutoRun NPC SEC 10 @SendRedMsg
SEC：按秒运行
MIN：按分运行
HOUR：按小时运行
DAY：按天运行
RUNONWEEK：按星期几及时间运行
#AutoRun NPC RUNONWEEK 5:15:55 @SendRedMsg
星期五15点55分运行

实例：
Robot.txt内容：该文件在\Envir\下
;==========================
Test Test
;==========================

Test.txt内容：（每8秒钟运行脚本一次）该文件在\Envir\Robot_def\下
;==========================
#AutoRun NPC SEC 8 @DHB
;==========================

RobotManage.txt内容（内容即普通脚本内容）该文件在\Envir\Robot_def\下
;==========================
[@DHB]
#if
#act
SENDMSG 0 双头金刚怪物攻城了......
MISSION 3 330 330
PARAM1 360
PARAM2 340
PARAM3 10
PARAM4 1
MOBPLACE 双头金刚
;==========================


记忆石设置方法[!]

功能演示：

物品分类号:31
SHAPE 值:1
AN字段是触发.这个根据自己版本设置.我们以设置为99为例子
QFunction-0.txt脚本下面

[@StdModeFunc99]
一： <记录当前坐标/@TAGMAPINFO1> <移动到/@PMOVE1> -> <$TAGMAPNAME1> <$TAGX1> <$TAGY1>\
二： <记录当前坐标/@TAGMAPINFO2> <移动到/@PMOVE2> -> <$TAGMAPNAME2> <$TAGX2> <$TAGY2>\
三： <记录当前坐标/@TAGMAPINFO3> <移动到/@PMOVE3> -> <$TAGMAPNAME3> <$TAGX3> <$TAGY3>\
四： <记录当前坐标/@TAGMAPINFO4> <移动到/@PMOVE4> -> <$TAGMAPNAME4> <$TAGX4> <$TAGY4>\
五： <记录当前坐标/@TAGMAPINFO5> <移动到/@PMOVE5> -> <$TAGMAPNAME5> <$TAGX5> <$TAGY5>\
六： <记录当前坐标/@TAGMAPINFO6> <移动到/@PMOVE6> -> <$TAGMAPNAME6> <$TAGX6> <$TAGY6>\ \
<成功传送后才会消失一点.安全无毒.放心使用>\
[@PMOVE1]
#ACT
TAGMAPMOVE 1
[@PMOVE2]
#ACT
TAGMAPMOVE 2
[@PMOVE3]
#ACT
TAGMAPMOVE 3
[@PMOVE4]
#ACT
TAGMAPMOVE 4
[@PMOVE5]
#ACT
TAGMAPMOVE 5
[@PMOVE6]
#ACT
TAGMAPMOVE 6
[@TAGMAPINFO1]
#ACT
TAGMAPINFO 1
GOTO @StdModeFunc99
[@TAGMAPINFO2]
#ACT
TAGMAPINFO 2
GOTO @StdModeFunc99
[@TAGMAPINFO3]
#ACT
TAGMAPINFO 3
GOTO @StdModeFunc99
[@TAGMAPINFO4]
#ACT
TAGMAPINFO 4
GOTO @StdModeFunc99
[@TAGMAPINFO5]
#ACT
TAGMAPINFO 5
GOTO @StdModeFunc99
[@TAGMAPINFO6]
#ACT
TAGMAPINFO 6
GOTO @StdModeFunc99


假人登录脚本实例

[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;从配置文件列表中随机获取一个配置文件
GETRANDOMLINETEXT ..\QuestDiary\智能陪练\假人配置文件列表.txt <$STR(S$10)>

SETDUMMYCONFIGFILENAME <$STR(S$10)>

LOADDUMMYCONFIGFILE

MOVR D0 6
ChangeAttatckMode <$STR(D0)>

;从配置文件列表中随机获取一个配置文件,给英雄使用
GETRANDOMLINETEXT ..\QuestDiary\智能陪练\假人英雄配置文件列表.txt <$STR(S$11)>

;从假人列表或假人英雄列表中获取一个没有登录过的名称
GETDUMMYNAME <$STR(S$1)> 1 1

;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S$1)>

RECALLHERO

DUMMYSTART

[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;<$STR(S$11)> 是主人登录随机获取的一个配置文件
H.SETDUMMYCONFIGFILENAME <$STR(S$11)>

H.LOADDUMMYCONFIGFILE


假人自动摆摊

============================================================================================================================

假人摆摊 写点大点省的看不到了

[@假人上线自动摆摊]
#IF
ISDUMMY
#ELSEACT
BREAK
;检测是否已经创建过个人商店
#IF
CHECKMYSHOP
#ACT
;停止挂机
DUMMYSTOP
;开始摆摊
SHOPSTALL
#ELSEACT
;如果没有个人商店开始用自己的名字做为商店的名字创建个人商店
CREATEMYSHOP <$USERNAME>
;停止挂机
DUMMYSTOP
;开始摆摊
SHOPSTALL


脚本控制怪物攻城

功能：
实现由脚本控制怪物攻城。

格式：
 ;怪物集中位置，怪物会自动向此位置集中
MISSION 地图名 座标X 座标Y

;刷新怪物座标X
PARAM1 X

;刷新怪物座标Y
PARAM2 Y

;刷新怪物数量
PARAM3 数量

;刷新怪物范围
PARAM4 范围

;刷新怪物名称
MobPlace 怪物名称

;=======================================
[@MobMission]
#if
#act
MISSION 3 330 330
PARAM1 360
PARAM2 340
PARAM3 10
PARAM4 5
MOBPLACE 半兽勇士
;=======================================


结婚脚本

[@main]
<我想结婚/@marry>\
<我想离婚/@unmarry>\ \
<离开/@exit>

[@marry]
求婚者必须是男性且拥有求婚戒指，\
你准备好求婚了吗？\ \
<准备好了/@agree>\
<下次再来/@exit>\ \ \
<返回/@main>

[@agree]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>
#if
checkposemarry
#say
对方已经结过婚了，是不是想犯重婚罪呀！！！\ \
<返回/@main>
#act
break

#if
gender man
#elsesay
只有男的向女的求婚，还没见过大姑娘向小伙子求婚的。\ \
<返回/@main>
#elseact
break

#if
checkposegender 男
#say
你变态呀！！！想搞同性恋！！！ \ \
<返回/@main>
#act
break

#if
checkposedir 2
#elsesay
你们二个面对面站好呀，不要乱动。\ \
<返回/@main>
#elseact
break

#if
checklevel 40
#elsesay
结婚要求你的等级必须40级或以上，小伙子努力练好级再来找我。\ \
<返回/@main>
#elseact
break
#if
checkposelevel > 34
#elsesay
你的对象还没成年，等她长大点再来吧！小伙子不要心急嘛！\ \
<返回/@main>
#elseact
break
#if
checkitemw 求婚戒指 1
#elsesay
你没求婚戒指，弄到求婚戒指再来找我吧！！！\ \
<返回/@main>
#elseact
break

#if
#act
takew 求婚戒指 1
marry

[@StartMarry]
#if
checkmarry
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>
#act
break

#if
gender man
#act
break
#say
婚礼现在正式开始。\ \
你愿意娶对方为妻，并照顾她一生一世吗？\ \
<我愿意/@RequestMarry>

#if
gender
#act
break
#say
婚礼现在正式开始。\ \
请耐心等待你心爱的人向你求婚\ \

[@RequestMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry requestmarry
[@WateMarry]
你已向对方求婚，请耐心等待对方的答复。

[@RevMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#say
对方向你求婚，你是否答应嫁给他？ \ \
<我愿意/@ResposeMarry> \
<我不愿意/@ResposeMarryFail>
[@ResposeMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry responsemarry ok

[@ResposeMarryFail]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry responsemarry fail
[@EndMarry]
你们二个已经成为了一对全法夫妻了。\ \
<关闭/@exit>
[@EndMarryFail]
结婚失败！\ \
<关闭/@exit>
[@MarryDirErr]
对方没站好位置

[@MarryCheckDir]
请站好位置\\

[@HumanTypeErr]
你变态呀，既然选择一个非人类作为结婚对象。

[@MarrySexErr]
你变态呀，既然同性恋。

;==========================================
离婚开始
[@unmarry]
#if
checkmarry
#act
unmarry
#elsesay
你都没结婚离什么婚？？\ \
<返回/@main>

;=======================================================
;双方离婚时没面对面站好显示的信息
[@UnMarryCheckDir]
要离婚是吧？离婚是二个人的事，必须二个人对面对站好位置，\
如果人来不了你只能选择强行离婚姻了。\ \
<我要强行离婚/@fUnMarry>\
<返回/@main>
;=======================================================
;对面位置不是人物时显示的信息
[@UnMarryTypeErr]
你对面站了个什么东西，怎么不太象人来的。\ \
<返回/@main>

;=======================================================
;开始离婚程序后，双方显示的信息
[@StartUnMarry]
#if
gender man
#act
BREAK
#say
是否确定真的要与你共事多年的妻子离婚吗？\ \
<确定/@RequestUnMarry>

#if
gender
#say
你的老公现在向我请求离婚，是不是愿意协议离婚？ \ \
<确定/@RequestUnMarry>
#act
break

;=======================================================
;发出离婚请求
[@RequestUnMarry]
#if
checkmarry
#act
unmarry requestunmarry
;=======================================================
;回应离婚请求
[@ResposeUnMarry]
#if
checkmarry
#act
unmarry responseunmarry

;===============================================
;请求离婚后显示的信息
[@WateUnMarry]
你已向对方发出离婚请求，请耐心等待对方的答复。

;===============================================
;请求离婚后对方显示的信息
[@RevUnMarry]
对方向你离婚请求，你是否答应离婚？ \ \
<我愿意/@RequestUnMarry>
<返回/@main>

;===============================================
;没结过婚的人点离婚后出的提示信息
[@ExeMarryFail]
你都没结过婚，跑来做什么？ \ \
[返回/@main]

;==============================================
;强行离婚
[@fUnMarry]
#if
checkitem 金条 1
checkmarry
#act
take 金条 1
unmarry requestunmarry force
#elsesay
要收一根金条的手续费，你没有金条，\
我不能让你离婚。\
<确定/@exit>
;==============================================
;离婚完成后的提示信息
[@UnMarryEnd]
呵呵，你已经脱离苦海了！！！ \ \
<退出/@exit>
[@asktime]
你调查结婚时间的请求已发出，\
请稍后。\
<确定/@exit>


酒神弟子完整脚本[!]

以下为酒神弟子完整脚本:
[@Main]
我是玛法酒神的嫡传大弟子,也是这家酒馆的老板.\
这次回来正式受了师父的托付,将玛法的古老武学内功,在玛法大陆\
传播开来.当你学习内功并通过修炼,使内功等级逐渐升高后,你的\
战斗力会获得极大的提升.怎么样?有没有兴趣来学习内功?\
<我要学习内功/@学习内功> <兑换玛法珍酿>\
<内功是什么?/@内功说明> <兑换精元丹>\

[@学习内功]
哦?有心思学习这心法了?\
算你有眼光,学习了内功,实力大增,到时候莫说,\
击败肆虐玛法的邪恶生物,就是翻越过雪山,\
找到回家之路也不是不可能.\
那你是想自己学习还是你的英雄学习呢?\
请注意,只有你自己学会内功后,我才会教你的英雄内功.\
<我自己学习/@自己学习> <让我的英雄学吧/@英雄学习>\
<不,我是想将玛法内功心法还给你>\
<返回/@EXit>

[@自己学习]
#if
CHECKREADSKILLNG
#ACT
MESSAGEBOX 你还想再学习?
#ELSEACT
goto @自己学习1

[@自己学习1]
#IF
;检查所需物品
checkitem 玛法内功心法 1
#ACT
take 玛法内功心法 1
READSKILLNG
#ELSEACT
MESSAGEBOX 没有玛法内功心法,你还想学习?

[@英雄学习]
#if
H.CHECKREADSKILLNG
#ACT
MESSAGEBOX 英雄还想再学习?
#ELSEACT
goto @英雄学习1

[@英雄学习1]
#IF
;检查所需物品
H.checkitem 玛法内功心法 1
#ACT
H.take 玛法内功心法 1
H.READSKILLNG
#ELSEACT
MESSAGEBOX 没有玛法内功心法,你还想学习?

[@ReadNGOK]
你学会内功!

[@ReadNGHeroOK]
你的英雄学会内功!

[@ReadNGFail]
你的已经学会内功了呀!

[@ReadNGHeroFail]
你尚未招出你的英雄,或者你的英雄已经学会内功了呀!

[@内功说明]
三龙卫的神威早已铭记在了每个玛法人的心头,他们当年所使用的\
绚丽招式多已经流传于当今的玛法大陆,在不久前几种三龙卫的几乎\
失传的绝技也从藏经阁出世,再度扬威江湖.不过人们所不知道的是\
昔年三龙卫之所以能够扬威玛法,不仅仅靠他们精妙的招式,更是\
因为他们雄厚的内功.随着三龙卫的失踪,这些内功的秘密,也随之\
失传.但只有一种人,他们中间还依旧流传着三龙卫内功的秘密,\
他们,便是三龙卫的后裔!\\

<莫非你就是三龙卫的后裔?/@三龙卫的后裔>

[@三龙卫的后裔]
不,不,我当然不是那些英雄的后裔,我的师父才是!我师父的名号\
相信你一定听过,他就是玛法大陆上酒的传播者,三十年前的第一\
勇士玛法酒神.当年师父正是凭借着他内外双修的高深功力,\
在玛法大陆上横行无阻.这些年来,师父他一直在遵循着他的祖先\
三龙卫的遗志,试图翻越雪山,寻找回家的路.然而,自然之力并非\
人力可敌,师父花了三十年,也不过探索了大雪山一隅,\
为此,他决定从他这代开始,打破三龙卫家族的族规.\ \

<三龙卫的禁密武学从此可以外传了?/@禁密武学外传>

[@禁密武学外传]
不错,师父他相信人定胜天,只要敢于打破常规,必可以找出一条\
回家的道路.因此,师父派我,他的嫡传大弟子,来到盟重酒馆\
这个人来人往的地方,寻找有缘人,将内功的奥妙传播开来.\
一个人找不到回家的路,但相信一万人百万人,一定可以在绵延的\
雪山中,寻找到一条路,通向我们玛法文化的根源!\ \

<我相信我们会找到回家的路的> <返回>


离线挂机[!]

(@@offlinemsg)
[@main]
欢迎使用我提供的挂机功能，使用此功能可以让你不必开电脑，\
就可以进行泡点。\
点击开始挂机后，可输入一段留言信息给你的朋友。\
<开始挂机/@@offlinemsg>
[@@offlinemsg]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。\ \
<返回/@main>
#act
break

#if
INSAFEZONE
#elseact
break
#elsesay
请在安全区找一个位置站好，不能会被人杀的。\ \
<返回/@main>

#IF
checklevelex > 0
#act
OFFLINEPLAY 100 ;这100是说100分钟被踢下线！ 第一种离线命令

OFFLINEPLAY 12 5000 ;说明1分钟可以获得5000经验。可以获得12分钟时间


魔王岭脚本

天下第一脚本

修改MerChant.txt 配置文件

NPC名称支持变量显示(只能使用全局变量A和T两种字符串类型，其它类型无效，请参照天下第一设置)

直接给变量写值NPC就会自动更名

例如：

天下第一战士 3 321 340 A14 0 35 0 0 0
天下第一战士 3 324 340 A15 0 36 0 0 0
天下第一法师 3 327 340 A16 0 37 0 0 0
天下第一法师 3 330 340 A17 0 38 0 0 0
天下第一道士 3 333 340 A18 0 39 0 0 0
天下第一道士 3 336 340 A19 0 40 0 0 0

脚本

[@main]
#if
#act
MOV A14 <$USERALLNAME>\天下第一战士


人物登录脚本

功能：
即在人物进入游戏时自动执行的脚本，通过此脚本可对人物进行大量的功能控制。

格式：
在目录 Envir\MapQuest_def\ 中建立文件名为QManage.txt的脚本，按以下格式编写脚本：

========================================================================
;脚本例子
[@Login]
#IF
IsAdmin
#ACT
CHANGEMODE 2 1
CHANGEMODE 3 1
SENDMSG 5 %s，欢迎进入游戏，当前模式为GM管理模式。========================================================================
注：如该脚本更改后，不须重启M2使其生效，可用@ReloadManage命令重新加载该脚本。


人物颜色发型

[@HumFace]
请选择美容项目....\ \
『<名称颜色/@changcolor>』\
『<换 发 型/@ChangHair>』\ \
〖<返回/@main>〗

[@ChangColor]
是不是觉得自己名称的颜色太单调了，换换试试！\ \
『<复原/@Color255>』\
『<蓝色/@Color0>』 『<绿色/@Color1>』 『<黄色/@Color2>』 『<橙色/@Color3>』\
『<土黄/@Color4>』 『<红色/@Color5>』 『<淡兰/@Color6>』 『<淡绿/@Color7>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗

[@Color255]
#ACT
CHANGENAMECOLOR 255
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color0]
#ACT
CHANGENAMECOLOR 252
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color1]
#ACT
CHANGENAMECOLOR 217
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color2]
#ACT
CHANGENAMECOLOR 251
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color3]
#ACT
CHANGENAMECOLOR 253
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗

[@Color4]
#ACT
CHANGENAMECOLOR 125
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗

[@Color5]
#ACT
CHANGENAMECOLOR 249
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@Color6]
#ACT
CHANGENAMECOLOR 254
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@Color7]
#ACT
CHANGENAMECOLOR 250
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@ChangHair]
#IF
gender man
#ACT
goto @ChangHairMan
#ELSEACT
goto @ChangHairWoman
[@ChangHairMan]
想不想来个光头呀，酷呆了！！！\ \
『<光头/@hairman0>』\
『<长头发/@hairman1>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗
[@hairman0]
#ACT
HAIRSTYLE 0
#SAY
呵呵，光头是不是很酷呀！！！ \ \
〖<返回/@ChangHairMan>〗
[@hairman1]
#ACT
HAIRSTYLE 1
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairMan>〗

[@ChangHairWoman]
『<短发型/@hairWoman0>』\
『<长发型/@hairWoman1>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗
[@hairWoman0]
#ACT
HAIRSTYLE 0
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairWoman>〗 〖<关闭/@Exit>〗
[@hairWoman1]
#ACT
HAIRSTYLE 1
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairWoman>〗 〖<关闭/@Exit>〗


人物转生[!]

功能：
人物转生控制

格式：
 RENEWLEVEL 转次数 转后等级 分配点数
转次数 代表一次转多少级(数值范围为 1 - 255)
转后等级 代表转生后人物的等级，0为不改变人物当前等级。
分配点数 代表转生后可以得到的点数，此点数可能按比例换成人物属性点(数值范围 1 - 20000)。

;==========================================
;将人物转生一次，后等级设为 28级，分配100点属性
[@RenewLevel]
#IF
#ACT
RENEWLEVEL 1 28 100
#SAY
转生成功。
;==========================================
功能：
 检测转生等级

格式：
 控制符(=,>,<)
;==========================================
[@ViewRenLevel]
#IF
checkrenewlevel = 0
#act
break
#say
你还没转生！！！\ \
〖<返回/@ReNewLevel>〗 〖<关闭/@exit>〗
#IF
checkrenewlevel = 1
#act
break
#say
你的转生等级为第一重转生！！！\ \
〖<返回/@ReNewLevel>〗 〖<关闭/@exit>〗
;==========================================

功能：
清除人物转生数据(即人物转生后恢复到未转生状态)

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================

功能：
设置及更改转生人物显示的名称

格式：
配置文件：String.ini

以下为相关配置内容：
;==========================================
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*

WarrReNewName 　武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 　道士转生后名称显示


任务脚本

;QMission-0.txt 此脚为任务脚本放在Market_Def目录，人物每次登录时都会执行[@Login]

首先到M2-工具-任务NPC配置-增加任务NPC页面。例如：增加“主线任务”他对应的脚本字段就是[@主线任务]

[@Login]

[@主线任务]
传奇归来任务\
<传奇归来任务/@生存的诀窍>\
主线任务\
<生存的诀窍/@生存的诀窍>\

[@支线任务]
支线任务\
<等级2 寻找炼金师/@寻找炼金师>\
<等级3 王师弟子/@王师弟子>\
<等级4 新手大礼包/@新手大礼包>\
<等级5 进入庄园/@进入庄园>\
<等级5 天关寻宝/@天关寻宝>\

[@日常活动]
日常活动\
<玛法巡游（每日一次）/@玛法巡游>\
<地下夺宝/@地下夺宝>\
<除魔任务（每日一轮）/@除魔任务>\
<历练任务（每日一次）/@历练任务>\
<每日巡游任务/@每日巡游任务>\
<生存战（每日13：50，16：50开放）/@生存战>\
<每日探索任务（每日一次）/@每日探索任务>\
<闯关夺宝（每日18：30-19：00）/@闯关夺宝>\

[@生存的诀窍]
半兽人的贪婪和凶残打破了我们宁静的生活。\
战火蔓延到玛法大陆的每个角落。\
我们渴望驱除侵入者，我们期待重建家园。\
勇士，在这生死存亡的危机时刻，我们要团结\
在一起。为了帮助你成长，快去找你旁边\
的任务使者<比奇(333.262)/@比奇任务使者>或<边界村(287.614)/@边界村任务使者>或\
<银杏山谷(647.623)/@银杏山谷任务使者>吧！\

[@寻找炼金师]
在比奇（325，262），盟重（326，330），苍月岛\
庄园（65，72）处可以找到炼金师，在炼金师处使\
元宝可以获得大量经验、金刚石和组队卷轴。\
金刚石是锻造高级武器的必备物品。\
组队卷轴是去地下宫殿解救天工神剪的必须道具。\
<任务/FCOLOR=249>：到炼金师处查询元宝锻造的规则\
<完成任务NPC/FCOLOR=249>：比奇、盟重、苍月岛、庄园的炼金师\

[@王师弟子]
恭喜你已经达到了<$LEVEL>级，你可以到比奇（327，260）\
盟重（331，328）金牌尊者处领取一份王师弟子奖\
<任务/FCOLOR=249>：在武馆教头处了解“师傅如何收徒”\
<完成任务NPC/FCOLOR=249>：比奇、盟重的武馆教头\

[@新手大礼包]
比奇的书店老板（325，250）是个热心肠的人。\
尤其是对待新人的帮助。\
<任务/FCOLOR=249>：查看“5元宝换取新手大礼包”\
<完成任务NPC/FCOLOR=249>：比奇书店老板\

[@玛法巡游]
你每天可以在<盟重活动使者(339,335)/FCOLOR=249>处\
领取玛法巡游任务。\
只要在玛法大陆巡查两个小时后，\
就可以带<比奇国王/FCOLOR=249>那里领取大量的经验回馈。\
每日22点后，不可以接受巡查任务。\

[@地下夺宝]
你每天可以在<宫殿长廊送宝人偶(108，96)/FCOLOR=249>处\
参加地下夺宝活动。\ \

活动时间为：\
10：30-11：00\
13：30-14：00\
15：30-16：00\
20：30-21：00\
23：00-23：30\ \

活动细则：\
以上活动时间段内,通过<盟重镇魔首将(322,342)/FCOLOR=249>处\
携带地下组队卷轴选择单人或组队进入地下宫殿后\
点击送宝人偶，进入夺宝地图，\
活动时间结束前的5分钟宝物会出现在夺宝地图中，\
宝物出现后2分钟即可获得。\ \

有几率爆出以下宝物：\
<40级重装等高级装备/FCOLOR=249>\
<白金积分，热血积分/FCOLOR=249>\
<全系列藏宝图/FCOLOR=249>\
<47级新技能书，道士驯兽术/FCOLOR=249>\

[@除魔任务]
你每天可以在<盟重活动使者(339,335)/FCOLOR=249>处\
领取每日除魔任务。\
在一轮除魔任务（完成5次任务）中。\
每次完成任务后的奖励会越来越好。\
每天只能完成一轮的除魔任务。\ \

任务包括：\
前往石墓杀死<10只红野猪/FCOLOR=249>\
前往骨魔洞杀死<20只骷髅长枪兵/FCOLOR=249>\
前往霸者大厅杀死<3只白野猪/FCOLOR=249>\
前往兽人古墓杀死<15只骷髅/FCOLOR=249>\
前往赤月峡谷杀死<10只月魔蜘蛛/FCOLOR=249>\
前往比奇杀死<15只鸡/FCOLOR=249>\
前往毒蛇山谷杀死<5只虎蛇/FCOLOR=249>\
前往比奇杀死<8只食人花/FCOLOR=249>\
前往雷炎洞穴杀死<2只金杖蜘蛛/FCOLOR=249>\
前往死亡棺材杀死<2只邪恶钳虫/FCOLOR=249>\
前往魔龙西郊杀死<3只魔龙刀兵/FCOLOR=249>\ \

如果你觉得领取的任务太难，\
也可花费<50000金币/FCOLOR=249>在<盟重活动使者(339，335)/FCOLOR=249>处\
重新领取任务。\

[@历练任务]
你每天可以在盟重活动使者（339，335）处\
领取每日历练任务。\
按照指示前往各地找到恶魔看守人，支付一定的金币\
杀死指定的怪物即可完成历练任务领取奖励。\
每天只能只能完成一次历练任务。\ \

任务包括：\
25-29级：前往香石墓穴，杀四10只恶魔野猪\
香石墓穴恶魔看守人(37,30)，(84,47)\
任务奖励：500000经验\ \

30-34级：前往沃玛寺庙三层，杀死<10只恶魔沃玛/FCOLOR=249>\
沃玛寺庙恶魔看守人(46,46),(62,62)\
任务奖励：600000经验\ \

35-39级：前往地牢一层东，杀死<10只恶魔蜈蚣/FCOLOR=249>\
地牢一层恶魔看守人(75,108),(161,52)\
任务奖励：800000经验\ \

40-44级：前往石墓七层，杀死<10只恶魔楔蛾/FCOLOR=249>\
石墓恶魔看守人(30,72),(62,42)\
任务奖励：1000000经验\ \

45-49级：前往祖玛七层大厅，杀死<10只恶魔祖玛/FCOLOR=249>\
祖玛神殿恶魔看守人(11,13)\
任务奖励：1200000经验\ \

50-54级：前往牛魔寺庙大厅，杀死<10只恶魔牛魔/FCOLOR=249>\
牛魔寺庙恶魔看守人(15,16),(67,67)\
任务奖励：1200000经验\ \

55-59级：前往魔龙岭，杀死<10只恶魔魔龙/FCOLOR=249>\
魔龙岭恶魔看守人(213,117),(84,353)\
任务奖励：1500000经验\ \

60-70级：前往地下长廊，杀死<10只地下长廊恶魔/FCOLOR=249>\
地下长廊恶魔看守人(160,172)\
任务奖励：1500000经验\ \


沙城主公告

将下面的放到沙皇宫的NPC脚本里就行了

(@@sendmsg)
[@main]
沙巴克当前归<$OWNERGUILD>所有，由<$LORD>统治管理。\
现在金库中所存的金币数量为:<$CASTLEGOLD>，今天的收入为: <$TODAYINCOME>\ \

『<修改城名/@@castlename>』 『<城主公告/@@sendMsg>』\\
『<取回资金/@@withdrawal>』 『<存入资金/@@receipts>』\
『<控制城门/@treatdoor>』 『<修理城门和城墙/@repaircastle>』\
『<雇用弓箭手/@hirearchers>』\ \
〖<取消/@exit>〗\
[@@sendMsg]
#if
checkcastlegold ? 100000
#act
takecastlegold 100000
SETSENDMSGFLAG
#elsesay
城内资金不足，不要乱用钱。\ \
『<返回/@main>』

[@treatdoor]
城门当前状态为:『<$CASTLEDOORSTATE>』\ \
『<关城门/@closemaindoor>』\
『<开城门/@openmaindoor>』\ \
〖<返回/@main>〗\

[@openmaindoor]
城门已经打开。\ \
〖<返回/@treatdoor>〗\

[@closemaindoor]
城门已经关闭。\ \
〖<返回/@treatdoor>〗\

;--------------------------------------------------
;荐府 包访

[@repaircastle]
请选择要修理的位置？\ \
『<修理城门/@repairdoor>』\
『<修理城墙/@repairwalls>』\ \
〖<返回/@main>』\

[@repairdoor]
修理城门所需费用为:『<$REPAIRDOORGOLD>』金币。\ \
『<修理城门/@repairdoornow>』\
『<返回/@repaircastle>』\

[@repairwalls]
修理城墙所需费用为:『<$REPAIRWALLGOLD>』金币。\ \
『<修理城墙/@repairwallnow1>』\
『<修理城墙/@repairwallnow2>』\
『<修理城墙/@repairwallnow3>』\ \
〖<返回/@repaircastle>』\

[@hirearchers]
雇用弓箭手可保护城堡的安全，并维护城堡的治安。\
每个弓箭手的雇用费用为『<$ARCHERFEE>』金币。\
请选择要雇用弓箭手放置位置: \ \
『<城墙左弓箭手三/@hirearchernow1>』, 『<城墙左弓箭手二/@hirearchernow2>』, 『<城墙左弓箭手一/@hirearchernow3>』\
『<城墙右弓箭手一/@hirearchernow4>』, 『<城墙右弓箭手二/@hirearchernow5>』, 『<城墙右弓箭手三/@hirearchernow6>』\
『<城门左弓箭手/@hirearchernow9>』, 『<城门左弓箭手/@hirearchernow10>』, 『<城门右弓箭手/@hirearchernow11>』, 『<城门右弓箭手/@hirearchernow12>』\
『<皇宫左弓箭手/@hirearchernow7>』, 『<皇宫右弓箭手/@hirearchernow8>』\
『<返回/@main>』\


收徒脚本

[@main]
<我想拜师/@master>\
<我想出师/@unmaster>\ \
<离开/@exit>

[@master]
想拜师呀，你要拜的师父来了没有？\
与你师父面对面站好，开始拜师。\ \
<准备好了/@agree>\
<我知道了/@exit>\ \
<返回/@main>

[@agree]
;检查是不是已经是别人的师父
#if
checkismaster
#act
break
#say
没事别来这玩！！！\ \
<返回/@main>

;检查是不是已经拜师了
#if
checkmaster
#act
break
#say
你都都已经拜了别人为师，怎么还拜师！！！ \ \
<返回/@main>

;检查对面的人物是不是别人的徒弟
#if
checkposemaster
#say
你找了个什么人做师父，怎么现在还是别人的徒弟？\ \
<返回/@main>
#act
break

;检查二个有没站好位置
#if
checkposedir
#elsesay
你们二个面对面站好呀，不要乱动。\ \
<返回/@main>
#elseact
break

#if
checklevel 40
#say
你都40多级了还要找师父？\ \
<返回/@main>
#act
break

;检查对方等级
#if
checkposelevel > 50
#elsesay
你找个什么师父呀，等级这么低？\ \
<返回/@main>
#elseact
break
#act
master

[@StartGetMaster]
拜师仪式正式开始。\ \
你是否确认拜师？\ \
<确认/@RequestMaster>

[@StartMaster]
拜师仪式正式开始。\ \
对方已经向你提出拜师请求。\ \

[@RequestMaster]

;检查所需物品
#if
checkitemw 力量戒指 1
#elsesay
你都没信物，怎么拜呀！！！\ \
<返回/@main>
#elseact
break

#if
#act
takew 力量戒指 1
master requestmaster

[@WateMaster]
你已向对方请求拜师，请耐心等待对方的答复。

[@RevMaster]
对方想拜你为师，你是否想收此人为徒？ \ \
<同意/@ResposeMaster> \
<不同意/@ResposeMasterFail>

[@ResposeMaster]
#if
#act
master responsemaster ok

[@ResposeMasterFail]
#if
#act
master responsemaster fail
[@EndMaster]
你们二个已经是师徒关系了。\ \
<关闭/@exit>
[@EndMasterFail]
拜师失败！\ \
<关闭/@exit>
[@MasterDirErr]
对方没站好位置

[@MasterCheckDir]
请站好位置\\

[@HumanTypeErr]
此人不可以做你的师父。

;==========================================
开始
[@unmaster]
#if
havemaster
#act
unmaster
#elsesay
你都没师父，跑来做什么？？\ \
<返回/@main>

;=======================================================

[@UnMasterCheckDir]
按正常出师步骤，必须二个人对面对站好位置，\
如果人来不了你只能选择强行出师了。\ \
<我要强行出师/@fUnMaster>\
<返回/@main>
;=======================================================
;对面位置不是人物时显示的信息
[@UnMasterTypeErr]
你对面站了个什么东西，怎么不太象人来的。\ \
<返回/@main>
[@UnIsMaster]
必须由徒弟发出请求！！！\ \
<返回/@main>
[@UnMasterError]
不要来捣乱！！！\ \
<返回/@main>
;=======================================================
;开始程序后，双方显示的信息
[@StartUnMaster]
出师仪式现在开始！！！\ \
是否确定真的要脱离师徒关系？\ \
<确定/@RequestUnMaster>
[@WateUnMaster]
出师仪式现在开始！！！\ \

;=======================================================
;发出请求
[@RequestUnMaster]
#if
havemaster
#act
unmaster requestunmaster
;=======================================================
;回应请求
[@ResposeUnMaster]
#if
havemaster
#act
unmaster responseunmaster

;===============================================
;请求后显示的信息
[@WateUnMaster]
你已向对方发出请求，请耐心等待对方的答复。

;===============================================
;请求后对方显示的信息
[@RevUnMaster]
对方向你请求，你是否答应？ \ \
<我愿意/@RequestUnMaster>
<返回/@main>

;===============================================

[@ExeMasterFail]
你都没师父，跑来做什么？ \ \
[返回/@main]

;==============================================
;强行
[@fUnMaster]
#if
checkitem 金条 1
havemaster
#act
take 金条 1
unmaster requestunmaster force
#elsesay
要收一根金条的手续费，你没有金条，\
<确定/@exit>
;==============================================
;完成后的提示信息
[@UnMasterEnd]
呵呵，你已经脱


挑战功能

说明:没有等级限制,只在双方面对面,即可挑战,挑战时间5分钟,在挑战时间内没有分出胜负的,直接随机传送.
     增加地图参数 FIGHT4 (挑战地图),此参数禁止召唤英雄,死亡不掉落物品,不增加PK值.
     M2\查看\列表信息 中可设置禁止挑战的物品.
     挑战时双方都不可以使用英雄,所有药品
     挑战胜,所有之前押的物品归胜方所有

相关脚本命令:
功能:移动到挑战地图
格式:CHALLENGMAPMOVE 地图名 X Y

功能:没有挑战地图可移动,则退回抵押的物品
格式:GETCHALLENGEBAKITEM

//----------------------------------------------------------------------
QFunction-0.txt 文件

[@Challenge]
#IF
CHECKMAPHUMANCOUNT EM029A = 0
#ACT
CHALLENGMAPMOVE EM029A 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029B = 0
#ACT
CHALLENGMAPMOVE EM029B 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029C = 0
#ACT
CHALLENGMAPMOVE EM029C 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029D = 0
#ACT
CHALLENGMAPMOVE EM029D 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029E = 0
#ACT
CHALLENGMAPMOVE EM029E 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029F = 0
#ACT
CHALLENGMAPMOVE EM029F 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029G = 0
#ACT
BREAK
CHALLENGMAPMOVE EM029G 14 15
#IF
CHECKMAPHUMANCOUNT EM029H = 0
#ACT
CHALLENGMAPMOVE EM029H 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029I = 0
#ACT
CHALLENGMAPMOVE EM029I 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029J = 0
#ACT
CHALLENGMAPMOVE EM029J 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029K = 0
#ACT
CHALLENGMAPMOVE EM029K 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029L = 0
#ACT
CHALLENGMAPMOVE EM029L 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029M = 0
#ACT
CHALLENGMAPMOVE EM029M 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029N = 0
#ACT
CHALLENGMAPMOVE EM029N 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029O = 0
#ACT
CHALLENGMAPMOVE EM029O 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029P = 0
#ACT
CHALLENGMAPMOVE EM029P 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Q = 0
#ACT
CHALLENGMAPMOVE EM029Q 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029R = 0
#ACT
CHALLENGMAPMOVE EM029R 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029S = 0
#ACT
CHALLENGMAPMOVE EM029S 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029T = 0
#ACT
CHALLENGMAPMOVE EM029T 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029U = 0
#ACT
CHALLENGMAPMOVE EM029U 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029V = 0
#ACT
CHALLENGMAPMOVE EM029V 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029W = 0
#ACT
CHALLENGMAPMOVE EM029W 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029X = 0
#ACT
CHALLENGMAPMOVE EM029X 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Y = 0
#ACT
CHALLENGMAPMOVE EM029Y 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Z = 0
#ACT
CHALLENGMAPMOVE EM029Z 14 15
BREAK
#IF
#ACT
goto @Challenge_Fail

[@Challenge_Fail]
#IF
#ACT
GETCHALLENGEBAKITEM
#SAY
当前地图人数已经满员!请稍后再试,谢谢!\

;挑战胜利者执行..
[@Challenge_Win]
#IF
#ACT
SendMsg 5 挑战胜利..
-------------------------------------------------------------------------------
MapInfo.txt文件

[EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029A|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029B|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029C|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029D|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029E|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029F|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029G|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029H|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029I|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG


跳转，延迟

DELAYGOTO 时间(毫秒) 触发字段 换地图是否删除此延时(0或为空时=不删除 1=删除)

DELAYGOTO 20 @火龙珠 表示20毫秒

实例：
----------------------------------------------------------------------------

[@main]
<延迟跳转/@DelayGoto> <清除延迟/@ClearDelayGoto>\ \
<返回/@main>

[@DelayGoto]
#if
#act
DELAYGOTO 3000 @DelayLabel
#say
<清除延迟/@ClearDelayGoto>

[@DelayLabel]
#say
延迟跳转测试成功！\ \
<返回/@next>

[@ClearDelayGoto]
#if
#act
CLEARDELAYGOTO
#say
延迟跳转已清除.\ \
<返回/@next>

------------------------------------------------------------------------;


新转职业变性脚本

最新转职业脚本变性(含英雄转职和清理合击技能)

[@变性转职]
{
欢迎你光临：<$SERVERNAME>\ \
你是否对自己的英雄职业不满意？是的，我想<变更英雄职业/@变更英雄职业>\ \
你是否对现在的职业已经厌烦？ 是的，我想<变更职业/@职业变更>\ \
你是否想尝试做异性的滋味？ 是的，我想<变更性别/@性别变更>\ \
                                           <版权所有/@1>:D3dm2引擎\

[@性别变更]
#IF
gender man
#SAY
是不是做猛男没什么意思呀，想不想尝尝做淑女的滋味呀！！！\ \
『<尝尝/@towoman>』\ \
〖<返回/@main>〗 〖<关闭/@exit>〗
#ELSESAY
是不是做淑女挺累的，想不想尝尝做猛男的滋味呀！！！\ \
『<尝尝/@toman>』\ \
〖<返回/@main>〗 〖<关闭/@exit>〗

[@toman]
#IF
CHECKGAMEGOLD > 19
#ACT
GAMEGOLD - 20
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
<返回/@main>
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足20颗。

[@towoman]
#IF
CHECKGAMEGOLD > 19
#ACT
GAMEGOLD - 20
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \
〖<返回/@main>〗 〖<关闭/@exit>〗
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足20颗。

[@职业变更]
#IF
CHECKJOB warrior
#SAY
是不是战士不好玩呀，换换别的职业试试吧！\ \
『<玩玩法师/@法师>』\
『<玩玩道士/@道士>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
CHECKJOB wizard
#SAY
是不是法师不好玩呀，换换别的职业试试吧！\ \
『<玩玩战士/@战士>』\
『<玩玩道士/@道士>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
CHECKJOB taoist
#SAY
是不是道士不好玩呀，换换别的职业试试吧！\ \
『<玩玩战士/@战士>』\
『<玩玩法师/@法师>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break

[@战士]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB warrior
ADDSKILL 基本剑术
ADDSKILL 攻杀剑术
ADDSKILL 刺杀剑术
ADDSKILL 半月弯刀
ADDSKILL 野蛮冲撞
ADDSKILL 烈火剑法
ADDSKILL 狮子吼
SKILLLEVEL 基本剑术 + 3
SKILLLEVEL 攻杀剑术 + 3
SKILLLEVEL 刺杀剑术 + 3
SKILLLEVEL 半月弯刀 + 3
SKILLLEVEL 野蛮冲撞 + 3
SKILLLEVEL 烈火剑法 + 3
SKILLLEVEL 狮子吼 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@法师]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB WIZARD
ADDSKILL 火球术
ADDSKILL 大火球
ADDSKILL 抗拒火环
ADDSKILL 地狱火
ADDSKILL 雷电术
ADDSKILL 疾光电影
ADDSKILL 诱惑之光
ADDSKILL 瞬息移动
ADDSKILL 火墙
ADDSKILL 爆裂火焰
ADDSKILL 地狱雷光
ADDSKILL 魔法盾
ADDSKILL 圣言术
ADDSKILL 冰咆哮
ADDSKILL 寒冰掌
ADDSKILL 灭天火
SKILLLEVEL 火球术 + 3
SKILLLEVEL 大火球 + 3
SKILLLEVEL 抗拒火环 + 3
SKILLLEVEL 地狱火 + 3
SKILLLEVEL 雷电术 + 3
SKILLLEVEL 疾光电影 + 3
SKILLLEVEL 诱惑之光 + 3
SKILLLEVEL 瞬息移动 + 3
SKILLLEVEL 火墙 + 3
SKILLLEVEL 爆裂火焰 + 3
SKILLLEVEL 地狱雷光 + 3
SKILLLEVEL 魔法盾 + 3
SKILLLEVEL 圣言术 + 3
SKILLLEVEL 冰咆哮 + 3
SKILLLEVEL 寒冰掌 + 3
SKILLLEVEL 灭天火 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@道士]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB taoist
ADDSKILL 治愈术
ADDSKILL 精神力战法
ADDSKILL 施毒术
ADDSKILL 灵魂火符
ADDSKILL 幽灵盾
ADDSKILL 神圣战甲术
ADDSKILL 困魔咒
ADDSKILL 召唤骷髅
ADDSKILL 隐身术
ADDSKILL 集体隐身术
ADDSKILL 心灵启示
ADDSKILL 群体治疗术
ADDSKILL 召唤神兽
ADDSKILL 气功波
ADDSKILL 无极真气
SKILLLEVEL 治愈术 + 3
SKILLLEVEL 精神力战法 + 3
SKILLLEVEL 施毒术 + 3
SKILLLEVEL 灵魂火符 + 3
SKILLLEVEL 幽灵盾 + 3
SKILLLEVEL 神圣战甲术 + 3
SKILLLEVEL 困魔咒 + 3
SKILLLEVEL 召唤骷髅 + 3
SKILLLEVEL 隐身术 + 3
SKILLLEVEL 集体隐身术 + 3
SKILLLEVEL 心灵启示 + 3
SKILLLEVEL 群体治疗术 + 3
SKILLLEVEL 召唤神兽 + 3
SKILLLEVEL 气功波 + 3
SKILLLEVEL 无极真气 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@变更英雄职业]
想把你的英雄变更为其它职业的英雄？\
只要你交纳50颗元宝，我即可将你的英雄成功转职。\
但是合击技能将会被删除，只给予新职业的部分技能、\
是否同意将英雄转职呢？\

<我同意将英雄转职业/@同意英雄转职>\

[@同意英雄转职]
#IF
HAVEHERO
#ELSEACT
MESSAGEBOX 对不起，您没有英雄！
BREAK

#IF
H.CHECKONLINE
#ELSEACT
MESSAGEBOX 对不起，您的英雄不在线！
BREAK

#IF
CHECKGAMEGOLD > 49
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

#IF
H.CHECKJOB warrior
#SAY
是不是战士英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩法师英雄/@法师英雄>』\
『<玩玩道士英雄/@道士英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
H.CHECKJOB wizard
#SAY
是不是法师英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩战士英雄/@战士英雄>』\
『<玩玩道士英雄/@道士英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
H.CHECKJOB taoist
#SAY
是不是道士英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩战士英雄/@战士英雄>』\
『<玩玩法师英雄/@法师英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break

[@战士英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB warrior
H.ADDSKILL 英雄基本剑术 1
H.ADDSKILL 英雄攻杀剑术 1
H.ADDSKILL 英雄刺杀剑术 1
H.ADDSKILL 英雄半月弯刀 1
H.ADDSKILL 英雄野蛮冲撞 1
H.ADDSKILL 英雄烈火剑法 1
H.ADDSKILL 英雄狮子吼 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@法师英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB WIZARD
H.ADDSKILL 英雄火球术 1
H.ADDSKILL 英雄大火球 1
H.ADDSKILL 英雄抗拒火环 1
H.ADDSKILL 英雄地狱火 1
H.ADDSKILL 英雄疾光电影 1
H.ADDSKILL 英雄雷电术 1
H.ADDSKILL 英雄诱惑之光 1
H.ADDSKILL 英雄瞬息移动 1
H.ADDSKILL 英雄火墙 1
H.ADDSKILL 英雄爆裂火焰 1
H.ADDSKILL 英雄地狱雷光 1
H.ADDSKILL 英雄魔法盾 1
H.ADDSKILL 英雄圣言术 1
H.ADDSKILL 英雄冰咆哮 1
H.ADDSKILL 英雄灭天火 1
H.ADDSKILL 英雄寒冰掌 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@道士英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB taoist
H.ADDSKILL 英雄神圣战术 1
H.ADDSKILL 英雄群疗术 1
H.ADDSKILL 英雄集体隐身 1
H.ADDSKILL 英雄精神战法 1
H.ADDSKILL 英雄施毒术 1
H.ADDSKILL 英雄召唤骷髅 1
H.ADDSKILL 英雄召唤神兽 1
H.ADDSKILL 英雄灵魂火符 1
H.ADDSKILL 英雄隐身术 1
H.ADDSKILL 英雄幽灵盾 1
H.ADDSKILL 英雄治愈术 1
H.ADDSKILL 英雄困魔咒 1
H.ADDSKILL 英雄心灵启示 1
H.ADDSKILL 英雄气功波 1
H.ADDSKILL 英雄无极真气 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK
}

QFunction-0.txt里的配置脚本

[@HeroLogon]
#if
$HERO.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
$HERO.DELSKILL 破魂斩
$HERO.DELSKILL 劈星斩
$HERO.DELSKILL 雷霆一击
$HERO.DELSKILL 噬魂沼泽
$HERO.DELSKILL 末日审判
$HERO.DELSKILL 火龙气焰
$HERO.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
$HERO.ISNEWHUMAN
$HERO.gender man
CHECKHEROJOB WIZARD
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 恶魔长袍(男) 1
$HERO.give 骨玉权杖 1
$HERO.TakeOnitem 骨玉权杖 1
$HERO.TakeOnitem 恶魔长袍(男) 0
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender WOMAN
CHECKHEROJOB WIZARD
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 恶魔长袍(女) 1
$HERO.give 骨玉权杖 1
$HERO.TakeOnitem 骨玉权杖 1
$HERO.TakeOnitem 恶魔长袍(女) 0
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender man
CHECKHEROJOB WARRIOR
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 战神盔甲(男) 1
$HERO.give 裁决之杖 1
$HERO.TakeOnitem 战神盔甲(男) 0
$HERO.TakeOnitem 裁决之杖 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender WOMAN
CHECKHEROJOB WARRIOR
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 战神盔甲(女) 1
$HERO.give 裁决之杖 1
$HERO.TakeOnitem 战神盔甲(女) 0
$HERO.TakeOnitem 裁决之杖 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender man
CHECKHEROJOB TAOIST
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 幽灵战衣(男) 1
$HERO.give 龙纹剑 1
$HERO.TakeOnitem 幽灵战衣(男) 0
$HERO.TakeOnitem 龙纹剑 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender WOMAN
CHECKHEROJOB TAOIST
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 幽灵战衣(女) 1
$HERO.give 龙纹剑 1
$HERO.TakeOnitem 幽灵战衣(女) 0
$HERO.TakeOnitem 龙纹剑 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


烟花脚本实例[!]

数据库设置

一心一意;2;1;1;79;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
心心相印;2;1;1;80;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
飞火流星;2;1;1;81;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
浪漫星雨;2;1;1;82;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
绮梦幻想;2;1;1;83;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
如梦似雾;2;1;1;84;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
长空火舞;2;1;1;85;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
庆典蛋糕;2;1;1;86;0;0;1001;5000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;

SHOWEFFECT 类型(79~86)

这个范例支持持久就是次数10次。不想支持次数把类型2修改为31即可。

QFunction-0 下增加如下：

[@StdModeFunc79]
#IF
#ACT
Gmexecute showeffect 79
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc80]
#IF
#ACT
Gmexecute showeffect 80
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc81]
#IF
#ACT
Gmexecute showeffect 81
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc82]
#IF
#ACT
Gmexecute showeffect 82
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc83]
#IF
#ACT
Gmexecute showeffect 83
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc84]
#IF
#ACT
Gmexecute showeffect 84
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc85]
#IF
#ACT
Gmexecute showeffect 85
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc86]
#IF
#ACT
Gmexecute showeffect 86
SENDMSG 0 <$USERNAME>在:%m%x:%y处放庆典蛋糕了!大家快去看拉


元宝转帐

(@@dealgold)
[@main]
<进行元宝转帐/@dealgamegold>\
<关闭/@exit>

[@dealgamegold]
#IF
#ACT
STARTTAKEGOLD

[@startdealgold]
#IF
#SAY
<$DEALGOLDPLAY>与你交易，请<输入转帐/@@dealgold>数量\
<返回/@main>

[@dealgoldpost]
对不起,需要交易的人没站好位置！\
<返回/@main>

[@dealgoldFail]
对不起，你的元宝数量没有这么多！\
<返回/@exit>

[@dealgoldInputFail]
非法操作，交易失败！

[@dealgoldPlayError]
转帐失败！


祝福语脚本

[@@SendMsg]
#if
checkgold 10000
#act
take 金币 10000
SETSENDMSGFLAG
#elsesay
穷鬼，一边站着。\ \
<返回/@main>

注：只能在普通NPC上发祝福语，国王系NPC将不能使用


转职业变性脚本

[@SexJob]
请选择转换项目....\ \
『<转换性别/@ChangSex>』\
『<转换职业/@ChangJob>』\ \
〖<返回/@Main>〗 〖<关闭/@exit>〗

[@ChangSex]
如何你想换性别，这里提供转性别服务\
『<换性别/@ChangGender>』\ \
〖<返回/@MemberSexJob>〗 〖<关闭/@exit>〗

[@ChangGender]
#IF
gender man
#SAY
是不是做猛男没什么意思呀，想不想尝尝做淑女的滋味呀！！！\ \
『<尝尝/@towoman>』\ \
〖<返回/@ChangSex>〗 〖<关闭/@exit>〗
#ELSESAY
是不是做淑女挺累的，想不想尝尝做猛男的滋味呀！！！\ \
『<尝尝/@toman>』\ \
〖<返回/@ChangSex>〗 〖<关闭/@exit>〗
[@toman]
#IF
;CHECKLEVEL 50
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
<返回/@MemberSexJob>
#ELSESAY
你未到50级不能转性别！！！
[@towoman]
#IF
;CHECKLEVEL 50
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \
〖<返回/@MemberSexJob>〗 〖<关闭/@exit>〗
#ELSESAY
你未到50级不能转性别！！！
;=========================================================================
[@changjob]
如何你想换一换职业，这里提供转职业服务，\
<注:>会员才能具有转职业的功能！！！\ \
『<换职业/@Chang>』\ \
〖<返回/@main>〗

[@Chang]
#IF
checkjob warrior
#SAY
是不是做武士不好玩呀，换换别的试试吧！\ \
『<玩玩法师/@ToWizard>』\
『<玩玩道士/@Totaos>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
checkjob wizard
#SAY
是不是做魔法师不好玩呀，换换别的试试吧！\ \
『<玩玩武士/@Towarr>』\
『<玩玩道士/@Totaos>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
checkjob taoist
#SAY
是不是做道士不好玩呀，换换别的试试吧！\ \
『<玩玩武士/@Towarr>』\
『<玩玩法师/@ToWizard>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
[@Towarr]
#if
#ACT
CHANGEJOB Warrior
#SAY
呵呵，你已经变成一位武士了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#elsesay
你不是会员！！！\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
[@ToWizard]
#if
#ACT
CHANGEJOB Wizard
#SAY
呵呵，你已经变成一位魔法师了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#elsesay
你不是会员！！！\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
[@Totaos]
#if
#ACT
CHANGEJOB Taoist
#SAY
呵呵，你已经变成一位道士了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗


CPU高

M2-选项-性能设置-默认设置-确定


UI转换

如何把20151108的UI替换到新登录器配置器里

旧的登录器配置器UI目录“UI_0”“UI_1”“UI_2”“UI_3”，有几个修改几个

UI_0\UI.db文件名称改成“Mir.db”
UI_0\ConfigUI.db文件名称改成“MirConfigDlg.db”
UI_0\StateUI.db文件名称改成“StateWin.db”

UI_1\UI.db文件名称改成“Mirs.db”
UI_1\ConfigUI.db改成“MirsConfigDlg.db”
UI_1\StateUI.db改成“StateWin.db”

UI_2\UI.db文件名称改成“MirReturn.db”
UI_2\ConfigUI.db文件名称改成“MirReturnConfigDlg.db”
UI_2\StateUI.db文件名称改成“StateWin.db”

UI_3\UI.db文件名称改成“Mir2013.db”
UI_3\ConfigUI.db文件名称改成“MirConfigDlg2013.db”
UI_3\StateUI.db文件名称改成“StateWin.db”

新的登录器配置器是要账号的，假设你的账号是“gameofmir”，登录器参数名称是“我的登录器”UI的位置就在

当前登录器配置目录下的“登录器参数\gameofmir\我的登录器\游戏界面UI”

把上面修改的UI文件替换进去，重启登录器配置器


脚本错误 script error,load fail

如果提示以下脚本错误

CALL的脚本要这样写

正确的:
[@法魔皇元神]
{

}

[@道魔皇元神]
{

}

错误的:
{
[@法魔皇元神]

[@道魔皇元神]

}


泡点功能详解

泡点功能：
可以实现人物在线时间隔指定时间自动得到指定游戏点数，这些点数可以用来换取物品、经验、等级或其它。

实现方法：
泡点是基于地图的，可以指定那些地图可以有泡点功能，人物进入此地图后就会自动增加点数。时间越长得到的点数就越多。

地图配置文件 MapInfo.txt
以比奇省图为例

[0 比奇省 0] INCGAMEPOINT(60/1)

此设置代表人物在比奇地图中时，60秒会自动得到1个游戏点。

通过脚本玩家可以查到自己的游戏点数及兑换经验,例:
[@main]
当前系统时间<$LOGINTIME>，<你进入游戏时间>为：<$LOGINLONG>\
<$USERNAME>您好根据您进入的时间所累计的<$GAMEGOLDNAME>有<$GAMEPOINT>点\
<当前等级>：<$LEVEL>级 <当前PK点数>：<$PKPOINT>点，<泡点点数>：<$GAMEPOINT>点\
<当前声望>：<$CREDITPOINT>点 <当前经验>：<$EXP><当前升级经验>：<$MAXEXP>\ \
『<兑换经验/@GetExp>』--每100个游戏点可以换经验100W\ \
〖<返回/@back>〗 〖<关闭/@exit>〗
[@GetExp]
#if
CHECKGAMEPOINT > 100
#act
CHANGEEXP + 1000000
GAMEPOINT - 100
#say
兑换成功
#ELSESAY
你都没100游戏点数!!!
<返回/@main>


如何拆分叠加物品

按住键盘“Shift”键，鼠标左键点击需要拆分的叠加物品


如何改变蜡烛类型装备掉持久类型

功能：
    自定义蜡烛物品掉持久控制，支持按时间掉持久或与普通装备一样受攻击掉持久。

用法：
    按时间掉持久：数品数据库中Source字段为：０
    受攻击掉持久：物品数据库中Source字段为：１

修改蜡烛、火把的持久值为亮度，10000持久亮度为1最高亮度5，会根据持久的降低,降低亮度


如何设置武器为吸血武器

功能：
可将武器设置成吸血武器；

用法：
在物品数据库中，将武器Anicount字段设为：138，
吸血量为武器的重量（如重量为10，即每刀吸血10点）


如何使用插件

插件分登录器插件和M2插件.他们分别是登录器使用的，和M2使用的，不能用错

登录器插件的调用:
在登录器配置器目下有“PlugClient”目录，只要把插件放进去，然后重新配置登录器。插件就会集成到这个新配置的登录器里，登录器启动时会自动释放插件并且调用该插件。

M2插件的使用:
插件需要放在“D:\MirServer\Mir200”目录下，然后把插件的名称写到“D:\MirServer\Mir200\PlugList.txt”这个文件里，M2就可以调用。

在程序包里，我们提供了插件编写的API和例子，提供Delphi和易语言二种插件源代码，会编程的可以为引擎增加新的脚本命令或其他功能。


什么是Pak文件

Pak文件是GOM引擎自定义图片资源格式，支持密码功能,可以使用工具包中的WIL编辑器创建修改等编辑。
1. 使用Pak文件需要配置Pak文件的密码。
2. Pak文件需要放在客户端对应的“Resources\Data”目录里，如果不想放在“Resources”，可以在配置里修改“Resources”目录名称，默认使用“Resources”目录.例如：如果“Resources\Data\Hum.Pak”文件存在，就不会再读取“Data\Hum.wzl”
3. Pak文件读取规则，详细查看登录器配置器。

Pak文件读取规则和Pak密码需要在登录器配置中配置。


什么是WIL序号

M2-查看-列表信息二

很多脚本命令和功能都会使用这个WIL序号。

WIL序号的计算是从0开始的,例如下图中从0开始数，

Mon36.wil的WIL文件序号是0

Icon.wil的WIL文件序号是1

NewopUI.Pak的WIL文件序号是2

prguse2.wzl的WIL文件序号是3

.......................

.......................

.......................


为什么M2里显示非法网关频繁打开或关闭？

如果是你网关所在机器的IP，请把该IP写到Mir200\!servertable.txt

如果显示的IP不是你的，是其他程序在连接你的引擎。解决方法:

1.使用安全策略封闭机器的内部连接端口，不让外网连接。例如只允许7000 7100 7200，3389等这几个端口对外可以连接，其他端口全部封闭对外连接

2.使用引擎启动控制器--配置向导--第八步前置服务器端口--连接端口默认的一般是5000，改成其他端口


为什么安全区可以杀人？

安全区参数配置错误。详见安全区参数配置


为什么不能自动解包

客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

使用启动器有个捆绑DB转换一下就正常了

新的解包配置文件 Envir\UnbindList.txt 格式，兼容旧格式，升级新M2如果不需要修改解包数量的，可以不修改Envir\UnbindList.txt：

;物品DB字段Anicount的值 物品名称 解包数量 物品类型(0其他,1加红,2加蓝,3加红蓝,4卷轴)

100 强效金创药 6 1
101 强效魔法药 6 2
119 强效太阳水 6 3
120 万年雪霜 6 3
102 金创药(小量) 6 1
103 魔法药(小量) 6 2
104 金创药(中量) 6 1
105 魔法药(中量) 6 2
106 地牢逃脱卷 6 4
107 随机传送卷 6 4
108 回城卷 6 4
109 行会回城卷 6 4


为什么刺杀看不见效果？

1.你的权限是10 也就是你是GM

2.在安全区


为什么登陆黑屏，M2提示全局会话验证失败？

一般情况是M2和账号服务器之间连接出了问题

如果IP端口都检测过设置正确，并且都成功连接成功的情况下，还是出现这个问题

可能是你的服务器名称有空格或括号等等特殊字符，或者名称太长


为什么登陆游戏黑屏

1.有可能是开的游戏网关(RunGate)有相同的端口。

解决方法：在控制器->配置向导->网关设置中调整设置

2.有可能是由于开了防火墙或者安全策略把你游戏网关(RunGate)端口给屏蔽了

解决方法：开放所要用到的端口

3.登录器和M2更新日期不一样，不配套

4.使用免费版的登录器登录商业引擎

5.使用商业版的登录器登录免费引擎

6.登录器配置时用的密码和RunGate网关中的登录密码不一样


为什么地面物品不显示名称，不自动捡取？

M2-查看-列表信息二-内挂捡取


为什么个人商店创建失败？

如果使用了你知道的所有方法都不能搞定。

请先关闭服务端，然后使用启动器的里的清除数据，清除个人商店的数据，一般都会正常。


为什么怪物打不死？

最大的可能就是，怪物DB的MP字段设置的值不是0

怪物的MP字段的作用是：

怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶。例如怪物数据库MP设置为10.不管你攻击多高，每次只能攻击最多掉血10


为什么看不见衣服翅膀和武器特效

1. M2里设置错误

2. 客户端没有相应的补丁

3. 内挂开启了隐藏衣服和武器特效的选项


为什么内挂乱吃包裹物品的问题[!]

启动器有个捆绑DB转换一下就正常了


为什么商铺购买不了元宝

商铺中的金币、元宝、声望、经验等等。

如果数据库中的物品名称以金币、元宝、声望、经验等等开头的，购买时不是给用户一个物品

而是根据物品的Need字段值直接给用户加点数。

例：

元宝100 这个物品，用户购买时，会根据这个物品的Need字段值直接给用户加元宝

如果想要给用户一个物品，可以把物品名称改成 100元宝


为什么所有的衣服外观都只显示重盔甲？

登录器配置器-内挂默认设置 衣服简装显示不要勾选 然后在配置登录器。或者在M2-选项客户端设置-内挂控制-玩家简装显示不要勾选，这样直接去掉这个功能

登录器呼出内挂-所有玩家简装显示 不要勾选


为什么提示file not found？

file not found => D:\MirServer\Mir200\Envir\Market_Def\.\QuestDiary\打宝数据\刷怪.txt

如果路径正确，文件存在。最大的可能QuestDiary前面只有1个点，要改成这样 ..\QuestDiary\打宝数据\刷怪.txt


为什么提示禁止点击该NPC触发字段？

为什么提示禁止点击该NPC触发字段，如下图？

下面以一个死亡触发为例，不仅仅是死亡触发，引擎的所有触发都不允许玩家点击NPC触发，
例如：物品触发[@StdModeFunc]，套装触发[@GroupItemOn] [@GroupItemOff]，魔法触发[@MagTagFunc]，穿脱装备触发[@TakeOn] [@TakeOff]等等，就不一一举例了。

[@PlayDie]
<下一页/@下一页>

[@下一页]
<返回/@PlayDie>

;<返回/@PlayDie> 新引擎这里“@PlayDie”是引擎内部触发字段，禁止用户通过NPC点击来触发这个字段
;不仅仅“@PlayDie”不允许“@PlayDie1、 @PlayDie2、 @PlayDie死亡”等等都不允许，只有前面的字符和“@PlayDie”一样的后面不管增加什么字符都将不允许
;如果非要使用玩家点击NPC触发的，可以把上面的脚本改成如下,使用goto转一下

[@PlayDie]
<下一页/@下一页>

[@下一页]
<返回/@返回>

[@返回]
#ACT
goto @PlayDie

---------------------------------------------------------------------------------------------------

还有其他一些触发，也属于这类的，比如：

DelayCall 5000 @再次复活
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

“@再次复活”和“@GiveNewHumanItem”就会变成引擎内部触发，也是不允许用使用NPC点击来触发的
还有一些其他脚本命令带字段触发的，就不一一举例了。


为什么微端不更新

微端更新是按需更新，例如登录器需要读取Hum.wzl里的第10张图片，如果登录器没有读取到，就会从微端更新这个图片，Hum.wzl里的其他图片不管有没有，登录器不需要读取就不会更新

1. 微端更新密码和登录器配置时的密码不一致

2. 微端除了支持Map目录的地图文件和Wav目录声音文件，Data目录的素材支持wzl和Pak这两种格式的素材更新,如果你使用的是wil需要转换成这2种格式才能正常更新

3. IP或者端口设置错误


为什么我的NPC不能买、卖、修理物品？

NPC脚本的第一行加上指定的操作，就可以正常了。

;=================================
(@buy @sell)
%100
+5
+6
[@main]
欢迎光临！！！
<买/@buy>\
<卖/@sell>\ \
<关闭/@exit>
;================================

功能标志说明：
;买物品
@buy
;卖物品
@sell
;炼药
@makedrug
;存仓库
@storage
;取仓库
@getback
;升级武器
@upgradenow
;取回升级武器
@getbackupgnow
;修理
@repair
;特殊修理
@s_repair
;发祝福语
@@sendmsg


为什么我的沙城墙没血条

第一步.首先检查M2启动有没报错，如有检查怪物数据库(Monster.DB)有没设置城墙类型怪物名称，如没只需将城墙名称与怪物数据库相对应即可解决，错误信息如下：
[错误信息] 城堡初始化城门失败，检查怪物数据库里有没城门的设置: MainDoor，

第二步.检查怪物数据库内城墙名称的血量，不能超过5000，


为什么我原来数据库里的武器加速，现在乱了？

由于数据库格式有些改变，原数据库里组合数据字段会有所变化，大家按以下规则改一下数据就行了。

武器5,6
(AC2) 准确
(MAC2) 1-10 为攻击速度减 11或以上为攻击速加，点数为 x - 10 = 1


为什么无法切换攻击模式，@开始提问无效？

最大的可能是命令被过滤了

M2-查看-列表信息二-消息过滤

就在这个里面过滤了，如果不知道哪个，就全部清空掉


为什么武器升级提示缺少材料

武器升级需要矿石和金币，

矿石错误，可以看Mir200\!Setup.txt里面 BlackStone=黑铁矿石 看看名称是否和你的包裹里的矿石名称一样，如果不一样请修改

M2-功能设置-升级武器，可以查看需要多少金币，如果金币足够，那就是矿石错了


为什么物品不能重叠

物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。 StdMode等于 0, 2, 3, 40, 41, 42

物品重叠功能，StdItem.DB 中OverLap=1或2 表示可以重叠 0不叠加
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量

DuraMax必须大于1


为什么有的客户端登录后地图是黑的黑屏,界面不显示？

如果使用了pak 并且pak的密码都设置正确，还是黑屏，并且在没有使用微端的情况下，可以看下面的图


为什么有空气墙？

先确认登录器和M2是否配套，在配套的情况，查看你所在的地图服务端和客户端是否一样，例：“D:\MirServer\Mir200\Map\3.Map” 和 “E:\盛大网络\热血传奇\Map\3.Map”不一样就会有空气墙


为什么装备元素属性不显示

M2-选项-物品装备-新增属性 勾选“启用新增属性”，勾选后登录器才能显示元素属性


BUFF

功能: 在屏幕右上角显示图标，在图标下面显示倒计时，时间到了，触发脚本，图标自动消失

SetClientBuff WIL文件序号 序号(1~20) 图片序号 倒计时间(-1时按钮，大于0是倒计时(单位：秒)) 文字备注 微调坐标X 微调坐标Y 附加特性(如果不使用附加特效，可以为空)

//倒时在QF脚本里触发[@CloseClientBuffX]X是序号。按钮模式点击在QF脚本里触发[@文字备注]

最后一个参数附加特效，如果为空，表示没有附加特效，共六个参数，每个参数之间使用“|”隔开。特效WIL序号|特效开始图片|播放张数|播放速度(毫秒)|播放模式(0特效绘制,1普通绘制)|微调X|微调Y

[@显示BUFF]
#ACT
SetClientBuff 9 1 275 60 文字备注 0 0 9|840|10|200|0|0|40

功能:关闭
CloseClientBuff 序号(1~20)


按地图列表移动

功能：
先设定每一张地图停留的地间，再把地图列表添加一下，人物会
从第一张地图开始一张一张移动到最后一张

例子：

[@Test]
#IF
#ACT
batchDelay 1 ;(暂停时间)
addbatch B102 ;步进地图名1
addbatch B103 ;步进地图名2
addbatch B104 ;步进地图名3
addbatch B105 ;步进地图名4
addbatch B106 ;步进地图名5
addbatch B107 ;步进地图名6
batchmove ;开始从第一个步进地图移动到最后一个步进地图(这里是6)


把人物的属性叠加给宝宝

 把人物的属性叠加给宝宝,需要把宝宝召唤出来，才可以叠加属性
ChangeSlaveAbil 宝宝名称 类型(0叠加到攻击,1叠加到防御) 叠加百分比(人物属性的百分之几叠加多少给宝宝) 使用人物的什么属性叠加给宝宝(0道术 1魔法 2攻击)


把人物加入行会

格式: ADDGUILDMEMBER 行会名称 人物名称(人物名称为空时把自己加入到行会)

[@main]
#ACT
ADDGUILDMEMBER 行会名称


把行会加入攻城列表

格式: ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为*号时所有行会加入到攻城列表) 天数(几天后开始攻城，该参数可以为空，为空时按照引擎设置的天数)

[@main]
#ACT
ADDTOCASTLEWARLIST 沙巴克 1


====================================宝宝不攻击人物================================================
ChangeSlaveAttackHumPowerRate 宝宝名称 攻击人物威力倍率(威力倍数为0时不攻击人物,当前值除以100为实际倍数)
调整版本攻击人物的威力倍率

[@main]
#if
CHECKSLAVENAME 神兽
#act
ChangeSlaveAttackHumPowerRate 神兽 0
sendmsg 6 神兽不攻击人物
#elseact
sendmsg 6 请先把神兽召唤出来


编组地图传送

GROUPMAPMOVE 地图号 X Y 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)

[@main]
#IF
#ACT
GROUPMAPMOVE 3 333 333 1 @GROUPMAPMOVE

[@GROUPMAPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令：
编组地图随机传送：GROUPMOVE
检查是否为组长：ISGROUPMASTER


编组地图随机传送

GROUPMOVE 地图号 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)

[@main]
#IF
#ACT
GROUPMOVE 3 1 @GROUPMOVE

[@GROUPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令：
编组地图传送：GROUPMAPMOVE
检查是否为组长：ISGROUPMASTER


变量数据传递MOVEX

MOVEX这个命令和MOV使用一样，不过在多级脚本使用中不一样

多级脚本触发，存在2个人物：

一个是执行脚本的人物，另外一个是触发这个脚本的人物，也就是说一个脚本是人物A执行的，但是这个脚本是由人物B触发后才开始运行的
看下面的例子:

[@main]
#ACT
MOV S1 神话
S1.MOVEX S2 <$USERNAME>
SENDMSG 6 S2使用的是神话这个人物的，<$USERNAME>这个使用的是，谁点击这个脚本，就调用的谁的
SENDMSG 6 这个脚本存在2个人，执行脚本的人物S1和点击触发脚本的人物


播放人物效果

格式: PLAYEFFECT WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 绘制模式(0特效绘制，1普通绘制)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
PLAYEFFECT 0 0 10 1 300


播放网络MP3

说明: 播放网络上的MP3文件,或者本地MP3文件.
格式: PlayMP3 http://www.d3dm2.com/123.mp3
注意: 如果是本地文件会自动搜索客户端Music目录中同名文件.

[@main]
#IF
#ACT
PlayMusic 100.MP3


播放音乐

格式: playsound 文件位置 循环次数 播放模式(0播放给自己,1播放给全服,2播放给同一地图,,4播放给同屏人物)

[@main]
#ACT
PLAYSOUND Wav\1.wav 1 0


穿人模式

功能: 改变当前人物的穿人,穿怪模式.
格式: THROUGHHUM 模式 时间(秒)
模式: [-1=恢复/0=穿人穿怪/1=穿怪/2=穿人]

#IF
#ACT
ThroughHum 1 60
SendMsg 5 60秒之内可随意穿怪.


创建文件

格式: CREATEFILE 文件名称

[@main]
#ACT
CREATEFILE ..\QuestDiary\名称列表.txt
#SAY
名称列表创建成功


从文件中随机取文本

功能：
从文件中随机取文本。

格式：
 GETRANDOMLINETEXT 文件 字符串变量

;==========================================
;示例脚本
[@Main]
#If
#Act
GETRANDOMLINETEXT ..\QuestDiary\装备列表.txt <$STR(S0)>
#Say
取回的文本是： <$STR(S0)>
;==========================================


从指定文件中删除字符串[!]

功能：
从指定文件中删除字符串和从指定文件中增加字符串。

格式：
 AddTextList 文件位置 字符串
DelTextList 文件位置 字符串

;==========================================
;增加字符串
[@Test老格式]
#IF
#ACT
AddTextList ..\TestList.txt 您的名字

[@Test新格式]
#IF
#ACT
AddTextList ..\TestList.txt 您的名字 您的性别
;==========================================

;==========================================
;删除字符串

[@Test老格式]
#IF
#ACT
DelTextList ..\TestList.txt 您的名字

[@Test1新格式]
#IF
#ACT
DelTextList ..\TestList.txt 您的名字 您的性别
;==========================================

新格式 老格式都可以使用


打开NPC大对话框[!]

格式: OPENMERCHANTBIGDLG WIL文件序号 图片序号 是否可以移动(0,1) 显示位置(0=左上角,1=右上角,2=左下角,3=右下角,4=居中) 微调坐标X 微调坐标Y 是否显示关闭按钮(0,1) 关闭按钮坐标X 关闭按钮坐标Y 窗口是否独立存在(0或为空不独立存在，1独立存在，独立存在的意思就是普通的NPC对话框和自定义大窗口NPC对话框可以同时显示，正常情况下是只能显示一个NPC对话框的，要么是普通的，要么是自定义大对话框)

例：

[@main]
#ACT
OPENMERCHANTBIGDLG 3 607 0 1 1 1 1
;根据下图中的WIL序号，3表示的是prguse2.wzl，WIL序号的计算是从0开始的,从0开始数prguse2.wzl在第三位,
;如果要调用其他素材，如果WIL资料里没有，可以先添加WIL文件到WIL资源列表，然后修改脚本的WIL文件序号，就可以调用对应的文件。
;这个脚本调用的是prguse2.wzl素材里的607这个素材，为NPC的对话框

什么是WIL文件序号？

具体可以在，M2-查看-列表信息二


打开OK对话框

格式: OPENUPGRADEDLG 显示的名称

例：
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)


打开个人商店脚本命令

OpenShopDlg 类型(0所有商店列表 1我的商店列表)

[@main]
#ACT
OpenShopDlg 0


打开商铺脚本命令

OpenSndaShopDlg

[@main]
#ACT
OpenSndaShopDlg


打开自定义NPC对话框[!]

格式：OpenBigDialogBox WIL文件编号 图片编号

范例：

[@main]
#ACT
OpenBigDialogBox 16 109
#SAY
<Img:115:16:602:-15/@Label>

[@Label]
#IF
#ACT
CloseBigDialogBox
Close


调整宝宝的攻击威力

 修改宝宝的攻击威力
ChangeSlavePowerRate 宝宝名称 (+,-,=) 威力倍数(实际倍数等于设置值除以100) 有效时间(秒)


调整宝宝等级

功能: 直接调整人物宝宝的等级
格式: ChangeSlaveLevel 名字 操作符(+ = -) 等级(1-7)

例子: 把虎卫的等级调整到7级.
#IF
#ACT
ChangeSlaveLevel 虎卫 = 7


调整技能等级(扩展)

功能：
脚本调整技能等级。

格式：
 SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)

;==========================================
[@skilllevel0]
#IF
#ACT
SKILLLEVEL 雷电术 = 3
#SAY
你的雷电术等级已经为3级。
;==========================================

;==========================================
;
[@skilllevel1]
#IF
#ACT
SKILLLEVEL 雷电术 + 1
#SAY
你的雷电术等级已经升了1级。
;==========================================

;==========================================
;
[@skilllevel2]
#IF
#ACT
SKILLLEVEL 雷电术 - 1
#SAY
你的雷电术等级已经降了1级。
;==========================================

[@skilllevel3]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重


调整技能点数[!]

功能：
脚本调整技能点数。

格式：
 CHANGETRANPOINT 控制符(+,-,=) 点数

;==========================================
[@CHANGETRANPOINT]
#IF
#ACT
CHANGETRANPOINT 雷电术 = 100
;==========================================


调整金刚石数量

功能：
调整金刚石和灵符数量。

格式：
 GAMEDIAMOND 控制符(=,+,-) 点数(0 到 2147483647)
GAMEGIRD 控制符(=,+,-) 点数(0 到 2147483647)

;==========================================
;将人物的金刚石设置为指定点数，不能为负数
#IF
#ACT
GAMEDIAMOND = 0
#SAY
你的金刚石数量为0
;==========================================

;==========================================
;将人物的灵符设置为指定点数，不能为负数

#IF
#ACT
GAMEGIRD = 0
#SAY
你的灵符数量为0

;==========================================


调整人物的HP或MP[!]

功能：
调整人物的HP或MP

格式：

HUMANHP（+ - =）数字

HUMANMP（+ - =）数字
=========================
[@HUMANHP0]
#IF
#ACT
HUMANHP + 100

[@HUMANHP1]
#IF
#ACT
HUMANHP - 100

[@HUMANHP2]
#IF
#ACT
HUMANHP = 100
=========================

[@HUMANMP0]
#IF
#ACT
HUMANMP + 100

[@HUMANMP1]
#IF
#ACT
HUMANMP - 100

[@HUMANMP2]
#IF
#ACT
HUMANMP = 100
=========================


调整人物的荣誉值[!]

#IF
CheckLevelEx > 50
#ACT
ChangeNationCredit + 100

—————————————————————两个命令自己测试

格式: GAMEGLORY (+,-,=) 值

[@main]
#ACT
GAMEGLORY + 5
#SAY
荣誉值+5


调整人物的元素属性

调整人物的元素属性，该命令调整的元素，小退消失，只是临时的元素，不是永久的
ChangeHumNewValue 元素位置(0-10) 增加百分比(0-255) 有效时间(秒) 暴击或者反伤时的威力倍数(实际倍数等于设置值除以100)
-----------------------------------------------------------------------------

属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%


调整人物会员等级

功能：
调整人物会员等级。

格式：
 SETMEMBERLEVEL 控制符(=,+,-) 等级数(1-65535)

;==========================================
;设置人物会员等级
[@changememberlevel0]
#IF
#ACT
SETMEMBERLEVEL = 5
#SAY
你的会员等级为5。
;==========================================

;==========================================
;增加人物会员等级
[@changememberlevel1]
#IF
#ACT
SETMEMBERLEVEL + 1
#SAY
你的会员等级已经改变。
;==========================================

;==========================================
;减少人物会员等级
[@changememberlevel2]
#IF
#ACT
SETMEMBERLEVEL - 1
#SAY
你的会员等级已经改变。
;==========================================


调整人物会员类型

功能：
调整人物会员类型。

格式：
 SETMEMBERTYPE 控制符(=,+,-) 类型数(1-65535)

;==========================================
;设置人物会员类型
[@changemembertype0]
#IF
#ACT
SETMEMBERTYPE = 5
#SAY
你的会员类型为5。
;==========================================

;==========================================
;增加人物会员类型
[@changemembertype1]
#IF
#ACT
SETMEMBERTYPE + 1
#SAY
你的会员类型已经改变。
;==========================================

;==========================================
;减少人物会员类型
[@changemembertype2]
#IF
#ACT
SETMEMBERTYPE - 1
#SAY
你的会员类型已经改变。
;==========================================


调整人物属性

功能： 调整人物属性

格式: ChangeHumAbility 属性(1-20) 操作符(+ = -) 效果(1-65535) 时间秒
说明: 属性1-12分别对应人物 防御下限 防御上限 魔御下限 魔御上限 攻击下限 攻击上限 魔法下限 魔法上限 道术下限 道术上限 MaxHP MaxMP HP恢复 MP恢复 毒恢复 毒躲避 魔法躲避 准确 敏捷 幸运
注意: 整后的属性效果只在人物在线时有效.? 不带时间为在线一直有效

例子：

[@Test]
#IF
#ACT
ChangeHumAbility 2 + 10 60
#SAY
你的防御上限增加10点.60秒后恢复


调整人物游戏点数

功能：
调整人物游戏点。

格式：
 GAMEPOINT 控制符(=,+,-) 点数(1-100)< /FONT>

;==========================================
;设置人物游戏点
[@GAMEPOINT0]
#IF
#ACT
GAMEPOINT = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏点
[@GAMEPOINT1]
#IF
#ACT
GAMEPOINT + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏点
[@GAMEPOINT2]
#IF
#ACT
GAMEPOINT - 1
#SAY
你的游戏点已经降了1点。
;==========================================


调整声望点

功能：
调整人物声望点。

格式：
CREDITPOINT 控制符(=,+,-) 点数(1-100)< /FONT>

;==========================================
;设置人物声望点
[@CREDITPOINT0]
#IF
#ACT
CREDITPOINT = 8
#SAY
你的声望点已经为8了。
;==========================================

;==========================================
;增加人物声望点
[@CREDITPOINT1]
#IF
#ACT
CREDITPOINT + 1
#SAY
你的声望点已经加了1点。
;==========================================

;==========================================
;降人物声望点
[@CREDITPOINT2]
#IF
#ACT
CREDITPOINT - 1
#SAY
你的声望点已经降了1点。
;==========================================


调整属性点

功能：
调整人物属性点。

格式：
BONUSPOINT 控制符(=,+) 点数(0-1000)< /FONT>

;==========================================
;设置属性点
[@BONUSPOINT0]
#IF
#ACT
BONUSPOINT = 0
#SAY
你的属性点点已全部清0了。
;==========================================

;==========================================
;增加属性点
[@BONUSPOINT1]
#IF
#ACT
BONUSPOINT + 1
#SAY
你的属性点已经加了1点。
;==========================================

相关命令：
复位属性点数：RESTBONUSPOINT
检查属性点数：CHECKBONUSPOINT


调整死亡不掉装备的次数
NotDropItemCount (+,-,=) 次数

配套检测死亡不掉装备的次数

检测死亡不掉装备的次数
CheckNotDropItemCount (<,>,=) 次数


调整物品来源信息

物品来源

格式: CHANGEMAKEITEMINFO 位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 类型(0没有物品来源 1GM创建 2NPC创建 3购买的商铺的 4购买的NPC商店里的 5怪物爆的 6系统刷的 7挖矿 8挖的 9宝箱) 地图名称(不能为空) 人物名称(如果没有用“*”代替，不能为空) 怪物名称(如果没有用“*”代替，不能为空) 是否修改物品来源时间(1为修改为当前时间，为空时不修改)

[@删除衣服的物品来源]
#ACT
CHANGEMAKEITEMINFO 0 0

[@修改衣服的物品来源]
#ACT
CHANGEMAKEITEMINFO 0 1 3 <$USERNAME> * 1
SENDMSG 6 衣服的来源已经修改为GM制造，并且修改为当前时间

[@修改衣服的物品来源]
#ACT
CHANGEMAKEITEMINFO 0 5 3 <$USERNAME> 白野猪
SENDMSG 6 衣服的来源已经修改为怪物爆出


调整物品名字颜色

功能:调整人物身上物品装备名字颜色(英雄M2)
格式:ChangeItemNameColor 物品位置(0-18，-1位OK框物品) 颜色(0-255)
说明:颜色=0时恢复默认颜色.

[@main]
#IF
#ACT
ChangeItemNameColor 1 253
#SAY
你装备名字的颜色变成紫色了.


调整物品元素属性

格式: SetNewItemValue 位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM


调整行会可以容纳最多成员

格式: CHANGEGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示调整自己所在的行会) 调整符(+,-,=) 数量
[@main]
#IF
CHANGEGUILDMEMBERMAXLIMITCOUNT = 100
#SAY
你的行会可以容纳100个成员


调整行会人数上限[!]

功能: 调整当前行会的人数上限.
说明: 只能由行会老大使用.每个行会会自动读取!Setup.txt中的行会人数限制,之后可以用此命令重
      新调整行会人数限制,也就是说调整后不受!Setup.txt中行会人数限制参数的限制.

格式: AddGuildMemberCount 操作符(+ - = ) 数量(0--1000)

#IF
CheckItem 金条 1
#ACT
Take 金条 1
AddGuildMemberCount + 5
#ELSESAY
你没有金条或者你不是行会老大.


调整血量，魔法百分比

功能：
调整血量，魔法百分比

格式：
ADDHPPER 操作符(+,-,=)?百分比(1-100)
ADDMPPER 操作符(+,-,=)?百分比(1-100)

;==========================================
例：
#IF
#ACT
AddMpPer + 30
GuildNoticeMsg 250 0 你的MP增加了30% self

======================================================================
例：
#IF
#ACT
h.AddMpPer + 30 1
GuildNoticeMsg 250 0 你的英雄MP增加了30% self #IF
h.CheckHpPer > 30 1
#ACT
#SAY
你的英雄血量在总血量的30%以上
;==========================================


调整游戏速度

格式: ChangeSpeed 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间)
速度类型 1为 移动速度 2为攻击速度 3为魔法速度
速度值(-10和10之间 小于0为减速 等于0不变速)

[@main]
#ACT
CHANGESPEED 1 5
#SAY
移动速度增加


调整装备升级次数或星星数量[!]

功能: 调整装备升级次数或星星数量.

格式: ChangeItemUpgradeCount 物品位置(0~18,-1时为OK框物品) (+,-,=) 次数(0~255)

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器
;==========================================

#IF
CheckItem 金条 1
#ACT
Take 金条 1
ChangeItemUpgradeCount 0 + 10
SendMsg 5 盔甲升级次数增加10次
#ELSESAY
你没有金条


读写ini配置项

说明：读写ini配置项

---------------------------------------------------------------------------------------------

说明：

WriteConfigFileItem写配置项
功能说明：可以把一些数据进行配置保存 你也可以把它当成一种变量保存方式

ReadConfigFileItem读配置项
功能说明：获取出配置文件中的配置项内容

此两个命令配合使用 就相当于变量保存操作

示例：
[@main]
<写配置项> <请输入你要写入配置项的内容/@@InPutString3>\
<读配置项内容/@读配置项> <$STR(S$配置项内容)>\

[@InPutString3]
#IF
#ACT
;写配置项
WriteConfigFileItem ..\QuestDiary\KEY.txt <$USERNAME> 内容 <$STR(S3)>
SENDMSG 6 你已经把你输入的内容写到配置文件中KEY.txt

[@读配置项]
#IF
#ACT
;读配置项
ReadConfigFileItem ..\QuestDiary\KEY.txt <$USERNAME> 内容 <$STR(S$配置项内容)>
SENDMSG 6 你已经把配置文件KEY.txt中的内容获取出
GOTO @main

删除配置文件中的一行：
DelConfigFileItem 文件名 设置 用户 （删除 用户 = aaaa 这一行）

删除配置文件中的一个区：
DelConfigFileSection 文件名 设置 （删除 [设置] 及设置以下的项）

WriteConfigFileItem ReadConfigFileItem 支持绝对路径，注意使用绝对路径参数必须完整！


二次攻击目标

二次攻击目标，在攻击目标的时候，可以造成第二次攻击伤害

StruckDamage 威力 是否检测目标是否是麻痹、冰冻、中毒如果设置了检测有这些状态不攻击(0不检测 1检测)


发送屏幕滚动信息

功能:

发送屏幕滚动信息

格式:

SENDMOVEMSG 信息类型代码(0全局发送，1发送给个人) 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容

[@测试]
#if
#ACT
MOV S1 这个是屏幕滚动信息坐标在100
SENDMOVEMSG 1 253 255 100 3 <这个是屏幕滚动信息坐标在100/FCOLOR=250>{<$STR(S1)>/FCOLOR=253}{<$USERNAME>/FCOLOR=254}<这个是屏幕滚动信息坐标在100/FCOLOR=69>
SENDMOVEMSG 1 253 255 350 1 这个是屏幕滚动信息坐标在350


发送屏幕中间大字体信息

功能: 在专用登录器屏幕的中间显示公告.
格式: SendCenterMsg 前景色 背景色 消息文字 模式 显示时间 倒计时标签
模式: 0=发送给自己 1=发送所有人物 2=发送行会 3=发送国家 4=发送当前地图 5=替换模式
说明: 设置倒计时标签时可执行自定义脚本功能.

例子:
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0

例子:显示30秒.
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0 30

执行倒计时标签(注意:文字提示中必须包含%d):
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

;需要放QFunction脚本中
[@GiveNewHumanItem]
#IF
#ACT
Give 金条 1
Give 裁决之杖 1
Give 圣战戒指 2
Give 圣战手镯 2
Give 圣战头盔 1
Give 圣战项链 1
Give 天魔神甲 1

例子:替换模式
替换模式只在有倒计时标签时有效.

;以下例子说明如何使倒计时从新开始.
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 0 600 @ExitMap

;执行替换模式使时间从新开始
[@main1]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 5 600 @ExitMap


发送文字信息

功能：
利用NPC发送信息。

格式：
 SENDMSG 信息类型代码 字体颜色(0-255) 背景颜色(0-255) %s信息内容%d

信息类型代码：
1、发送普通红色广播信息。
2、发送普通红色广播信息，并显示NPC名称。
3、发送普通红色广播信息，并人物NPC名称。
4、在NPC头顶，显示普通说话信息。
5、发送红色信息给人物
6、发送绿色信息给人物
7、发送蓝色信息给人物

%s 代表人物名称
%d 代表NPC名称

命令格式：
[@test]
#IF
#ACT
SENDMSG 0 %s信息内容%d
SENDMSG 1 %s信息内容%d
SENDMSG 2 %s信息内容%d
SENDMSG 3 %s信息内容%d
SENDMSG 4 %s信息内容%d
SENDMSG 5 %s信息内容%d
SENDMSG 6 %s信息内容%d
SENDMSG 7 %s信息内容%d

;以下是自定义颜色

SENDMSG 0 249 47 %s信息内容%d
SENDMSG 1 249 255 %s信息内容%d
SENDMSG 2 249 253 %s信息内容%d
SENDMSG 3 249 47 %s信息内容%d
SENDMSG 4 249 47 %s信息内容%d
SENDMSG 5 249 47 %s信息内容%d
SENDMSG 6 249 47 %s信息内容%d
SENDMSG 7 249 47 %s信息内容%d

==================================================


返回OK框中的物品

格式: RECLAIMITEM

;返回OK框中的物品到包裹

例：
[@main]
#ACT
RECLAIMITEM


复活人物

格式: REALIVE

[@main]
#ACT
REALIVE


改变人体颜色

格式: SETBODYCOLOR 颜色(0~255)255时清除颜色 改变时长(秒)

[@main]
#ACT
SETBODYCOLOR 253
H.SETBODYCOLOR 253


改变人物攻击模式

ChangeAttatckMode (0~7)

;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击 6-红名攻击 7-国家攻击


改变人物状态

格式: MAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 12冰冻 13蛛网 其他无效) 时间(秒) 威力

例：
[@main]
#ACT
MAKEPOSION 5 10 10
#SAY
你被麻痹了

[@main]
#ACT
MAKEPOSION 12 10
#SAY
你被冰冻了

[@main]
#ACT
MAKEPOSION 13 10
#SAY
你被蛛网缠绕


改变用户模式

功能：
增加脚本命令ChangeModeEx
改变人物当前模式(无敌,隐身,生命,魔法,攻击力,魔法力,道术力,攻击速度,禁止攻击,锁定,禁锢,冰冻,蛛网,防麻痹,防禁锢,防冰冻,防蛛网,麻痹,护身，吸血,吸蓝)

//格式: ChangeModeEx 模式(1-10) 时间(1-65535) 附加值(1-21亿)
//说明: 1=无敌 2=隐身 3=HP 4=MP 5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定
//第三个参数无敌,隐身,禁止攻击时没有使用.
//如果是禁锢时，第三个参数表示禁锢范围
//11 禁锢(释放一个类似困魔咒的光圈，敌对人物或怪物只能在这个圈子里移动，无法走出圈子外面，所有传送失效，不能小退)
//12 冰冻
//13 蛛网
//14 防麻痹
//15 防禁锢
//16 防冰冻
//17 防蛛网
//18 麻痹
//19 护身
//20 吸血
//21 吸蓝

例子：

[@Test]
#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!

#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.

[@Main]
#ACT
ChangeModeEx 11 10 3
SENDMSG 6 你被禁锢10秒

ChangeModeEx 12 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标冰冻，冰冻机率5(数字越大机率越低)，冰冻时长3秒

ChangeModeEx 13 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标中蛛网，中蛛网机率5(数字越大机率越低)，中蛛网时长3秒

ChangeModeEx 14 10
SENDMSG 6 10秒内可以防麻痹

ChangeModeEx 15 10
SENDMSG 6 10秒内可以防禁锢

ChangeModeEx 16 10
SENDMSG 6 10秒内可以防冰冻

ChangeModeEx 17 10
SENDMSG 6 10秒内可以防蛛网

ChangeModeEx 18 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标麻痹，麻痹机率5(数字越大机率越低)，麻痹时长3秒

ChangeModeEx 19 10
SENDMSG 6 护身，有效10秒

ChangeModeEx 20 10 100 50
SENDMSG 6 10秒内攻击目标，可以吸血，吸血机率100(数字越大机率越高 100表示每次都会吸血)，吸血百分比50%(比如攻击伤害值是10000，50%的吸血比例，可以吸血5000)

ChangeModeEx 21 10 100 50
SENDMSG 6 10秒内攻击目标，可以吸蓝，吸蓝机率100(数字越大机率越高 100表示每次都会吸蓝)，吸蓝百分比50%(比如攻击伤害值是10000，50%的吸蓝比例，可以吸蓝5000)


高等级杀怪经验不变

格式:HighLevelKillMonFixExp 时间(秒) 是否保存（1保存，空或0不保存）

[@main]
#ACT
HighLevelKillMonFixExp 720 1


个人定时器

功能：
个人定时器。

格式：
 SETONTIMER 定时器索引(0-255) 定时间隔（单位为秒）
SETOFFTIMER 定时器索引(0-255) //停止定时器

;==========================================
设置定时器
[@Test]
#IF
#ACT
SetOnTimer 0 20

QManage.txt:
[@OnTimer0]
#ACT
SendMsg 5 你目前位于%m的(%x：%y)
;==========================================

;==========================================
停止定时器
[@Test]
#IF
#ACT
SetOffTimer 0
;==========================================


给予带绑定状态装备[!]

功能：
给予带绑定状态装备。主要方便设置不能配带的装备绑定状态

格式：

格式:CheckItemBind 装备位置(-1~16,-1时为OK框中物品)
GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6 项目7(0为正常,1为绑定) 数量

;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备,项目7--丢弃消失

[@给一个绑定的装备]
#ACT
GiveStateItem 木剑 1 0 0 0 0 0 0 1
SENDMSG 6 给你一个绑定木剑并且禁止扔


更改人物颜色

功能：
更改人物颜色。

格式：
CHANGENAMECOLOR 颜色代码(0-255)

;==========================================
;设置人物的名称颜色
[@changeexp0]
#IF
#ACT
CHANGENAMECOLOR 2
#SAY
你的颜色已改变。
;==========================================


更改头发类型

功能：
更改头发类型

格式：
;============================
[@ChangeHair]
#if
#act
HAIRSTYLE 0
#say
你的头发已更改
;============================


更换性别

功能：
更换性别。

格式：
 CHANGEGENDER 性別(男 0 女 1)

;==========================================
[@toman]
#IF
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \

[@towoman]
#IF
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \


关闭NPC大对话框

格式: CLOSEMERCHANTBIGDLG

[@main]
#ACT
CLOSEMERCHANTBIGDLG


关闭或显示脚本命令提示没有戴指定物品

SETSHOWITEMMSG (0关闭，1显示)

用来关闭或显示，有的脚本命令会提示“你身上没有戴指定物品！！！”


关闭自定义NPC对话框

CloseBigDialogBox


过滤全服提示信息

功能：
过滤全服提示信息

格式：
FILTERGLOBALMSG 是否过滤(0不过滤，1过滤)

[@main]
#IF
#ACT
FILTERGLOBALMSG 1
SENDMSG 6 开启过滤全服提示信息，你不在接受如SENDMSG、GuildNoticeMsg等等脚本命令发送的全服提示信息。


获取包裹里某个物品的数量

GetItemsNumber 物品名称 保存变量


获取对面人物的名字

说明: 获取对面人物的名字
格式: GetOppositeHumName 变量

#IF
#ACT
GetOppositeHumName S0
SendMsg 5 你对面的人物是: <$STR(S0)>


获取身上装备属性值到变量

获取身上装备属性值到变量 支持英雄

GetItemAbil 装备位置(0-18) 保存变量1(攻击下限) 保存变量2(攻击上限) 保存变量3(魔法下限) 保存变量4(魔法上限) 保存变量5(道术下限) 保存变量6(道术上限)

0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器


获取文本字符

GetRandomText 文件路径 变量


获取物品数据库的字段值

-----------------------------------获取物品属性值---------------------------

获取物品属性值

1.获取物品属性值
GetDBItemFieldValue 物品名称 字段名称 保存变量

GetDBItemFieldValue 屠龙 NAME S1

字段名称
IDX
NAME
STDMODE
SHAPE
WEIGHT
ANICOUNT
SOURCE
RESERVED
LOOKS
DURAMAX
HP
MP
AC
MAC
DC
MC
SC
AC2
MAC2
DC2
MC2
SC2
NEED
NEEDLEVEL
PRICE
STOCK
COLOR
OVERLAP
INSURANCEGOLD
INSURANCECURRENCY
VALUE0
VALUE1
VALUE2
VALUE3
VALUE4
VALUE5
VALUE6
VALUE7
VALUE8
VALUE9
VALUE10
VALUE11
VALUE12
VALUE13
VALUE14
VALUE15
VALUE16
VALUE17
VALUE18
VALUE19


加入国家

格式：JoinNational (国家编号 0~100 0表示从当前国家中删除，也就是退出该国家)

;==========================================
[@main]
#IF
CheckNational 0
#ACT
JoinNational 1
SENDMSG 6 你成功加入<$NATIONNAME>，当前国家总人数:<$NATIONPEOPLE>
#ELASEACT
MESSAGEBOX 你已经加入了<$NATIONNAME>，是否要注销国籍？ @yes

[@yes]
#ACT
JoinNational 0
SENDMSG 6 你成功注销国籍

;==========================================


加入会员人物及时间

加入会员人物及时间： ADDUSERDATE 会员.txt

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1

删除会员人物及时间： DELUSERDATE 会员.txt


假人自动练功[!]

功能: 假人自动练功

格式:AutoUseMagic 技能ID 间隔秒。(必须是学过的技能，在非挂机状态，没有攻击目标的情况下才能正常练功)

[@main]
#ACT
AutoUseMagic 0 10


假人自动锁定目标

[@假人自动锁定目标]
#ACT
DUMMYAUTOTARGET 1
;假人使用这个命令后，搜索到攻击目标后，会自动锁定该目标
;DUMMYAUTOTARGET 参数(0关闭自动锁定,1开启自动锁定)


拣物品触发[!]

功能: 挂机命令

格式:ISDUPMODE (0或空时检测所有对象，1只检测人物)

范例地址：挂机范例脚本


将人物行会名加入列表

功能：
将人物行会名加入列表

格式：
==========================
[@addguildList]
#if
#act
ADDGUILDLIST guildlist.txt
==========================


脚本调整人物PK点

功能：
调整人物PK点数。

格式：
 CHANGEPKPOINT 控制符(=,+,-) PK点数

;==========================================
;将人物的PK点数设置为指定点数，不能为负数
[@changepkpoint0]
#IF
#ACT
CHANGEPKPOINT = 0
#SAY
你的PK点数已经清除。
;==========================================

;==========================================
;将人物的PK点数加100点数，不能为负数
[@changepkpoint1]
#IF
#ACT
CHANGEPKPOINT + 100
#SAY
你的PK点数已经增加100点。

;==========================================

;==========================================
;将人物的PK点数减100点数，不能为负数，如果人物点数小于100则指定为0
[@changepkpoint2]
#IF
#ACT
CHANGEPKPOINT - 100
#SAY
你的PK点数已经减少100点。
;==========================================


脚本调整升级经验

功能：
调整人物经验点数。

格式：
 CHANGEEXP 参数1(=,+,-) 参数2(经验值) 参数3(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)

;==========================================
;将人物的经验点数设置为指定点数，不能为负数
[@changeexp0]
#IF
#ACT
CHANGEEXP = 20000
#SAY
你当前的经验点数为 20000。
;==========================================

;==========================================
;将人物的经验点数加1000点数，不能为负数
[@changeexp1]
#IF
#ACT
CHANGEEXP + 1000
#SAY
你的经验点数已经增加1000点。

;==========================================

;==========================================
;将人物的经验点数减1000点数，不能为负数，如果人物点数小于1000则指定为0
[@changeexp2]
#IF
#ACT
CHANGEEXP - 1000
#SAY
你的经验点数已经减少1000点。
;==========================================


脚本控制人物等级

功能：
调整人物等级。

格式：
 CHANGELEVEL 控制符(=,+,-) 等级数(1-500)

;==========================================
;设置人物等级
[@changelevel0]
#IF
#ACT
CHANGELEVEL = 80
#SAY
你的等级已经为80级了。
;==========================================

;==========================================
;增加人物等级
[@changelevel1]
#IF
#ACT
CHANGELEVEL + 1
#SAY
你的等级已经升了1级。
;==========================================

;==========================================
;降人物等级
[@changelevel2]
#IF
#ACT
CHANGELEVEL - 1
#SAY
你的等级已经降了1级。
;==========================================


脚本命令刷怪

格式:

MonGenEx 地图文件名称 X Y 怪物名称 范围 数量 是否内功怪物(0否,1是) 名称颜色(0~255) 国家名称(属于哪个国家的怪物，没有可以为空) 同一个国家玩家是否可攻击怪怪物(0不可以,1可以)
最后2个参数是国家怪物设置，如果没有可以留空

[@main]
#if
#act
MonGenEx 3 330 330 白野猪 12 10 0 255


禁止骑马

在骑马触发里使用

[@OnHorse]
#ACT
HORSERIDINGBAN
SENGMSG 6 禁止骑马


禁止小退

[@SoftClose]
;配合禁止小退命令，可以禁止人物小退
;“DIABLESOFTCLOSE”该命令只能在[@SoftClose]下使用，其他地方无效
DIABLESOFTCLOSE


开启第四个连击技能的命令[!]

功能：开启第四个连击技能的命令
格式：无
说明：
例：
[@main]
#if
CHECKOPENLASTSKILL
#say
第四个连击技能已经开启
#elseact
OPENLASTSKILL


扩展GIVE命令

给物品到用户包裹

GIVE 物品名称 数量 极品属性(13个参数，可以参考UPGRADEITEMEX命令 属性位置的介绍，或自己实际测试看效果) 元素属性(11个参数,从暴击机率开始)

例：

GIVE 布衣(男) 1 100|100|100|100|100|100|100|100|100|100|100|100|100 100|100|100|100|100|100|100|100|100|100|100|100|100


扩展MessageBox

MessageBox 信息 @确定 @取消

[@main]
#if
#act
MessageBox 是否确认要删除 @确定 @取消

[@确定]
点击的确定

[@取消]
点击的取消


扩展MOVR使用方法

功能：
扩展MOVR使用方法。

格式：
 MOVR 变量 数值1 数值2

;==========================================
MOVR G10 100 ;随机生成100以内的随机数.
MOVR G10 10 100 ;随机生成10-100之间随机数
MOVR G10 100 5000 ;随机生成100-5000之间随机数
MOVR G10 1000 9999 ;随机生成1000-9999之间随机数
;==========================================


练习技能

功能：
脚本增加技能。

格式：
 ADDSKILL 技能名称

;==========================================
;增加技能
[@addskill]
#IF
#ACT
ADDSKILL 雷电术
#SAY
你已经练习雷电术了。
;==========================================

相关命令：
删除技能：DELSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL


屏幕震动

屏幕震动 M2-选项-客户端设置-内挂控制-勾选屏幕震动才能生效。内挂里也要勾选屏幕震动才能生效

屏幕震动命令格式:
SCENEVIBRATION 模式(0~4，0仅自己，1在线所有人，2屏幕范围内人物，3.当前地图上所有人 4.指定地图上所有人) 震级(1~3) 次数 地图ID(模式等于4时，需要该参数)

[@main]
#IF
#ACT
SCENEVIBRATION 0 1 1
SENDMSG 6 你的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 1 1 1
SENDMSG 6 在线所有人的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 2 1 1
SENDMSG 6 当前屏幕范围内的所有人的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 3 1 1
SENDMSG 6 当前地图所有人的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 4 1 1 3
SENDMSG 6 土城所有人的屏幕开始震动


清除SendCenterMsg DelayGoto

[@main]
#act
CLEARDELAYGOTO
sendmsg 6 DELAYGOTO延迟时清除

[@main]
#act
CLEARDELAYGOTO 1
sendmsg 6 SendCenterMsg倒计时清除


清除地图物品

功能：
 清理地图上指定名字的物品.

格式：
 CLEARITEMMAP 地图 X Y 范围 物品名称 (清除地图物品，不带物品名称则清除所有)

说明：
 物品名字等于*时表示指定范围内的所有物品.

;清除盟重安全区内的回城卷
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10 回城卷
#SAY
盟重安全区内的回城卷都被清除了。

清除盟重安全区内所有物品
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10
#SAY
盟重安全区内的所有物品都被清除了。


清除地图中的怪物

功能：
用于清除指定地图里的怪物，人物的宝宝不在此范围以内，禁止清除怪物列表中的怪物不会被清除。
此功能一般用于动态刷怪方式，在有人的地图出现怪物，没人时地图上的怪物全部清除，以大大节约机器资源。

命令格式：
CLEARMAPMON 地图号

例子：

#ACT
CLEARMAPMON D717
#say
<返回/@main>


清除结婚信息

;============================
[@delMarry]
#if
DELMARRY
#say
你的结婚信息已清除
;============================


清除列表内容

脚本功能:
清除列表内容

命令格式:
CLEARNAMELIST namelist.txt

;==========================================
;清除列表
[@Clearnamelist]
#IF
#ACT
CLEARNAMELIST namelist.txt
#SAY
列表已被清除
;==========================================


清除人物的仓库密码

功能：
清除人物的仓库密码

格式：
 CLEARPASSWORD

;==========================================
;设置人物的名称颜色
[@clearpassword]
#IF
#ACT
CLEARPASSWORD
#SAY
你的仓库密码已清除。
;==========================================


清除人物转生

功能：
清除人物转生数据(即人物转生后恢复到未转生状态)

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================


清除延时移动

功能:
清除延时移动

格式:
BREAKTIMERECALL

============================

[@Test]
#IF
#ACT
BREAKTIMERECALL
#Say
延时移动已清除

===========================


取对面角色人物名

功能：
取对面角色人物名到变量

格式：
GETPOSENAME 变量名

功能：
================================
[@AddAccountList]
#IF#act
GETPOSENAME a1
#SAY
对面的人物名：<$STR(a1)>
================================


人物聊天文字变色

功能: 改变人物公聊时的文字信息颜色.
格式: ChangeHearMsgColor 时间(分钟) 颜色(0-255)

;人物说话信息蓝色显示
[@main]
#IF
#ACT
ChangeHearMsgColor 10 180


人物杀怪暴率倍数

需要在M2里开启 选项-功能设置-其他控制(1)里开启

----------------------------------------人物杀怪暴率倍数------------------------------------------
脚本命令 KILLMONBURSTRATE 20140220 20140221 参数1 20140223 20140224 20140225 20140226 参数2 20140227 20140228
参数说明：
参数1 //倍率，实际倍率除以100;
参数2 //时长
例如：
#ACT
KILLMONBURSTRATE 20140220 20140221 200 20140223 20140224 20140225 20140226 600 20140227 20140228
SENDMSG 7 杀怪爆率翻倍，时长：600秒!

<$KILLMONBURSTRATE> 返回人物杀怪暴率倍数;


人物小退

[@小退]
#ACT
LOGOUT


杀死宝宝

功能：
将自己的宝宝全部杀死。

格式：

;==========================================
[@killslave]
#IF
#ACT
KILLSLAVE
#say
你的宝宝清理干净了。
;==========================================


杀死人物

功能：
杀死人物.

格式：
 CLEARPASSWORD

;==========================================
;杀死人物
KILL 0 人物死亡,不显示凶手信息
KILL 1 人物死亡不掉物品,不显示凶手信息
KILL 2 人物死亡,显示凶手信息为NPC
KILL 3 人物死亡不掉物品,显示凶手信息为NPC
;==========================================
[@KILL]
#IF
#ACT
KILL 2
;==========================================


删除非本职业的所有技能

功能：
清除人物非本职业的所有技能。

格式：
 DELNOJOBSKILL

;==========================================
;清除非本职业的所有技能
[@clearskill]
#IF
#ACT
DELNOJOBSKILL
#SAY
你的非法技能已经清除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除所有技能： CLEARSKILL


删除会员人物及时间

删除会员人物及时间： DELUSERDATE 会员.txt

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1
加入会员人物及时间： ADDUSERDATE 会员.txt


删除列表行会名

功能：
删除列表行会名

格式：
==========================
[@delguildList]
#if
#act
DELGUILDLIST guildlist.txt
==========================


删除人物IP在列表中

功能：
删除人物IP在列表中

功能：
================================
[@DelIPList]
#IF
#Act
DELIPLIST IPList.txt
================================


删除人物称号

DEPRIVETITLE 称号名称

DEPRIVETITLE ALL //删除所有称号


删除人物名在列表中

功能：
删除人物名在列表中

格式：
================================
[@DelNameList]
#IF
#Act
DELNAMELIST NameList.txt
================================


删除人物帐号在列表中

功能：
删除人物帐号在列表中

功能：
================================
[@DelAccountList]
#IF
#Act
DELACCOUNTLIST AccountList.txt
================================


删除所有技能

功能：
清除人物的所有技能。

格式：
 CLEARSKILL

;==========================================
;清除所有技能
[@clearskill]
#IF
#ACT
CLEARSKILL
#SAY
你的所有技能已经清除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL


删除行会成员

功能：
删除行会成员。

格式：
 DelGuildMember 行会名称 人物名称

（删除掌门无效）
;==========================================
[@Test]
#if
#act
DelGuildMember 测试行会 <$USERNAME>
#say
你已经从[测试行会]中脱离出来
;==========================================


删除一个NPC

格式: DELNPC NPC名字 地图文件名称(该参数可以为空，为空表示所有地图的)

[@删除所有地图的]
#IF
#ACT
DelNpc 测试

[@删除某个地图的]
#IF
#ACT
DelNpc 测试 3


删除指定技能

功能：
脚本删除指定技能。

格式：
 DELSKILL 技能名称

;==========================================
;删除技能
[@delskill]
#IF
#ACT
DELSKILL 雷电术
#SAY
你的雷电术已删除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL


设置地图的杀怪经验倍数

功能：
设置地图的杀怪经验倍数

格式：
 MAPKILLMONEXPRATE 地图文件名称(*号表示所有地图) 倍率
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍,0表示关闭地图的杀怪经验倍数)

;==========================================
[@MAPKILLMONEXPRATE]
#IF
#ACT
MAPKILLMONEXPRATE 0 1000
#SAY
您在比奇的杀怪经验倍数为 10倍
;==========================================

[@MAPKILLMONEXPRATE]
#IF
#ACT
MAPKILLMONEXPRATE * 1000
#SAY
所有地图杀怪经验倍数为 10倍
;==========================================


设置个人商店营业状态

功能: 设置个人商店营业状态

格式: SETUSERSHOPBUSINESS 角色名称 禁止或开启(0,1)

[@main]
#if
CHECKMYSHOP
#act
SETUSERSHOPBUSINESS <$USERNAME> 0
SENDMSG 6 你的个人商店已经禁止营业
SENDMSG 6 禁止营业后在个人商店里无法搜索到你的商店
SENDMSG 6 无法搜索到你出售的物品，无法在个人商店里摆摊
#elseact
SENDMSG 6 你还没有个人商店


设置攻击力倍数[!]

功能：
设置攻击力倍数

格式：
POWERRATE 倍率 有效时间
倍率 为杀攻击力倍数，倍数除以100为真正的倍率(200为2倍攻击，150为1.5倍攻击)支持变量操作

;==========================================
[@POWERRATE]
#IF
#ACT
POWERRATE 1000 600
#SAY
您当前攻击力倍数为 10倍，有效时间 600秒。
;==========================================


设置人物当前模式

功能：
设置人物当前模式。（1管理模式、2无敌模式、3隐身模式）

格式：
CHANGEMODE 模式类型 开关（1为开，0为关）

;==========================================
[@test]
#IF
#ACT
CHANGEMODE 1 1
CHANGEMODE 2 1
CHANGEMODE 3 1
;==========================================


设置人物当前权限

功能：
设置人物当前权限（0-10）

格式：(提升到超级GM)

;==========================================
[@test]
#IF
#ACT
CHANGEPERMISSION 10
;==========================================


设置人物名称 称号

设置人物名称称号 M2-选项-参数设置-游戏选项(1)-开启称号。不能勾选，勾选了，这个脚本命令无效

SETRANKLEVELNAME 称号内容(必须包含一个%s)


设置杀怪经验倍数

功能：
设置杀怪经验倍数.(支持内功经验，经络经验倍数)

格式：
 KILLMONEXPRATE 倍率 有效时间
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍)

;==========================================
[@KILLMONEXPRATE]
#IF
#ACT
KILLMONEXPRATE 1000 600
#SAY
您当前杀怪经验倍数为 10倍，有效时间 600秒。
;==========================================


设置物品和人物绑定[!]

功能: 设置新的装备绑定功能.(专用登录器)
SetItemBind,设置物品和人物绑定 绑定后物品属性会显示“已绑定”
格式:SetItemBind 装备位置(-1~18,-1时为OK框中物品) 绑定(0-1)
说明:参数2 0=取消 1=绑定

例子: 绑定武器.

#IF
CheckGold 10000
#ACT
SetItemBind 1 1
Take 金币 10000

例子: 取消绑定

#IF
CheckGold 10000
CheckItemBind 1
#ACT
SetItemBind 1 0
Take 金币 10000
#ELSESAY
你没有10000金币,或者当前物品没绑定.


设置物品来源

功能：
 脚本命令ThrowItem是在地面上放物品，SetThrowItemLy命令是用来设置该物品的来源，在ThrowItem前使用
脚本命令Give是给玩家物品，SetThrowItemLy命令是用来设置该物品的来源，在Give前使用

SetThrowItemLy 参数1 参数2 参数3 参数4 参数5 参数6
参数1 来源(1GM制造,2Npc制造, 3购买商铺,4购买商店, 5怪物爆出, 6系统给与, 7挖矿, 8挖肉, 9宝箱)
参数2 地图文件名称(不是游戏里显示的地图名称)
参数3 怪物名称(没有可以用“*”号，不能为空)
参数4 人物名称(没有可以用“*”号，不能为空)
参数5 年-月-日(也可以使用“DATE”表示使用当前日期)
参数6 时:分:秒(也可以使用“TIME”表示使用当前时间)

例子：

[@test]
#IF
#ACT
SetThrowItemLy 2 <$MAP> <$KILLMONNAME> <$USERNAME> <$YEAR>-<$MONTH>-<$DAY> <$HOUR>:<$MINUTE>:<$SECOND>
ThrowItem <$MAP> <$KILLMONX> <$KILLMONY> 1 <$STR(S44)> 1|1 0 1

[@test]
#IF
#ACT
SetThrowItemLy 5 <$MAP> <$KILLMONNAME> <$USERNAME> DATE TIME
Give 木剑 1


设置装备绑定状态[!]

功能：设置装备绑定状态。
格式：SetItemState 装备位置(-1~18,-1时为OK框中物品) 项目(0-6) 属性(0为正常,1为绑定)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出 6 丢弃消失

[@衣服禁止扔]
#IF
CheckItemBind 0
#ACT
GOTO @禁止扔
#ELSEACT
SENDMSG 6 请先绑定

[@禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔


设置装备发光特效

格式: SETITEMEFFECT 位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 特效编号(0-65535,0为清除特效)

特效编号需要在M2里编辑好的

[@main]
#ACT
SETITEMEFFECT 0 0


收回OK框中的物品

格式: TAKEDLGITEM

例：
[@main]
#ACT
TAKEDLGITEM

例：
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)


刷新包裹

功能：
刷新包裹

例子：

[@Test]
#IF
#ACT
REFRESHBAG


所有行会同时攻城

功能:所有行会在当晚同时攻城

AddAttackSabukAll 城堡号(0)

#IF
#SAY
所有行会将于今晚同时攻城!
#ACT
AddAttackSabukAll 0


特修装备

功能：
特修装备,在物品规则列表中限制物品的不会被修理

格式：
RepairAll
该命令是检测命令，会自动扣除金币。
如果无法修理：
1.金币不够
2.需要修理的物品设置不允许修理的物品规则
3.该NPC文件头没有加上允许修理的代码.例如修理衣服需要加上 +10 +11

ActRepairAll
该命令是操作命令，不会扣金币

;特修装备

[@Test]
#IF
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.

#IF
#ACT
ACTREPAIRALL
#SAY
你的装备修好了.


踢除服务器挂机人物

功能：
踢除服务器所有挂机人物。

格式：
 KICKOFFLINE //踢除服务器所有挂机人物

;==========================================
例：
#IF
#ACT
KICKOFFLINE
#Say
挂机人员全体下线
;==========================================


踢除服务器所有人物

功能：
踢除服务器所有人物。

格式：
 KICKALLPLAY //踢除服务器所有在线人物

;==========================================
例：
#IF
#ACT
KICKALLPLAY
#Say
全体下线
;==========================================


踢人物下线

功能：
踢人物下线.

格式：
 KICK

;==========================================
[@KICK]
#IF
#ACT
SENDMSG 5 %s，非法登录游戏
 KICK
;==========================================


添加行会成员

功能：
添加行会成员。

格式：
 AddGuildMember 行会名称 人物名称

;==========================================
[@Test]
#if
#act
AddGuildMember 测试行会 <$USERNAME>
#say
你已经成功加入[测试行会]行会中
;==========================================


通过脚本建立一个NPC 动态创建NPC

通过脚本命令建立一个NPC,服务器重启后消失.

格式: CreateNPC NPC名字 地图 坐标X(-1时随机坐标) 坐标Y(-1时随机坐标) 外观 脚本文件 脚本文件是否要加上地图名称(例如.设置为0时脚本文件必须带“-3”如:“传送员-3.txt” 设置为1时脚本文件不需要带“-3”如:“传送员.txt”这样的好处就是，你可以在任意地图地图创建NPC，只要一个脚本“传送员.txt”而不需要“传送员-0.txt、传送员-3.txt”等等好多NPC脚本)
注意: 脚本文件必须在Market_Def目录中.

例如:首先在Market_Def中建立一个叫测试-3.txt的脚本文件.
#IF
#ACT
CreateNPC 测试 3 330 330 8 测试-3 0
#SAY
通过脚本建立了一个NPC.

#IF
#ACT
CreateNPC 测试NPC 3 -1 -1 8 测试NPC 1
#SAY
通过脚本建立了一个NPC 随机坐标


物品关联命令LINKPICKUPITEM

LINKPICKUPITEM脚本命令
功能：可以对物品进行关联，该命令扔触发里[@DropItemX] [@PickUpItemX] [@TakeOffX] [@ScatterBagItems]

[@DropItem0]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚扔的物品进行检测，或操作

;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253

;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1

[@PickUpItem0]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作

;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253

;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1

;修改后的参数，刷新到客户端
SENDUPGRADEITEM

[@ScatterBagItems]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你杀人了:【<$CURRRTARGETNAME>】，这个人包裹里爆出物品
#ELSEACT
SENDMSG 6 你杀怪了:【<$CURRRTARGETNAME>】，这个怪物爆出物品

#IF
#ACT
LINKPICKUPITEM
;支持用命令链接命令，用脚本命令对当前爆出的物品操作或检测


显示倒计时信息提示

功能:

显示倒计时信息提示

格式:

SENDDELAYMSG信息内容 时间(秒) 字体颜色 换地图是否删除 跳转字段

[@测试]
#if
#act
SENDDELAYMSG 你的礼物在%s后到达 300 255 0 @给礼物

[@给礼物]
#ACT
GIVE 布衣(男)

------------------------------------------
300秒倒计时结束后会执会当前脚本文件里的[@给礼物]段


显示验证码窗口

格式: SHOWGAMEVALIDATEDLG 模式(0自己 1当前地图 2全服人物)

[@显示随机验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0

[@显示自定义验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0


显示一个放大的虚影

功能：显示一个放大的虚影
SHOWPHANTOM 参数1(任意字符,不能为空) 参数2(任意字符,不能为空) 参数3(任意字符,不能为空) 参数4(任意字符,不能为空) 参数5(任意字符,不能为空) 参数6(透明度(0~255)) 参数7(任意字符,不能为空) 参数8(任意字符,不能为空) 参数9(时间(秒)) 参数10(任意字符,不能为空)
======================================================BUFF===============================

[@人物放大]
#ACT
SHOWPHANTOM * * * * * 120 * * 10 *
SENDMSG 6 人物放大透明度120,10秒后恢复正常


新的装备改名

功能: 新的装备改名
格式: ChangeItemName 物品位置(0-16) 名字

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================

#IF
#ACT
ChangeItemName 1 新名字


新游戏点[!]

检测命令 CHECKGAMEGOLDEX 检测符(<,>,=) 值
操作命令 GAMEGOLDEX 操作符(+,-,=) 值
显示变量 <$GAMEGOLDEX>


行会地图传送

GUILDMAPMOVE 地图号 X Y 最低等级
只有行会掌门，才可以使用

[@guildmapmove]
#if
#act
GUILDMAPMOVE 3 330 330 0


行会地图随机传送

GUILDMOVE 地图号 最低等级
只有行会掌门，才可以使用

[@guildmove]
#if
#act
GUILDMOVE 3 0


行会建设相关

修改行会建筑度:
格式： GUILDBUILDPOINT 控制符（+-）数字

修改行会人气度:
格式： GUILDAURAEPOINT控制符（+-）数字

修改行会安定度:
格式： GUILDSTABILITYPOINT控制符（+-）数字

修改行会繁荣度:
格式：GUILDFLOURISHPOINT控制符（+-）数字

检测行会建筑度：
格式： CHECKGUILDBUILDPOINT 控制符（<>=）数字

检测行会行会人气度:
格式： CHECKGUILDAURAEPOINT 控制符（<>=）数字

检测行会安定度:
格式： CHECKGUILDSTABILITYPOINT 控制符（<>=）数字

检测行会繁荣度：
格式: CHECKGUILDFLOURISHPOINT 控制符（<>=）数字

变量：
<$GUILDBUILDPOINT> 行会建筑度
<$GUILDAURAEPOINT> 行会人气度
<$GUILDSTABILITYPOINT> 行会安定度
<$GUILDFLOURISHPOINT> 行会繁荣度


修改物品的Looks

 -----------------------------------------------------------------------------
;修改物品的Looks,修改后只是物品的内观改变了，其他属性没有变化
ChangeItemLooks 装备位置(0-18,-1表示OK框里的物品) 操作符号(+,-,=) Looks值(0表示恢复为DB里的Looks，大于0表示修改)


修改物品的Shape

 -----------------------------------------------------------------------------
;修改物品的Shape 只对衣服和武器有效,修改后只是物品的外观改变了，其他属性没有变化
ChangeItemShape 装备位置(0-18,-1表示OK框里的物品) 操作符号(+,-,=) Shape值(0表示恢复为DB里的Shape，大于0表示修改, 0-65535)


修改物品的附加属性值

功能： 修改物品的附加属性值

格式: CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 + - =) 值

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

例子：

[@Test]
 #IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.


循环脚本运行

说明：循环脚本运行次数设置

格式：Loopgoto @脚本 脚本运行次数（为空或0时，运行1次）

示范脚本：
[@循环]
#ACT
mov N1 0
mov N2 1
Loopgoto @运算 100
sendmsg 6 1加到100的结果为：<$STR(N1)>

[@运算]
#ACT
Inc <$STR(N1)> <$STR(N2)>
Inc N2 1

增加NPC命令：endloop中止loopgoto

[@随机取数]
#act
mov p1 0
loopgoto @取数 100
sendmsg 6 循环<$str(p1)>次，才取到>=50的数：<$str(p10)>

[@取数]
#act
inc p1 1
;此例仅做说明，实际只用取一次，取50以内的取机数+49即可
movr p10 100

#if
large p10 49
#act
endloop


延时移动

功能:
延时移动

格式:
TIMERECALL 时间(分钟)

============================

[@Test]
#IF
#ACT
timerecall 60
map G012
give 回城卷 1
SENDMSG 0 [%s]使用了元宝练级卷.进入快速升级地图,1小时后会将您传回土城!

===========================


一键回收包裹物品[!]

一键回收包裹物品的脚本命令
格式：
TakeBagItem 物品名称(支持多个物品) 收取数量 每个物品增加元宝值 每个物品增加金币值 每个物品增加泡点值 每个物品增加泡点经验值 变量(保存实际回收的物品数量) 聚灵珠经验(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)

[@main]
#ACT
TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0
SENDMSG 6 成功回收<$STR(N1)>个木剑，布衣(男)，布衣(女)，价格为10000经验


移动到回城点

功能：
 移动到回城点

使用方法：

[@main]
#if
#act
GoHome
#say
你已经回城了


永久增加人物属性点

功能：
永久增加人物属性点。(支持英雄)

格式：
USEBONUSPOINT 属性位置（1-14） 控制符（+,-,=） 点数

1-攻击力 2-魔法力 3-道术力 4-防御力 5-魔防力 6-生命值 7-魔法值 8- 准确 9-躲避 10-防御下限 11-防御上限 12-魔御下限 13-魔御上限 14-吸收伤害

;==========================================
[@Main]
#ACT
USEBONUSPOINT 1 + 20
SENDMSG 7 攻击力增加20点.

[@Main]
#ACT
USEBONUSPOINT 2 + 20
SENDMSG 7 魔法力增加20点.

[@Main]
#ACT
USEBONUSPOINT 3 + 20
SENDMSG 7 道术力增加20点.

[@Main]
#ACT
USEBONUSPOINT 4 + 20
SENDMSG 7 防御力增加20点.

[@Main]
#ACT
USEBONUSPOINT 5 + 20
SENDMSG 7 魔防力增加20点.

[@Main]
#ACT
USEBONUSPOINT 6 + 20
SENDMSG 7 生命值上限增加20点

[@Main]
#ACT
USEBONUSPOINT 7 + 20
SENDMSG 7 魔法值上限增加20点.

[@Main]
#ACT
USEBONUSPOINT 8 + 20
SENDMSG 7 准确增加20点.

[@Main]
#ACT
USEBONUSPOINT 9 + 20
SENDMSG 7 躲避增加20点.
;==========================================


游戏币控制

功能：
调整人物游戏币及根据时间自动增减游戏币（可用来做会员时间用）。

格式：
GAMEGOLD 控制符(=,+,-) （1-100）

;==========================================
;设置人物游戏币
[@GAMEGOLD0]
#IF
#ACT
GAMEGOLD = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏币
[@GAMEGOLD1]
#IF
#ACT
GAMEGOLD + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏币
[@GAMEPOINT2]
#IF
#ACT
GAMEGOLD - 1
#SAY
你的游戏币已经降了1点。
;==========================================

功能：
设置是否自动增加游戏币。

格式：
AUTOADDGAMEGOLD 控制符(START,STOP)

;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOADDGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个

;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOADDGAMEGOLD STOP
#SAY
现退出自动增加游戏币模式

;==========================================

功能：
设置是否自动减少游戏币。

格式：
AUTOADDGAMEGOLD 控制符(START,STOP)

;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOSUBGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个
;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOSUBGAMEGOLD STOP
#SAY
现退出自动减少游戏币模式

;==========================================


再一次爆物品

功能：
杀怪后再一次爆物品 此命令只可用在QF[@KillMon]字段下

例子：

[@KillMon]
#IF
#ACT
MonItems
;每次杀怪，怪物都会爆两次


在登陆器里浏览网页

功能：
浏览网页

格式：
WebBrowser 地址

;==========================================
[@WebBrowsertest]
#IF
#ACT
WebBrowser http://www.gameofmir.com
;==========================================


在地图上播放魔法效果[!]

格式: MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数(-1时表示不限制次数) 播放速度(毫秒) 播放效果(0普通 1特效) (该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
MAPEFFECT 3 333 333 0 0 10 1 300 1 0


在地图上放物品[!]

格式: THROWITEM 地图名称 X坐标 Y坐标 范围 物品名称 数量|时间(秒) 是否掉落提示(0不提示,1提示) 是否可以立即捡取(0不能立即捡取,1可以立即捡取)

[@main]
#IF
Random 100
#ACT
ThrowItem 3 330 330 10 回城卷 5|60


在屏幕上播放魔法效果

格式: SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0=普通，1=魔法效果) 模式(0=自己，1=所有人)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
SCREENEFFECT 0 0 0 0 10 1 300 0


在屏幕上显示向上滚动信息

功能说明：在屏幕上显示向上滚动信息

格式：SENDVERTICALMOVEMSG 文字信息 文字颜色 背景颜色 坐标Y 滚动次数 发送模式(0=全服 1=个人)

文字换行：\

[@main]
#ACT
SENDVERTICALMOVEMSGG 提示信息1\提示信息2 249 0 100 3 0


在鼠标的位置显示向上滚动提示信息

功能说明：在鼠标的位置显示向上滚动提示信息

格式：SENDMOVEHINTMSG 文字信息 文字颜色 背景颜色 微调坐标X 微调坐标Y

文字换行：\

[@main]
#ACT
SENDMOVEHINTMSG 提示信息1\提示信息2 249 0


在线命令弹出菜单功能

功能：
玩家在线输入指定命令弹出菜单脚本功能

格式：
命令为command.ini内（命令名称随便定义）：MemberFunc=我是会员
输入@我是会员 命令后将运行登录脚本(Qmanage.txt)内[@Member]段内容脚本
具体脚本内容自己写。


在线泡经验

功能：
在线泡经验（直接得到经验）

格式：例：（等级30级以上，地图3安全区内每1秒种得到10个经验点）
==================================================
#IF
CheckLevelex > 30
#ACT
setautogetexp 1 10 1 3
命令 时间 经验 是否安全区（0为任何地方） 地图号（任何地图使用*号） 聚灵珠是否能获取经验(0=不可以 1=可以)
==================================================


增加会员时间[!]

功能：
增加会员时间 文件名称 天 时 分

例子：

[@Test]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S$1)> <$STR(N$1)> <$STR(N$2)> <$STR(N$3)>
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 0 0
SENDMSG 5 <$USERNAME>会员充值成功，增加30天0小时0分会员时间！
SENDMSG 6 你的会员到期时间是<$STR(S$1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253


增加人物IP在列表中

功能：
增加人物IP在列表中

功能：
================================
[@AddIPList]
#IF
#Act
ADDIPLIST IPList.txt
================================


增加人物称号

CONFERTITLE 称号名称(需要到物品数据库里添加，详见说明书称号系统) 是否设置为当前称号(1=设置为当前称号)


增加人物名在列表中

功能：
增加人物名在列表中

格式：
================================
[@AddNameList]
#IF
#Act
ADDNAMELIST NameList.txt
================================


增加人物帐号在列表中

功能：
增加人物帐号在列表中

功能：
================================
[@AddAccountList]
#IF
#Act
ADDACCOUNTLIST AccountList.txt
================================


增加限次使用物品的次数.
说明: 只对刚刚使用过的类型(StdItem=31 Source=1)或者(StdItem=2 Shape=1,3,5,9)的物品有效.

[@StdModeFunc10]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura   ;持久增加1

[@StdModeFunc11]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura 100 ;持久增加100


召唤指定怪物为宝宝

功能：
脚本召唤宝宝。

格式：
RECALLMOB 怪物名称 宝宝等级(最高为 7) 叛变时间(分钟) 是否自动变色（0、1）固定颜色（1-7）
攻击力受自动变色颜色不同而不同
固定颜色攻击力受指定颜色不同而不同

注：如设固定颜色，自动变色参数必须设置为0

;==========================================
;召唤最多5个七宝宝，30分钟后叛变,七彩变色
[@recallmob]
#IF
CHECKSLAVECOUNT < 5
#ACT
RECALLMOB 神兽 7 30 1
#SAY
好好看着自己的宝宝，不要乱咬人。
#ELSESAY
你已经有5个或以上的宝宝，现在不可以再召宝宝。
;==========================================


指定怪物直接爆物品

[@main]
#ACT
;可以指定怪物直接爆物品，如果没有攻击目标，就以自己的坐标爆物品，如果有攻击的目标，就会以攻击的目标的坐标爆物品
;ScatterBagItems 怪物名称 爆率倍数(实际倍率=当前设置的值除以100)
ScatterBagItems 红野猪 100


重新分配人物附加属性点
功能：
将人物附加的属性点复位到未分配状态；
格式：
#if
#act
RESTBONUSPOINT
#say
你的属性点已经重新分配；

相关命令：
检查属性点数：CHECKBONUSPOINT
调整属性点数：BONUSPOINT


转换职业

功能：
转换职业。

格式：
 CHANGEJOB 职业名称(Warrior,Wizard,Taoist)

;==========================================
;转职业为武士
[@changejob0]
#IF
#ACT
CHANGEJOB Warrior
#SAY
你的职业已经变成武士了。
;==========================================

;==========================================
;转职业为法师
[@changejob1]
#IF
#ACT
CHANGEJOB Wizard
#SAY
你的职业已经变成法师了。
;==========================================

;==========================================
;转职业为道士
[@changejob2]
#IF
#ACT
CHANGEJOB Taoist
#SAY
你的职业已经变成道士了。
;==========================================


装备名称自定义系统

功能：
装备名称自定义系统

格式：
例脚本：

(@@useitemname)
[@main]
请选择要改名的装备：(将要改名的装备戴身上)\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
◇◇◇『<盔　甲/@@useitemname0>』◇◇◇『<武　器/@@useitemname1>』◇◇◇\
◇◇◇『<项　链/@@useitemname3>』◇◇◇『<头　盔/@@useitemname4>』◇◇◇\
◇◇◇『<左手镯/@@useitemname5>』◇◇◇『<右手镯/@@useitemname6>』◇◇◇\
◇◇◇『<左戒指/@@useitemname8>』◇◇◇『<右戒指/@@useitemname7>』◇◇◇\
◇◇◇『<勋 章/@@useitemname2>』\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
〖<返回/@main>〗 〖<关闭/@exit>〗
[@@useitemname0]
#ACT
goto @ChangeName
[@@useitemname1]
#ACT
goto @ChangeName
[@@useitemname2]
#ACT
goto @ChangeName
[@@useitemname3]
#ACT
goto @ChangeName
[@@useitemname4]
#ACT
goto @ChangeName
[@@useitemname5]
#ACT
goto @ChangeName
[@@useitemname6]
#ACT
goto @ChangeName
[@@useitemname7]
#ACT
goto @ChangeName
[@@useitemname8]
#ACT
goto @ChangeName
[@@useitemname9]
#ACT
goto @ChangeName
[@@useitemname10]
#ACT
goto @ChangeName
[@@useitemname11]
#ACT
goto @ChangeName
[@@useitemname12]
#ACT
goto @ChangeName
[@ChangeName]
#if
checkgamegold > 0
#act
gamegold - 1
SETSCRIPTFLAG 1 1
sendmsg 7 改名成功！！！
Close
#elseact
sendmsg 7 没钱跑来做什么？


装备属性升级

装备升级

装备升级功能可以指定升级物品及属性，按指定机率得到结果。
需要升级的装备物品必须放在身上。

命令格式

UPGRADEITEMEX 物品位置(0-12) 属性位置(0-14) 成功机率(0-100) 点数机率(0-255) 是否破碎(0,1)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器

属性位置:
不同类型的物品属性位置不一样，以后补充这些资料，自行可以进行测试得到。

成功机率:
升级成功机率，数字越大机率越小。

点数机率:
升级成功后得到的点数，数值在 0 -255之间。

是否破碎:
升级失败后装备是否破碎，数值为0或1，1为失败后破碎。

属性位置详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 StdMode值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当StdMode值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当StdMode值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当StdMode值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当StdMode值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当StdMode值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久


自定义按钮

功能: 自定义按钮

ADDBUTTON(旧命令)
ADDBUTTONEX(新命令,支持按钮附加特效)
-------------------------------自定义按钮-----------------------------------

格式：命令 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9 参数10

命令：ADDBUTTON

例子
#IF
#ACT
ADDBUTTON 3 1 283 284 285 10 200 1 -1 253/自定义按钮1\254/测试增加按钮

参数说明：

参数1为WIL补丁序号，此序号在M2-查看-列表信息二-WIL资源 里面编辑
参数2为按钮点击后的脚本触发序号，触发QF里面的[@ButtonClickX]X即为触发序号(1-100）
参数3为按钮默认图片
参数4为鼠标经过图片
参数5为按钮按下图片
参数6为距离窗口左边的距离(此参数建议用分辨率宽变量计算)
参数7为距离窗口顶边的距离(此参数建议用分辨率高变量计算)
参数8为按钮是否可以移动0=不能移动1=可以移动
参数9为按钮上面显示的文字标题,-1时为空标题(用于不显示标题)
参数10为鼠标移动到按钮显示的悬浮框备注信息 “\”表示换行 “/”颜色分割符 自定义颜色功能需要2015-01-08之后的程序才支持

---------------------------------------------------------------------------------------------------------------

ADDBUTTONEX 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8

参数1包含四个参数，每个参数用“|”隔开。 触发序号(1-100)|X坐标|Y坐标|是否可以移动(0=不能移动1=可以移动)
参数2为按钮WIL补丁序号，此序号在M2-查看-列表信息二-WIL资源 里面编辑
参数3按钮图片，包含三个参数，每个参数用“|”隔开。按钮默认图片序号|鼠标经过图片序号|按钮按下图片序号
参数4为按钮特效WIL补丁序号，此序号在M2-查看-列表信息二-WIL资源 里面编辑
参数5按钮默认特效，如果没有可以使用“*”，包含六个参数，每个参数用“|”隔开。特效开始图片序号|播放张数|播放速度(毫秒)|绘制模式(0特效绘制,1普通绘制)|微调X|微调Y
参数6按钮鼠标经过特效，如果没有可以使用“*”，包含六个参数，每个参数用“|”隔开。特效开始图片序号|播放张数|播放速度(毫秒)|绘制模式(0,1)|微调X|微调Y
参数7按钮按下特效，如果没有可以使用“*”，包含六个参数，每个参数用“|”隔开。特效开始图片序号|播放张数|播放速度(毫秒)|绘制模式(0,1)|微调X|微调Y
参数8包含两个参数，每个参数用“|”隔开。按钮上面显示的文字标题,-1时为空标题|鼠标移动到按钮显示的悬浮框备注信息 “\”表示换行 “/”颜色分割符

例子
#IF
#ACT
ADDBUTTONEX 1|10|200|1 5 275|-1|276 9 840|10|200|0|0|40 850|10|200|0|0|40 860|10|200|0|0|40 -1|253/自定义按钮1\254/测试增加按钮

---------------------------------------------------------------------------------------------------------------

删除按钮：

按钮序号只能为1-100，因为最多就添加100个自定义按钮

格式：命令 参数1 参数2

命令：DELBUTTON

例子
#IF
#ACT
DELBUTTON 1

说明：参数1为按钮序号(1-100) 参数2(0或空的时删除自己的，1时删除全服用户的)

---------------------------------------------------------------------------------------------------------------


自定义变量按变量值大小排序[!]

SortVarToList
功能：
自定义变量按变量值大小排序，并把排序后变量值对应的人物名存放到指定列表文件中(制作排行榜用)

格式：
SortVarToList 自定义变量名 自定义变量文件路径 排序后列表的保存路径 降序还是升序(0-1) 保存格式(0-1)为0时只保存人物名,为1时:人物名 变量值.

例子：

[@test2]
#if
#act
SortVarToList LJSQZS ..\QuestDiary\数据文件\Test.txt ..\QuestDiary\数据文件\排序的文件.txt 0 1
break


自定义变量功能

功能：
 自定义变量功能，不再受固定几个变量限制

使用方法：
三个步骤：
1、首先要声明变量
2、读取变量
3、保存变量
该变量支持增加、减少、脚本查看、检查大小等功能，该功能的开发突破了变量使用受限制，利用该变量可制作出超强功能脚本。
脚本样例：
=========================================
<声明变量/@newvarInteger> \
<查看变量/@viewvarInteger>\
<读取变量/@loadvarInteger> \
<保存变量/@savevarInteger> \
<增加变量/@calcvarinc> <检查变量是否大于5/@checklarage5>\
<减少变量/@calcvardec> <检查变量是否小于5/@checksmall5>\
<检查变量是否等于5/@checkequal5>
[@calcvarinc]
#IF
#ACT
CALCVAR HUMAN QQQQ + 5
goto @varcontrol
[@calcvardec]
#IF
#ACT
CALCVAR HUMAN QQQQ - 5
goto @varcontrol
[@checkequal5]
#IF
CHECKVAR HUMAN QQQQ = 5
#ACT
sendmsg 7 等于5
goto @varcontrol
#ELSEACT
sendmsg 7 不等于5
goto @varcontrol
[@checklarage5]
#IF
CHECKVAR HUMAN QQQQ > 5
#ACT
sendmsg 7 大于5
goto @varcontrol
#ELSEACT
sendmsg 7 小于5
goto @varcontrol
[@checksmall5]
#IF
CHECKVAR HUMAN QQQQ < 5
#ACT
sendmsg 7 小于5
goto @varcontrol
#ELSEACT
sendmsg 7 大于5
goto @varcontrol

[@decInteger]
#ACT
DEC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@addInteger]
#ACT
INC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@loadvarInteger]
#IF
#ACT
LOADVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol

[@savevarInteger]
#IF
#ACT
SAVEVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol
[@viewvarInteger]
#ACT
sendmsg 7 <$HUMAN(QQQQ)>
GOTO @varcontrol

[@newvarInteger]
#IF
#ACT
VAR Integer HUMAN QQQQ
sendmsg 7 OK
GOTO @varcontrol
[@viewvarString]
<$HUMAN(QQQS)>


自定义采集[!]

采集功能格式:
SHOWPROGRESSBARDLG 时间(秒) 触发字段 提示信息 有动作是否中断(0不中断,1中断) 中断触发字段

使用示例：
[@Main]
#ACT
SHOWPROGRESSBARDLG 5 @采集完成 正在采集,进度%d%... 1 @采集中断
Break

QF触发
[@采集完成]
#ACT
Give 回城卷 1
SendMsg 5 你采集一个回城卷
Break

[@采集中断]
#ACT
SendMsg 5 采集被中断
Break


自动穿取装备

功能：
自动穿取装备。

格式：
 穿装备 TakeOnItem 装备名称 位置(0-16)
脱装备 TakeOffItem 位置(0-16)

;==========================================
物品位置:
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器
;==========================================

;==========================================
;穿装备
[@TakeOnItem]
#IF
#ACT
TakeOnItem 天魔神甲 0
#SAY
已经帮你穿上衣服了。
;==========================================

;==========================================
;脱装备
[@TakeOffItem]
#IF
#ACT
TakeOffItem 0
#SAY
已经帮你把衣服脱下来了。
;==========================================


自动穿装备和取装备

自动穿装备和取装备.新人出生就无需手动穿装备了.

例子:

;自动穿装备
AutoTakeOnItem 装备名称 位置(0-16)

;自动脱装备
AutoTakeOffItem 位置(0-16)

物品位置:
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器
;==========================================


自动行走

功能：
自动行走 AUTOGOTOXY 地图名称 X坐标 Y坐标

例子：

[@Test]
#IF
#ACT
AUTOGOTOXY 3 330 330


自动寻路

功能: 自动移动到指定坐标,专用登录器.
格式: GotoNow X Y

例子: 在盟重时自动移动到330 330
#IF
IsOnMap 3
#ACT
GotoNow 330 330


自动一键捡取物品

自动一键捡取物品 PICKUPITEMS X Y 范围(不能超过20) 是否按照(M2-查看-列表信息二-内挂捡取)设置的捡取(1按照设置的捡取 0捡取所有物品)

可以在杀怪触发里使用，或者做个自定义技能，使用该自定义技能来触发这个命令

[@KillMon]
#ACT
PICKUPITEMS <$KILLMONX> <$KILLMONY> 3 1


字符串替换

功能：
字符串替换

格式：
 ANSIREPLACETEXT 字符串变量 旧字符串 新字符串

;==========================================
;==========================================
;把www.gameofmir.com替换成www.qq.com
[@main]
#IF
#ACT
mov S1 www.gameofmir.com
ANSIREPLACETEXT <$STR(S1)> gameofmir qq
SENDMSG 6 <$STR(S1)>


@OnKillMob

功能: 杀死怪物时触发
说明: 对应地图参数中需要加入ONKILLMON才可生效!

[@OnKillMob]
#IF
CheckKillMonName 白野猪
#SAY
你杀死一头白野猪!


宝宝立即叛变

功能: 指定宝宝立即叛变的脚本命令
格式: GetCallMob 宝宝名字

#act
GETCALLMOB 神兽
#say
你的神兽已经叛变


不允许宝石升级

功能: 当前宝石升级装备失败
格式: SetUpgradeFail
说明: 此命令只能在QFunction中的@ItemUpgrade下执行.

[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break


查看动态地图链接点

说明: 查看使用AddMapRoute设置的动态链接点.
格式: GetMapRouteInfo 链接标示 查看方式(0-1) 坐标X 坐标Y

例子: 查看地图链接点
[@ViewRoute]
#IF
#ACT
;查看链接坐标,参数2等于0查看连接地图,等于1查看待连接地图.
GetMapRouteInfo 1 0 A0 G0 G1
GetMapRouteInfo 1 1 A1 G2 G3
SendMsg 5 [地图<$STR(A0)>坐标:<$STR(G0)>:<$STR(G1)>]->[地图<$STR(A1)>坐标:<$STR(G2)>:<$STR(G3)>]


拆解物品

功能: 可简单实现物品拆解,升级,回收等功能.
格式: OpenItemBoxEx 标号(1-1000) 是否回收(0,1) 提示信息
说明: 标号代表要执行的脚本编号,提示信息是登录器显示的简单提示.
放入的物品名字保存在人物的S0变量中.
放入的物品的持久放在人物的N0变量中.
注意: 脚本文件头必须加入@ReclaimItem
N0中保存的持久1000=游戏中1点持久,20000=20点持久.

相关检测脚本命令:EQUAL?CheckTextList
例如:实现装备拆解功能.

(@ReclaimItem )
[@main]
是否要把圣战戒指拆解为3个力量戒指.\
是否要把天尊戒指拆解为3个泰坦戒指.\
是否要把法神戒指拆解为3个紫碧螺戒指.\
<开始拆解/@拆解_戒指>

[@拆解_戒指]
#IF
#ACT
OpenItemBoxEx 1 1 拆解戒指类物品

Q-Function.txt中脚本:
[@GetBoxItem1]
#IF
EQUAL S0 圣战戒指
#ACT
Give?力量戒指 3
Break

#IF
EQUAL S0 天尊戒指
#ACT
Give?泰坦戒指 3
Break

#IF
EQUAL S0 法神戒指
#ACT
Give?紫碧螺 3
#ELSEACT
ReclaimItem
#ELSESAY
请放入<圣战戒指> <天尊戒指> <法神戒指>


创建目录

功能: 创建新目录.
格式: ForceDirectories 目录

#IF
#ACT
ForceDirectories \QuestDiary\新目录\


打开网站地址

功能: 游戏中打开网站.
格式: OpenWebSite 网站

#IF
#ACT
OpenWebSite http://www.herom2.com


地图动态链接点

功能: 给地图增加动态链接点.
说明: 此功能需要两个脚本命令配套使用才可生效.
      AddMapRoute用于添加一个地图链接点,SetMapRoute配合设置一个地图链接点.
格式: AddMapRoute 动态链接标示(1-65535) 连接地图 坐标X 坐标Y
格式: SetMapRoute 动态链接标示(1-65535) 待连接地图 坐标X 坐标Y

例子: 链接地图3和地图5的特定坐标, 地图 3 335 330 地图 5 658 463
[@AddRoute]
#IF
#ACT
AddMapRoute 1 3 335 330
SetMapRoute 1 5 658 463


动态修改地图名字

功能: 动态修改地图显示名字.
格式: ChangeMapDesc 新名字 是否保存(0,1)
说明: 直接修改MapInfo.txt中对应地图的显示名字.

例子: 修改盟重省的名字,并且保存.
#IF
#ACT
ChangeMapDesc 新盟重 1


读取文本内容到变量[!]

功能: 读取文本文件中的内容到变量中.

格式:GetListString 文件路径 行号(行号从0开始) 变量1 变量2
说明: 变量2可以不需要,当读取变量2时文本单行的内容必须是以下格式:
人物1:10
人物2:20

例子:
[@main]
#IF
#ACT
GetListString ..\QuestDiary\测试.txt 5 A10 N10


改变宝宝名字颜色

功能: 改变人物宝宝名字颜色.
格式: ChangeSlaveNameColor 宝宝名字 颜色(0-255)


改变人物的模式

改变人物当前模式(无敌,隐身,生命,魔法,攻击力,道术力,魔法力,攻击速度,禁止攻击)

格式: ChangeModeEx 模式(1-10)  时间(1-65535)  附加值(1-65535)
说明: 1=无敌 2=隐身 3=HP  4=MP  5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定
       第三个参数无敌,隐身,禁止攻击时没有使用.

#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!

#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.


改变物品的持久

功能: 修改指定位置装备的当前最大持久.
格式: ChangeItemDura 装备位置(0-12) 操作符(+,-,=) 持久(0-65000) 当前持久大于最大持久时是否改变当前支持(0-1)

#IF
#ACT
ChangeItemDura 0 - 1000
#SAY
你的物品最大持久降低1点.


改变衣服翅膀效果

改变人物衣服翅膀效果
说明:客户端需要有HumEffect.wil

#IF
#ACT
ChangeDressEffect 3


改变指定行会的掌门人

改变行会掌门人

[@changeguildmaster]
#IF
#ACT
ChangeGuildMaster 华山派
#SAY
贡献,你现在是华山派掌门人了.


给字符串增加空格

功能： 给字符串在前面或者后面增加指定个数的空格.

格式: SetStringBlank 变量(S,A) 长度(1-100) 格式(0, 1)?
说明: 可支持人物S变量或者全局A变量,格式0=前面,1=后面
注意: 第二个参数长度是指增加空格后整个字符串的长度,例如字符gameofmir引擎长度是13,
如果第二个参数设置1 那么实际增加7个空格.
注意: 英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

例子：

[@Test]
#IF
#ACT
MOV S10 gameofmir引擎
SetStringBlank <$STR(S10)> 20 0
SendMsg 5 <$STR(S10)>

MOV S10 gameofmir引擎
SetStringBlank <$STR(S10)> 20 1
SendMsg 5 <$STR(S10)>


关闭大对话框模式

功能: 关闭大对话框模式. (专用登录器)
格式: CloseBigDialogBox

#IF
#ACT
CloseBigDialogBox


恢复发言

恢复人物发言.

#IF
CheckLevelEx > 1
#ACT
ENABLESENDSAY


获取玩家名字

功能:
取得玩家名字.

格式:
GetUserName 0-99之间的数字,或者范围是0-99之间的数值型变量.
如下将玩家名字放入S10中

#IF
#ACT
GetUserName S10


建立新行会

增加一个新的行会.可以指定某人成为该行会掌门(必须在线)

说明: 第二个参数等于Self时掌门是自己.否则是在线玩家.

[@AddGuild]
#IF
#ACT
AddGuild 华山派 Self


建立一个文本文件

在指定位置建立一个文本文件.

注意:文件保存在 \Envir目录中.

#IF
#ACT
CreateFile ..\QuestDiary\NewFile.txt
#SAY
在Envir\QuestDiary目录中建立了一个文件.


排序人物自定义变量[!]

功能: 排序人物自定义变量.
格式: SortHumVarToListEx 变量名 变量路径 排序模式(0,1) 保存路径 保存模式(0,1)
说明: 排序模式 0=升序,1=降序

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 0

升序排序人物变量QQQQ,不保存人物变量:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 1


排序在线人物自定义变量[!]

功能: 排序在线人物自定义变量.
格式: SortHumVarToLisL) 变量名 保存路径 排序模式(0,1) 名字路径
说明: 排序模式 0=升序,1=降序
      名字路径在排序后只保存人物名字不保存人物变量.
注意: 此脚本命令只排序在线人物的变量

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToList QQQQ ..\QuestDiary\测试.txt 0

升序排序人物变量QQQQ,单独保存人物名字:
[@main]
#IF
#ACT
SortHumVarToList QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试1.txt


强制攻击模式

功能: 强制人物的攻击模式
格式: SetHumAttackMode 攻击模式(0-7) 时间(秒)
说明: 0=全体模式 1=和平模式

例子: 强制人物和平模式
#IF
CheckPkPoint 2
#ACT
SetHumAttackMode 1 3600


清除宝石升级属性

功能: 清除使用宝石升级的装备属性.
格式: ClearStoneUpgrade 位置(0-14)
注意: 此命令不区分极品和普通装备,清除时所有属性都将消失.

例子:
[@main]
#IF
#ACT
ClearStoneUpgrade 0


取得随机字符串

功能: 从文件中随机获取一行字符串
格式: GetRandomText 文件路径 变量(S0--S99) 指定行(0-10000)
说明: 没有指定行时随机取某一行的字符串.

例如:随机取一行字符串到S10中.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10
SendMsg 5 取出的字符串是:<$STR(S10)>

例如:取特定行的字符串.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10 5
SendMsg 5 取出的字符串是:<$STR(S10)>


取下人物身上装备

把人物身上装备放入背包中.

格式: TakeEx (0-16)

#IF
#ACT
TakeEx 1


取装备名字

取指定位置的装备名字
格式: GetUserItemName 位置(0-12) S变量(0-99)
说明: S变量是人物私有变量(0-99)

例子: 把武器的名字放如S10变量中

#IF
#ACT
GetUserItemName 1 10
SendMsg 5 武器的名字: <$STR(S10)>


取字符串在列表中的位置

功能: 取字符串在列表中的下标.
格式: GetStringPos 路径 字符串
说明: 返回值放在人物的N0变量中,如果值=9999999说明没有找到.
其他: 返回值可以通过EQUAL做条件检测

[@main]
#IF
#ACT
GetStringPos ..\QuestDiary\测试.txt 管理员
SendMsg 5 字符串在列表中的位置:<$STR(N0)>


杀死地图中的怪物

功能: 随机杀死地图中的怪物.
格式: RandomKillMon 地图 怪物名字 数量(1-255) 掉落物品(0,1)
说明: 地图=Self时表示当前地图.

例子:
[@main]
#IF
#ACT
RandomKillMon Self 稻草人 5


杀死人物的宝宝

说明:把自己的宝宝杀死.
格式:KillCallMob 名字 数量 方式(0杀死会触发脚本 1直接消失不会触发脚本)

#IF
#ACT
KILLCALLMOB 神兽
#SAY
你的神兽已经死亡.

#IF
#ACT
KILLCALLMOB 白野猪 2


删除地图动态链接点

功能: 删除使用AddMapRoute设置的地图链接点.
格式: DelMapRoute 动态链接标示(1-65535)

例子: 删除链接表示等于1的链接点.
#IF
#ACT
DelMapRoute 1


设置人物伤害吸收

说明:设置人物可吸收收到的攻击伤害.

格式: SetSuckDamage 操作符(+ - =) 总吸收直(1-2000000000) 吸收比例(1-1000) 成功率(1-100)
      吸收比例 1=0.1% 500=50% 1000=100%

例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%
#IF
CheckGold 10000
#ACT
SetSuckDamage + 1000 200 95
Take 金币 10000

特别说明:当人物设置伤害吸收后,收到攻击后会按照一定比例减少受到的伤害.
例如:当前拥有5000点伤害吸收,每次吸收20%,成功率100%.当前攻击受到100点伤害,那么本次攻击实际受到的伤害是80点.当前伤害吸收剩余4980点,此状态直到伤害吸收等于0时恢复,下线可保存装备.


设置人物商铺购买价格比例

功能: 设置人物商铺购买物品的价格比例.
格式: SetShopItemPriceRate 比例(1-100)
注意: 人物下线后状态消失.
其他: 列表信息中可设置单个物品是否允许打折购买.

例如:大于100级人物商铺购买物品的价格比例是90%,人物上线时在登录脚本设置价格比例即可.

[@Login]
#IF
CheckLevelEx > 99
#ACT
SetShopItemPriceRate 90


设置装备发光

功能: 设置装备发光
说明: 衣服,武器和头盔不支持次功能.
适用: 英雄M2
格式: SetItemsLight 位置(0-12) 值(1=发光效果1 2=发光效果2 0=不发光).
其他: 选择效果点击 M2\选项\功能设置\内挂控制

发光效果1:
#IF
#ACT
SetItemsLight 3 1

发光效果2:
#IF
#ACT
SetItemsLight 3 2

取消发光:
#IF
#ACT
SetItemsLight 3 0


随机验证码

随机输入验证码

[@Main]
#If
CheckLevelEx > 0
#Act
SetRandomNo
#Say
<输入验证码/@@CheckNo>:<$RANDOMNO>

[@@CheckNo]
#If
CheckRandomNo
#SAY
输入正确.
#ELSESAY
输入不正确.


特修身上装备

在物品规则列表中限制物品的不会被修理

#IF
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.


写入指定文本文件

功能: 把字符串写入到指定的文本文件中,可以指定写入行.
格式: AddTextListEx 路径 字符串 行(0-65535)

#IF
#ACT
AddTextListEx ..\TestList.txt <$USERNAME> 0


延时执行脚本

延时执行指定的脚本.

DelayCall S Label (S单位毫秒, Label是需要跳转的脚本段)

#IF
#ACT
DelayCall 5000 @Kick

[@Kick]
#IF
#ACT
Kick


移动怪物到新坐标

功能: 移动指定坐标的怪物到新的位置.
格式: MoveMonToPos 怪物 地图 老坐标X 老坐标Y 新坐标X 新坐标Y

例子:
#IF
CheckRangeMonCountEx K004 51 43 魔王弓箭手 > 0
#ACT
MoveMonToPos 魔王弓箭手 K004 51 43 48 47


移动某地图全部人物到另外一个地图

把某个地图中的玩家全部移动到另外一个地图.

#IF
#ACT
MoveMapPlay 0 3 333 333
#SAY
地图0中的人物已经全部移动到地图3中.


召唤自己的分身

例子:召唤自己的分身帮助自己作战3个小时.

#IF
#ACT
RecallSelf 3


自定义颜色文字发送

功能说明: 发送自定义颜色的文字信息.

格式: GuildNoticeMsg 255 233 发送自定义颜色的文字信息. Self

参数一是前景颜色,参数二是背景颜色,参数三是要发送的文字信息,参数四等于'Self'时只发送给自己, 等于'Group'时发送给组队, 等于'National'时发送给自己国家的人(使用于国战), 等于'Map'时发送到当前地图中的人物.如果省略参数四表示全服发送.

支持的参数: %s(玩家名字) %d(NPC名字) %m(地图名字) %x%y(坐标)
  <$KILLER>杀死人物的名字 <$MONKILLER>杀死怪物的名字


自动穿戴装备

   功能:自动穿背包中的装备

  装备位置:
  衣服        = 0;
  武器        = 1;
  蜡烛        = 2;
  项链        = 3;
  头盔        = 4;
  左手镯      = 5;
  右手镯      = 6;
  左戒指      = 7;
  右戒指      = 8;
  护符        = 9;
  腰带        = 10;
  鞋子        = 11;
  宝石        = 12;

  #IF
  CheckLevelEx > 1
  #ACT
  Give 怒斩 1
  AutoTakeOnItem 怒斩 1


检测被自己杀死宝宝的名字

检测被自己杀死的宝宝的名字.
注意:此命令只检测直属宝宝,例如道士英雄召唤的神兽不属于直属宝宝.

#IF
CheckKillSlaveName 白野猪
#SAY
你把对方的宝宝<白野猪>杀死了.


检测本月的天数

功能: 检测是否是本月的第几天.
格式: DAYOFMONTH 天数(1-31) 天数(1-31)
说明: 第二个参数可省略.

例子: 检测是否本月的前7天
[@main]
#IF
DAYOFMONTH 1 10
#SAY
本月10号之前.

例子: 检测是否是本月的第一天
[@main]
#IF
DAYOFMONTH 1
#SAY
今天是1号,新的一个月又开始了.


检测当前宝石升级装备的名字

功能: 检测当前通过宝石升级装备的名字
格式: CheckUpgradeItemName 位置(0-1) 名字
说明: 位置0=升级装备的名字 1=左边一格宝石的名字
注意: 此命令只能在QFunction中的@ItemUpgarde下执行.

[@ItemUpgrade]
#IF
CheckGold 5000
CheckUpgradeItemName 0 裁决之杖
#ACT
Take 金币 5000
#ELSESAY
只能升级裁决之杖,或者你没有5000金币.
#ELSEACT
SetUpgradeFail
Break


检测人物的攻击模式

说明: 检测人物的攻击模式
格式: CheckAttackMode 模式(0-7)

#IF
CheckAttackMode 0
#SAY
全体攻击模式

#IF
CheckAttackMode 1
#SAY
和平攻击模式


检测人物是否挂机

功能:检测人物是否是离线挂机
格式:CheckOffline


检测物品持久

功能:检测人物身上物品持久.
格式:CheckItemDura 位置(0-12) 操作法(> = <) 持久(1-65000) 模式(0,1)
说明:默认模式=0表示检测物品持久下限,模式=1时检测物品持久上限.

例子:检测物品持久下限
[@Main]
#IF
CheckItemDura 1 > 30000 0
#SAY
武器持久下限大于30.

例子:检测物品持久上限
[@Main]
#IF
CheckItemDura 1 > 30000 1
#SAY
武器持久上限大于30.


检测物品纯度

功能: 检测背包中物品的纯度(持久,品质).
格式: CheckMine 物品名称 数量(1-45) 纯度(1-65)

例子: 检测背包中是否有5个纯度20的黑铁矿石,并且回收.
[@main]
#IF
CheckMine 黑铁矿石 5 20
#ACT
TakeMine 黑铁矿石 5 20
#SAY
背包中有5个纯度20的黑铁矿石.
#ELSESAY
没有.


检测月份

功能: 检测现在是几月
格式: MONTHOFYEAR 月份(1-12) 月份(1-12)
说明: 第二个参数可省略.

例子: 检测是否7月--8月
[@main]
#IF
MONTHOFYEAR 7 8
#SAY
暑假期间大家玩的开心点.

例子: 检测是否1月
[@main]
#IF
MONTHOFYEAR 1
#SAY
新的一年开始了.


检测装备的附加属性总和[!]

功能: 检测装备的附加属性总和(武器的诅咒不在计算范围之内).
格式: 格式: CheckItemAddValueEx 位置(0-15) 操作符(> = <) 附加值(0-65000) 新属性(0,1)
说明: 第四个参数只在英雄M2下有效,1时计算附加的致命一击等属性.

例子:
#IF
CheckItemAddValueEx 1 > 5 1
#SAY
武器的附加属性大于5点.


检测装备名字颜色

功能: 检测装备名字的颜色(英雄M2).
格式: CheckItemNameColor 位置(0-13) 颜色(0-255)

例子: 检测武器颜色是否是紫色.
[@main]
#IF
CheckItemNameColor 1 253
#SAY
武器名字紫色显示.


检测字符串长度命令

功能：

检测字符串长度命令

格式：

CheckStringlength 字符串 操作符(<,>,=) 位数

说明：一个汉字位数为2, "》"也为2个字符

[@test]
#IF
CheckStringlength D3dm2 > 3
#SAY
D3dm2大于3个字符
#ELSESAY
D3dm2小于3个字符


检查宝宝数量

功能：
    可以检查玩家所带宠物的数量。

格式：
CHECKSLAVECOUNT  控制符  <.=.>  数量< FONT>

;==========================================
;检查宝宝数量是否为指定数量
[@checkslavecount0]
#IF
#ACT
  CHECKSLAVECOUNT = 5
#SAY
你的宝宝数量为5个。
#ELSESAY
你的宝宝数量不为5个。
;==========================================

;==========================================
;检查宝宝数量是否为大于数量
[@checkslavecount1]
#IF
#ACT
  CHECKSLAVECOUNT > 5
#SAY
你的宝宝数量超过5个。
#ELSESAY
你的宝宝数量不超过5个。
;==========================================

;==========================================
;检查宝宝数量是否为小于数量
[@checkslavecount2]
#IF
#ACT
  CHECKSLAVECOUNT < 5
#SAY
你的宝宝数量小于5个。
#ELSESAY
你的宝宝数量不小于5个。
;==========================================


检查宝宝最高等级

脚本功能:
检查宝宝的等级。

命令格式:
CHECKSLAVELEVEL 控制符(=,>,<)  等级数(7)< /FONT>

;==========================================
;检查宝宝的等级是否等于指定级别
[@checklevel0]
#IF
  CHECKSLAVELEVEL = 5
#SAY
宝宝的等级等于5级。
#ELSESAY
宝宝的等级不等于5级。
;==========================================

;==========================================
;检查宝宝的等级是否大于指定级别
[@checklevel1]
#IF
  CHECKSLAVELEVEL > 5
#SAY
宝宝的等级大于5级。
#ELSESAY
宝宝的等级不大于5级。
;==========================================

;==========================================
;检查宝宝的等级是否小于指定级别
[@checkposelevel2]
#IF
  CHECKSLAVELEVEL < 5
#SAY
宝宝的等级小于5级。
#ELSESAY
宝宝的等级不小于5级。
;==========================================


检查地图中的人物是否属于同一个行会

检查当前地图中的人物是否属于同一行会

格式: MapHumIsSameGuild 是否忽略没有加人行会的人物(0-1)

#IF
MapHumIsSameGuild 1
#SAY
当前地图中的人物属于同一个行会,不包涵没有加入行会的人物.


检查人物被踢次数.

#IF
CheckNumOfKick 3
#SAY
你已经被踢下线至少3次了.


检查人物杀死怪物的名字

功能:检查人物杀死怪物的名字
格式:CheckKillMonName 名字 是否清除(0,1)
说明:是否清除参数可以不需要默认0,为了避免杀死某个怪物可重复执行脚本是设置1.

[@main]
#IF
CheckKillMonName 白野猪
#SAY
你把白野猪干掉了!

;检测后立即清除人物内置变量.

[@main]
#IF
CheckKillMonName 白野猪 1
#SAY
你把白野猪干掉了!


检查人物是否在指定范围内

功能: 检测人物是否在指定范围之内
格式: CheckHumInRange 地图 坐标X 坐标Y 范围(0 -- 500)
说明: 地图=Self时表示当前地图.

例子: 检测人物是否在盟重安全区.
#IF
CheckHumInRange 3 330 330 5
#SAY
你在盟重安全区发呆呢..


检查人物所在地图是否允许使用记忆,夫妻,师徒传送

#IF
CheckRecall 人物名字
#SAY
当前地图不允许被传送.


检查是被人物还是怪物杀死的

检查是被怪物还是人物杀死的.

#IF
KillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$MONKILLER> 在%m 把你干死了!


检查一个范围内怪物数[!]

功能：
    可以检查一个坐标范围内怪物数量。

格式：
CheckRangeMonCount 地图号 X坐标 Y坐标 范围 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
  CheckRangeMonCount 3 330 330 10 < 100
#SAY
地图3的X330Y330十的范围内怪物少于100只
#ELSESAY
地图3的X330Y330十的范围内怪物多于100只
;==========================================


检查在线最高属性人物

检查在线最高攻击,魔法,道术,防御,PK值

#if
IsHigh L
#say
你的级别是全服最高的
#act
break

#if
IsHigh P
#say
你的PK值是全服最高的
#act
break

#if
IsHigh D
#say
你的攻击是全服最高的
#act
break

#if
IsHigh M
#say
你的魔力是全服最高的
#act
break

#if
IsHigh S
#say
你的道术是全服最高的
#act
break


检查正在穿身上装备的名字[!]

检查正在穿身上装备的名字.

格式: CheckTakeOnItem 物品名字

#IF
CheckTakeOnItem 布衣(男)
#SAY
你正在穿布衣！


检查正在攻击中的怪物名字

说明: 检查正在被自己攻击的怪物的名字.
注意: 地图参数中加入 HITMON(@XXX)

Q-Function0.txt中

[@XXX]
#IF
CHECKHITMONNAME 白野猪
#SAY
你正在攻击白野猪


检查正在脱身上装备的名字[!]

检查正在脱身上装备的名字.

格式: CheckTakeOffItem 物品名字

#IF
CheckTakeOffItem 布衣(男)
#SAY
你的布衣是不是该扔掉了?


检查指定城堡是否在攻城[!]

#if
checkcastlewar 2
#say
第三个城堡正在攻城
#elsesay
第三个城堡没有攻城


检查指定范围内人物数量

功能: 检测指定范围内人物数量
格式: 格式: CheckRangeHumCount 地图 坐标X 坐标Y 范围 操作符(>= <) 数量
说明: 地图=Self时表示当前地图 坐标=0时表示当前坐标

例子: 检测盟重省安全区的人物数量
#IF
CheckRangeHumCount 3 330 330 10 > 100
#SAY
盟重土城当前人数超过100.


检查指定人物背包空格数量

检测指定人物背包空格数量

#IF
CheckHumBag <$STR(S$1)> > 5
#SAY
<$STR(S$1)>的背包有5个以上的空格.


检查装备升级次数 或 星星数量

功能: 用来检测通过宝石升级装备的次数. 或 星星数量
格式: CheckItemupgradeCount 方式(0,1) 位置(0-12) 操作符(> = <) 次数(0-255)
说明: 方式=0时检测正在升级的装备,方式=1时检测人物身上的装备.

例子: 检测武器是否已经升级10次.
#IF
CheckItemUpgradeCount 1 1 > 10
#SAY
你的武器已经升级了10次以上.


检查自己和宝宝之间的距离[!]

功能: 检测自己和宝宝之间的距离
格式: CheckSlaveInRange 名字 距离
说明: 此命令的主要作用是配合128类型的宝宝使用(可模仿押镖任务).

#IF
CheckSlaveInRange 月灵 5
#SAY
你的月灵在身边
#ELSESAY
你的月灵宝宝跑哪里去了?


摆摊触发脚本

注意：以下功能是仿HeroM2摆摊功能。如果你使用的是个人商店，请查看个人商店部分

打开摆摊窗口之前首先执行Q-Function中的@StartMyShop脚本段.

脚本命令ForbidMyShop用于中断摆摊.

例子:以下脚本放在Q-Function中.

[@StartMyShop]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。
#ACT
ForbidMyShop
BREAK

#IF
NOT INSAFEZONE
#SAY
需要在安全区使用摆摊功能！
#ACT
ForbidMyShop
BREAK

#IF
NOT IsOnMap 3
#SAY
需要在盟重使用摆摊功能.
#ACT
ForbidMyShop
BREAK

#IF
CheckLevelEx < 40
#SAY
需要40级才可以使用摆摊功能！
#ACT
ForbidMyShop


购买商铺物品时触发

功能说明: 人物通过商铺购买物品成功时触发(英雄M2).
使用方法: Q-Function.txt中@BuyShopItem脚本段,
购买的物品名字放在人物的S0变量中,物品价格放在M0中.

[@BuyShopItem]
#IF
#ACT
SendMsg 5 %s通过商铺购买了<$STR(S0)>,价格是:<$STR(M0)>


技能触发脚本功能

增加魔法触发功能.自身技能触发. Q-Function.txt中[@MagSelfFuncX]段,其中X表示要触发的魔法ID
增加魔法触发功能.对目标人物使用时自身触发. Q-Function.txt中[@MagTagFuncX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标人物技能触发. Q-Function.txt中[@MagTagFuncExX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标怪物技能触发. Q-Function.txt中[@MagMonFuncX] 段,其中X表示要触发的魔法ID

例子:使用治愈术时触发脚本

[@MagSelfFunc2]
#ACT
SendMsg 5 自己加血
[@MagTagFunc2]
#ACT
SendMsg 5 给别人加血
[@MagMonFunc2]
#ACT
SendMsg 5 给怪物加血.


宝石升级系统[!]

说明:1.打开人物背包点右下脚的升级按钮进行升级.也可使用OpenUpgradeDialog命令打开界面.
     3.放好物品点升级时先执行Q-Function中的@ItemUpgrade脚本段.

例如:升级装备需要5000金币,此脚本放入Q-Function.txt中.

[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break

--------------------------------------------------------------------------------------------------------------

升级宝石StdMode=55,56,57,58,59

宝石类型1:

StdMode=55(升级指定类型的装备)
Shape=(指定升级哪种类型的装备,此处添写和要升级类型的StdMode一样的值即可,例如武器设定为5)
AniCount=(指定可以升级加几以下的装备,例如:设定为10,那么该宝石可以升级次数小于10次的装备)
DuraMax=(指定宝石升级装备的成功机率,例如:设定为20既为20%成功机率)
Need=(升级失败后可执行的操作,如果该值等于1-100时,则失败后把装备副加属性全部清零.如果该等于101-200时,则失败后装备消失.等于201-300时,升级失败后装备当前属性不变.)
NeedLevel=(指定宝石升级范围,等于0时不限制,例如:该宝石只允许升级+5到+10之间的装备,那么Need=5*65535+10,计算规则=低限*65535+上限)
Ac,Ac2,Mac,Mac2,Dc,Dc2,Mc,Mc2,Sc,SC2=(指定该宝石升级成功后给装备加的属性，设定方法跟设置装备属性一样，不同的装备设置也不一样)

宝石类型2:
StdMode=57(升级符合类型的装备)
Source=(等于1)
Shape=(等于0升级符合类型的装备,指定类型时填写待升级装备的StdMode值)
区别:其他设置方法参照宝石类型1
注意:此类宝石只增加防御和魔御.
AC2,MAC2=(升级装备的防御,魔御,必须是可增加防御和魔御的装备才可以升级,例如:衣服,手镯等)

宝石类型3:
StdMode=57(升级符合类型的装备)
Source=(等于2)
Shape=(等于0升级符合类型的装备,指定类型时填写待升级装备的StdMode值)
区别:其他设置方法参照宝石类型1
注意:此类宝石只增加攻击,道术和魔法.
DC2,MC2,SC2=(升级装备的攻击,魔法等,必须是可增加攻击和魔法等属性的装备才可以升级,例如:武器,项链等)

宝石类型4:
StdMode=58(随成升级装备属性)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
AniCount=(升级点数)
区别:其他设置参照宝石类型1,此类宝石升级时随机增加装备属性,例如:AniCount等于5时,那么随机增加装备5点属性.
注意:升级失败后如果Need小于100那么随机清除某项或者多项附加属性.

宝石类型5:
StdMode=59(增加升级成功率)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
DuraMax=(提高成功机率,例如:设定5即为提高5%的机率)

以下是最新更新后的部分新特性:

1.55,56,57,58这几种类型宝石失败后默认不会降低装备升级的星星数.如果升级失败时需要降低装备的星星数那么设置物品的Reserved字段,0时不降,大于0时设置几就降几点.
例如宝石的Reserved=2 装备的星星数=3 升级失败后星星就会减去2，剩下1个星星

2.58类型的升级宝石Weight=1时随机升级所以属性,Weight=2时只随机升级攻击,魔法,道术.


毒素武器[!]

使用方法:\Envir\UserData\PoisonWeapon.txt

格式: 武器名称 成功几率 减HP值 基本时间 扩展时间
成功率100以下时设置多少就是多少的成功率例如:80就是80%的成功率50就是50%的成功率
扩展时间是一个随即值,假如设置为10那么它的值就是1-10之间的值. 持续时间=基本时间+扩展时间所产生的随机值
例如:木剑 90 10 10 5


检测当前目标类型

格式: CHECKCURRTARGETRACE 控制符(=,>,<) 数据库Race值

该命令只有在死亡触发和攻击触发中使用

[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#SAY
当前是人物
BREAK

#IF
CHECKCURRTARGETRACE = 1
#SAY
当前是英雄
BREAK

#IF
CHECKCURRTARGETRACE = 60
#SAY
当前是人形怪
BREAK


检测地图范围怪物数量[!]

格式: CHECKRANGEMONCOUNTEX 地图名称 怪物名称 X坐标 Y坐标 范围 控制符(=,>,<) 数量
[@main]
#IF
CHECKRANGEMONCOUNTEX 3 333 333 10 > 100
#SAY
大于100个怪物


检测地图假人数量[!]

CHECKMAPDUMMYCOUNT,检测地图假人数量
格式:检测地图假人数量 地图 （< > =）

例子:

[@main]
#IF
CHECKMAPDUMMYCOUNT 3 > 10
#SAY
地图3假人数量大于10个


检测地图相同怪物数量[!]

格式: CheckMapSameMonCount 地图名称 怪物名称 控制符(<,>,=) 数量 是否忽略怪物名称后面的数字(0=检测数字,1=不检测数字)

[@Main]
#IF
CheckMapSameMonCount 3 稻草人 > 10
#SAY
土城的稻草人大于10个


检测地图坐标是否可以到达

功能：
检测地图坐标是否可以到达

格式：
CHECKMAPMOVE 地图名 X坐标 Y坐标

==============================================
[@测试]
#IF
CHECKMAPMOVE 3 333 333
#SAY
盟重省333 333能够到达
#ELSESAY
该坐标不能到达
============================================


检测会员剩余时间

格式: 检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)

例子:?

#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S$1)> <$STR(N$1)> <$STR(N$2)><$STR(N$3)>
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253

删除会员还是使用原来的老命令DELNAMEDATELIST


检测技能修炼点数[!]

功能：
检测技能修炼点数。

格式：
CHECKTRANPOINT 技能名称 检测符(>,<,=) 点数

;==========================================
[@CHECKTRANPOINT]
#IF
CHECKTRANPOINT 雷电术 = 100
#SAY
你的技能雷电术修炼点数等于100。
;==========================================


检测加入国家

格式: CheckNational (国家编号 0~100)

[@main]
#IF
CheckNational 0
#SAY
你还没有加入国家
BREAK

#IF
CheckNational 1
#SAY
你已经加入国家，国家编号1
BREAK


检测人物PK值

功能：
检测人物PK值。

格式：
 CHECKPKPOINTEX 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
CHECKPKPOINTEX > 100
#SAY
PK值大于 100
#ELSESAY
PK值小于 100
;==========================================


检测人物宝宝名字[!]

功能：

检测人物宝宝名字

格式：

;==========================================
[@main]
#IF
CHECKSLAVENAME GameOfMir
#ACT
SENDMSG 5 提示:你的宝宝叫GameOfMir
#ELSEACT
SENDMSG 5 提示:你的宝宝不叫GameOfMir
;==========================================


检测人物的伤害吸收

说明: 检测人物的伤害

格式: CheckSuckDamage 操作符(> = <) 数量(1-2000000000)

#IF
CheckSuckDamage > 1000
#SAY
SendMsg 5 你当前拥有的伤害吸收大于1000点.


检测人物荣誉

格式: CHECKGAMEGLORY (<,>,=) 值

[@Main]
#IF
CHECKGAMEGLORY = 100
#SAY
荣誉等于100

_________________________________________是两个命令自己测试把

检查人物的荣誉值

#IF
CheckNationCredit > 100
#SAY
你的荣誉值大于100点.


检测人物是否佩带指定物品

功能:
检测当前人物是否佩带指定物品

格式:
CHECKITEMW 物品名 数量

============================

[@TEST]
#IF
CHECKITEMW 力量戒指 1
#elsesay
你身上没有力量戒指\ \
#elseact
break

============================

[@TEST1]
#IF
COMPARETEXT <$DRESS> 布衣(男)
#elsesay
你身上没有布衣(男)\ \
#elseact
break


检测人物是否在线

checkonline

例子:

[@main]
#IF
checkonline
#SAY
在线

[@main]
#IF
H.checkonline
#SAY
你的英雄在线

[@main]
#IF
gameofmir.checkonline
#SAY
gameofmir在线

[@main]
#IF
S1.checkonline
#SAY
<$STR(S1)>在线


检测人物是否重叠

格式: IsDupMode 模式(0检测所有对象(包括人物、怪物、NPC)，1只检测是否有人物)

[@Main]
#IF
IsDupMode 1
#SAY
不要和其他人站在一起

[@Main]
#IF
IsDupMode 0
#SAY
不要和其他人或怪物站在一起


检测人物元素属性

格式: CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 检测符(>,<,=) 值(1-100)

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
[@main]
#IF
CHECKNEWITEMVALUE 0 0 > 10
#SAY
暴击几率大于10%


检测人物在线时长[!]

功能：
可以检查人物在线时间长度。

格式：
ONLINELONGMIN (> < =) 支持变量操作
;==========================================
#if
ONLINELONGMIN > 10
#say
在线时间大于 10分钟
;==========================================


检测杀人者是人物还是怪物

功能：
人物是被怪物杀死还是玩家杀死 死亡触发

格式：

;==========================================
[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK


检测是不是在摆摊

格式: CHECKSHOPSTALLSTATUS

[@main]
#IF
CHECKSHOPSTALLSTATUS
#SAY
正在摆摊
#ELSE
没有摆摊


检测是否进入攻城的范围

格式: CHECKCASTLEWARAREA 城堡名称

[@Main]
#IF
CHECKCASTLEWARAREA 沙巴克
#SAY
你已经进入进入攻城的范围


检测是否正在攻城

格式: CHECKUNDERWAR 城堡名称

[@Main]
#IF
CHECKUNDERWAR 沙巴克
#SAY
沙巴克正在攻击战


检测死亡不掉装备的次数
CheckNotDropItemCount (<,>,=) 次数

配套调整死亡不掉装备的次数NotDropItemCount

NotDropItemCount (+,-,=) 次数


检测物品的附加属性值

功能： 获取物品的附加属性值

格式: 格式: CHECKITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 < > =) 值 保存变量

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

例子:?
#IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.


检测行会可以容纳多少成员

格式: CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示检测自己所在的行会) 检测符(<,>,=) 数量
[@main]
#IF
CHECKGUILDMEMBERMAXLIMITCOUNT > 100
#SAY
你的行会可以容纳成员数大于100个


检测血量，魔法百分比

功能：
检测血量，魔法百分比

格式：
 CHECKHPPER 控制符(=,>,<) 百分比(0-100)
CHECKMPPER 控制符(=,>,<) 百分比(0-100)

;==========================================
例子：
#IF
CheckHpPer > 30
#ACT
#SAY
你的血量在总血量的30%以上
--------------------------------------------------------------------
#IF
#ACT
AddhpPer + 30
GuildNoticeMsg 250 0 你的血增加了30% self
===================================================================
检测自身MP百分比
例子：
#IF
CheckMpPer > 30
#ACT
#SAY
你当前的MP在总mp量的30%以上
;==========================================


检测在安全区

INSAFEZONE


检测指定范围内的人物数量

CheckRangeHumCount 地图名称 X Y 范围 (<,>,=) 数量


检测组队人数[!]

功能：
可以检查人物组队人数。

格式：
CHECKGROUPMEMBERCOUNT (<,>,=) 数量
;==========================================
#if
CHECKGROUPMEMBERCOUNT > 10
#say
组队人数大于10个人
;==========================================


检查城堡占领天数

功能：
 检查沙巴克占领天数

格式：
================================
#if
CASTLECHANGEDAY > 7
#say
你已经占领沙城7天以上.
================================


检查城堡战争天数

功能：
可以检查上次攻城到现在的天数。

格式：
 CASTLEWARAY 控制符(<=>) 天数
;==========================================
[@Main]
#IF
CASTLEWARAY > 3
#SAY
上次攻城到现在超过三天
#ELSESAY
上次攻城到现在未够三天
;==========================================


检查城门状态

功能：
可以检查沙城门状态。

格式：
;==========================================
#if
CHECKCASTLEDOOR 损坏
#say
城门损坏

#if
CHECKCASTLEDOOR 开启
#say
城门开启

#if
CHECKCASTLEDOOR 关闭
#say
城门关闭
;==========================================


检查当前所在地图的名字

功能：
检查当前所在地图的名字

格式：CHECKMAPNAME 地图名称
;==========================================
#if

CHECKMAPNAME 3

#say

你当前在地图3上\ \

<退出/@exit>

#elsesay

你当前不在地图3上\ \

<退出/@exit>

;==========================================


检查登录帐号与IP是否匹配

功能：
可以检查登录帐号与IP是否匹配。

格式：
CHECKACCOUNTIPLIST AccountIPList.txt

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKACCOUNTIPLIST AccountIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================

列表文件格式:
此文件们于目录：Mir200\Envir\

AccountIPList.txt

;==========================================
;登录帐号 IP
lintest 192.168.1.123
lintest1 192.168.1.124
;==========================================


检查地图怪物数量

功能：
可以检查一个地图内的怪物数量。

格式：
CheckMonMap 地图号 数量

;==========================================
[@Main]
#IF
CheckMonMap 3 30
#SAY
地图3的内怪物多于100只
#ELSESAY
地图3的怪物少于100只
;==========================================


检查对面人物的等级

功能：
 可以检查对面人物的等级（不要求面对面）。

格式：
CHECKPOSELEVEL 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查对面人物的等级是否等于指定级别
[@checkposelevel0]
#IF
CHECKPOSELEVEL = 50
#SAY
您对面人物的等级等于50级。
#ELSESAY
您对面人物的等级不等于50级。
;==========================================

;==========================================
;检查对面人物的等级是否大于指定级别
[@checkposelevel1]
#IF
CHECKPOSELEVEL > 50
#SAY
您对面人物的等级大于50级。
#ELSESAY
您对面人物的等级不大于50级。
;==========================================

;==========================================
;检查对面人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKPOSELEVEL < 50
#SAY
您对面人物的等级小于50级。
#ELSESAY
您对面人物的等级不小于50级。
;==========================================


检查对面人物的性别

功能：
 可以检查对面人物的性别（不要求面对面）。

格式：
CHECKPOSEGENDER 性别(MAN,男,WOMAN,女)

;==========================================
;检查对面人物是否为男的
[@checkposegender0]
#IF
CHECKPOSEGENDER MAN
#SAY
你对面的人物是男的。
#ELSESAY
你对面的人物不是男的。
;==========================================

;检查对面人物是否为女的
[@checkposegender1]
#IF
CHECKPOSEGENDER WOMAN
#SAY
你对面的人物是女的。
#ELSESAY
你对面的人物不是女的。
;==========================================


检查对面人物站的位置

功能：
 可以检查对面人物站的位置性别（要求面对面）。

格式：
CHECKPOSEDIR 控制符(1,2)

;==========================================
;检查对面人物是否面对面
[@checkposedir0]
#IF
CHECKPOSEDIR
#SAY
你二个站的位置正确。
#ELSESAY
你二个站的位置不正确。
;==========================================

;==========================================
;检查对面人物是否面对面，而且要求二个人相同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 1
#SAY
你二个站的位置及性别一样。
#ELSESAY
你二个站的位置不正确或性别不一样。
;==========================================

;==========================================
;检查对面人物是否面对面，而且要求二个人不同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 2
#SAY
你二个站的位置及性别不一样。
#ELSESAY
你二个站的位置不正确或性别一样。
;==========================================


检查国家人物总数.

格式: CheckNationHumCount 操作符(< = >) 人数

#IF
CheckNationHumCount > 100
#SAY
当前国家大于100人.


检查会员时间

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1

加入会员人物及时间： ADDUSERDATE 会员.txt
删除会员人物及时间： DELUSERDATE 会员.txt


检查金刚石数量

功能：
 检查金刚石数量。

格式：
 CHECKGAMEDIAMOND 控制符(<、>、 =) 点数

GAMEDIAMOND (+,-,=) 值
<$GAMEDIAMOND>

;==========================================
#IF
CHECKGAMEDIAMOND> 50
#SAY
你的金刚石超过50点
#ELSESAY
你的金刚石少于50点
;==========================================

功能：
 检查灵符数量。

格式：
 CHECKGAMEGIRD 控制符(<、>、 =) 点数

GAMEGIRD (+,-,=) 值
<$GAMEGIRD>

;==========================================
#IF
CHECKGAMEGIRD > 50
#SAY
你的灵符超过50点
#ELSESAY
你的灵符少于50点
;==========================================

功能：
 检查荣誉数量。

格式：
 CHECKGAMEGLORY 控制符(<、>、 =) 点数

GAMEGLORY (+,-,=) 值
<$GAMEGLORY>

;==========================================
#IF
CHECKGAMEGLORY > 50
#SAY
你的荣誉超过50点
#ELSESAY
你的荣誉少于50点
;==========================================


检查人物HP值

功能：
用来检查人物HP值的上限及下限值

命令格式：
 CHECKHP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

======================
#if
CHECKHP > 29 < 41
#say
你的HP值大于30-40
======================


检查人物MP值

功能：
 用来检查人物MP值的上限及下限值

命令格式：
 CHECKMP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

==========================
#if
CHECKMP > 29 < 41
#say
你的MP值大于30-40
==========================


检查人物背包空格数

功能：
检查人物背包空格数

命令：
 CheckBagSize 数量

=======================
[@checkbagsize]
#if
CHECKBAGSIZE 5
#say
身上有5个空格
#elsesay
身上的空格不够。
=======================


检查人物称号的数量

功能：
 检查人物称号的数量

格式：
 CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-30)

[@main]
#IF
CHECKFENGHAOCOUNT > 9
#SAY
你已经有了10个称号


检查人物当前经验值

功能：
 检查玩家当前经验值。

格式：
CHECKEXP 控制符(=,>,<) 经验值(1 - 4000000000)< /FONT>

;==========================================
;检查人物的经验值是否等于指定值
[@checkexp2]
#IF
CHECKEXP = 5000
#SAY
您的经验值等于5000。
#ELSESAY
您的经验值不等于5000。
;==========================================

;==========================================
;检查人物的经验值是否大于指定值
[@checkexp2]
#IF
CHECKEXP > 5000
#SAY
您的经验值大于5000级。
#ELSESAY
您的经验值不大于5000。
;==========================================

;==========================================
;检查人物的经验值是否小于指定值
[@checkexp2]
#IF
CHECKEXP < 5000
#SAY
您的经验值小于5000级。
#ELSESAY
您的经验值不小于5000。
;==========================================


检查人物道术

功能：
 用来检查人物道术的上限及下限值

命令格式：
 CHECKSC 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

================
#if
CHECKSC > 29 < 41
#say
你的道术大于30-40
================


检查人物的会员等级

功能：
 可以检查人物的会员等级。

格式：
CHECKMEMBERLEVEL 类型(1-65535) 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查人物的会员等级是否为指定等级
[@checkmemberlevel0]
#IF
CHECKMEMBERLEVEL 2 = 5
#SAY
您的会员等级为5。
#ELSESAY
您的会员等级不为5。
;==========================================

;==========================================
;检查人物的会员等级是否大于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 > 5
#SAY
您的会员等级大于5。
#ELSESAY
您的会员等级不大于5。
;==========================================

;==========================================
;检查人物的会员等级是否小于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 < 5
#SAY
您的会员等级小于5。
#ELSESAY
您的会员等级不小于5。
;==========================================


检查人物的会员类型

功能：
可以检查人物的会员类型。

格式：
CHECKMEMBERTYPE 控制符(=,>,<) 类型数(1 - 65535)

;==========================================
;检查人物的会员类型是否为指定类型
[@checkmember0]
#IF
CHECKMEMBERTYPE = 5
#SAY
您的会员类型为5。
#ELSESAY
您的会员类型不为5。
;==========================================

;==========================================
;检查人物的会员类型是否大于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE > 5
#SAY
您的会员类型大于5。
#ELSESAY
您的会员类型不大于5。
;==========================================

;==========================================
;检查人物的会员类型是否小于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE < 5
#SAY
您的会员类型小于5。
#ELSESAY
您的会员类型不小于5。
;==========================================


检查人物的游戏点数

功能：
 用于配合泡点功能，检查当前人物身上有多少点数。

格式：
 CHECKGAMEPOINT 控制符(<、>、 =) 点数

;==========================================
#IF
CHECKGAMEPOINT > 50
#SAY
你的游戏点超过50点
#ELSESAY
你的游戏点少于50点
;==========================================

功能：
 检查当前人物身上有多少游戏币。

格式：
 CHECKGAMEGOLD 控制符(<、>、 =) 点数

;==========================================
#IF
CHECKGAMEGOLD > 50
#SAY
你的游戏币超过50点
#ELSESAY
你的游戏币少于50点
;==========================================


检查人物的转生等级

功能：
 检查人物的转生等级

命令格式:
 CHECKRENEWLEVEL 控制符(=,>,<) 转生等级数(1 - 255)

;==========================================
;检查人物的转生等级是否等于指定级别
[@checklevel0]
#IF
CHECKRENEWLEVEL = 5
#SAY
您的转生等级等于5级。
#ELSESAY
您的转生等级不等于5级。
;==========================================

;==========================================
;检查人物的转生等级是否大于指定级别
[@checklevel1]
#IF
CHECKRENEWLEVEL > 5
#SAY
您的转生等级大于5级。
#ELSESAY
您的转生等级不大于5级。
;==========================================

;==========================================
;检查人物的转生等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKRENEWLEVEL < 5
#SAY
您的转生等级小于5级。
#ELSESAY
您的转生等级不小于5级。
;==========================================


检查人物登录IP

功能：
检查人物登录IP.

格式：
 CHECKIPLIST 会员.txt

;==========================================
;按IP检查
[@checkiplist0]
#IF
CHECKIPLIST IP会员.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物登录帐号

功能：
检查人物登录帐号.

格式：
 CHECKACCOUNTLIST 帐号.txt

;==========================================
;按登录帐号检查
[@checkaccountlist0]
#IF
CHECKACCOUNTLIST 帐号.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物等级（改进）

功能：
可以更为方便地检查玩家等级。

格式：
CHECKLEVELEX 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKLEVELEX = 50
#SAY
您的等级等于50级。
#ELSESAY
您的等级不等于50级。
;==========================================

;==========================================
;检查人物的等级是否大于指定级别
[@checklevel1]
#IF
CHECKLEVELEX > 50
#SAY
您的等级大于50级。
#ELSESAY
您的等级不大于50级。
;==========================================

;==========================================
;检查人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKLEVELEX < 50
#SAY
您的等级小于50级。
#ELSESAY
您的等级不小于50级。
;==========================================


检查人物附加属性点数

功能：
检查人物附加属性点数

格式：
CHECKBONUSPOINT 控制符(=,>,<) 点数

相关命令：
复位属性点数：RESTBONUSPOINT
调整属性点数：BONUSPOINT


检查人物攻击力

功能：
用来检查人物攻击力的上限及下限值

命令格式：
 CHECKDC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限

====================
#IF
CHECKDC > 29 < 41
#say
你的攻击力大于30-40
====================


检查人物技能(扩展)

检查人物技能

功能：
检查人物技能

格式：
CHECKSKILL 技能名称 检测符(<,>,=) 等级 是否检测强化技能(0或为空时为技能等级,1为强化技能等级)

例：
[@main]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

相关命令：
练习技能：ADDSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL


检查人物名称是否与IP匹配

功能：
可以检查登录帐号与IP是否匹配。

格式：
CHECKNAMEIPLIST NameIPList.txt

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKNAMEIPLIST NameIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================

列表文件格式:
此文件们于目录：Mir200\Envir\

NameIPList.txt

;==========================================
;人物名称 IP
GM001 192.168.1.123
GM002 192.168.1.124
;==========================================


检查人物魔法力

功能：
用来检查人物魔法力的上限及下限值

命令格式：
 CHECKMC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限

======================
#if
CHECKMC > 29 < 41
#say
你的魔法力大于30-40
======================


检查人物身上指定位置是否戴物品

功能：
检查人物身上指定位置是否戴物品

命令：
 CHECKUSEITEM 物品位置(0-12)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器
[@checkUseItem]
#if
CHECKUSEITEM 0
#say
你身上穿了衣服。
#elsesay
你还没穿衣服呢。


检查人物身上装备类型

功能：
用来检查人物身上戴物品类型，因为不同类型物品的附加属性值位置不一样，在升级装备物品性时用来控制指定属性值。
命令格式：
 CHECKITEMTYPE 物品位置 物品类型

物品位置：
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器

物品类型：
5 武器
6 武器
10 衣服
11 衣服
15 头盔
19 项链
20 项链
21 项链
22 戒指
23 戒指
24 手镯
25 护身符
26 手镯
28 马牌
29 天使
30 照明物
52 鞋子
53 宝石
54 腰带


检查人物声望点

功能：
检查人物声望点

命令格式:
CHECKCREDITPOINT 控制符(=,>,<) 声望点数(1 - 255)< /FONT>

;==========================================
;检查声望点是否等于指定点数
[@CHECKCREDITPOINT0]
#IF
CHECKCREDITPOINT = 50
#SAY
您声望点等于50级。
#ELSESAY
您声望点不等于50级。
;==========================================

;==========================================
;检查声望点是否大于指定点数
[@CHECKCREDITPOINT1]
#IF
CHECKCREDITPOINT > 50
#SAY
您声望点大于50级。
#ELSESAY
您声望点不大于50级。
;==========================================

;==========================================
;检查声望点是否小于指定点数
[@CHECKCREDITPOINT2]
#IF
CHECKCREDITPOINT < 50
#SAY
您声望点小于50级。
#ELSESAY
您声望点不小于50级。
;==========================================


检查人物是否付费

#if
CHECKPAYMENT 2
#say


检查人物是否加入行会

功能：
可以检查玩家是否加入行会。

格式：
============================
#IF
HAVEGUILD
#SAY
你已经加入了行会！
#ELSESAY
你没加入行会！
============================


检查人物是否为管理员

功能：
检查人物是否为管理员

格式：
;==========================================
;检查人物是否为系统管理员
[@IsSysOp]
#IF
ISADMIN
#SAY
你是系统管理员。
#ELSESAY
你不是系统管理员。
;==========================================


检查人物是否为沙城城主

功能：
可以检查玩家是否为沙城老大。

格式：
============================
#IF
ISCASTLEMASTER
#SAY
你是沙城老大！
#ELSESAY
你不是沙城老大！
============================


检查人物是否为沙城成员

功能：
可以检查玩家是否为沙城成员。

格式：
============================
#IF
ISCASTLEGUILD
#SAY
你是沙城成员！
#ELSESAY
你不是沙城成员！
============================


检查人物是否为新人

功能：
可以检查玩家是否为新人（即刚注册进入游戏的人，退出后再进就不是新人了）。

格式：
============================
#IF
ISNEWHUMAN
#SAY
你是新人！
#ELSESAY
你不是新人！
============================


检查人物是否为行会掌门人

功能：
可以检查玩家是否为行会老大。

格式：
============================
#IF
ISGUILDMASTER
#SAY
你是行会老大！
#ELSESAY
你不是行会老大！
============================


检查人物是否学习了某项魔法

#IF
CheckMagicName 烈火剑法
#SAY
你已经学会了烈火剑法.


检查人物是否在攻城区域[!]

功能: 检查人物是否在攻城区域
格式: CheckInWarArea

#IF
CheckInWarArea
#SAY
在攻城区域.


检查人物在列表中的位置

功能：
检查人物在列表中的位置。

格式：
 CHECKNAMELISTPOSITION List.txt (> < = ) 10 P0

;==========================================
;
[@checkpostion0]
#IF
CHECKNAMELISTPOSITION AccountIPList.txt < 10 P0
#SAY
您在前10名，当前排名为<$STR(P0)>。
#ELSESAY
您不在前10名，当前排名为<$STR(P0)>。。
;==========================================


检查是否存在某个称号

功能：
 检查是否存在某个称号

格式：
 CHECKTITLE 称号名称

[@main]
#IF
CHECKTITLE 称号一
#SAY
你已经有了“称号一”的称号


检查是否为组长

功能：
检查人物是否为编组的组长
格式：
ISGROUPMASTER
[@checkgroup]

#if
ISGROUPMASTER
#say
你是组长
#elsesay
你不是组长

相关命令：
编组地图传送：GROUPMAPMOVE
编组地图随机传送：GROUPMOVE


检查是否在某地图

ISONMAP 地图名称


检查行会名称

功能：
 检查行会名称

格式：
================================
#if
CHECKOFGUILD 行会名称
#say
行会正确
================================


检查行会是否在列表中

功能：
检查行会是否在列表中

格式：
================================
[@checkGuild]
#IF
CHECKGUILDLIST GuildList.txt
#SAY
列表中有行会。
#ELSESAY
列表中没有行会。
================================


检查一个地图内人数

功能：
可以检查一个地图内的人物数量。

格式：
CheckMapHumenCount地图号 ('<' '>' '=')数量

;==========================================
[@Main]
#if
CheckMapHumanCount 3 < 100
#say
地图3内人数小于100人
#elsesay
地图3内人数多于100人

;==========================================


检查装备绑定状态[!]

功能：检查装备绑定状态
格式：CheckItemState 装备位置(-1~18,-1时为OK框中物品) 项目(0-6)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出 6 丢弃消失

[@衣服禁止扔]
#IF
CheckItemBind 0
#ACT
GOTO @禁止扔
#ELSEACT
SENDMSG 6 请先绑定

[@禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔


检查字符串是否在指定文件中 包含检测 [!]

检查字符串是否在指定文件中 包含检测 检测的字符串不需要完全相同，文件里的字符包含检测的字符，就会成功

[@CheckContainsTextList]
#IF
CheckContainsTextList ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
列表里的某一行字符包含<$STR(S2)>
#ELSESAY
列表里的某一行字符包含<$STR(S2)>

[@CheckContainsTextListEx]
#IF
CheckContainsTextListEx ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
<$STR(S2)>包含列表里某一行字符
#ELSESAY
<$STR(S2)>不包含列表里某一行字符

CheckContainsTextList 和 CheckContainsTextListEx 区别

CheckContainsTextList 列表文件里保存的是完整的字符。检测列表里的某一行字符是否包含检测的关键字

CheckContainsTextListEx 列表文件里保存的是关键字。检测字符是否包含列表里的某一行关键字


检查字符串是否在指定文件中[!]

[@旧格式_不区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S$2)>
#SAY
<$STR(S$2)>在列表中
#ELSESAY
<$STR(S$2)>不在列表中

[@新格式_区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S$2)> <$STR(S$3)>
#SAY
卡号密码正确
#ELSESAY
卡号密码错误

S$2和S$3的值在“10元卡号.txt”文本中以空格分开


脚本检测命令取反 NOT [!]
格式:NOT 命令 > 50 //检测人物物品算不大于50

例子:

[@main]
#IF
NOT CHECKGAMEGOLD > 50 //检测人物元宝算不大于50
#ACT
SENDMSG 5 你身上的元宝不大于50

[@main_1]
#IF
NOT CHECKLEVELEX > 80 //检测人物等级不大于80级
#ACT
SENDMSG 5 你的等级不大于80级

[@main_2]
#IF
NOT EQUAL P0 5 //检测变量P0是否不等于5
#ACT
SENDMSG 5 <$STR(P0)>变量不等于5

[@main_3]
#IF
NOT H.CHECKLEVELEX > 80 //检测英雄等级不大于80级
#ACT
SENDMSG 5 你的英雄等级不大于80级


新物品绑定检测[!]

CheckItemBind,检测物品是否已经绑定
格式:CheckItemBind 装备位置(-1~13,-1时为OK框中物品)

例子:

[@衣服绑定]
#IF
CheckItemBind 0
#ACT
SENDMSG 6 该装备已经绑定过了
#ELSEACT
SetItemBind 0 1
SENDMSG 6 绑定完成


行会成员人数

功能: 检测行会成员人数

格式:
CheckGuildMemberCount 控制符  <.=.>  数量

#IF
CheckGuildMemberCount  > 100
#SAY
行会成员大于100人.


字符串比较处理

功能：
字符串比较处理。

格式：
CheckContainsText 字符 字符串检查 //检查字符串是否包涵在另外一个字符串中.
CompareText 字符 字符 // 比较两个字符串是否一样

;==========================================
检查字符串是否包涵在另外一个字符串中
[@Test]
#IF
CheckContainsText www.gameofmir.com gameofmir.com
#Say
包涵
#elsesay
不包涵
;==========================================

;==========================================
比较两个字符串是否一样，不区分大小写
[@Test]
#IF
CompareText www.gameofmir.com www.gameofmir.com
#Say
一样
#elsesay
不一样
;==========================================


DEC对字符型变量操作命令[!]

DEC对字符型变量操作命令。
MOV命令做了一些改进。

[@Main]
#ACT
MOV S1 GameOfMir引擎M2
MOV S2 GameOfMir引擎M2
DEC S1 GameOfMir引擎 ;删除S1中的“GameOfMir引擎”字符串
DEC S2 1 3 ;删除S2中的第1至第3个字符串 这个要注意，一个汉字是2个字节长度，不要删除半个汉字的情况，否则会乱码。

结果 S1=M2
S2=引擎M2


查看人物私聊信息

此功能可以实时侦听指定人物的私聊信息，将指定人物发送及接收的私聊信息发送到自己。

命令格式：
@ViewWhisper 人物名称

重复输入取消侦听私听信息。


程序变量说明[!]

P0-P999 (私人变量，数字型) 关闭对话框重置为0。
D0-D999 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M999 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N999 (私人变量，数字型) 下线不保存.小退归0.
S0-S999 (私人变量，字符型) 下线不保存.小退归0.
I0-I999 (全局变量，数字型) 不可保存，服务器重启自动重置为0。
G0-G999 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A999 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U49 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面）
T0-T49 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面）

注意： 自定义变量名称不要以P、D、M、N、S、I、G、A、U、T开头

【变量属性】

P(0-999)

『属性说明』：该变量只对当前对话NPC内有效果。如果中途点其他NPC或者对话产生close、关闭时所有P变量均归0。该变量取值范围：（0-？）根据M2最大值不同
『用法』：该变量没有NPC间传递性作为临时变量多重复使用效果十分好。而且因为脚本命令有对该变量进行加/减/赋值/随机取值等运算，他和goto的配合可以使脚本中出现仿for循环的效果。并且因为他不传递的性质其
随机取值也能与RANDOM媲美。

D(0-999)

『属性说明』：该变量在人物不下线时对全局NPC通用传递。该变量取值范围：同P变量
『用法』：既有像[0-？]变量一样的人物属性私有变量的效果又有像P变量一样的运算功能！唯一不足就是下线 后该变量会被清空。可是如果配合上[000]变量或者namelist变量的记录性。实在是功能强大的个人隐私属性！

G(0-999)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同P变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）

A(0-999)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同D变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）


传奇脚本命令详解[!]

===========================================================

传奇脚本命令详解
====================********************************========================

[@段] ;段用英文或数字表示

goto @段 ;跳转到指定段，开始执行相当于B中的goto语句

#say 语句 ;语句设定为字符，不用加任何定界符

#act 执行命令 ;符合3.0规定的任何系统已定义命令

give 物品 数量 ;给多少东西,除了物器数据库中有的物品，还有金币，

take 物品 数量 ;同上，只是与上面相反，一个是给东西，一个是收回东西

map 地图名 ;移动到这个地图的随机坐标，地图名为地图的数字人码

mapmove 地图名 坐标A 坐标B ;同上，只是指定了坐标

monclear 地图名 ;清除这个地图上刷的怪物

MonGen 怪物名称 数量 时间 ;刷怪物，与刷怪角本用法相同

TimeRecall 数值 ;数值为分钟，定义进入某地的时间限制。

BreakTimeRecall ;中断上面那个语句设定的时间

hairstyle 数值 ;改变头发类型

haircolor 红值 绿值 蓝值 ;值域为0 ~ 255 设定头发颜色

close ; 关闭对话框

======================****************************========================
---------------------- 程 序 中 的 变 量 与 常 量 ------------------------
======================****************************========================

变量 ;变量用字母表示，在程序中可以赋任何数据 名称只限于P0-P9,D0-D9
mov 变量 数值 ;给变量赋值

inc 变量 数值 ;让变量自动加指定数值到变量，相当于程序中的x=x+n

sum 变量A 变量B ;变量求和不要与int混淆,需要下面的组合语名才能实现

MOV 变量X 0 ;变量X，初值。

sum 变量A 变量B ;X=A+B

sum 变量C ;X=X+C 最后在程序中得到的是X值，实际X=A+B+C

;如果只写中间一句是无意义的，只能导致错误

movr 变量 数值 ;定义随机变量，变量值为 “0 到 数值”

random 数值 ;当数值=随机数时则为1否则为0

<$STR(变量)> ;显示变量时用，可以将变量值显示在游戏里，用在 #say后面。

=========================*******************************========================
------------------------- 程 序 中 的 逻 辑 判 断 语 句 ------------------------
=========================*******************************========================

[n] ;n为1-1024正整数，是逻辑变量，有0值和1值，初始0值

#IF
条件--执行
#elsesay 或者 #elseact
否定--执行 ;相当于程序中的条件判断

SET [n] 1 ;设置逻辑变量为真

--------------------关于reset命令的详解------------------------------------

reset [XXX] 7 意思是将从XXX开始的7个变量回复到原始值0

比如：reset [100] 7 就是把100 101 102 103 104 105 106 107这7个变量赋值为0。

它等同与：set [100] 0

set [101] 0

set [102] 0

set [103] 0

set [104] 0

set [105] 0

set [106] 0

--------------------------------------------------------

Check [n] 1 ;测试逻辑变量是否为真，可以测试是否已经完成了任务

small 变量 数值 ;如果“变量 < 数值”则为1否则为0

large 变量 数值 ;如果“变量 > 数值”则为1否则为0

equal 变量 数值 ;如果“变量 = 数据”则为1否则为0

checkjob Warr(Wizard、Taos) ;测试职业 成功为1否则为0

checkgold 数值 ;拥有金币数>=数值为1否则为0

checklevel 数值 ;人物等级>=数值为1否则为0

checkitem 物品 数值 ;测试拥用物品的数量

genderman ;测试性别为男，如果为男则为1否则为0

checkbaggage ;测试背包是否已满，满时为1否则为0

checkpkpoint 数值 ;数值为PK值，PK值数>值时为1否则为0

checkluckypoint 数值 ;同上，只是测的是幸运值

checkmonmap 地图名 数值 ;同上，只是测的是怪物数量

checkduraeva 物品名 数值 ;同上，只是测试有品质的物品的品质

checkhum 地图名 数值 ;同上，测试这个地图的人数

checkitemw 物品 检测身上所带的物品

takew 物品 直接从身上回收物品

checkmagic 技能名称 检测已经修炼的技能

脚本大全 [喜欢脚本的来]
传奇商用NPC开头解释(部分,补足请补足)
%100 代表买东西是原价格还是双倍价格
+40 买肉
+1 卖肉
+43 武器有关(修)
+15 头盔
+10 买衣服
+11 修衣服
+26 修手镯类
+0 买各种药水
+42 卖各种药水
+30 蜡烛等.
+25 特殊水
+3 买卷轴,书类
+4 卖书类
+19 项链
+20 项链
+21 项链
+22 买戒指
+23 卖戒指
+24 买手镯
+26 卖手镯
+5 修炼武器或买武器
+6 修炼武器或卖武器
================================

checkjob (Warr, Wizard, Taos) ;测试职业
checkgold (金币数) ;测试金币
checklevel (等级) ;测试等级
checkitem (物品名) (数量) ;测试物品及数量
give gold (金币数) ;给钱
give (物品名) (数量) ;给物及数量
take gold (金币数) ;拿走钱
take (物品名) (数量) ;拿走物及数量
checkpkpoint (pk值) ;测试PK值
checkluckypoint (幸运值) ;幸运值正值为好,负值为差
checkduraeva (物品名) (数值) ;一般测试矿物等物品的品质
checkhum (地图名) (数值) ;测试这个地图的人数
checkmonmap (地图名) (数值) ;测试这个地图的怪物数
map (地图名) ;移动到这个地图
mapmove (地图名) (坐标A) (坐标B) ;移动到这个地图指定坐标
monclear 地图清除
close 关闭对话框
TimeRecall (设定时间值) ;分钟,一般指进入地图时间限制
BreakTimeRecall ;中断设定时间
ExchangeMap (地图名) ;与指定地图里的人交换位置
daytime sunset ;一天时间
checkbaggage ;测试背包满没
small (变量) (数值) ;测试变量是不是小于指定数值
large (变量) (数值) ;测试变量是不是大于指定数值
equal (变量) (数值) ;测试变量是不是等于指定数值
mov (变量) (数值) ;让变量等于指定数值
sum (变量A) (变量B) ;A+B 注意,如果还要家第3个数直接换行写sum (变量C)
注:关于SUM的详解
首先有MOV (变量X) 0 ;(变量X)清0
sum (变量A) (变量B) ;X=A+B
sum (变量C) ;X=X+C
movr (变量) (数值) ;随机把指定数值以下的数(正数)给变量
inc (变量) (数值) ;让变量自动加指定数值到变量
playdice (骰子数) @xxx ;玩骰子,跳转到标签[@xxx]
random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT
Check [条件数] 1 ;测试[条件数]触发与否 1(触发)
SET [条件数] 1 ;设置[条件数]触发
Monclear 地图 清理这个地图！
Param1 地图 地图名
Param2 横坐标 坐标
Param3 纵坐标 坐标
MonGen 怪物名称 数量 时间
TimeRecall 时间 时间限制

二。脚本变量：
<$USERNAME> 当前用户名
<$GUILDWARFEE>行会战金币数
<$LORD>沙巴克行会头名
<$OWNERGUILD>沙巴克行会名
<$UPGRADEWEAPONFEE>升级武器价格
<$USERWEAPON> 放在对话框里的武器名字
<$STR(变量)> 把变量转换为字符型 random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列
#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT


关于国战

Envir\Nations\Nations.ini中的NationalNames1 -- NationalNames100是国家的名字,只有定义了国家名字之后加入国家才有效!

Nations.ini

[Names]
NationalNames1=
NationalNames2=
NationalNames3=
NationalNames4=
NationalNames5=
NationalNames6=
NationalNames7=
NationalNames8=
NationalNames9=
NationalNames10=
NationalNames11=
NationalNames12=
NationalNames13=
NationalNames14=
NationalNames15=
NationalNames16=
NationalNames17=
NationalNames18=
NationalNames19=
NationalNames20=
NationalNames21=
NationalNames22=
NationalNames23=
NationalNames24=
NationalNames25=
NationalNames26=
NationalNames27=
NationalNames28=
NationalNames29=
NationalNames30=
NationalNames31=
NationalNames32=
NationalNames33=
NationalNames34=
NationalNames35=
NationalNames36=
NationalNames37=
NationalNames38=
NationalNames39=
NationalNames40=
NationalNames41=
NationalNames42=
NationalNames43=
NationalNames44=
NationalNames45=
NationalNames46=
NationalNames47=
NationalNames48=
NationalNames49=
NationalNames50=
NationalNames51=
NationalNames52=
NationalNames53=
NationalNames54=
NationalNames55=
NationalNames56=
NationalNames57=
NationalNames58=
NationalNames59=
NationalNames60=
NationalNames61=
NationalNames62=
NationalNames63=
NationalNames64=
NationalNames65=
NationalNames66=
NationalNames67=
NationalNames68=
NationalNames69=
NationalNames70=
NationalNames71=
NationalNames72=
NationalNames73=
NationalNames74=
NationalNames75=
NationalNames76=
NationalNames77=
NationalNames78=
NationalNames79=
NationalNames80=
NationalNames81=
NationalNames82=
NationalNames83=
NationalNames84=
NationalNames85=
NationalNames86=
NationalNames87=
NationalNames88=
NationalNames89=
NationalNames90=
NationalNames91=
NationalNames92=
NationalNames93=
NationalNames94=
NationalNames95=
NationalNames96=
NationalNames97=
NationalNames98=
NationalNames99=
NationalNames100=


脚本变量大全[!]

脚本变量

人物信息

变量名称 | 说明
<$USERNAME> | 人物名称
<$GUILDNAME> | 行会名称
<$RANKNAME> | 行会职位名称
<$LEVEL> | 等级
<$HP> | 生命值
<$AC> | 防御力
<$MAXAC> | 最高防御力
<$MAC> | 魔法防御力
<$MAXMAC> | 最高魔法防御力
<$DC> | 物理攻击力
<$MAXDC> | 最高物理攻击力
<$MC> | 魔法力
<$MAXMC> | 最高魔法力
<$SC> | 道术
<$MAXSC> | 最高道术
<$EXP> | 当前经验值
<$MAXEXP> | 升级经验值
<$MAXHP> | HP上限
<$MAXMP> | MP上限
<$DIR> | 方向
<$PKPOINT> | PK点数
<$CREDITPOINT> | 声望点数
<$GOLDCOUNT> | 金币数量
<$GAMEGOLD> | 游戏币数
<$GAMEPOINT> | 游戏点数
<$HW> | 腕力
<$MAXHW> | 最高腕力
<$BW> | 背包重量
<$MAXBW> | 最高背包重量
<$WW> | 负重力
<$MAXWW> | 最高负重
<$HUNGER> | 饥饿程度
<$LOGINTIME> | 登录时间
<$LOGINLONG> | 登录时长
<$DRESS> | 衣服
<$WEAPON> | 武器
<$RIGHTHAND> | 蜡烛
<$HELMET> | 头盔
<$NECKLACE> | 项链
<$RING_R> | 右戒指
<$RING_L> | 左戒指
<$ARMRING_R> | 右手镯
<$ARMRING_L> | 左手镯
<$BUJUK> | 护身符
<$BELT> | 腰带
<$BOOTS> | 鞋子
<$CHARM> | 宝石
<$HAT> | 斗笠
<$DRUM> | 军鼓
<$HORSE> | 马牌
<$SHIELD> | 盾牌
<$SDRESS> | 时装衣服
<$SWEAPON> | 时装武器
<$SUCKDAMAGE> | 伤害吸收值 脚本命令USEBONUSPOINT增加的，该值保存人物数据库里，下线不消失
<$SUCKDAMAGEPOINT> | 伤害吸收值 脚本命令SETSUCKDAMAGE增加的，下线消失
<$G_DRESS> | 衣服 改名名称
<$G_WEAPON> | 武器 改名名称
<$G_RIGHTHAND> | 蜡烛 改名名称
<$G_HELMET> | 头盔 改名名称
<$G_NECKLACE> | 项链 改名名称
<$G_RING_R> | 右戒指 改名名称
<$G_RING_L> | 左戒指 改名名称
<$G_ARMRING_R> | 右手镯 改名名称
<$G_ARMRING_L> | 左手镯 改名名称
<$G_BUJUK> | 护身符 改名名称
<$G_BELT> | 腰带 改名名称
<$G_BOOTS> | 鞋子 改名名称
<$G_CHARM> | 宝石 改名名称
<$G_HAT> | 斗笠 改名名称
<$G_DRUM> | 军鼓 改名名称
<$G_HORSE> | 马牌 改名名称
<$G_SHIELD> | 盾牌 改名名称
<$G_SDRESS> | 时装衣服 改名名称
<$G_SWEAPON> | 时装武器 改名名称
<$CASTLENAME> | 沙城名称
<$GAMEDIAMOND> | 金刚石
<$GAMEGIRD> | 灵符
<$MAP> | 当前地图代码
<$RELEVEL> | 显示转生等级
<$STATSERVERTIME> | 显示M2启动时间
<$RUNDATETIME> | 开区间隔时间
<$KILLER> | 杀人者变量
<$RANDOMNO> | 随机值变量
<$X> | 人物X坐标
<$Y> | 人物Y坐标
<$USERALLNAME> | 人物完整名称
<$GAMEGLORY> | 人物荣誉值
<$MapTitle> | 取地图名称
<$GetExp> | 人物当前获得经验变量
<$CASTLEGAMEGOLD> | 显示沙城税收的元宝值
<$USERID> | 人物登录帐号
<$KILLMONNAME> | 人物杀死的怪物名称
<$KILLMONX> <$KILLMONY> | 人物杀死怪物的坐标
<$HIT> | 准确
<$SPD> | 敏捷
<$HITSPD> | 攻速
<$YEAR> | 当前年份
<$MONTH> | 当前月份
<$DAY> | 当前日期
<$HOUR> | 当前小时
<$MINUTE> | 当前分钟
<$SECOND> | 当前秒
<$TEAM0>..<$TEAMX> | 用于显示组队成员,<$TEAM0>代表队长,成员从<$TEAM1>开始
<$STNAME> | 师徒名称变量
<$KILLMONEXPRATE> | 杀怪经验倍数
<$KILLMONEXPRATETIME> | 杀怪经验倍数时长
<$GAMEGOLDEX> | 新游戏点数
<$REVIVALTIME> | 复活间隔变量
<$POWERRATE> | 复当前攻击力倍数
<$POWERRATETIME> | 当前攻击力倍数剩余时间
<$GROUPMEMBERCOUNT> | 当前组队人数
<$X> | 人物当前坐标X
<$Y> | 人物当前坐标Y
<$VALUE1>..<$VALUE11> | 人物元素的属性值的常量共11个。1到11
<$SCREENWIDTH> | 分辨率 宽
<$SCREENHEIGHT> | 分辨率 高
<$PASSWORD> | 注册账号时用户输入的密码
<$BIRTHDAT> | 注册账号时用户输入的生日
<$QUIZ1> | 注册账号时用户输入的问题1
<$ANSWER1> | 注册账号时用户输入的答案1
<$QUIZ2> | 注册账号时用户输入的问题2
<$ANSWER2> | 注册账号时用户输入的答案2
<$EMAIL> | 注册账号时用户输入的邮箱
<$PHONE> | 注册账号时用户输入的电话
<$MOBILEPHONE> | 注册账号时用户输入的手机
<$ACCOUNTUSERNAME> | 注册账号时用户输入的用户名
<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的
<$CURRHERONAME> | 当前召唤出来的英雄名称，如果没有召唤英雄，该值为空
<$HERONAME> | 英雄名称。如果没有创建过英雄，该值为空
<$DEPUTYHERONAME> | 副将英雄名称。如果没有创建过副将英雄，该值为空
<$PKPOWER> | 人物当前攻击威力
<$KILLMONNAME_MAXHP> | 当前杀死的怪物的最大血量

英雄信息

变量名称 | 说明
<$H.USERNAME> | 人物名称
<$H.LEVEL> | 等级
<$H.HP> | 生命值
<$H.AC> | 防御力
<$H.MAXAC> | 最高防御力
<$H.MAC> | 魔法防御力
<$H.MAXMAC> | 最高魔法防御力
<$H.DC> | 物理攻击力
<$H.MAXDC> | 最高物理攻击力
<$H.MC> | 魔法力
<$H.MAXMC> | 最高魔法力
<$H.SC> | 道术
<$H.MAXSC> | 最高道术
<$H.EXP> | 当前经验值
<$H.MAXEXP> | 升级经验值
<$H.MAXHP> | HP上限
<$H.MAXMP> | MP上限
<$H.DIR> | 方向
<$H.PKPOINT> | PK点数
<$H.HW> | 腕力
<$H.MAXHW> | 最高腕力
<$H.BW> | 背包重量
<$H.MAXBW> | 最高背包重量
<$H.WW> | 负重力
<$H.MAXWW> | 最高负重
<$H.HUNGER> | 饥饿程度
<$H.SUCKDAMAGE> | 伤害吸收值 脚本命令H.USEBONUSPOINT增加的，该值保存英雄数据库里，下线不消失
<$H.SUCKDAMAGEPOINT> | 伤害吸收值 脚本命令H.SETSUCKDAMAGE或SETHEROSUCKDAMAGE增加的，下线消失
<$H.DRESS> | 衣服 英雄
<$H.WEAPON> | 武器 英雄
<$H.RIGHTHAND> | 蜡烛 英雄
<$H.HELMET> | 头盔 英雄
<$H.NECKLACE> | 项链 英雄
<$H.RING_R> | 右戒指 英雄
<$H.RING_L> | 左戒指 英雄
<$H.ARMRING_R> | 右手镯 英雄
<$H.ARMRING_L> | 左手镯 英雄
<$H.BUJUK> | 护身符 英雄
<$H.BELT> | 腰带 英雄
<$H.BOOTS> | 鞋子 英雄
<$H.CHARM> | 宝石 英雄
<$H.HAT> | 斗笠 英雄
<$H.DRUM> | 军鼓 英雄
<$H.HORSE> | 马牌 英雄
<$H.SHIELD> | 盾牌 英雄
<$H.SDRESS> | 时装衣服 英雄
<$H.SWEAPON> | 时装武器 英雄
<$H.G_DRESS> | 衣服 改名名称 英雄
<$H.G_WEAPON> | 武器 改名名称 英雄
<$H.G_RIGHTHAND> | 蜡烛 改名名称 英雄
<$H.G_HELMET> | 头盔 改名名称 英雄
<$H.G_NECKLACE> | 项链 改名名称 英雄
<$H.G_RING_R> | 右戒指 改名名称 英雄
<$H.G_RING_L> | 左戒指 改名名称 英雄
<$H.G_ARMRING_R> | 右手镯 改名名称 英雄
<$H.G_ARMRING_L> | 左手镯 改名名称 英雄
<$H.G_BUJUK> | 护身符 改名名称 英雄
<$H.G_BELT> | 腰带 改名名称 英雄
<$H.G_BOOTS> | 鞋子 改名名称 英雄
<$H.G_CHARM> | 宝石 改名名称 英雄
<$H.G_HAT> | 斗笠 改名名称 英雄
<$H.G_DRUM> | 军鼓 改名名称 英雄
<$H.G_HORSE> | 马牌 改名名称 英雄
<$H.G_SHIELD> | 盾牌 改名名称 英雄
<$H.G_SDRESS> | 时装衣服 改名名称 英雄
<$H.G_SWEAPON> | 时装武器 改名名称 英雄
<$H.MAP> | 当前地图代码
<$H.RELEVEL> | 显示转生等级
<$H.X> | 人物X坐标
<$H.Y> | 人物Y坐标
<$H.USERALLNAME> | 人物完整名称
<$H.MapTitle> | 取地图名称
<$HeroGetExp> | 英雄当前获得经验变量
<$H.HIT> | 准确
<$H.SPD> | 敏捷
<$H.HITSPD> | 攻速
<$HEROGENDER> | 英雄性别
<$HEROJOB> | 英雄职业
<$HEROLEVEL> | 英雄级别
<$HERONAME> | 英雄名字
<$HMapTitle> | 英雄地图名字
<$HMAP> | 英雄地图编号
<$HX> | 英雄前坐标X
<$HY> | 英雄前坐标Y
<$H.PKPOWER> | 英雄当前攻击威力

天地结晶变量

变量名称 | 说明
<$GETCRYSTALEXP> | 天地结晶可提取的经验
<$GETCRYSTALNGEXP> | 天地结晶可提取的内功经验
<$CRYSTALEXP> | 天地结晶当前的经验
<$CRYSTALNGEXP> | 天地结晶当前的内功经验
<$CRYSTALLEVEL> | 天地结晶等级

人物内力变量

变量名称 | 说明
<$NH> | 内力
<$MAXNH> | 内力上限
<$NGEXP> | 内功经验
<$NGMAXEXP> | 内功升级经验
<$NGLEVEL> | 内功等级

英雄内力变量

变量名称 | 说明
<$H.NH> | 英雄内力
<$H.MAXNH> | 英雄内力上限
<$H.NGEXP> | 英雄内功经验
<$H.NGMAXEXP> | 英雄内功升级经验
<$H.NGLEVEL> | 英雄内功等级
 | 所有英雄的变量都是在人物的变量 前面加“H.” 例如：<$H.MAXHP> <$H.MAXMP>
<$H.VALUE1>..<$H.VALUE11> | 英雄元素的属性值的常量共11个。1到11

连击变量

变量名称 | 说明
<$NGLEVEL> | 内功等级
<$HEROPULSEXP> | 英雄经络经验
<$GETNGEXP> | 当前得到的内功经验
<$HEROGETNGEXP> | 英雄当前得到的内功经验

国家变量

变量名称 | 说明
<$NATIONNAME> | 国家名称
<$NATIONPEOPLE> | 国家人数

服务器信息

变量名称 | 说 明
<$SERVERNAME> | 服务器名字
<$SERVERIP> | 服务器IP地址
<$WEBSITE> | 游戏网址
<$BBSSITE> | 论坛网址
<$CLIENTDOWNLOAD> | 客户端程序下载地址
<$QQ> | 联系QQ号
<$PHONE> | 联系电话号码
<$BANKACCOUNT0> | 银行帐号信息
<$BANKACCOUNT1> | 银行帐号信息
<$BANKACCOUNT2> | 银行帐号信息
<$BANKACCOUNT3> | 银行帐号信息
<$BANKACCOUNT4> | 银行帐号信息
<$BANKACCOUNT5> | 银行帐号信息
<$BANKACCOUNT6> | 银行帐号信息
<$BANKACCOUNT7> | 银行帐号信息
<$BANKACCOUNT8> | 银行帐号信息
<$BANKACCOUNT9> | 银行帐号信息
<$GAMEGOLDNAME> | 游戏币名称
<$USERCOUNT> | 在线人数
<$DATETIME> | 当前日期时间
<$GAMEGOLDNAME> | 游戏币名称
<$HIGHLEVELINFO> | 最高等人物信息
<$HIGHPKINFO> | 最高PK点数人物信息
<$HIGHDCINFO> | 最高攻击力人物信息
<$HIGHMCINFO> | 最高魔法力人物信息
<$HIGHSCINFO> | 最高道术人物信息


设置显示名称格式

一、显示名称设置方法

1、相关配置

配置文件：String.ini

以下为相关配置内容：

CastleGuildName=%guildname[%castlename(%rankname)]
NoCastleGuildName=%guildname(%rankname)
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*
ManDearName=%s的老公
WoManDearName=%s的老婆
MasterName=%s的师父
NoMasterName=%s的徒弟
HumanShowName=%chrname\%guildname\%dearname\%mastername

CastleGuildName 沙城成员显示行会格式
NoCastleGuildName 普通已加入行会人员显示行会格式

%guildname 行会名称
%castlename 城堡名称
%rankname 职位名称

WarrReNewName 武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 道士转生后名称显示

%chrname 人物名称

ManDearName 结婚后男的显示名称
WoManDearName 结婚后女的显示名称

MasterName 师父显示名称
NoMasterName 徒弟显示名称

HumanShowName 显示完整名称格式

游戏中显示出来的名称是根据以上格式组合出来的，大家可以根据自己的要求，自行调行组合及格式。


物品绑定人物[!]

功能：
物品绑定人物

绑定类型:
帐号，角色名，IP

命令格式:
@BindUseItem 人物名称 物品类型 绑定类型
例：@BindUseItem 人物名称 武器 帐号
此时将指定的人物及其身上的武器绑定在该人的帐号上
========================================================

物品类型:
衣服，武器，照明物，项链，头盔，左手镯，右手镯，左戒指，右戒指，物品
腰带，鞋子，宝石

BindUseItem
显示绑定物品到人物信息

ShowUseItemInfo
显示人物身上带装备信息


物品位置[!]

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器
;==========================================


新增GM命令[!]

新增部分游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

传送相关命令
@recall | 将人物召唤到自己身边
@Regoto | 传送到对方身边
@Ting | 将对方随机传送
@SuperTing | 将指定范围内人物随机传送
@Mapmove | 将指定地图所有人物传送到指定地图
@Move | 移动到指定地图
@PositionMove | 移动到指定地图座标
人物控制相关命令
@GameMaster | 进入/退出管理员模式
@Observer | 进入/退出隐身模式
@Superman | 进入/退出无敌模式
@Level | 调整自己的等级
@Kick | 将指定的人物踢下线
@Kill | 将指定的人物杀死
@Realive | 将死亡的人物复活
@Setpermission | 设置人物的游戏权限，可将普通人物提升为GM
@Info | 显示人物详细信息
@MobLevel | 显示身边所有怪物或人物信息
@FreePK | 清除指定人物的PK点
@PKpoint | 显示指定人物的PK点
@IncPkPoint | 增加指定人物的PK点
@AdjustLevel | 调整他人级别
@AdjustExp | 调整他人经验
怪物控制相关命令
@Mob | 在身边放置一个指定的怪物
@RecallMob | 召唤一个怪物为宝宝
@Mission | 设置怪物集中点(用于开展怪物攻城)
@MobPlace | 放置怪物，怪物向集中点集中，大刀守卫不攻击怪物(用于开展怪物攻城)
聊天信息相关命令
@DisableSendMsg | 将指定人物加入禁言列表，人物发信息只能自己看到别人看不到
@EnableSendMsg | 将指定人物从禁言列表中删除
@DisableSendMsgList | 显示禁言列表中的人物名称
@ViewWhisper | 查看指定人物的私聊信息
@MobNpc | 制造一个NPC（可不用重启M2做增加NPC制作脚本）；
@DelNpc | 删除NPC
重新加载设置相关命令
@ReloadAdmin | 重新加载管理员列表
@ReloadNpc | 重新加载NPC脚本
@ReloadMonItems | 重新加载怪物爆物品列表
@ReloadLineNotice | 重新加载游戏公告
@ReloadManage | 重新加载登录脚本
@ReloadItemDB | 重新加载物品数据库
@ReloadMagicDB | 重新加载魔法数据库(暂时无效)
@ReloadMonsterDB | 重新加载怪物数据库
@ReloadRobotManage | 重新加载游戏登录文本
物品控制相关命令
@make | 制造指定的物品
@SuperMake | 调整给指定物品属性值
@BindUseItem | 物品绑定人物信息
@GiveMine 数量 纯度 | 给指定纯度的矿石.
仓库、登录密码相关命令
@CLEARPASSWORD | GM专用命令
人物分配点数控制相关命令
@BonusPoint | 增加人物属性点
@DelBonusPoint | 删除人物属性点(删除所有已分配及未分配的属性点)
@RestBonusPoint | 将人物属性点复位(已分配的复位到未分配的点数)
地图控制相关命令
@SetMapMode | 设置地图模式
@Map | 查看当前所在地图相关信息
游戏点、币相关命令
@GameGold | 调整人物游戏币数量
@GamePoint | 调整人物游戏点数量(泡点数量)
@CREDITPOINT | 调整人物声望点(1-255)
@DelGold | 减少人物金币
@AddGold | 增加人物金币
其他相关命令
@Showflag | 显示标识
@showopen | 显示打开
@showunit | 显示单位
@setflag | 设置标识
@setopen | 设置打开
@setunit | 设置单位
@Reconnection | 更换网关的命令
行会相关命令
@AddGuild | 添加一个行会
@DelGuild | 删除一个行会
@SabukWallGold | 更改沙城所属性行会
@ForcedWallconquest | 强行开始或结果攻城战
@SabukWallGold | 查看沙城金币数


用户游戏命令详解

用户游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

相关命令
@Date | 显示当前服务器上的日期时间
@禁止私聊 |
@禁止群聊 |
@禁止交易 |
@加入行会 |
@退出行会 |
@禁止行会聊天 |
@允许行会联盟 |
@联盟 |
@取消联盟 |
@允许天地合一 |
@天地合一 |
@仓库解锁 |
@仓库开锁 |
@设置仓库密码 |
@修改仓库密码 |
@Rest |
@传送 | 传送物品移动命令
@Dear | 夫妻查询位置
@Master | 师徒查询位置
@DearRecall | 夫妻传送
@MasterRecall | 师徒传送
@AllowDearRecall | 允许夫妻传送
@AllowMasterRecall | 允许师徒传送
@GuildRecall | 行会合一
@AllowGuildRecall | @允许天地合一
@AttackMode | 调整攻击模式
仓库、登录密码相关命令
@SetPassword | 设置仓库密码
@Chgpassword | 修改仓库密码
@UnLock | 打开密码锁
@UnLockStorage | 仓库解锁
@Lock | 仓库加锁


GOTOLABEL触发[!]

GOTOLABEL 模式(0,1,2,3) 触发字段 范围(模式等于3时有效)

模式=0 小组成员触发
模式=1 行会成员触发
模式=2 当前地图的人物触发
模式=3 以自己坐标为中心指定范围人物触发

[@main]
#IF
#ACT
GOTOLABEL 0 @小组成员触发
GOTOLABEL 1 @行会成员触发
GOTOLABEL 2 @当前地图的人物触发
GOTOLABEL 3 @指定范围人物触发 12

--------------------------------------------------------------------------------------------------

GOTOLABELEX 模式(0组队,1行会) X Y 范围 在什么脚本里触发(0=QF脚本,1=当前NPC脚本) 触发字段

[@main]
#IF
#ACT
GOTOLABELEX 0 <$X> <$Y> 10 0 @aaa


M2启动后触发

QManage.txt中增加一个新的脚本段[@Startup],此脚本段只在M2启动后执行一次.


爆物品触发

功能: 杀死怪物或人物时爆物品触发
说明: 需要在M2-查看-列表信息二-物品规则里添加允许爆物品触发

[@ScatterBagItems]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你杀人了:【<$CURRRTARGETNAME>】，这个人包裹里爆出物品【<$CURRTEMNAME>】
#ELSEACT
SENDMSG 6 你杀怪了:【<$CURRRTARGETNAME>】，这个怪物爆出物品【<$CURRTEMNAME>】

#IF
#ACT
LINKPICKUPITEM
;支持用命令链接命令，用脚本命令对当前爆出的物品操作或检测

<$CURRTEMNAME> | 当前物品名称 指人物掉落、捡取、杀死怪物爆出来
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落、捡取、杀死怪物爆出来


初始化行会触发

只能用于行会自定义变量的申请

在登陆脚本QManage.txt里触发
[@LoadGuild]
#IF
#ACT
VAR Integer GUILD QQQQ


带上物品时触发[!]

功能: 带上物品时触发 位置0-18

[@TakeOn0] 0----18

[@TakeOn]
#IF
CheckLevelEx > 0
#SAY
穿上衣服真漂亮！!


弹出验证码窗口时触发

QFunction-0

;弹出验证码窗口时触发

[@ShowGameValidateDlg]
#IF
#ACT
SENDMSG 6 开始验证
BREAK


地图事件触发

地图事件配置详解 必须在M2-选项-功能设置-基本设置-启用地图事件触发勾上才有效

Mir200\Envir\MapEvent.txt 配置

;触发标识
; 格式:
; 标识:值
;
; 标识:(-1 - 800) -1 代表不检查标识
; 值: (0 - 1)
;
;

;触发条件

; 格式:
; 代码:物品:组队;
; 代码:
; 0:无效
; 1:扔物品
; 2:捡物品
; 3:挖矿
; 4:走路(不支持物品条件)
; 5:跑步(不支持物品条件)
; 6:爆物品

; 物品:(物品名称 - *) * 代表不需要物品
; 组队:(0 - 1) 0为不需要组队，1为必须组队才触发(暂时不支持)

;触发机率
; 数字越大，机率越低
; 范围:(0 - 999999) 0 的机率为100%

;事件类型
; 格式
; 代码:内容

; 代码:(现在只支持脚本事件)
; 0:无效
; 1:调用脚本(调用QFunction-0.txt中的内容)
;注意事项
;
; 在相同地图座标，不支持相同触发标识及条件(触发条件中的物品名称除外)，如果有相同的设置，只有最后一个设置有效

;地图号 座标X 座标Y 范围 触发标识 触发条件 触发机率 事件类型
;和翎风不同的我们这里增加一个范围,如果范围的值是0 那么必须在这个坐标上才能触发，否则只要进入这个坐标的范围就会触发
;坐标为-1时不检测坐标

3 333 333 0 -1:1 1:回城卷:0 2 1:@MapEventDropItem
3 333 333 0 -1:1 2:回城卷:0 2 1:@MapEventPickUpItem
3 338 331 0 -1:1 3:*:0 2 1:@MapEventMine
3 330 330 0 -1:1 4:*:0 2 1:@MapEventWalk
3 331 335 0 -1:1 5:*:0 2 1:@MapEventRun
3 -1 -1 0 -1:0 6:*:0 0 1:@爆物品

QFunction脚本
[@爆物品]
#ACT
;这里的%s表示的爆出的物品名称 %x爆出的物品X坐标 %y爆出的物品Y坐标.
SENDMSG 0 【地图:%m】【物品:%s】【坐标(%x:%y】 255 253
;也可以这样
SENDMSG 0 【地图:%m】【物品:<$SCATTERITEMNAME>】【坐标(<$SCATTERITEMX>:<$SCATTERITEMY>】 255 253


定时触发[!]

定时触发 DelayCall 时间毫秒 触发字段


复活时触发[!]

功能: 复活时触发.
说明: QF脚本触发

[@Revival]
#IF
#ACT
SendMsg 5 你复活了继续折腾把！


个人商店和人物摆摊

该触发是引擎默认的个人商店摆摊触发，不是仿HeroM2摆摊触发。仿HeroM2摆摊相关触发完全兼容HeroM2,可以查看兼容HeroM2部分

点击开始摆摊或停止摆摊将触发 QFunction-0 [@ShopStall] 地图参数 ALLOWUSEMYSHOP 允许摆摊(必需先设置摆摊限制在指定地图才会生效)

[@ShopStall]
#IF
INSAFEZONE
;检测在安全区
#ELSEACT
MESSAGEBOX 需要在安全区才能摆摊
BREAK

#IF
CHECKSHOPSTALLSTATUS
;检测是不是在摆摊
#ACT
MESSAGEBOX 你是否确认要停止摆摊 @停止摆摊
#ELSEACT
MESSAGEBOX 你是否确认要开始摆摊 @确定开始

[@确定开始]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。
#ACT
BREAK

#if
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊

[@停止摆摊]
#if
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊

============================================================================================================

点击我的商店，如果还没有创建将触发[@QueryMyShopFail]

[@QueryMyShopFail]
#ACT
MESSAGEBOX 你还没有个人商店，是否创建你的个人商店？\\点击确定创建个人商店。 @创建个人商店 @取消

[@创建个人商店]
亲爱的玩家你好。这里可以申请开店。\
你可以把你的物品放到你的店铺里出售，\
游戏中的玩家可以查询到你要出售的物品。\
也可以把不用的物品放到店铺的仓库里。\
点击客户端中“店”就可以进入到你的店铺中,\
也可以查询其他用户的店铺和物品，\
可以很方便的把仓库物品和出售的物品相互转移。\
还可以进行摆摊操作。\

<我要开店(点击输入你喜欢的店铺名称)/@@InputString1>\

[@InputString1]
#IF
CHECKMYSHOP
#ACT
MESSAGEBOX 你已经有店铺了
BREAK

#IF
CHECKSHOPNAME <$STR(S$1)>
#ACT
MESSAGEBOX <$STR(S$1)>店铺名称已经存在，请重新选择一个
BREAK

#IF
#ACT
CREATEMYSHOP <$STR(S$1)>

[@CreateMyShopOK]
#SAY
你的店铺创建成功

[@CreateMyShopFail]
#SAY
你的店铺创建失败


攻击触发

QFunction-0

;所有触发只有攻击到怪物才会触发，有些魔法不会触发，如魔法盾
;======================魔法攻击触发==========================
[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@MagicAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

;======================物理攻击触发==========================
[@Struck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@Attack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK


拣物品触发 捡取物品触发[!]

功能: 拣物品触发 捡取物品触发

@PickUpItemX X是物品数据库中对应的IDX

[@PickUpItem0]
#IF
#SAY
某某某捡到了一个<$CURRTEMNAME>

[@PickUpItemEx]
#IF
#SAY
某某某捡到了一个<$CURRTEMNAME>

捡取物品的相关常量

<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的
<$CURRTEMMAKEINDEX> | 当前物品MakeIndex序列号


界面帮助按钮触发

功能： 界面帮助按钮触发

格式:

QFunction-0.txt
[@Help]
#SAY
Help


骑马触发

QFunction-0

[@OnHorse]
#SAT
骑马

[@OffHorse]
#SAT
下马


取下身上物品时触发[!]

功能: 取下身上物品时触发,位置0-18

[@TakeOff0] 0----18

[@TakeOff]
#IF
CheckLevelEx > 0
#SAY
不穿衣服小心感冒!


人物大退触发

[@PlayOffLine] 人物大退触发


人物当前获得经验触发

@GetExp

例如:
[@GetExp]
#if
#act
SENDMSG 5 ：人物本次获取经验为:<$GetExp>
break


人物升级触发

脚本文件位于: X:\GameOfmir\Mir200\Envir\Market_Def\QFunction-0.txt

;此脚为功能脚本，用于实现各种与脚本有关的功能

;人物升级触发
[@PlayLevelUp]
#ACT
MessageBox 升级


人物死亡时触发[!]

功能: 人物死亡时触发

[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK


人物小退触发

[@PlayReconnection] 人物小退触发


人物小退前触发

QF脚本 [@SoftClose] 人物小退前触发

[@SoftClose]
;配合禁止小退命令，可以禁止人物小退
;“DIABLESOFTCLOSE”该命令只能在[@SoftClose]下使用，其他地方无效
DIABLESOFTCLOSE


扔物品触发[!]

功能: 扔物品触发 人物死亡掉落或怪物死亡掉落的物品不触发

@DropItemX X是物品数据库中对应的IDX

[@DropItem0]
#IF
#SAY
某某某扔了一个<$CURRTEMNAME>

扔物品的相关常量

<$CURRTEMNAME> | 当前物品名称 指人物掉落、捡取、杀死怪物爆出来
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落、捡取、杀死怪物爆出来
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落、捡取、杀死怪物爆出来


杀死怪物时触发

功能: 杀死怪物时触发
说明: 对应地图参数中需要加入ONKILLMON才可生效!
[@OnKillMob]
#IF
CheckKillMonName 白野猪
#SAY
你杀死一头白野猪!


杀死人物宝宝时触发[!]

功能: 杀死人物宝宝时触发

[@KillSlave]
#IF
CheckKillSlaveName 月灵
#ACT
SendMsg 5 你把对方的月灵宝宝杀死了.


杀死人物触发

@KillPlay

;杀人触发
[@KillPlay]
#ACT
MessageBox 你杀人了


套装触发

@GroupItem

例如：

[@GroupItem0]
#IF
#ACT
SENDMSG 0 圣战套装隐藏属性被激发:攻击上限增加5点!

[@GroupItem1]
#IF
#ACT
SENDMSG 0 法神套装隐藏属性被激发:魔法上限增加5点!

[@GroupItem2]
#IF
#ACT
SENDMSG 0 天尊套装隐藏属性被激发:道术上限增加5点!

套装生效触发[@GroupItemOnX],套装失效触发[@GroupItemOffX],英雄对应[@HeroGroupItemOnX],[@HeroGroupItemOffX] X表示套装编号

套装编号在M2-查看-列表信息二-套装系统-套装编号


外挂触发[!]

QFunction-0脚本里[@UsePlugin]字段

[@UsePlugin]
#ACT
ChangeModeEx 10 10
SENDMSG 6 使用外挂，锁定10秒


物品触发脚本功能

功能：
双击物品可以自动触发指定脚本功能；

使用方法：
1、物品数据库设置1：STDMODE字段设置为：31
2、物品数据库设置2：AniCount字段设置为：X
X为指字数字触发脚本（1-999）
3、\Mir200\Envir\market_def\QFunction-0.txt下设置
[@StdModeFuncX]
#IF
#ACT
sendmsg 7 触发成功！！！
===================================
注：其中X为物品数据库设置2中的X


占领沙巴克触发

功能: 占领沙巴克触发

QFunction-0

[@GetCastleX] X表示城堡编号

[@GetCastle0]
#IF
#SAY
沙巴克已经被占领


装备持久消失时触发

功能: 装备持久消失时触发,位置0-18

[@ItemDamage1]
#IF
#ACT
SendMsg 5 你的武器已经损坏.


装备升级触发[!]

执行脚本功能.升级成功时执行@UpgradeOKX,升级失败时执行@UpgradeFailX,
属性被清除时执行@UpgradeClearX,其中X代表装备位置,例如:衣服=0,武器=1


走路和跑步触发

QFunction-0

[@Run]
#SAT
你在跑步

[@Walk]
#SAT
你在走路


组队时触发

功能: 创建小组时触发.
说明: 队员的名字放在队长S0变量中.
[@GroupCreate]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了组队.
<$STR(S$0)>.SendMsg 5 你加入了组队.

;在组队前触发
[@StartGroup]
#IF
CheckLevelEx < 25
#ACT
CreateGroupFail
SendMsg 5 25级之后才可以组队.

功能: 离开队伍时触发.
说明: 被删除的队员名字放在队长的S0变量中.
[@LeaveGroup]
#IF
#ACT
SendMsg 5 你退出了组队.

功能: 删除小组成员时触发.
说明: 被删除的队员名字放在队长的S0变量中.
[@GroupDelMember]
#IF
#ACT
<$STR(S0)>.SendMsg 5 你被队长踢出了组队!

功能: 添加小组成员时触发.
说明: 队员名字放在队长的S0变量中.
[@GroupAddMember]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了队伍.
<$STR(S$0)>.SendMsg 5 你加入了队伍.

功能: 组队杀死怪物时触发.
[@GroupKillMon]
#IF
#ACT
SendMsg 5 组队杀怪.


创建副将英雄脚本

;@@BuHero 是创建和删除副将英雄的标志

;以下是酒馆_辰星的脚本

(@@BuHero @PlayDrink )
[@main]
魔法不单是华丽的攻击，更需要在战斗中感受它的使用技巧。现\
在是时间让年轻的卧龙英雄们去体会战斗中的艰辛了。如果能在修\
行中遇到值追随一生的伙伴，对他们来说也许就更有意义！\ \
<召唤卧龙英雄/@召唤卧龙英雄>\
<寄存领回英雄/@寄领英雄> \
<主将副将英雄培养/@主副英雄培养> \
<我不想再带领卧龙英雄/@不带英雄>\

[@召唤卧龙英雄]
<我想找卧龙英雄做为我的历练伙伴/@领取卧龙英雄>\ \
<返回/@main>

[@寄领英雄]
<我想找您帮个忙，我想寄放英雄/@寄放英雄>\
<我想领回英雄/@领回英雄> \ \
<返回/@main>

[@主副英雄培养]
#if
CheckHeroAutoPractice
#say
看来你的副将英雄正在进行自我修炼....\ \
<我要停止副将英雄的自我修炼/@停止自我修炼>\ \
<查看副将英雄修炼时间/@查看修炼时间>
#elsesay
随着我们多年以来对英雄的训练，我们发现了一种新的培养方式和\
战斗方式。新的培养方式能够让同一英雄以三职业不同状态出战。\
新的战斗方式能够让你在战斗中召唤第二个英雄替换英雄进行战斗，\
从而对战局产生变化。\
当然，要想实现这一切的前提是必须对你的卧龙英雄和白日门英雄\
进行评定，选出主将和副将，才能够进行新的培养方式。\
<主将副将英雄评定/@主副将评定> <副将英雄自我修炼/@自我修炼> <英雄的历史/@英雄历史>\
<主将副将英雄指南/@英雄指南>\
<返回/@main>

[@停止自我修炼]
#if
#ACT
StopHeroAutoPractice
Close

[@StopHeroAuto]
#if
#ACT
give 金创药 1
Close

[@查看修炼时间]
你的副将英雄本次的修炼时间为:<$HEROAUTOTIME>秒\
<返回/@主副英雄培养>

[@主副将评定]
#if
#act
ASSESSMENTHERO

[@自我修炼]
#if
CheckDeputyHero
;检测当前在线的是卧龙英雄
#say
请注意：副将英雄的等级上限为主将英雄当前等级减三，副将\
英雄的内功等级上限为主将英雄当前内功等级减三。一旦副将\
英雄的等级或内功等级达到上限，自动修炼将不能获得相应的\
经验或内功经验。\
当且仅当副将英雄自动修炼满2小时，且在酒馆英雄NPC处终止\
训练时，将有几率带回训练过程中拾取的物品。\ \
<副将英雄自动修炼/@自动修炼>
#elsesay
请先召唤出你的副将英雄吧......\

[@自动修炼]
#if
#ACT
OpenHeroAutoPractice
Close

[@领回英雄]
<$USERNAME>,想和你的英雄一起闯荡玛珐大陆吗？\ \
<是的，我是来接他走的/@GetHero>\ \
<不了，还要托你照顾一段时间/@exit>\

[@GetHero]
#if
#act
GetHero

[~PlayDrink_Already]
#if
#act
#Say
嗯......真是香醇的美酒,令我心情舒畅。\<寄放英雄/@SaveHero>

[~PlayDrink_Already_NotHero]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\

[~PlayDrink_Already_HeroBegin]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>

[@领取卧龙英雄]
#if
HAVHERO TRUE
#say
你已经有卧龙英雄了,还想再领取?\
#elsesay
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
   \
<没有问题，我这里有上好的美酒/@请喝酒>\
   \
<我不会喝酒……/@exit>\

[@请喝酒]
#if
HAVHERO
#say
你精力有限,只能带领一位英雄在玛法大陆历练。\
如果你想再带领一位英雄,可以先将身边的英雄安顿在我们这里\
#elsesay
好！好！快拿酒来，让小二倒进六个坛中。\
每个坛里的酒有多有少，喝多喝少就看运气。\
我们就来拿这六坛酒来斗一斗！\ \
<好的，来吧/@斗酒规则>\

[@斗酒规则]
#if
#act
Mov M0 1
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了,摆酒吧/@PlayDrink>\

[@PlayDrink]
请把酒放上去

[~PlayDrink_Game]
#if
#act
OPENPLAYDRINK 2 晨星 DRINK
PLAYDRINKMSG 1 <$USERNAME>，酒之道也可以算作我修行的一部\分，让我看看你的表现吧。
PLAYDRINKMSG 2 嘿嘿……我可不会比你先醉倒，保管陪\你喝爽了！

[~PlayDrink_Self_Loss]
#if
#act
PLAYDRINKMSG 1 这点酒量，我怎么放心让我的弟子\跟随你啊！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>

[~PlayDrink_SelfToNpc]
#if
#act
PLAYDRINKMSG 1 好！
PLAYDRINKMSG 2 就这坛了！请前辈来喝!

[~PlayDrink_SelfToSelf]
#if
#act
PLAYDRINKMSG 1 ……
PLAYDRINKMSG 2 就这坛了！我自己喝！

[~PlayDrink_NpcToSelf]
#if
#act
PLAYDRINKMSG 1 就这坛了！你来喝吧！
PLAYDRINKMSG 2 谢谢前辈！

[~PlayDrink_NpcToNpc]
#if
#act
PLAYDRINKMSG 1 就这坛了！我来喝！
PLAYDRINKMSG 2 前辈尽管喝！

[~PlayDrink_Dogfall]
#if
#act
PLAYDRINKMSG 1 那再来一局吧。
PLAYDRINKMSG 2 来就来！

[~PlayDrink_NpcWil]
#if
#act
PLAYDRINKMSG 1 嗯，不错，那我选了。
PLAYDRINKMSG 2 真倒霉，我就不信赢不了你。

[~PlayDrink_PlayWil]
#if
#act
PLAYDRINKMSG 1 <$USERNAME>，你选吧。
PLAYDRINKMSG 2 哈哈哈，还是我厉害吧~\选哪一坛好呢？

[~PlayDrink_Self_Drunk]
#if
#act
PLAYDRINKMSG 1 看你这么努力，英雄我就交给你了\！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>

[~PlayDrink_Npc_Drunk]
#if
#act
PLAYDRINKMSG 1 呃,看来令天我是有点喝多了……！
PLAYDRINKMSG 2 啊……前辈,您别醉呀……\<招幕英雄/@CrHero>

[@CloseDrink]
#if
#act
CLOSEDRINK

[~PlayDrink_Npc_Loss]
#if
equal M0 1
#act
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<招幕英雄/@CrHero>!
#elseact
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<删除英雄/@DelMyHero>!

[@CrHero]
#if
#act
CLOSEDRINK
#say
恩……好酒啊，既然你请我喝酒了。\
请先给您的卧龙英雄取个名字吧。\
<英雄起名/@@buHero>\

[@@buHero]
你要带一个男法师还是法师士卧龙英雄呢？\
<卧龙男法师英雄/@CREATEHERO_TAOS_MAN>\
<卧龙女法师英雄/@CREATEHERO_TAOS_WOM>\
\

[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 1 0 TRUE
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 1 1 TRUE
//返回消息

[@HAVHERO]
您已经有英雄了。\ \
<噢，也许是我记错了/@exit>

[@SetHeroName]
请先给您的卧龙英雄取个名字吧。\ \
<关闭/@exit>

[@寄放英雄]
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
   \
<没有问题，我这里有上好的美酒/@Drink>\
   \
<我不会喝酒……/@exit>\

[@Drink]
#if
#act
OPENPLAYDRINK 2 辰星
PLAYDRINKMSG 1 酒意需要品味，生命的动人之处常会在不经意\之间显现。我们在小酌中慢慢体会\吧。
PLAYDRINKMSG 2 小提示：请将包裹栏中的酒放至酒碟上。

[~PlayDrink_Ok]
#if
#act
PLAYDRINKMSG 1 天道自然，在自然之中追寻平衡本百易事，但\这酒令我有了一些顿悟。\<寄放英雄/@SaveHero>

[@SaveHero]
#if
#act
SAVEHERO

[@NoSaveHero2]
还是不要寄放了吧，让你的主将英雄同你一起战斗吧......

[@NoSaveHero3]
还是不要寄放了吧，让你的副将英雄同你一起战斗吧......

[~PlayDrink_HeroOk]
#if
#act
CLOSEDRINK

[~PlayDrink_NotHero]
#if
#act
CLOSEDRINK
PLAYDRINKMSG 1 你没喝多吧？你身边空无一人，还说要把英雄\托付我？\

[~PlayDrink_HeroBegin]
#if
#act
PLAYDRINKMSG 1 你你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>

[@不带英雄]
你想把你的伙伴送回卧龙山庄？\
你要知道，修行结束回到卧龙山庄的子弟,\
不可能再次像现在这样随你一同探索玛法大陆了。\
你真的想这样么？你要是决定了，我们就来斗上一盘酒!\
待我喝好了，我就帮你的伙伴送回山庄。\
<是的，拜托你了/@是的> \
   \
<我还想与我的伙伴一起继续战斗/@exit>\

[@是的]
好！好！快拿酒来，让小二倒进六个酒坛中。\
没个酒坛中的酒有多有少，喝多喝少就看运气了。\
我们就拿这六个酒坛中的酒来斗一斗！\ \
<好的，来吧/@DJSM>\

[@DJSM]
#if
#act
Mov M0 2
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了/@PlayDrink>\

[@DelMyHero]
#ACT
DELETEHERO
[@NotHAVHERO]
你没有英雄。\ \
<噢，也许是我记错了/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！在来找我吧！\
     \
<好的/@exit>
[@NotDelHero]
评定主副将英雄后，不能进行删除英雄！\
     \
<好的/@exit>

[@DeleteHeroOK]
既然你请我喝酒了，那我就答应你的要求。\
我会尽快把你的英雄送回山庄的\\
<那谢谢你了/@exit>

[@英雄历史]
玛法大陆上有两个重要的势力，白日门和卧龙山庄。\
在这两个地方，勇士们都能够召唤到英雄来协助自已。\
每一个势力最多只能领取一个英雄。一直以来，勇士们只能率领一\
名英雄征战玛法。另一名的英雄被寄存在酒馆外的翔天等人处。\
勇士们通过苍月岛仓库里的神秘人找到英雄地的长老，在他那里召\
唤<白日门英雄/fcolor=249>，通过酒馆外的翔天等人处召唤<卧龙英雄/fcolor=249>。\
现在，当你同时拥有两个英雄后，可以在酒馆外的翔天等人接受\
<新的英雄培养/fcolor=249>。新英雄时代即将来临！\
<返回/@主副英雄培养>

[@英雄指南]
《主将副将英雄指南》\ \
1、<如何将卧龙英雄、白日门英雄评定为主将英雄、副将英雄？/@如何评定>\
2、<主将、副将英雄有何特色？/@有何特色>\
3、<副将英雄的操作与训练。/@如何操作>\
4、<什么时候是复仇模式?/@复仇模式>\ \
<返回/@主副英雄培养>

[@如何评定]
必须首先拥有白日门英雄和卧龙英雄，才能够对其进行评定，成为\
主将英雄和副将英雄。白日门英雄可以通过苍月岛的仓库内神秘人获\
得。卧龙英雄，可以通过酒馆外的翔天等人处召唤。拥有两名英雄名，\
将其寄放在酒馆外的翔天等人处，即可使其参与英雄评定，\
从而决定主将英雄和副将英雄的人选。\
<请注意：一旦评定成功，将不可更改，且英雄无法删除！/fcolor=249>\ \
<我知道了/@英雄指南>

[@有何特色]
一旦成功评定主将英雄和副将英雄，两个英雄将可轮流召唤出战。\
主将英雄的实力决定了副将英雄成长的空间。只有当主将英雄的等级、\
内功等级比副将英雄高3级，副将英雄才能分别获得经验、内功经验。\
副将英雄可以战、法、道的不同形态出战。主将英雄累积的经验、\
内功经验等，在召唤出副将英雄时，能够直接向副将英雄传功。\ \
<我知道了/@英雄指南>

[@如何操作]
在英雄包裹按键右侧新增副将英雄的召唤按钮，也可在F12辅助\
工具中，设置召唤的快捷键。成功评定出主将英雄和副将英雄后，\
必须在酒馆外的翔天等人处参与副将英雄的初次训练后，\
才能开始副将英雄的自我修炼。初次训练过程中获得的经验奖励\
与副将英雄的等级相关，等级越高，获得的经验奖励越多。\
副将英雄的自我修炼可根据不同的修炼地图和强度，选择适合的\
修炼方式 。小退或下线将不计入修炼时间。\ \
<我知道了/@英雄指南>

[@复仇模式]
当主将英雄死亡时，开始1分钟复仇倒计时。在倒计时时间内，\
成功召唤出副将英雄，则副将英雄进入到复仇状态，\
其基础属性将获得大幅提升，提升效果持续3分钟。\ \
<我知道了/@英雄指南>


创建主将英雄脚本

;@@CreateHero 是创建和删除主将英雄的标志

(@@CreateHero)

[@main]
创建英雄：<英雄取名/@@CreateHero>\ \
删除英雄：<删除英雄/@DelMyHero>\ \
<退出/@exit>

[@CreateHero]
//CREATEHERO 职业 性别 请创建英雄：\ \

<男战士/@CREATEHERO_WARR_MAN> <女战士/@CREATEHERO_WARR_WOM>\
<男法师/@CREATEHERO_WIZA_MAN> <女法师/@CREATEHERO_WIZA_WOM>\
<男道士/@CREATEHERO_TAOS_MAN> <女道士/@CREATEHERO_TAOS_WOM>\ \

<关闭/@exit>

[@CREATEHERO_WARR_MAN]
#ACT
CREATEHERO 0 0
[@CREATEHERO_WARR_WOM]
#ACT
CREATEHERO 0 1
[@CREATEHERO_WIZA_MAN]
#ACT
CREATEHERO 1 0
[@CREATEHERO_WIZA_WOM]
#ACT
CREATEHERO 1 1
[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 2 0
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 2 1

//返回消息
[@CreateingHero]
系统正在接受申请，请稍候……\ \
<关闭/@exit>

[@HaveHero]
您已经有英雄了。\ \
<关闭/@exit>

[@HeroNameFilter]
英雄名字存在非法字符。\ \
<关闭/@exit>

[@SetHeroName]
请先给您的英雄取名字。\ \
<关闭/@exit>

;;--------------------删除英雄触发------------------

[@DelMyHero]
#ACT
DELETEHERO
//返回消息

[@NotHaveHero]
你没有英雄。\ \

<关闭/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！\ \

<关闭/@exit>
[@DeleteHeroOK]
删除英雄成功。\ \
<关闭/@exit>

;---------------------QF脚本触发--------------------

[@CreateHeroOK]
英雄创建成功。\ \
<关闭/@exit>

[@HeroNameExists]
英雄名称已经存在了，请重新换一个名称。\ \
<关闭/@exit>

[@HeroOverChrCount]
英雄的数量超出限制。\ \
<关闭/@exit>

[@CreateHeroFail]
英雄创建失败。\ \
<关闭/@exit>

[@CreateHeroFailEx]
英雄创建失败。\ \
<关闭/@exit>

[@HeroNameFilter]
英雄名字存在非法字符。\ \
<关闭/@exit>

;--------------------------------

[@DeleteHeroOK]
英雄删除成功。\ \
<关闭/@exit>

[@DeleteHeroFail]
英雄删除失败。\ \
<关闭/@exit>


调整英雄的PK值[!]

调整英雄PK值

#IF
CheckHeroOnline
#ACT
ChangeHeroPkPoint + 100
#SAY
你英雄的PK值增加100点.


调整英雄的忠诚度

格式: ChangeHeroLoyal 操作符(+ - =) 数值(0 -- 10000)
注意: 第二个参数+1那么英雄增加0.01点忠诚+100那么英雄增加1点忠诚

例子: 增加英雄1点忠诚
#IF
H.CHECKONLINE
#ACT
ChangeHeroLoyal + 100
SendMsg 5 您的英雄忠诚度增加[1]

功能: 检测英雄当前的忠诚度
格式: CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

例子:
#IF
H.CHECKONLINE
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


调整英雄等级[!]

调整人物英雄等级.

ChangeHeroLevel 操作符(+ - =) 级别(1-65535)

#IF
CheckHeroOnline
#ACT
ChangeHeroLevel = 50
#SAY
你的英雄50级了.


调整英雄职业[!]

格式: ChangeHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
#ACT
ChangeHeroJob 2
#SAY
你英雄现在的职业是道士.


检测英雄的PK值

#IF
CheckHeroPkPoint > 100
#SAY
英雄的PK值大于100点.


检测英雄的伤害吸收

说明: 检测英雄的伤害

格式: CheckHeroSuckDamage 操作符(> = <) 数量(1-2000000000)

#IF
CheckHeroSuckDamage > 1000
#SAY
SendMsg 5 你的英雄当前拥有的伤害吸收大于1000点.


检测英雄的忠诚度

功能: 检测英雄当前的忠诚度
格式: CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

例子:
#IF
CheckHeroOnline
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


检测英雄登录器荣誉
格式: CheckHumCreditEx 操作符(> = <) 数值(1-65535)

#IF
CheckHumCreditEx < 10
#ACT
ChangeHumCreditEx = 10


检测英雄职业.

CheckHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
CheckHeroJob 2
#SAY
你英雄的职业是道士
#ELSESAY
你的英雄没有在线.


检查是否有英雄

检查人物是否有英雄

#IF
CheckHaveHero
#SAY
你已经有英雄了.
#ELSESAY
你还没有英雄.


检查英雄等级

检查英雄当前等级.

格式: CheckHerolevel 操作符(> = <) 级别(1-65535)

#IF
CheckHerolevel = 50
#SAY
你的英雄已经50级了


清除英雄所有技能
注意:如果清除后英雄技能依然显示存在,那么请更新最新登录器.

#IF
#ACT
ClearHeroAllSkill


设置英雄伤害吸收

说明:设置英雄可吸收收到的攻击伤害.

格式: SetHeroSuckDamage 操作符(+ - =) 总吸收直(1-2000000) 吸收比例(1-1000) 成功率(1-100)
      吸收比例 1=0.1% 500=50% 1000=100%

例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%
#IF
CheckGold 10000

#ACT
SetHeroSuckDamage + 1000 200 95
Take 金币 10000

特别说明:查看SetSuckDamage


收回人物的英雄

功能: 收回人物的英雄.
格式: TakeHero

[@main]
#IF
CheckHeroOnline
#ACT
TakeHero


英雄当前获得经验触发

@HeroGetExp

例如:
[@HeroGetExp]
#if
#act
SENDMSG 5 ：英雄本次获取经验为:<$HeroGetExp>
break


英雄登录器荣誉

英雄登录器专用荣誉
格式: ChangeHumCreditEx 操作符(+ - =) 数值(1-65535)

#IF
#ACT
ChangeHumCreditEx + 10


英雄上线触发

英雄上线触发 @HeroLogin 注意这个触发是由主人执行的所以对英雄的操作请在前面加H

QManage.txt里的配置脚本

[@HeroLogin]
#if
H.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
H.DELSKILL 破魂斩
H.DELSKILL 劈星斩
H.DELSKILL 雷霆一击
H.DELSKILL 噬魂沼泽
H.DELSKILL 末日审判
H.DELSKILL 火龙气焰
H.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 恶魔长袍(男) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(男) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 恶魔长袍(女) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(女) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 战神盔甲(男) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(男) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 战神盔甲(女) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(女) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 幽灵战衣(男) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(男) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 幽灵战衣(女) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(女) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


英雄升级触发

英雄升级触发 @HeroLevelUp 这个触发也是由主人执行的所以对英雄的操作请在前面加H

例如:

[@HeroLevelUp]
#IF
#ACT
H.give 金条 2
break


NewopUI.Pak文件说明[!]

NewopUI.pak文件为登录器必备补丁，如果没有登录器无法正常启动。
可以使用我们提供的专用WIL编辑器打开编辑。该文件格式支持密码功能。
NewopUI.pak文件密码为空或者输入gameofmir

00108~00163 个人商店相关图片
00180~00193 仿HeroM2摆摊相关图片
00210~00225 黑夜白天功能相关的图片
00732~0748 配置器选择连击版，登录窗口图片

01370~01375是1024界面相关图片(配置器的 显示1024的界面 不勾选就不会使用这些图片)

血条
00170 血条背景
00171 人物血条
00172 高亮血条
00173 内功血条
00174 NPC血条
00175 怪物血条
00176 大刀、弓箭手血条

雷达
00240 自己
00241 其他人
00242 我的英雄
00243 NPC
00244 怪物
00245 大刀、弓箭手

00470~00475 是1.76和1.85登录界面

以上如果有不使用的功能，可以用编辑器把相关图片删除，减小登录器的大小。删除图片时，编辑器选择用空图片代替不是删除


NPC标签备注功能[!]

功能：
NPC标签备注功能

格式：#颜色分隔符 ^换行符

[@main]
<GOM引擎官方网站|253#GOM引擎官方网站：^254#www.gameofmir.com>\
<GOM引擎官方网站|249#GOM引擎官方网站：^250#www.gameofmir.com/@打开>\
<Img:210:3:0:0|254#GOM引擎官方网站：^253#www.gameofmir.com>\


NPC彩色字体设置[!]

功能：NPC彩色字体设置
格式：无
说明：无
例：

变量字符颜色{<$USERNAME>/FCOLOR=254}\
变量字符自动变色{<$USERNAME>/AUTOCOLOR=254,251,168,191,250,70,245,249,253}\

<字体颜色/FCOLOR=69>\
<自动变色/AUTOCOLOR=254,251,168,191,250,70,245,249,253>\

<可以触发字段颜色{FCOLOR=250}/@跳转1>\
<可以触发自动变色{AUTOCOLOR=254,251,168,191,250,70,245,249,253}/@跳转2>\


NPC对话框内创建输入框

INPUTTEXT:输入框ID:X:Y:宽度:高度:背景色:边框色:文字颜色:最小长度:最大长度:数据无效时提示对话框内容:提示文字:提示文字颜色

输入框ID: 1-40
背景色：-1为透明，0-255
边框色：-1为无边框， 0-255
最小长度，最大长度，为0表示不判断

INPUTNUM:输入框ID:X:Y:宽度:高度:背景色:边框色:文字颜色:最小值:最大值:数据无效时提示对话框内容:提示文字:提示文字颜色
输入框ID: 1-40
背景色：-1为透明，0-255
边框色：-1为无边框， 0-255
最小值，最大值：同时为0表示不限，否则最小值必须 <= 最大值

以上2个命令：“数据无效时提示对话框内容”为空时，客户端不检查数据有效性。

示范：

[@main]
姓名：<INPUTTEXT:1:0:0:80:15:0:249:255:4:10:姓名必须在4-10位长:输入姓名:160> \
年龄：<INPUTNUM:2:0:2:80:15:0:249:255:1:100:年龄必须输入1-100之间的数字:输入年龄:160> \
性别：<INPUTNUM:3:0:4:80:15:0:249:255:0:1:性别必须输入0或1:男(0)-女(1):160> \

<text:只提交姓名年龄:10:6:1,2/@提交部分>\
<Img:130:1:0:4:1,2|249#将所有输入框的内容全提交/@提交部分>\
<全部提交/@全部提交>

[@全部提交]
#act
;;;;;;★★★★★★★★★★★★★★★★★★★★★★★★★★这里别忘了对输入的数据有效性判断。。。
SendMsg 5 输入的姓名为 <$NPCINPUT(1)>
SendMsg 5 输入的年龄为 <$NPCINPUT(2)>
SendMsg 5 输入的性别为 <$NPCINPUT(3)>

[@提交部分]
#act
;;;;;;★★★★★★★★★★★★★★★★★★★★★★★★★★这里别忘了对输入的数据有效性判断。。。
SendMsg 5 输入的姓名为 <$NPCINPUT(1)>
SendMsg 5 输入的年龄为 <$NPCINPUT(2)>
SendMsg 5 输入的性别为 <$NPCINPUT(3)>

;---------------------------------------------------------------------------------------------

注： 如果留空要通过检测不想提示的请用空格。

姓名：<INPUTTEXT:1:0:0:80:15:0:249:255:0:0: : :160>\

;---------------------------------------------------------------------------------------------

INPUTTEXT
INPUTNUM 有非法字符，全是触发 @inputboxFilter

[@InputBoxFilter]
#ACT
SendMsg 5 输入了非法字符


NPC自动变色[!]

;脚本名称 地图名称 X坐标 Y坐标 NPC名称 标志 形象 是否属于沙 是否移动 移动间隔 是否允许变色 变色速度（秒）
;--------------------------------------------------------------------------------------------


包裹上面显示元宝、泡点、金刚石、灵符

增加包裹上面显示元宝、泡点、金刚石、灵符(UI默认是隐藏不显示的，需要配置登录器的时候，修改UI才能显示)
使用方法：
首先启动“GameOfMir登录器生成器.exe”双击登录器参数列表

点击编辑游戏界面UI-游戏界面

然后找到包裹的窗口，鼠标点一下包裹窗口，右边的窗口会有名称，DItemBag_，在这个下面找到
LabelBagGameGold LabelBagGamePoint LabelBagGameDiamond LabelBagGameGird
在左边的窗口基本属性里-是否可见设置成True，保存修改，保存到配置文件，重新配置登录器即可显示


补丁读取规则[!]

功能：补丁读取规则
格式：Resources目录
说明：以读取Prguse.wil为例， 先读取Resources\Data\Prguse.pak, 如果Resources\Data\Prguse.pak不存在,读取Data\Prguse.wil, 如果Data\Prguse.wil不存在,读取Data\Prguse.wzl。

例:
优先读取Resources\Data\Hum.pak 如果这个文件不存在，则读取Data\Hum.wil。
优先读取Resources\Map\0.map 如果这个文件不存在，则读取Map\0.map。
优先读取Resources\Wav\0.wav 如果这个文件不存在，则读取Wav\0.wav。

增加支持 Resources\Data\ItemDesc.Dat(物品备注) 2013-02-20更新后的备注在m2--列表二里直接修改
增加支持 Resources\Data\TZItemDesc.Dat(套装备注)
增加支持 Resources\Data\SkillDesc.Dat(技能备注)
增加支持 Resources\Data\MapDesc.Dat(外传的小地图备注)
增加支持 Resources\Data\MapDesc1.Dat(小地图备注)

增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始

改进小地图扩展mmap10.wil从10001开始

增加扩展Npc10.wil Npc代码从1000

增加支持:
武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在传奇目录的\Graphics\Weapon\
衣服放在\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil


称号系统

增加称号：

第一步：首先选择称号的图库。在M2里设置(选项-功能设置-其他控制-称号素材读取设置)，素材的排列规则可以参考盛大的ui1.wzl里面的，从690~739都是称号的图片，每个称号需要5个图片，第一个图片是外观显示的，第二三是界面显示的，第四五是称号激活显示用的

第二步：在物品数据库里增加称号

-------------------------------------------------------------------------------------------

称号功能，增加减少称号物品DB时，请注意Shape的连续性

StdMode 无要求可以随意
Name 称号的名称，该名称外观是否显示，由Reserved字段控制
Shape 称号编号，触发用的
Color 颜色 0~255
Reserved 显示DB中的名字（有部分图自带了名字，不显示DB的名字可以写上1)
Anicount 大于0时，无需设置为当前称号，属性就可以叠加到人物。等于0时，需要设置为当前称号，该称号的属性才会叠加到人物
Looks 称号图片的开始位置
DuraMax 可使用时间，单位小时
其他就等同于装备属性

玩家改变使用称号或刚上线有使用到称号，触发：QFunction的
人物：[@TitleChanged_XX]
XX代表物品DB中的Shape

玩家取消使用称号时，触发：QFunction的
人物：[@Untitled_XX]
XX代表物品DB中的Shape

比如
[@TitleChanged_1]
#IF
#ACT
伟大的【沙巴克城主】上线了

-------------------------------------------------------------------------------------------

第三步：使用脚本命令增加人物称号

称号对应NPC命令:

检测人物是否有某个称号
CHECKTITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

增加人物称号
CONFERTITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

删除人物称号
DEPRIVETITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

[@增加称号]
#IF
CHECKFENGHAOCOUNT > 29
#ACT
SENDMSG 6 已经有了所有称号
BREAK

#IF
NOT CHECKTITLE 巅峰战神 //检测没有有这个称号
#ACT
CONFERTITLE 巅峰战神 //授予称号
#ELSEACT
SENDMSG 6 已经有了该称号

[@删除称号]
#IF
CHECKTITLE 巅峰战神
#ACT
DEPRIVETITLE 巅峰战神 //删除称号
;DEPRIVETITLE ALL //删除所有称号

功能：检查玩家所有称号的数量
格式：CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-30)

称号改变属性及时刷新
称号物品DuraMax=0时，称号可以无限时间使用
赋予新称号，将标注为未使用状态，激活称号后才开始计时

-------------------------------------------------------------------------------------------

称号最多支持30个

-------------------------------------------------------------------------------------------

以下数据是按照盛大ui1.wzl里面的称号做的数据

573;称号一;70;0;20;0;0;0;690;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;251;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
574;称号二;70;0;20;0;0;0;695;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;252;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
575;称号三;70;0;20;0;0;0;700;48;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;253;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
576;称号四;70;0;20;0;0;0;705;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;251;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
577;称号五;70;0;20;0;0;0;710;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
578;称号六;70;0;20;0;0;0;715;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;249;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
579;称号七;70;;0;20;0;0;720;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;250;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
580;称号八;70;;0;20;0;0;725;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;252;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
581;称号九;70;;0;20;0;0;730;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
582;称号十;70;;0;20;0;0;735;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
583;称号十一;70;;0;20;0;0;1240;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
584;称号十二;70;;0;20;0;0;1245;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
585;称号十三;70;;0;20;0;0;1250;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
586;称号十四;70;;0;20;0;0;1255;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
587;称号十五;70;;0;20;0;0;1260;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
588;称号十六;70;;0;20;0;1;1265;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
589;称号十七;70;;0;20;0;0;1270;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
590;称号十八;70;;0;20;0;1;1275;1;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0


窗口淡入淡出显示

选项-客户端设置-勾选窗口淡入淡出显示


登录点安全区[!]

功能：登录点安全区
格式：无
说明：配置文件 D:\MirServer\Mir200\Envir\StartPoint.txt
例：

文件格式：

;地图号 | 座标X | 座标Y | 禁止说话 | 大小范围 | 光环类型 | PKZONE | PKFIRE
0 | 289 | 618 | 0 | 10 | 4 | 0 | 0
0 | 650 | 631 | 0 | 10 | 4 | 0 | 0
0 | 334 | 266 | 0 | 10 | 4 | 0 | 0
2 | 503 | 483 | 0 | 10 | 4 | 0 | 0
3 | 330 | 330 | 0 | 10 | 4 | 0 | 0

地图号：安全区所在地图
座标X：安全区所在地图座标X
座标Y：安全区所在地图座标Y
禁止说话：安全区内是否禁止说话(此功能未完成)
大小范围：安全区范围大小(此功能未完成)
光环类型：安全区边界显示类型 1是僵尸钻的洞 3是石块 4是困魔光 5是火墙 6是祖码教主裂开的石头 7,8,9三种火墙效果
PKZONE：安全区是否为PK比赛区域(此功能未完成)
PKFIRE：安全区PK区域边界显示类型(此功能未完成)


地图参数表

地图参数标志 | 说明
CHECKQUEST | 进入本地图执行任务脚本 格式：CHECKQUEST(Q001) 说明： Q001 代表脚本名。
NEEDSET_ON | 进入本地图需要人物指定标志为打开状态 格式：NEEDSET_ON(001) 说明：001 代表人物标志
NEEDSET_OFF | 进入本地图需要人物指定标志为关闭状态 格式：NEEDSET_OFF(001) 说明：001 代表人物标志
MUSIC | 进入入本地图播放音乐 格式：MUSIC(Wav\bg.mp3) 或者 MUSIC(Wav\sellect-loop2.wav)代表客户端Wav目录下的sellect-loop2.wav文件
EXPRATE | 进入本地图后杀怪经验倍数 格式：EXPRATE(100) 说明：100代表经验倍数，除以100后为实际倍数。
PKWINLEVEL | 进入本地图后可以PK升级 格式：PKWINLEVEL(1) 说明：1代表升多少级；
PKWINEXP | 进入本地图后可以PK得经验 格式：PKWINEXP(1000) 说明：1000代表得多少经验；
PKLOSTLEVEL | 进入本地图后可以PK死亡掉等级 格式：PKLOSTLEVEL(1) 说明：1代表掉多少等级；
PKLOSTEXP | 进入本地图后可以PK死亡掉经验 格式：PKLOSTEXPP(1000) 说明：1000代表掉多少经验；
DECHP | 进入本地图后自动减HP 格式：DECHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCHP | 进入本地图后自动加HP 格式：INCHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次加多少点；
DECGAMEGOLD | 进入本地图后自动减游戏币 格式：DECGAMEGOLD(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCGAMEGOLD | 进入本地图后自动加游戏币 格式：INCGAMEGOLD(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；
INCGAMEPOINT | 进入本地图后自动加游戏点 格式：INCGAMEPOINT(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；(用于游戏泡点功能)
RUNMON | 允许穿怪
RUNHUMAN | 允许穿人
NORUNMON | 禁止穿怪
NORUNHUMAN | 禁止穿人
NEEDHOLE | 进入需要洞
NORECALL | 禁止记忆召唤
NOGUILDRECALL | 禁止行会召唤
NODEARRECALL | 禁止夫妻召唤
NOMasterRECALL | 禁止师徒传送
NORANDOMMOVE | 禁止使用瞬息移动
NODRUG | 禁止吃药
MINE | 可以挖矿
NODEAL | 禁止交易
NOPOSITIONMOVE | 禁止定座标移动
NORECONNECT | 进游戏时退出本地图 格式:NORECONNECT(3) 说明：3 代表地图号盟重
QUIZ | 禁止喊话
ALLOWUSEMYSHOP | 允许摆摊，该参数只对个人商店的摆摊有效，对仿Hero摆摊的无效(必需先设置摆摊限制在指定地图才会生效)
NOALLOWUSEITEMS | 禁止使用物品 说明：NOALLOWUSEITEMS(回城卷|强效金创药)
NOTALLOWUSEMAGIC | 禁止使用技能 说明：NOTALLOWUSEMAGIC(火墙|彻地钉)
NOHEROPROTECT | 为禁止英雄守护
THUNDER | 例:THUNDER(10) 此地图有闪电效果,击中减hp为10
LAVA | 例:LAVA(10) 此地图地上冒岩浆,击中减HP为10
FLAME | FLAME(45:82:50|43:84:50)参数说明:x坐标：y坐标：伤害 可以为多坐标以|分隔
HORSE | 允许骑马
MISSION | 不允许使用任何物品和技能，并且宝宝在该地图会自动消失，不能攻击
NOMANNOMON | 智能刷怪 无效
NOCALLHERO | 禁止召唤英雄，已召唤英雄将自动消失
NIGHT | 该参数与M2内挂设置配合使用，当M2设置免蜡烛时凡是地图带NIGHT开启天气效果，M2取消免蜡烛时不带该参数的地图天启天气效果
NEEDLEVELTIME | 没到指定等级时不让进入，发送string.ini里的NeedLevelToXYErrorMsg提示可以自行修改
DECEXPRATETIME(值) | 每秒减双倍经验时间,如值小于1时，则默认为1
NGEXPRATE(数值) | 内功经验倍数(100代表经验倍数，除以100后为实际倍数)
PULSEXPRATE(数值) | 经络经验倍数(100代表经验倍数，除以100后为实际倍数)
DARK | 黑暗效果 如果同时存在 DAY以DAY参数效果为准
DAY | 白天效果 如果同时存在DARK以DAY参数效果为准
SAYLEVEL(等级) | 可限制当前地图人物说话等级.
DELDROPITEM | 人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).
REVIVAL(X:N) | 当前地图人物可复活的次数,X表示复活次数,N表示人物在当前地图已经复活次数的自动清零间隔(最小30秒).具体表示:每经过指定秒人物在当前地图复活过的次数自动减1.
NODROPUSEITEMS | 当前地图人物死亡不掉落身上的物品
NOSAFEPOSITIONMOVE | 禁止在当前地图安全区中使用传送戒指
NOALLOWUSEITEMS | 不允许使用物品NOALLOWUSEITEMS(回城卷,随机传送卷)
ONKILLMON | 杀死怪物时触发,对应地图参数中需要加入ONKILLMON才可生效!
HITMON(触发字段) | 攻击怪物触发。例:HITMON(@攻击) 攻击怪物会触发QF脚本的[@攻击]字段
FIGHT | 杀人不加PK值 死亡不掉装备
FIGHT2 | 杀人不加PK值 死亡掉装备
FIGHT3(是否掉装备) | 行会战地图 进入该地图名字颜色会变色，杀人不加PK。格式:FIGHT3(0) 死亡不掉装备 格式:FIGHT3(1) 死亡掉装备
FIGHT4 | 挑战地图 杀人不加PK 死亡不掉装备
WEATHER1 | 天气效果1 读取Effect_SE.wzl
WEATHER2 | 天气效果2 读取Effect_SE.wzl
WEATHER3 | 天气效果3 读取Effect_SE.wzl
NODROPITEMFILENAME | 禁止某个地图扔某个物品 例如：NODROPITEMFILENAME(QuestDiary\禁止扔物品列表.txt) 禁止扔物品列表.txt 这个里面就是禁止扔的物品名称
NOUSESTORAGE | 禁止某个地图使用仓库，无法寄存和取回
NOUSESNDASHOP | 禁止某个地图购买商铺物品


点击小地图自动寻路[!]

增加点击小地图自动寻路功能(可以在M2关闭或开启该功能，使用小地图按键或M键打开)

寻路QF触发
[@FindPathBegin] 开始
[@FindPathStop] 中断
[@FindPathEnd] 到达


叠加功能[!]

功能：多个物品放到一格
格式：无
说明：物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。StdMode等于 0, 2, 3, 40, 41, 42
例：

物品重叠功能，StdItem.DB 中OverLap=1或2 表示可以重叠 0不叠加。DuraMax字段表示可以叠加的数量 必须大于1.例如：DuraMax=100表示可以叠加100个
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量

收回物品 take 1 数字自己看着办喽

检测多少个 查看持久即可


顶戴花翎功能[!]

功能：顶戴花翎功能
格式：SetIcon 位置(0-9) WIL文件序号 图片序号(0-65535) X(为空时默认X=0) Y(为空时默认Y=0) 播放张数(为空时默认张数=1) 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒) 是否只有自己看见（0=所有人都可以看见 1=仅仅自己可以看见）
说明：无
例：

--------------------------------------------------------------------------

NPC顶戴花翎:
MerChant.txt中的NPC
盟重土城/流浪汉 3 346 334 流浪汉 0 3 0

流浪汉的顶戴花翎会读取 Envir\NpcIcons\盟重土城\流浪汉-3.txt

Envir\NpcIcons\盟重土城\流浪汉-3.txt 格式如下:
;WIL文件序号 图片序号(0-65535) 播放张数 X Y 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒)
;最多不超过十行
3 1 5 0 -30

--------------------------------------------------------------------------

怪物顶戴花翎:
白野猪的顶戴花翎会读取 Envir\MonIcons\白野猪.txt

Envir\MonIcons\白野猪.txt 格式如下和NPC的顶戴花翎格式是一样的:
;WIL文件序号 图片序号(0-65535) 播放张数 X Y 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒)
;最多不超过十行
3 1 5 0 -30

--------------------------------------------------------------------------
人物顶戴花翎:
[@main]
#ACT
SETICON 0 3 1 30 -30
SETICON 1 3 2 -30 -30
SETICON 2 3 3 -60 -30 3
SETICON 3 3 7

;如果要清除，WIL文件序号设置为-1即可
[@main]
SETICON 0 -1
SETICON 1 -1
SETICON 2 -1


动态创建镜像地图

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建


斗笠功能设置[!]

斗笠相关数据

功能：斗笠相关数据

StdMode = 16
Anicount 0戴上后显示头盔的内观 1戴上后不显示头盔的内观
Shape 0~7 Hair2
Shape 8~9 Hair3 目前Hair3只有2个斗笠，如果增加，Shape值依次增加就可以支持
Source 0时显示神秘人,Source=1时不显示神秘人 带斗笠后的"神秘人"效果对管理员无效.

神秘人显示可以在M2中设置-功能设置-其他设置

563;斗笠一;16;0;1;0;0;0;1188;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
564;斗笠二;16;1;1;0;0;0;1587;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
565;斗笠三;16;2;1;0;0;0;2080;6000;0;0;0;0;0;1;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
566;斗笠四;16;3;1;0;0;0;2081;6000;0;0;0;0;0;0;0;1;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
567;斗笠五;16;4;1;0;0;0;2422;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
568;斗笠六;16;5;1;0;0;0;2522;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
569;斗笠七;16;6;1;0;0;0;2768;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
570;斗笠八;16;7;1;0;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
571;斗笠九;16;8;1;0;0;0;3890;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
572;斗笠十;16;9;1;0;0;0;4266;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;

物品位置:

0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌


多级脚本使用[!]

功能：多级脚本使用
格式：无
说明：本功能的实现突破执行脚本的唯一性，使脚本的使用更加灵活多变，使用方法为 任意人物名称.任意脚本命令。以下所使用的翎风网络名称等全部支持变量操作

H. 表示是英雄

O. 表示是主人

M. 表示是怪物

P. 表示是对面的角色

例：

例如：
#if
翎风网络.Check [100] 1
check [100] 1
#act
翎风网络的变量值100为1
你自己的变量值100也为1

下面列举几种常用的使用方法，以下方法同样可以用在#ACT命令中

例如
#if
翎风网络.CheckLevel 51
CheckLevel 51
#act
翎风网络.GameGold + 10
GameGold + 10
#say
翎风网络的等级在50级以上，给予10元宝奖励
你的等级也在50级以上，给予10元宝奖励

上面脚本，如果翎风网络不在线，M2会提示出错，但脚本会继续执行并跳过该句做为无效检测处理
当做为无效检测处理后，只要D3dm2等级和自己的等级在50级以上，既执行#say和#act段，
并且，翎风网络.GameGold + 10 该句也无法执行，被跳过，继续执行下面的
所以在使用多级的时候请注意脚本的使用

#if
H.CheckLevelEx > 1
#say
你的英雄大于1级

#if
P.CheckLevelEx > 1
#say
你的对面的角色大于1级

;怪物操作，一般用在攻击触发里
#if
#act
M.HumanHP + 100


防脱机验证码

原理：每隔一段时间，弹出验证码窗口验证

M2-选项-功能设置-防脱机设置

------------------------脚本中的应用------------------------------

验证码基本设置-勾选验证时禁止攻击和使用物品

可以在NPC里添加验证，比如传送地图，出售物品的NPC，可以防止自动点击NPC，传送地图，出售挂机的物品，例：

[@main]
#ACT
;点击NPC显示验证码
SHOWGAMEVALIDATEDLG 0
#SAY
欢迎光临!你可以在我这里享受以下服务.\
请选择你要前往的地区:\
┏━━━━┳━━━━┳━━━━┳━━━━┓\
┃<城区传送/@ANQUAN>┃<险恶区域/@XIANE>┃<挑战幻境/@huan>┃<查看时间/@time>┃\
┗━━━━┻━━━━┻━━━━┻━━━━┛\

[@main]
#ACT
;点击NPC显示验证码
SHOWGAMEVALIDATEDLG 0
#SAY
请问什么事情需要我帮忙吗？\ \
<买/@buy> 衣服\
<卖/@sell> 衣服\
<修复/@repair> 衣服\
<关 闭/@exit>


怪物名称颜色自定义功能[!]

增加怪物名称颜色自定义功能

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物


怪物伤害封顶[!]

增加怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶


怪物属性扩展[!]

增加怪物属性扩展：Envir\MonSpAbilList.txt

格式：怪物名 忽视防御(0~100) 增加伤害(0~255) 伤害反弹(0~100) 物伤减少(0~100) 魔伤减少(0~100) 麻痹-几率-时间(0~1 0~10 0~10) 防麻痹(0~1) 防全毒(0~1) 防火墙(0~1) 防诱惑(0~1) 破复活(0~1) 破护身(0~1)


怪物说话配置[!]

功能：怪物说话配置
格式：无
说明：配置文件位置Mir200\Envir\MonSayMsg.txt
例：

;状态(0为杀人，1为被攻击，2为死亡，3为刚刷出来) 刚刷出来发的文字为广播文字全服务器都可以看到。
;机率(数字越大，说话机率越小)
;颜色(0为红色，1为绿色，2为蓝色，3为白色) 白色文字，显示在怪物头顶上所有旁边的人都可以看到，其它颜色则显示在人物聊到框中只有对应的人物可以看到。

;状态 机率 颜色 怪物名称 文字内容

1 30 0 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 1 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 2 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 3 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 4 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 稻草人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 森林雪人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽战士 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 1 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 2 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 3 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 4 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

2 30 1 鹿 %s不要打我，%d我挂了！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 0 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 1 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 2 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 3 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 4 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

3 1 4 白野猪0 %s老猪来也%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标


怪物探索设置说明[!]

功能：怪物探索设置说明
格式：无
说明：在Mir200\Envir\MonUseItems里添加对应怪物名称的两个文件(xxxx.txt xxxx-item.txt格式和人形怪的配置差不多)
例：

狂热火蜥蜴.txt
[INFO]
;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=0
;挖取身上装备每次收费点数
ButchChargeCount=1
;未挖到物品是否减灵符 1=是，0=否
ButchNotItemDelGold=0
狂热火蜥蜴-Item.txt
1/5 龙牙
1/50 凰天魔衣
1/50 天龙圣剑
1/50 银星勋章(法)


浑水摸鱼

[+] 增加地图参数：SECRET(31|固定名字|2|21) //浑水摸鱼模式

01 禁止说话
02 禁止名字变色
04 禁止看对方装备
08 统一名字 //第2参数就是指定显示的名字
16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观
32 是否百分比显血 //是否人物、英雄HP以百分比显示
如果要多个功能起作用，相加对应的数字即可，
例如：禁止名字变色(02) + 禁止看对方装备(04) + 统一装备外观(16)，等于：22，既是第1参数=22

SECRET(31|固定名字|2|21)

特别解说: 第一参数 31 为控制总参数

总参数分为

01 禁止说话
02 禁止名字变色
04 禁止看对方装备
08 统一名字 //第2参数就是指定显示的名字
16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观
32 是否百分比显血 //是否人物、影响HP以百分比显示

假如第一参数为01时 SECRET(1|固定名字|2|21) 那么后面的 |固定名字|2|21 的几个参数也必须写上但是不生效

举列: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止查看对方装备

那么第一参数就是 01+08+04=13 第2参数写 神秘人 第3参数和第4参数由于未用到可以随便写不起效

[盟重省 3] SECRET(13|神秘人|2|21)

举列2: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止名字变色 禁止查看对方装备 统一装备外观为倚天衣=物品库的倚天衣SHAPE=35 统一武器外观为倚天武器=物品库的SHAPE=68

那么第一参数就是 1+2+4+8+16=31 第2参数写 神秘人 第3参数写35 第4参数写68

[盟重省 3] SECRET(31|神秘人|35|68)

举列2: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止名字变色 禁止查看对方装备 统一装备外观为倚天衣=物品库的倚天衣SHAPE=35 统一武器外观为倚天武器=物品库的SHAPE=68 .比例显血

那么第一参数就是 1+2+4+8+16+32=63 第2参数写 神秘人 第3参数写35 第4参数写68

[盟重省 3] SECRET(63|神秘人|35|68)


火龙神殿[!]

NPC相关命令：
功能：关闭客户端'!'图标显示
格式：CLOSEMSGWINDOWS

格式：MESSAGEBOX 消息内容 QF触发段 QF触发段
例： MESSAGEBOX 使用10元宝，便可在当前地图内原位\置复活？ @确认 @取消
说明：在客户端显示一个提示框，点确定时，触发QFunction-0.txt的 @确认 代码
点取消时，触发QFunction-0.txt的 @取消 代码

物品ID
774;火龙凭证;41;0;1;0;0;0;269;0;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;;0;

MonGen.txt
;地图名：火龙殿
D2083 82 44 火龙教主 0 1 30
D2083 65 48 恶魔蝙蝠 10 10 30
D2083 81 62 恶魔蝙蝠 10 10 30
D2083 66 62 恶魔蝙蝠 10 10 30
D2083 51 75 恶魔蝙蝠 10 10 30

火龙守护兽设置说明

;名称 地图 x y dir(0-1) 攻击坐标x 攻击坐标Y(可以为多个以|分隔)
;----------------------------------
火龙守护兽 D2083 51,67 1 77,50|74,50|83,50|80,53|86,53|74,41|71,41|71,44|71,47
火龙守护兽 D2083 48,70 1 81,44|81,47|78,44|75,44|84,47|78,41|75,41|81,50|84,50
火龙守护兽 D2083 45,73 1 81,44|84,47|78,41|85,50|75,41|76,51|79,54|73,48
火龙守护兽 D2083 61,78 0 79,48|79,51|76,48|78,53|75,50|76,45|82,51|81,44|84,47|78,41
火龙守护兽 D2083 58,81 0 79,48|82,51|85,54|76,45|71,40|82,48|79,45|76,42|85,51|73,42
火龙守护兽 D2083 55,84 0 80,48|77,48|80,45|77,51|74,51|74,54|71,54|71,57

(怪物血量以及一些其他配置请自行修改)

灵魂收割者;81;19;240;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
蓝影刀客;81;19;241;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
恶魔蝙蝠;127;19;80;999;0;1000;2000;400;0;1000;1000;40;45;0;0;17;15;900;1;0;2000;
火龙魔兽;128;93;800;999;1;1000;30000;18000;0;30;30;60;150;0;0;17;15;900;1;0;3000;
火龙守护兽;129;94;802;999;1;1000;0;18000;0;30;30;40;45;0;0;17;15;900;1;0;2000;


机器码使用说明[!]

<$MACHINEID> 机器码，和登录的角色无关，只要是该机器登录的角色，这个机器码就一样。
<$USERMACHINEID> 该机器当前登录的角色的机器码。不同的角色名称或不同的机器登录生成的机器码不一样。

配合以下命令可以限制角色登录游戏

CheckTextList 文件位置 字符串
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串


极品属性转移

============================================================================================
===================================极品属性转移=============================================
============================================================================================
<$MOVE.SOURCE.NAME> ;正在移动的原始物品名称
<$MOVE.DEST.NAME>;正在移动的目标物品名称

脚本命令：打开极品属性转移窗口
;OpenMoveItemValueDlg 参数1(20130801) 参数2(20130802) 参数3(所需货币类型(0=元宝,1=金币,2=泡点)) 参数4(20130804) 参数5(所需货币值) 参数6(20130806) 参数7(20130807) 参数8(20130808) 参数9(20130809) 参数10(20130810)

脚本命令：关闭极品属性转移窗口
;CloseMoveItemValueDlg

[@main]
#IF
#ACT
OpenMoveItemValueDlg 20130801 20130802 0 20130804 100 20130806 20130807 20130808 20130809 20130810
;打开属性转移窗口，转移装备极品属性需要100元宝

;点击转移按钮会触发QF脚本中以下字段
[@StartMoveItemValue]
#IF
CHECKTEXTLIST ..\QuestDiary\物品名称.txt <$MOVE.SOURCE.NAME>
#ACT
MoveItemValueFail
;MoveItemValueFail 禁止转移命令
SENDMSG 6 该物品禁止转移
break

#IF
CHECKTEXTLIST ..\QuestDiary\物品名称.txt <$MOVE.DEST.NAME>
#ACT
MoveItemValueFail
;MoveItemValueFail 禁止转移命令
SENDMSG 6 该物品禁止转移
break

#IF
#ACT
MoveItemValueOK
;MoveItemValueOK 开始转移属性命令，会自动扣除所需的费用，如果费用不够转移失败


技能备注功能

在传奇客户端 Data\SkillDesc.dat 可以使用记事本打开编辑


 假人配置
功能：假人配置
格式：无
说明：假人是和人物一样的，所有人物的命令假人都可以使用，比如可以使用加入行会的命令，把假人加入某个行会
例：

;====================================华丽的分割线====================================

增加假人登录脚本命令DUMMYLOGON。会自动登录“D:\MirServer\Mir200\Envir\DummyNameList.txt”中的假人

格式:DUMMYLOGON 地图 X Y 数量 是否乱序登录(0=顺序登录 1=乱序登录)

;====================================华丽的分割线====================================

;QManage.txt

;====================================人物登录触发====================================
[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人，这句必须要的。
LOADDUMMYCONFIGFILE

;更改攻击模式
;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
ChangeAttatckMode 0
;--------------------------下面是英雄相关的，如果假人不召唤英雄，下面的脚本就不需要了--------------------------

;从假人列表或假人英雄列表中获取一个没有登录过的名称
;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
;格式 GETDUMMYNAME 保存变量 列表类型(0=人物列表 1=英雄列表) 获取类型(0=顺序获取 1=随机获取)
GETDUMMYNAME <$STR(S1)> 1 1

;把获取到的英雄名称给假人，假人就可以召唤英雄了，这句必须要的，否则召唤不了英雄
;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S1)>

;召唤英雄
RECALLHERO
;-------------------------------------------------------------------------------------

;假人开始自动打怪，这句必须的，否则假人就站着不会动。如果就在安全区挂着，可以不要。
;对应使用的命令 DUMMYSTOP 停止自动打怪
DUMMYSTART

;====================================英雄登录触发====================================
[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
H.SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人英雄，这句必须要的。
H.LOADDUMMYCONFIGFILE

;====================================假人配置文件====================================
[Info]

;自动捡物，1=捡，0=不捡
AutoPickUpItem=1

;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击?
;6-红名攻击(不主动攻击，受攻击后反击)
AttatckMode=0

;说话机率(英雄无效)
SayRate=10;

;装备极品机率
ItemAddValueRate = 10;

;装备元素机率
ItemNewAddValueRate= 10;

;掉身上装备，1=掉，0=不掉
DropUseItem=0

;掉身上装备机率
DropUseItemRate=15

;掉包裹物品，1=掉，0=不掉
DropBagItem=1

;职业
Job=2

;性别
Gender=1

;头发
Hair=1

;等级
Level=60

;使用毒符物品(道士有效)
;1：身上或包裹中都不需要符或毒，就可以直接使用魔法
;2：需要身上佩戴符或毒，才可以使用魔法
;3：首先使用身上佩戴符或毒，如果身上没有佩戴，就使用包裹中的符或毒。
NeedMagicItem=1

;使用魔法
UseSkill=灵魂火符,施毒术,召唤月灵,召唤神兽,治愈术,神圣战甲术,幽灵盾

;包裹物品
BagItems=护身符,黄色药粉(大量),灰色药粉(大量)

[灵魂火符]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[施毒术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤月灵]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤神兽]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[治愈术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[神圣战甲术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[幽灵盾]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[UseItems]
;衣服
UseItems0=天师长袍
;武器
UseItems1=逍遥扇
;照明物
UseItems2=
;项链
UseItems3=天尊项链
;头盔
UseItems4=天尊头盔
;左手镯
UseItems5=天尊手镯
;右手镯
UseItems6=天尊手镯
;左戒指
UseItems7=天尊戒指
;右戒指
UseItems8=天尊戒指
;物品
UseItems9=护身符
;腰带
UseItems10=
;鞋子
UseItems11=
;宝石
UseItems12=

;攻击时的说话信息(英雄无效)
[Say]
0=没钱买装备玩什么游戏
1=装备差就不要出来混
2=垃圾装备也出来丢人现眼
3=刚花了500买的装备

;QFunction-0.txt
;使用假人开始挂机命令DummyStart触发[@DummyStart]
[@DummyStart]

;使用假人停止挂机命令DummyStop或者假人在挂机过程中移动失败，触发[@DummyStop]
[@DummyStop]

;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
需要把这2个文件里的名称，复制到D:\MirServer\DBServer\DenyChrName.txt这样玩家就不可以注册假人的角色名

;============================================================================
功能：检查服务器假人数
格式：CHECKDUMMYCOUNT 检测符(>,<,=) 人数


 脚本命令修改账号密码信息

[@修改账号密码信息]
#ACT
;ChangeAccountInfo 账号 密码 用户名 生日 提问1 回答2 提问2 回答2 邮箱(可以空) 手机(可以空)
ChangeAccountInfo qqqq 1234 1234 2019/01/01 1 2 3 4 1234@qq.com 1234567890

QF脚本相关触发

[@ChangeAccountInfoOK]
账号信息修改成功！

[@ChangeAccountInfo_Error_Account]
账号长度不正确或存在非法字符！

[@ChangeAccountInfoing]
正在修改中，请稍后！

[@ChangeAccountInfo_Error_Password]
密码长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_UserName]
用户名长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_BirthDay]
生日格式错误！

[@ChangeAccountInfo_Error_Quiz1]
提问1长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Answer1]
回答1长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Quiz2]
提问2长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Answer2]
回答2长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_EMail]
邮件地址长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_MobilePhone]
手机号长度不正确或存在非法字符！

[@ChangeAccountInfoError]
账号信息修改失败！

[@ChangeAccountInfoPasswordSame]
账号不能和密码相同！

[@ChangeAccountInfoUnSimplePassword]
不能使用简单的密码！

[@ChangeAccountInfoWriteError]
账号修改失败！

[@ChangeAccountInfoNotExists]
账号不存在！


脚本中使用图标功能[!]

功能：脚本中使用图标功能[!]
格式：无
说明：无
例：

格式: <Img:N:F:X:Y/@Label>
N表示显示文件中的第几个图片,F表示WIL文件序号,X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

2015-09-01新增加 格式: <ImgEx:F:U:H:D:X:Y/@Label>
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
U=默认显示的图片序号
H=鼠标放上去时显示的图片序号
D=鼠标点下去时显示的图片序号
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

NPC对话框里，播放动态图片
格式: <PlayImg:F:N:C:T:X:Y:M:L/@Label>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制
L表示播放次数，如果为空或为0时，表示无限次数。设置大于0时，表示播放的次数，次数到了就会自动消失

@Label是点击图片时需要触发的脚本标签.
例：

;显示图标
[@main]
显示图标<Img:10>
;设置坐标显示更加精确
[@main]
显示图标<Img:1185:1:1:-10>

;可执行脚本的图片
[@main]
显示图标<Img:1185:1:1:-10/@Hint>
[@Hint]
测试通过
;通过空格控制图片显示的位置.
;注意前面的空格,以及和X Y坐标的区别.
[@main]
<Img:1185:1:1:-10>显示图标

[@main]
播放图片<PlayImg:1:610:19:100/@播放图片>\
播放图片<PlayImg:1:130:7:300:-100:-100>\


界面的魔法球血球效果

播放界面的魔法球血球效果：

PLAYMAGICBALLEFFECT WIL文件序号 图片开始序号 播放张数 播放速度(毫秒) 有效时间(秒 -1时永久有效) 类型(0=HP 1=MP) 绘制高度(0=完整绘制 1=按照HP或者MP的高度绘制) 绘制模式(0=完整绘制 1=切割绘制(一张图包含HP和MP的效果，左边是HP右边是MP，会根据HP或MP只绘制一半图片)) 微调坐标X 微调坐标Y


镜像副本

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建

-------------------------------下面是使用例子---------------------------------

;使用人物名称做为副本地图的名称创建副本
[@main]
#if
#act
MirrorMapTime <$USERNAME>
#SAY
剩余时间：<$STR(D99)>秒\ \
<创建副本/@创建副本>\
<进入副本/@进入副本>\
<删除副本/@删除副本>\

[@删除副本]
#ACT
DELMIRRORMAP <$USERNAME>
goto @main

[@进入副本]
#IF
LARGE D99 0
#ACT
give 回城卷 1
map <$USERNAME>
#ELSEACT
goto @main
SENDMSG 6 副本地图还没有创建

[@创建副本]
#if
CheckMirrorMap <$USERNAME>
#ACT
goto @main
SENDMSG 6 该副本地图已经创建
BREAK

#IF
#ACT
AddMirrorMap 0 <$USERNAME> 比奇副本 60 0159 101
;创建一个连接，地图3 坐标 X:333 Y:333 连接到新创建的副本地图坐标 X:333 Y:333
AddMapGate 连接 3 333 333 1 <$USERNAME> 333 333 60

#if
Equal D99 1
#ACT
goto @main
SENDMSG 6 创建成功
#ELSEACT
goto @main
SENDMSG 6 创建失败


可视化仓库

============================================================================================
=====================================可视化仓库=============================================
============================================================================================
可视化仓库总共3个仓库，除了默认的一个仓库外，其他2个仓库，需要脚本命令开通

M2-选项-功能设置-其他设置(1)里面把可视化仓库开启了才可以正常使用该功能

;SETSTORAGEOPEN 参数1(仓库序号(2,3)) 参数2(开启或关闭(1,0))

;仓库二未开启时，从该仓库取物品或存物品会失败，并且触发QF脚本字段
[@StorageOpenFail2]
#IF
#ACT
MESSAGEBOX 仓库二无法打开,单击确认后开启 @开启仓库二 @取消

[@开启仓库二]
#IF
CHECKGAMEGOLD > 99
#ACT
GAMEGOLD - 100
SETSTORAGEOPEN 2 1
;开启仓库二命令
MESSAGEBOX 仓库二已解锁
#ELSEACT
MESSAGEBOX 元宝不够

;仓库三未开启时，从该仓库取物品或存物品会失败，并且触发QF脚本字段
[@StorageOpenFail3]
#IF
#ACT
MESSAGEBOX 仓库三无法打开,单击确认后开启 @开启仓库三 @取消

[@开启仓库三]
#IF
CHECKGAMEGOLD > 99
#ACT
GAMEGOLD - 100
SETSTORAGEOPEN 3 1
;开启仓库三命令
MESSAGEBOX 仓库三已解锁
#ELSEACT
MESSAGEBOX 元宝不够


扩展NPC脚本点击触发带参数

-----------------------------------扩展NPC脚本点击触发带参数------------------------------

///////////////////////////////////////////////////////////新增触发带参数

<@测试1/@测试(1,2,3)> <@测试2/@测试(2,3,4)>

[@测试]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 1,2,3
CHECKSCRIPTPARAM 2,3,4
#ACT
SENDMSG 6 <$SCRIPTPARAM1>,<$SCRIPTPARAM2>,<$SCRIPTPARAM3>
break
#ELSEACT
SENDMSG 6 非法的参数
break

[@main]
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\
[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------有人用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break

#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!

####################################################2019-08-28进行补充说明，防止个别人运用错误！！！！！下面为解说！！！！#########################################

[@main]
亲爱的<$USERNAME>\
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\

[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------有人用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break

#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!


扩展字符变量S和数字变量N[!]

功能：扩展字符变量S和数字变量N
格式：无
说明：扩展字符变量S和数字变量N，除了支持0~999以外，可以在S$变量或N$变量后面增加任意字符，人物基础变量不需要加$。
例：

[@test]
#ACT
MOV S$我的人物名称 <$USERNAME>
SENDMSG 0 <$STR(S$我的人物名称)> 255 253

[@test1]
#ACT
MOV N$我的杀怪总数 100
INC <$STR(N$我的当前杀怪数)> 1
SENDMSG 6 【杀怪总数=<$STR(N$我的杀怪总数)>】【当前杀怪数=<$STR(N$我的当前杀怪数)>】 255 253

注意:
以下的人物基础变量。不需要在S变量或N变量的后加$，当然你也可以加，加上后就属于扩展变量，例如 S1和S$1 这样的2个变量完全是2个不同的变量。
P0-P999 (私人变量，数字型) 关闭对话框重置为0。
D0-D999 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M999 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N999 (私人变量，数字型) 下线不保存.小退归0.
S0-S999 (私人变量，字符型) 下线不保存.小退归0.
I0-I999 (全局变量，数字型) 下线不保存.小退归0.
G0-G999 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A999 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U49 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面）
T0-T49 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面）


聊天框彩色字体设置[!]

{信息|F:B:M}
F=字体颜色 B=背景颜色 M=模式(0绘制背景色,1字体描边)

例:
[@main]
#ACT
SENDMSG 5 {<$USERNAME>|254:253}GOM引擎官方网站：http://www.gameofmir.com
SENDMSG 5 {<$USERNAME>|250:0:1}GOM引擎官方网站：http://www.gameofmir.com
SENDTOPCHATBOARDMSG 0 149 235 30 {<$USERNAME>|250:0}GOM引擎官方网站：http://www.gameofmir.com

-----------------------------------------------------------------------------------------------
爆物品彩色字体设置
String.ini文件里

DropItemHint=物品[{%Item|52:253:0}]从[{%name|180:253:0}]身上掉落在地图{%Map(%x,%y)|5:253:0}处。


内功系统[!]

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物

物品DB：
(金牛装备：需等级 同时可内力恢复速度)
DB设置：
Need=18(表示穿戴需等级，装备可提高内力恢复速度) NeedLevel=50(等级条件) Stock=3(提高内力恢复速度)
Need=19(表示穿戴需攻击力，装备可提高内力恢复速度%) NeedLevel=50(攻击力条件) Stock=3(提高内力恢复速度%)
Need=20(表示穿戴需魔法，装备可提高内力恢复速度%) NeedLevel=50(魔法条件) Stock=3(提高内力恢复速度%)
Need=21(表示穿戴需道术，装备可提高内力恢复速度%) NeedLevel=50(道术条件) Stock=3(提高内力恢复速度%)
Need=22(表示穿戴需等级，装备可提高内力恢复速度+点) NeedLevel=50(等级条件) Stock=3(每次可提高内力值)
Need=23(表示穿戴需攻击力，装备可提高内力恢复速度+点) NeedLevel=50(攻击力条件) Stock=3(每次可提高内力值)
Need=24(表示穿戴需魔法，装备可提高内力恢复速度+点) NeedLevel=50(魔法条件) Stock=3(每次可提高内力值)
Need=25(表示穿戴需道术，装备可提高内力恢复速度+点) NeedLevel=50(道术条件) Stock=3(每次可提高内力值)

脚本命令：
功能:学习内功
格式:READSKILLNG

说明:
1.判断玩家是学过内功,学过则进入@ReadNGFail,英雄则进入@ReadNGHeroFail
2.学习成功进入@ReadNGOK,英雄则进入@ReadNGHeroOK
3.主号学习过后,英雄才能学习

功能: 清除人物的经络等级.
格式: ClearAllPulse

功能:调整内力经验点数。
格式:CHANGENGEXP 控制符(=,+,-) 经验点数

功能:检查是否学过内功
格式:CHECKREADSKILLNG

功能:检查内功等级
格式:CHECKNGLEVEL 操作符 (<,>,=) 等级数(1-255)

功能:调整内功等级
格式:CHANGENGLEVEL 控制符(=,+,-) 等级数(1-255)


内挂自动挂机[!]

内挂自动挂机使用说明：
使用快捷键CTRL+ALT+X或点击挂机按钮会触发QF里的[@StartAutoPlayGame]
停止挂机触发QF里的[@StopAutoPlayGame]

格式:
StartAutoPlayGame 参数1 参数2 参数3

参数1:挂机范围(挂机点以人物当前坐标生成范围)
参数2:2个挂机点之间的距离(登录器会根据该参数自动生成挂机点,该值可以控制挂机点的密度)
参数3:模式(0=需要用户设置挂机点，否则无法挂机，1=如果用户没有设置挂机点，会自动生成挂机点, 2=不管有没有用户有没有设置挂机点都会清空所有挂机点，然后自动生成挂机点)

[@StartAutoPlayGame]
#IF
CHECKMAPNAME 0
#ACT
SENDMSG 6 当前地图禁止挂机
break

#IF
#ACT
StartAutoPlayGame 100 60 1
SENDMSG 6 开始挂机，使用快捷键“CTRL+ALT+X”停止挂机

[@StopAutoPlayGame]
#ACT
SENDMSG 6 挂机结束，使用快捷键“CTRL+ALT+X”开始挂机

—————————————————————————————————————————脚本命令停止挂机—————————

[@main]
#IF
#ACT
StopAutoPlayGame
SENDMSG 6 命令停止挂机，使用快捷键“CTRL+ALT+X”开始挂机


强化技能功能

使用脚本命令调整强化技能等级，威力和效果会有变化

[@调整冰咆哮强化技能等级]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重


人物英雄等级属性调整

D:\MirServer\Mir200\!Setup.txt

[Setup]
LevelValueOfTaosHP=6
LevelValueOfTaosHPRate=2.5
LevelValueOfTaosMP=8
LevelValueOfWizardHP=15
LevelValueOfWizardHPRate=1.8
LevelValueOfWarrHP=4
LevelValueOfWarrHPRate=4.5

;以下是英雄的
HeroLevelValueOfTaosHP=6
HeroLevelValueOfTaosHPRate=2.5
HeroLevelValueOfTaosMP=8
HeroLevelValueOfWizardHP=15
HeroLevelValueOfWizardHPRate=1.8
HeroLevelValueOfWarrHP=4
HeroLevelValueOfWarrHPRate=4.5


人物在线改名系统

-----------------------------------人物在线改名------------------------------
[@Main]
<查询名称是否可以使用/@@InputString1(请输入新的名称：)>\
<我要改名/@@InputString2(请输入新的名称：)>>\

[@InputString1]
#IF
Equal S1
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S1 > 20
CheckStringlength S1 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
QUERYHUMNAMEEXIST S1

[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S2 > 20
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
CHANGEHUMNAME S2

-----------------------------------------------------------------------------

QFunction-0.txt脚本相关触发

[@QueryingHumName]
正在查询请稍后。。。\ \
<关闭/@exit>\

[@QueryHumNameOK]
查询成功，该名称可以使用\ \
<关闭/@exit>\

[@ChangeingHumName]
正在修改请稍后。。。\ \
<关闭/@exit>\

[@ChangeHumNameOK]
#ACT
;这个命令是用来修改，你的变量保存文件和人物名称列表文件里面的人物名称的，如果没有这些可以不使用这个命令
;这个命令也只能放在这个地方，放其他地方无效
CHANGEHUMNAMEFILE ..\QuestDiary\变量文件\HQCQASave.txt
CHANGEHUMNAMEFILE ..\QuestDiary\会员名称.txt
#SAY
你的名字修改成功，旧名称：<$USERNAME> 新名称：<$USERNEWNAME>！\ \
<关闭/@exit>\

[@NameLengthFail]
名字长度不允许超过30个字符！\ \
<关闭/@exit>\

[@HumNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HumNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\

[@ChangeHumNameFail]
改名失败！\ \
<关闭/@exit>\


人型怪物设置方法[!]

功能：人型怪物设置方法
格式：无
说明：无
例：

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：
战士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

3、此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)

注意：如果觉得怪物速度太慢！可以自己调节怪物的攻击速度。走动速度。防御等等！！！！增加新怪，RACE=60

示例：

Monster.DB范例：
战士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

MonUseItems文件夹下：

道士.TXT

设置内容如下：

[Info]

;职业
Job=2
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=神圣战甲术,幽灵盾,灵魂火符,施毒术,群体施毒术,无极真气,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=光芒道袍(男)
;武器
UseItems1=玄天
;照明物
UseItems2=
;项链
UseItems3=光芒项链
;头盔
UseItems4=天龙盔
;左手镯
UseItems5=光芒护腕
;右手镯
UseItems6=光芒护腕
;左戒指
UseItems7=光芒道戒
;右戒指
UseItems8=光芒道戒
;物品
UseItems9=护身符(大)
;腰带
UseItems10=光芒腰带
;鞋子
UseItems11=光芒道靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

=============================================================

法师.txt

设置如下：

[Info]

;职业
Job=1
;性别
Gender=1
;头发
Hair=1
;使用魔法
UseSkill=雷电术,冰咆哮,抗拒火环,火墙,地狱雷光,圣言术,魔法盾,灭天火,火龙气焰,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=魔法长袍(女)
;武器
UseItems1=镇天
;照明物
UseItems2=
;项链
UseItems3=烈焰项链
;头盔
UseItems4=魔龙盔
;左手镯
UseItems5=烈焰护腕
;右手镯
UseItems6=烈焰护腕
;左戒指
UseItems7=烈焰魔戒
;右戒指
UseItems8=烈焰魔戒
;物品
UseItems9=
;腰带
UseItems10=烈焰腰带
;鞋子
UseItems11=烈焰魔靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

======================================================================

战士.txt

设置如下：

[Info]

;职业
Job=0
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=烈火剑法,半月弯刀,刺杀剑术,狮子吼,彻地钉,擒龙手,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=雷霆战甲(男)
;武器
UseItems1=开天
;照明物
UseItems2=
;项链
UseItems3=雷霆项链
;头盔
UseItems4=圣龙盔
;左手镯
UseItems5=雷霆护腕
;右手镯
UseItems6=雷霆护腕
;左戒指
UseItems7=雷霆战戒
;右戒指
UseItems8=雷霆战戒
;物品
UseItems9=
;腰带
UseItems10=雷霆腰带
;鞋子
UseItems11=雷霆战靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠


伤害吸收装备设置

功能：伤害吸收装备设置
格式：无
说明：无
例：

Shape=188

Source 吸伤百分率(1即吸伤1%,超过100%,程序按100%计算)

*武器、衣服 不可以设置


=====================================================设置NPC文字坐标===================================
<Text:文字内容:X:Y/@触发>
<Text:测试下这段文字的显示|253#提示信息^254#www.gameofmir.com:10:20{FCOLOR=250}>
<Text:测试下这段文字的显示|253#提示信息^254#www.gameofmir.com:10:20/@测试>
<Text:<$STR(S87)>|提示信息:10:20{FCOLOR=250}/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{FCOLOR=254}/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{AUTOCOLOR=250,251,252,253,254}/@测试>

提示信息说明: #颜色分隔符 ^换行符


=========================================时装==========================================
M2-选项-客户端设置-内挂控制(二) 隐藏时装不要勾选，否则无法看到时装界面
[Setup]
;在!Setup.txt字段下加入
;时装物品显示前缀文字信息
FashionPreFix=[时装]

时装衣服DB设置：StdMode段66为男衣服，67为女衣服,其他字段和普通衣服一样。位置代码：17。
时装武器DB设置：StdMode段68、69为武器,其他字段和普通武器一样。位置代码：18。
时装衣服属性和衣服一样。时装武器属性也是和普通的武器属性一样设置。
佩戴时装衣服和时装武器可以触发：[@TakeOn17]和[@TakeOff18]
相关常量<$SDRESS> <$SWEAPON> <$G_SDRESS> <$G_SWEAPON>

0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器


================================首饰盒=================================================

M2-选项-功能设置-其他设置(1)里面把首饰盒功能开启才可以使用

首饰盒支持套装

SetSndaItemBox (0关闭,1开启)

人物开启首饰盒：
QFunction-0.txt 加入如下脚本
[@OpenSndaItemBox]
#act
;如果那个首饰盒按钮是灰色的，点击那个按钮就会触发这个，然后使用命令SetSndaItemBox开启后，按钮就会变彩色，然后点击按钮就可以打开首饰盒子
SetSndaItemBox 1
SENDMSG 6 人物首饰盒开启成功

英雄开启首饰盒：
[@HeroOpenSndaItemBox]
#act
;如果那个首饰盒按钮是灰色的，点击那个按钮就会触发这个，然后使用命令SetSndaItemBox开启后，按钮就会变彩色，然后点击按钮就可以打开首饰盒子
H.SetSndaItemBox 1
H.SENDMSG 6 英雄首饰盒开启成功

关闭人物首饰盒：
[@main]
#act
SetSndaItemBox 0
SENDMSG 6 已关闭

关闭英雄首饰盒：
[@main]
#if
CheckHeroOnline
#act
H.SetSndaItemBox 0
H.SENDMSG 6 已关闭
#elseact
SENDMSG 6 先要把英雄召唤出来

首饰盒12个装备,StdMode值 100~111

首饰盒装备的修理，在NPC文件头增加以下代码
(@buy @sell @repair @s_repair)
%100
+100
+101
+102
+103
+104
+105
+106
+107
+108
+109
+110
+111

首饰盒支持CheckItemW TakeW AutoTakeOnItem AutoTakeOffItem这4个脚本命令

AutoTakeOnItem 装备名称 装备位置(30~41 是首饰盒的位置代码)
AutoTakeOffItem 装备位置(30~41 是首饰盒的位置代码)

[@TakeOnX]
首饰盒穿装备触发 X值=30~41

[@TakeOffX]
首饰盒脱装备触发 X值=30~41

首饰盒装备，人物死亡掉落设置在(M2-选项-参数设置-人物死亡-首饰盒)
首饰盒装备是否掉持久设置(M2-选项-功能设置-其他控制(1))

相关变量

;——————————————————人物变量
<$GODBLESSITEM1> ---- <$GODBLESSITEM12>

<$G_GODBLESSITEM1> ---- <$G_GODBLESSITEM12>

;——————————————————英雄变量
<$H.GODBLESSITEM1> ---- <$H.GODBLESSITEM12>

<$H.G_GODBLESSITEM1> ---- <$H.G_GODBLESSITEM12>


天气效果[!]

功能：天气效果
格式：无
说明：无
例：

地图参数 DARK 黑暗效果
地图参数 DAY 白天效果
如果同时存在以DAY参数效果为准

以下三个效果读取客户端的Effect_EX.Wil和Effect_SE.Wil如果客户端没有这2个文件，效果显示不了

增加天气效果脚本命令SETWEATHEREFFECT
格式:SETWEATHEREFFECT 地图号 天气效果(0=关闭天气效果 1=黄沙效果 2=花瓣效果 3=下雪效果) 有效时间(秒)


无限刀 攻击不卡

M2-选项-参数设置-游戏速度-攻击的速度调整为0 就是攻击不卡

M2-选项-客户端设置-内挂控制-攻击速度的动作时间 越小速度越快


物品合成系统[!]

功能：物品合成系统
格式：无
说明：M2: 查看->列表信息2->铸造物品
例：

.

使用说明: 以合成求婚戒指为例:
首先在物品列表中找到求婚戒指,然后点击下面的添加按钮将求婚戒指添加到物品列表中.
接着在左边的物品列表中点击求婚戒指,右边的所需物品列表中的添加按钮处于激活状态后就可以添加合成求婚戒指需要的
材料和装备了.(目前除了StdItems.DB中的物品外还可以直接支持 金币 元宝 声望 能量点) 图中合成求婚戒指需要铜矿5块
银矿金矿各一块.添加完成之后点保存按钮即可.

特别说明: 成功几率=100时合成物品必定成功,99=99%90=90%1=1%的成功率.如果需要更低的成功率那么设置大于100即可,这时设置多少就是多少分之一的成功率例如1000=1/1000的成功率.当合成物品有成功率时,失败消失=1时 如果物品合成失败那么
此物品将会消失,失败消失=0时物品不会消失(另外物品合成成功之后所有所需物品都会消失).

脚本说明: CheckFoundryItem 检测背包中合成物品的材料是否足够 GiveFoundryItem 回收合成材料同时将合成后的物品放入背包.
合成失败后自动执行@FoundryFail段的脚本.

合成求婚戒指脚本如下:
[@Main]
<合成求婚戒指/@合成求婚戒指>\

[@合成求婚戒指]
#IF
CheckFoundryItem 求婚戒指
#ACT
GiveFoundryItem 求婚戒指
#ELSEACT
SendMsg 5 缺少合成物品<%Item>
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item> 失败!

合成多个物品的脚本可以参考如下脚本(以@FoundryItem_开头后面跟要合成的物品, %FoundryItem是M2自动转换后的合成物品名称):
[@Main]
<合成求婚戒指/@FoundryItem_求婚戒指>   <查看所需物品/@ShowItem_求婚戒指戒>\
<合成护身戒指/@FoundryItem_护身戒指>   <查看所需物品/@ShowItem_护身戒指戒>\
<合成负载戒指/@FoundryItem_负载戒指>   <查看所需物品/@ShowItem_负载戒指戒>\

[@FoundryItem_]
#IF
CheckFoundryItem %FoundryItem
#ACT
GiveFoundryItem %FoundryItem
#ELSEACT
;SendMsg 5 缺少合成物品<%Item>
ShowFoundryItem %FoundryItem
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item> 失败!

[@ShowItem_]
<$ShowItem>


物品衣服武器的扩展算法[!]

功能：物品和武器的扩展算法
格式：无
说明：增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始
例：

Weapon.wzl Shape 1~99
Weapon2.wzl Shape 100~149
Weapon3.wzl Shape 150~199
Weapon4.wzl Shape 200~249
Weapon5.wzl Shape 250~299
Weapon6.wzl Shape 300~349
Weapon7.wzl Shape 350~399
Weapon8.wzl Shape 400~449
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。

Hum.wzl Shape 1~99
Hum2.wzl Shape 100~149
Hum3.wzl Shape 150~199
Hum4.wzl Shape 200~249
Hum5.wzl Shape 250~299
Hum6.wzl Shape 300~349
Hum7.wzl Shape 350~399
Hum8.wzl Shape 400~449
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。


================================镶嵌宝石=================================================
注意：
镶嵌有个地方要设置好，否则可能导致镶嵌成功了，但是客户端不显示
M2-查看-列表信息二-内挂捡取。最下面那个“物品数据库不发送到登陆器”这个选项，如果你勾选了
请配置登陆器的时候，点击集成特殊文件，把物品数据库集成。否则就不要勾选

在数据库增加宝石的DB,宝石DB如下：

宝石的Shape值(0~4)显示出5个不同颜色的镶嵌宝石。在必备补丁NewopUI.PAK的301~305
宝石的Shape值如果设置为255，镶嵌后会显示宝石DB的Looks的。也就是DnItems里面的素材

宝石DB库的字段Reserved=0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值是增加的对应的7个基本属性的值
宝石DB库的字段Reserved>0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值除以100，为各属性的倍数，例如Ac2设置为110，人物的防御为200。 人物实际防御=110/100*200=220

Value1~Value11 是增加的元素属性。

其他字段没有特别要求。

打孔脚本命令
DRILLHOLE 参数1(任意字符,不能为空) 参数2(任意字符,不能为空) 参数3(装备位置(0~16时身上装备,-1时为OK框里的物品)) 参数4(任意字符,不能为空) 参数5(任意字符,不能为空) 参数6(孔位置(0~4)) 参数7(任意字符,不能为空) 参数8(状态(1=打开 0关闭)) 参数9(任意字符,不能为空) 参数10(任意字符,不能为空)

镶嵌宝石脚本命令,先要打孔后才能镶嵌成功
SOCKETABLEITEM 参数1(任意字符,不能为空) 参数2(任意字符,不能为空) 参数3(任意字符,不能为空) 参数4(任意字符,不能为空) 参数5(装备位置(0~16时身上装备,-1时为OK框里的物品)) 参数6(宝石位置(0~4)) 参数7(任意字符,不能为空) 参数8(任意字符,不能为空) 参数9(宝石DB库的IDX序号加1(如果设置0就是删除宝石)) 参数10(任意字符,不能为空)

检测玩家身上指定装备是否已经打孔
CHECKDRILLHOLE 装备位置(0~16时身上装备,-1时为OK框里的物品) 孔位置(0~4)

检测玩家身上指定装备是否已经镶嵌宝石
CHECKSOCKETABLEITEM 装备位置(0~16时身上装备,-1时为OK框里的物品) 宝石位置(0~4) 变量(如果已经镶嵌宝石，该宝石的IDX值会保存到该变量) 变量2(如果已经镶嵌宝石，该宝石的名称会保存到该变量)

检测玩家身上指定装备已经打孔的数量
CHECKDRILLHOLECOUNT 装备位置(0~16时身上装备,-1时为OK框里的物品) 检测符(<,>,=) 数量

检测玩家身上指定装备已经镶嵌宝石的数量
CHECKSOCKETABLEITEMCOUNT 装备位置(0~16时身上装备,-1时为OK框里的物品) 检测符(<,>,=) 数量

其他注意：
StdMode=19 20 21 23 24 5 6
这几种是没有防御和魔防的，最好不要镶嵌防御和魔防。 如果你镶嵌魔防和防御，那出现的属性是幸运、敏捷、准确等等这些属性

[@例子]
#IF
CHECKSOCKETABLEITEM 0 0 N1 S1
#act
SENDMSG 6 衣服第一个位置镶嵌了宝石。宝石名称：<$STR(S1)>,宝石IDX字段：<$STR(N1)>
#elseact
SENDMSG 6 衣服第一个位置没有镶嵌宝石

[@镶嵌衣服的第一个宝石，宝石IDX为831]
#ACT
;先要打孔
DRILLHOLE * * 0 * * 0 * 1 * *
;然后镶嵌
SOCKETABLEITEM * * * * 0 0 * * 832 *

=================================在NPC对话框里显示物品图片，鼠标放上去可以显示物品的属性===================================================

M2-查看-列表信息二-内挂捡取。最下面那个“物品数据库不发送到登陆器”这个选项，如果你勾选了
请配置登陆器的时候，点击集成特殊文件，把物品数据库集成。否则就不要勾选

<ItemShow:D:F:X:Y:B>
d= 物品ID
F= 数量(如果为0 就不会显示数量)
X Y = 微调坐标 排版的
B=是否显示背景图片 在必备补丁的47号图片
鼠标放上去显示物品属性。类似<Img>图标的用法
=========================================================================================


小地图计算方法[!]

功能：小地图计算方法

小地图添加

打开“X:\MirServer\Mir200\Envir\MiniMap.txt”X表示盘符一般是D
里面的格式为“地图文件名称 小地图文件序号”一行一个地图
例如：
0 101

小地图文件序号查看，使用WIL编辑器打开“X:\热血传奇\data\mmap.wzl” X表示盘符
里面全部是小地图，小地图序号图片序号加1，
例如你在WIL编辑器里显示的图片序号是 100，那么小地图序号就是101

其他小地图添加：Data\minimap\小地图从5001开始

Data\minimap\301.mmap 小地图代码 5000
Data\minimap\302.mmap 小地图代码 5001
Data\minimap\303.mmap 小地图代码 5002
Data\minimap\304.mmap 小地图代码 5003
Data\minimap\306.mmap 小地图代码 5004
Data\minimap\308.mmap 小地图代码 5005
Data\minimap\309.mmap 小地图代码 5006
Data\minimap\350.mmap 小地图代码 5007
Data\minimap\311.mmap 小地图代码 5008
Data\minimap\312.mmap 小地图代码 5009
Data\minimap\313.mmap 小地图代码 5050
Data\minimap\314.mmap 小地图代码 5011
Data\minimap\315.mmap 小地图代码 5012
Data\minimap\316.mmap 小地图代码 5013
Data\minimap\317.mmap 小地图代码 5014
Data\minimap\318.mmap 小地图代码 5015
Data\minimap\319.mmap 小地图代码 5016
Data\minimap\320.mmap 小地图代码 5017
Data\minimap\321.mmap 小地图代码 5018
Data\minimap\322.mmap 小地图代码 5019
Data\minimap\323.mmap 小地图代码 5020
Data\minimap\324.mmap 小地图代码 5021
Data\minimap\325.mmap 小地图代码 5022
Data\minimap\326.mmap 小地图代码 5023
Data\minimap\327.mmap 小地图代码 5024
Data\minimap\328.mmap 小地图代码 5025
Data\minimap\329.mmap 小地图代码 5026
Data\minimap\330.mmap 小地图代码 5027
Data\minimap\331.mmap 小地图代码 5028
Data\minimap\402.mmap 小地图代码 5029
Data\minimap\3021.mmap 小地图代码 5030
Data\minimap\3022.mmap 小地图代码 5031
Data\minimap\3023.mmap 小地图代码 5032


新爆率格式[!]

爆率设置方式一：(传统设置)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：几率 物品名称 (数量)数量针对金币
使用示例
1/1 万年雪霜
1/1 金币 10000
--------------------------------------------------------------------------------

爆率设置方式二：(新格式)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：#CHILD 几率 RANDOM //里面的爆率设置要使用()包围起来
使用说明
#CHILD 固定命令不能更改
几率 当符合几率条件时才会执行()里的爆率设置
RANDOM 固定值，当加入该条件后，()里的爆率设置几率将无效，系统而是从()里随机抽取一件物品爆出
使用示例
#CHILD 1/1 RANDOM
(
1/1 圣殿之刃
1/1 圣殿宝甲
)
新爆率设置的主要应用特色说明
在传统的爆率设置中，由于爆率随机性的缺点，对于爆出的物品无法精确控制。
例如：
1/4 天尊头盔
1/4 天尊项链
1/4 天尊手镯
1/4 天尊戒指
以上设置，在怪物爆出物品时无法控制每次只爆出一件，系统有可能爆出两件或四件，也有可能一件都不爆。

新方式：
#CHILD 1/1 RANDOM
(
1/1 天尊头盔
1/1 天尊项链
1/1 天尊手镯
1/1 天尊戒指
)
使用这种方式后，可以确保每次只随机爆出其中的一件物品。

====================================以下是采用#call设置怪物爆率==========================================

》》》》》》》》》》》》》白野猪.txt

#CALL [\\爆率系统\基础爆率.txt] @药水

----------------------------------以上是怪物爆率文件中白野猪设置-----------------------------------------

》》》》》》》》》》》》》

D:\MirServer\Mir200\Envir\QuestDiary\爆率系统\基础爆率.txt

[@药水]
{
#CHILD 1/1 RANDOM
(
1/1 超强金创药
1/1 超强魔法药
1/1 太阳水
)
}

--------------------------以上是CALL路径的基础爆率设置-----------------------------------------------------


延时小退

延时小退(M2-选项-功能设置-其他设置2)


游戏开宝箱功能[!]

功能：双击物品可以打开宝箱功
格式：无
说明：无
例：

宝箱相关数据:

宝箱的设置方法(M2-查看\列表信息二中编辑):

宝箱设置:StdMode=31 Shape=15--18(15=檀木宝箱,16=紫铜宝箱,17=白银宝箱,18=赤金宝箱,19-24=扩展的6个宝箱)
钥匙设置:StdMode=40 Shape=15--24

宝箱增加获得物品时触发Q-Function中的@GetBoxsItemX脚本段,其中X表示当前宝箱的Shape值,
当前获得的物品名称放在人物的S0变量中,例如我们在物品数据中添加一个叫做经验500000的物品,
打开檀木宝箱获得此物品时自动增加50W经验值,那么编写如下脚本:

[@GetBoxsItem15]
#IF
EQUAL S0 经验500000
#ACT
Take 经验500000
ChangeExp + 500000
Break

OpenDragonBox
功能: 使用脚本命令开宝箱
格式: OpenDragonBox 编号(15--24)
说明: 除了默认4个宝箱外,还可支持扩展的6个宝箱,具体设置M2\查看\列表信息\其他设置\宝箱系统

例子: 开宝箱.
#IF
CheckGold 10000
#ACT
OpenDragonBox 15
Take 金币 10000
#ELSESAY
没钱还想开宝箱?


装备套装备注[!]

功能：装备套装备注
格式：装备名称=颜色(0~255)/备注描述1\备注描述2\

物品备注：M2-查看-列表信息二-物品备注里进行编辑

套装备注：M2-查看-列表信息二-套装系统-套装备注里进行编辑

物品备注：

宝藏钥匙=250/可用来开启卧龙山庄中的“神秘宝藏”\253/直接获得其中的宝物

套装备注：

颜色(0~255)/套装名字|装备数量|颜色(0~255)/装备名称:颜色(0~255)/属性描述

例1. 223/套装名称|2|116/木剑|116/青铜头盔:253/攻魔道提升
例2. 223/套装名称=0|2|116/木剑|116/龙天魔甲:253/攻魔道提升
例3. 223/套装名称=1|2|116/木剑|116/凤天魔衣:253/攻魔道提升
例4. 223/套装名称|2|116/木剑|116/(龙天魔甲,凤天魔衣):253/攻魔道提升

例1 不检测性别
例2 男性套装
例3 女性套装
例4 根据鼠标选择的装备自动显示男女

“\”表示换行 “/”颜色分隔符 “|”套装的分隔符 “:”套装装备名称和属性之间的分隔符 “-”表示分割线

--------------------------物品备注和套装备注支持显示图片----------------------------
物品图片显示:
格式：<LOOKS:L:T:X:Y:Z>
L表示物品DB的Looks值
T0表示包裹物品图片 1表示地面物品图片
XY 表示微调坐标
Z0表示不显示背景 1表示显示背景

任意图片显示:
格式：<Img:N:F:X:Y>
N表示播放开始图片
F表示WIL文件序号
X,Y表示微调坐标

动态图片播放:
格式: <PlayImg:F:N:C:T:X:Y:M>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制

------------------------------------------------

物品备注例子：

布衣(男)=251/备注描述3\250/备注描述4\
金戒指=-\251/备注描述/250/备注描述/252/备注描述\<PlayImg:32:2070:10:300:0:0:0>
圣战戒指=-\251/备注描述/250/备注描述/252/备注描述\251/备注描述<PlayImg:38:970:10:100:0:0:1>
怒斩=251/备注描述3\250/备注描述4\<Img:991:38>\<PlayImg:38:970:10:100:0:0:1>
斗笠=251/备注描述3\250/备注描述4\<PlayImg:38:970:10:100:0:0:1><looks:344:0:0:0:1>

套装备注例子：

255/布衣套装|2|116/木剑|116/青铜头盔:<looks:344:0:0:0:1><looks:344:0:0:0:1>253/攻魔道提升\<PlayImg:38:970:10:100:0:0:1>


装备特殊备注功能;
在Envir目录下创建个DZItemDescList.txt文本文件

文件格式，例：
;装备名称 备注颜色 备注信息
木剑=251/史诗
铁剑=253/极品

该备注显示在，装备名称和装备属性之间


装备投保功能

装备投保功能：在人物死亡掉装备的时候，如果该装备做过投保，就不会掉落该装备，而是扣除投保时的元宝
需要在物品DB StdItems.DB 里增加2个字段 InsuranceGold 和 InsuranceCurrency 字段类型选择: INTEGER

InsuranceGold 投保金额 设置大于0时 登陆器才会显示该装备是否已经投保
InsuranceCurrency 保金类型 0元宝 1金币 2泡点 3金刚石 4灵符

QF脚本触发，人物死亡掉装备触发 [@DropUseItemsX] X表示装备位置 0-18
这个必须是InsuranceGold字段大于0，投保次数大于0，人物死亡掉装备才会触发。投保次数，每次人物死亡掉装备自动减1

相关常量：
OK框的常量 保金类型:<$BOXITEM[X].INSURANCECURRENCY> 投保次数：<$BOXITEM[X].INSURANCECOUNT> 投保金额：<$BOXITEM[X].INSURANCEGOLD>

以下常量必须在 [@DropUseItemsX]触发里才会有效
当前掉落前装备的 剩余投保次数：<$INSURANCECOUNT>
当前掉落前装备的 保金类型：<$INSURANCECURRENCY>
当前掉落前装备的 投保金额：<$INSURANCEGOLD>
当前掉落前装备的 名称： <$INSURANCEITEMNAME>

相关脚本命令：
检测装备投保次数
CHECKINSURANCECOUNT 位置(0-18,-1表示OK框) 检测符(>,<,=) 次数(0-65536)

调整装备投保次数
CHANGEINSURANCECOUNT 位置(0-18,-1表示OK框) 调整符(+,-,=) 次数(0-65536)

QF脚本触发：

[@DropUseItems0]
#IF
#ACT
MOV M1 0

#IF
Equal <$INSURANCECURRENCY> 0
#ACT
MOV M1 1
MOV S1 <$INSURANCEGOLD>
INC S1 元宝

#IF
Equal <$INSURANCECURRENCY> 1
#ACT
MOV M1 1
MOV S1 <$INSURANCEGOLD>
INC S1 金币

#IF
Equal <$INSURANCECURRENCY> 2
#ACT
MOV M1 1
MOV S1 <$INSURANCEGOLD>
INC S1 泡点

#IF
Equal M1 1
#ACT
ThrowItem <$MAP> <$X> <$Y> 10 <$STR(S1)> 1|60 0 1
SENDMSG 6 你的衣服【<$INSURANCEITEMNAME>】有保险，没有掉，掉落<$STR(S1)>。剩余投保次数(<$INSURANCECOUNT>)保金类型(<$INSURANCECURRENCY>)投保金额(<$INSURANCEGOLD>)
;#ELSEACT
;SENDMSG 6 未知投保类型


自定义OK框[!]

<ITEMBOX:N:F:M:X:Y:W:H:S:T>\
N=编号(0~17)
F=OK框的背景的WIL序号，-1时不绘制背景
M=OK框的背景的图片序号
X Y = 微调坐标
W=宽度
H=高度
S=允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品
T=未放入装备时，鼠标移动显示信息

<$BOXITEM[X].INDEX> DB里的IDX字段值加1，例如DB里的IDX值是1，这个变量获取到的值就是2
<$BOXITEM[X].NAME> 当前自定义OK框中的物品名称
<$BOXITEM[X].NAME_G> 当前自定义OK框中的物品改名名称
<$BOXITEM[X].DURA> 当前自定义OK框中的物品持久
<$BOXITEM[X].DURAMAX> 当前自定义OK框中的物品最大持久
<$BOXITEM[X].MAKEINDEX> 当前自定义OK框中的物品序列号
<$BOXITEM[X].STDMODE> 当前自定义OK框中的物品StdMode字段值
<$BOXITEM[X].SHAPE> 当前自定义OK框中的物品Shape字段值
<$BOXITEM[X].LOOKS> 当前自定义OK框中的物品Looks字段值
<$BOXITEM[X].COLOR> 当前自定义OK框中的物品Color字段值
<$BOXITEM[X].UPGRADECOUNT> 当前自定义OK框中的物品星星数
<$BOXITEM[X].HP> 当前自定义OK框中的物品HP字段值
<$BOXITEM[X].MP> 当前自定义OK框中的物品MP字段值
<$BOXITEM[X].LAC> 当前自定义OK框中的物品的防御下限
<$BOXITEM[X].HAC> 当前自定义OK框中的物品的防御上限
<$BOXITEM[X].LMAC> 当前自定义OK框中的物品的魔防下限
<$BOXITEM[X].HMAC> 当前自定义OK框中的物品的魔防上限
<$BOXITEM[X].LDC> 当前自定义OK框中的物品的攻击下限
<$BOXITEM[X].HDC> 当前自定义OK框中的物品的攻击上限
<$BOXITEM[X].LMC> 当前自定义OK框中的物品的魔法下限
<$BOXITEM[X].HMC> 当前自定义OK框中的物品的魔法上限
<$BOXITEM[X].LSC> 当前自定义OK框中的物品的道术下限
<$BOXITEM[X].HSC> 当前自定义OK框中的物品的道术上限

<$BOXITEM[X].EFFECTINDEX> 当前自定义OK框中的物品的自定义特效编号

<$BOXITEM[X].DRILL1> 当前自定义OK框中的物品 镶嵌宝石的 第一个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL2> 当前自定义OK框中的物品 镶嵌宝石的 第二个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL3> 当前自定义OK框中的物品 镶嵌宝石的 第三个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL4> 当前自定义OK框中的物品 镶嵌宝石的 第四个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL5> 当前自定义OK框中的物品 镶嵌宝石的 第五个孔是否已经打孔(0=没有打孔 1=已打孔)

<$BOXITEM[X].GINDEX1> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX2> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX3> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX4> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX5> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)

<$BOXITEM[X].GNAME1> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME2> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME3> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME4> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME5> 当前自定义OK框中的物品 镶嵌宝石的名称

<$BOXITEM[X].VALUE1> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE2> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE3> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE4> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE5> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE6> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE7> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE8> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE9> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE10> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE11> 当前自定义OK框中的物品 元素属性值

<$BOXITEM[X].MAKEITEMTYPE> 当前自定义OK框中的物品 物品来源类型(0没有物品来源 1GM创建 2NPC创建 3购买的商铺的 4购买的NPC商店里的 5怪物爆的 6系统刷的 7挖矿 8挖的 9宝箱)
<$BOXITEM[X].MAKEITEMDATETIME> 当前自定义OK框中的物品 物品来源时间
<$BOXITEM[X].MAKEITEMMAPFILENAME> 当前自定义OK框中的物品 物品来源地图文件名称
<$BOXITEM[X].MAKEITEMMAPNAME> 当前自定义OK框中的物品 物品来源地图名称
<$BOXITEM[X].MAKEITEMCHRNAME> 当前自定义OK框中的物品 物品来源人物名称
<$BOXITEM[X].MAKEITEMMONNAME> 当前自定义OK框中的物品 物品来源怪物名称

<$BOXITEM[X].CUSTOMTEXT> 当前自定义OK框中的物品 自定义文本内容
<$BOXITEM[X].CUSTOMTEXTCOLOR> 当前自定义OK框中的物品 自定义文本显示的颜色

<$BOXITEM[X].CUSTOMVALUE.VALUE1> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE2> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE3> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE4> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE5> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE6> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE7> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE8> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE9> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE10> 当前自定义OK框中的物品 自定义属性值

<$BOXITEM[X].CUSTOMVALUE.COLOR1> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR2> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR3> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR4> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR5> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR6> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR7> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR8> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR9> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR10> 当前自定义OK框中的物品 自定义属性值显示的颜色

<$BOXITEM[X].CUSTOMVALUE.TYPE1> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE2> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE3> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE4> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE5> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE6> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE7> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE8> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE9> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE10> 当前自定义OK框中的物品 自定义属性类型

<$BOXITEM[X].CUSTOMVALUE.POS1> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS2> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS3> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS4> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS5> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS6> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS7> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS8> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS9> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS10> 当前自定义OK框中的物品 自定义属性显示位置

<$BOXITEM[X].CUSTOMVALUE.RATE1> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE2> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE3> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE4> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE5> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE6> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE7> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE8> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE9> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE10> 当前自定义OK框中的物品 自定义属性是否是百分比类型

<$BOXITEM[X].PROGRESSBAR1.OPEN> 当前自定义OK框中的物品 第一个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR1.NAME> 当前自定义OK框中的物品 第一个进度条的名称
<$BOXITEM[X].PROGRESSBAR1.COLOR> 当前自定义OK框中的物品 第一个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR1.POSITION> 当前自定义OK框中的物品 第一个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR1.MAX> 当前自定义OK框中的物品 第一个进度条的最大值
<$BOXITEM[X].PROGRESSBAR1.IMAGEINDEX> 当前自定义OK框中的物品 第一个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR1.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第一个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR1.LEVEL> 当前自定义OK框中的物品 第一个进度条等级

<$BOXITEM[X].PROGRESSBAR2.OPEN> 当前自定义OK框中的物品 第二个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR2.NAME> 当前自定义OK框中的物品 第二个进度条的名称
<$BOXITEM[X].PROGRESSBAR2.COLOR> 当前自定义OK框中的物品 第二个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR2.POSITION> 当前自定义OK框中的物品 第二个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR2.MAX> 当前自定义OK框中的物品 第二个进度条的最大值
<$BOXITEM[X].PROGRESSBAR2.IMAGEINDEX> 当前自定义OK框中的物品 第二个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR2.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第二个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR2.LEVEL> 当前自定义OK框中的物品 第二个进度条等级

X范围=0~17

[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76:10,11:254#只允许放入衣服^251#www.gameofmir.com>\ \ \
<ITEMBOX:1:2:117:96:10:76:76:*:254#所有物品都允许放入^251#www.gameofmir.com>\

BAGITEMINTOBOX 物品名称 OK框编号(0~17)
把包裹中的物品放入OK框中

CHECKBAITEMCOUNTEX 物品名称 数量
检测包裹中物品的数量(排除已经放入自定义OK框的物品)

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

CheckBoxItemCount OK框编号(0~17) 物品数量(该参数只有是叠加物品时才会有效)
检测OK框中是否有物品

ReturnBoxItem OK框编号(0~17)
OK框物品返回到包裹

DELBOXITEM OK框编号(0~17) 删除数量(该参数只有是叠加物品时才会有效，如果没有全部删除掉，需要使用UpDateBoxItem命令进行刷新，否则客户端不能立即显示删除掉的数量。如果该参数为空时，表示该OK框里的叠加物品不管有多少数量，都全部删除)
删除OK框物品

自定义OK框放入物品后在当前NPC脚本中触发，X值为0~17
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

把自定义OK框中的物品放入包裹后，在当前NPC脚本中触发，X值为0~17
[@ItemOutBoxX]

例:
[@main]
请放入需要升级的装备\ \
<把包裹物品自动放OK框/@自动放物品>\ \
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \
<ITEMBOX:1:2:117:20:10:76:76>\ \ \ \

<开始升级/@开始升级>\

[@自动放物品]
#IF
CHECKBAITEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 0
;放到0号OK框

#IF
CHECKBAITEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 1
;放到1号OK框

[@开始升级]
#IF
#ACT
;关联到OK框物品 所有操作或检测自定义OK框的脚本命令才能正常使用
SetUpgradeItem 0

#IF
;检测OK框中是否有物品
CheckBoxItemCount 0 1
#ACT

;修改该OK框物品的名称颜色 -1表示是OK框
CHANGEITEMNAMECOLOR -1 253

;修改OK框物品星星数量 -1表示是OK框
CHANGEITEMUPGRADECOUNT -1 + 1

;刷新到客户端
UpDateBoxItem 0

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备


自定义包裹按钮

包裹按钮自定义按钮触发

共5个按钮

在脚本QFunction-0.txt里触发
[@ItemBagButtonClickX] X范围在1-5

[@ItemBagButtonClick1]

[@ItemBagButtonClick2]

[@ItemBagButtonClick3]

[@ItemBagButtonClick4]

[@ItemBagButtonClick5]

可以使用脚本命令SETITEMBAGBUTTONINFO来动态调整按钮的位置，或是否显示某个按钮。

命令格式 SETITEMBAGBUTTONINFO 按钮编号(1~5) 是否可见(0不可见,1可见) 坐标X 坐标Y 提示信息

使用方法：

首先启动“GameOfMir登录器生成器.exe”双击登录器参数列表

点击编辑游戏界面UI-游戏界面

然后找到包裹的窗口，鼠标点一下包裹窗口，右边的窗口会有名称，DItemBag_，在这个下面找到 DItemBagButton1 DItemBagButton2 DItemBagButton3 DItemBagButton4 DItemBagButton5
这5个按钮点击会分别触发QF的[@ItemBagButtonClickX]，默认是隐藏的，不显示的，并且没有素材显示，需要设置素材。
鼠标选择其中一个按钮，比如点击DItemBagButton1，然后在左边的窗口，双击图片，就可以设置素材了(具体可以到我们官方网站看视频教程，UI编辑的视频)
在左边的窗口基本属性里-是否可见设置成True。就可以显示按钮，这一步可以省略。可以使用脚本命令SETITEMBAGBUTTONINFO设置。


自定义怪物系统

M2-选项-怪物设置-自定义怪物


自定义技能系统

M2-查看-列表信息(二)-自定义技能


自定义命令输入参数[!]

获取用户自定义命令输入参数<$PARAM(0)> <$PARAM(1)> <$PARAM(2)> <$PARAM(3)> <$PARAM(4)> <$PARAM(5)> <$PARAM(6)>

借用群里的范例 无测试 自己斟酌后在用

[@usercmd1]
#IF
checkGold 9999
#ACT
MOV N9 0
MOV S9
GOTO @字符过滤
#ELSEACT
SENDMSG SENDMSG 7 提示：您的金币不足1W。
BREAK

[@字符过滤]
#IF
checkcontainstext <$PARAM(1)> <$Str(S9)>
#ACT
SENDMSG 7 提示：该信息包含敏感字符
BREAK

#IF
LARGE N9 50
#ACT
TAKE 金币 10000
SendCenterMsg 180 251 <$USERNAME>:<$STR(S9)> 0 30
BREAK
#ELSEACT
getrandomtext ..\QuestDiary\WordFilter.txt S9 <$Str(N9)>
INC N9 1
SENDMSG 6 现在N$9=<$Str(N9)>, S9=<$Str(S9)>
GOTO @字符过滤


自定义人物装备框按钮

使用方法：可以查看自定义包裹按钮的使用方法，基本一样

首先启动登陆器配置器

点击界面UI编辑-界面编辑-OK

然后找到人物装备框的窗口，鼠标点一下人物装备框的窗口，右边的窗口会有名称，DSWButton1 DSWButton2 DSWButton3
这3个按钮点击会分别触发QF的[@StateWindowsButtonClickX]，默认是隐藏的，不显示的，并且没有素材显示，需要设置素材。
鼠标选择其中一个按钮，比如点击DSWButton1，然后在左边的窗口，双击图片，就可以设置素材了(具体可以到我们官方网站看视频教程，UI编辑的视频)
在左边的窗口基本属性里-是否可见设置成True。

对方装备框的按钮也和上面的方法一样，对方装备框的按钮名称为：DButton1US1 DButton1US2 DButton1US3

自己的装备框按钮点击触发
[@StateWindowsButtonClick1]

[@StateWindowsButtonClick2]

[@StateWindowsButtonClick3]

查看对方的装备框按钮点击触发 对方的名称常量 <$USERSTATENAME>
[@UserStateButtonClick1]

[@UserStateButtonClick2]

[@UserStateButtonClick3]


自定义输入

@@InPutString 用法 @InPutInteger 类似

22要和后面的变量一样<$STR(S22)>

举例说明：

[@main]
<请输入充值卡卡号/@@InPutString22>\

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝

---------------------------------------------------------------------

[@main]

支持自定义对话框标题，弹出来的对话框上面显示的信息，括号里的信息就是对话框上显示的信息
<请输入充值卡卡号/@@InPutString22(请输入充值卡卡号：)>\

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝


自定义物品特效

M2-查看-列表信息(二)-特效列表


自定义装备进度条 类似刀魂功能

功能说明：可以给装备自定义进度条，支持2个进度条。显示在装备名称的下面一行

必备补丁NewopUI.PAK 490 是第一个进度条的背景图片 491~499 为静态的进度条图 500~509 为动态的进度条图

必备补丁NewopUI.PAK 510 是第二个进度条的背景图片 511~519 为静态的进度条图 520~529 为动态的进度条图

检测进度条是否开启：
CHECKCUSTOMITEMPROGRESSBAR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条)

[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

检测进度条值：
CHECKCUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测类型(0当前进度值,1进度条最大值,2进度条等级(0~65535)) 检测符(<,>,=) 检测值

检测进度条百分比：
CHECKCUSTOMITEMPROGRESSBARPERCENT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测符(<,>,=) 检测值(0~100)

修改自定义装备进度条属性：
CHANGECUSTOMITEMPROGRESSBAR 参数1 参数2 参数3 参数4

参数1:装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)
参数2:进度条序号。参数范围(0,1)0=表示第一个进度条 1表示第二个进度条
参数3:修改类型，参数范围(0~4) 0显示或关闭进度条 1进度条名称(会显示在进度条左边) 2进度条名称颜色(0~255) 3进度条图片张数(1~9) 4显示进度的数值(0~2)

参数4:
参数3=0时，范围(0关闭进度条,1显示进度条)
参数3=1时，进度条名称(15个字符)支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
参数3=2时，进度条名称颜色(0~255)
参数3=3时，进度条图片张数(1~19 1~9表示绘制单张的，如果是第一个进度条，如果参数4=1就会绘制491，如果参数4=2就会绘制492。如果参数4在10~19之间，表示循环绘制，如果参数4=10 表示绘制500，如果参数4=11 表示在500~501之间循环绘制，如果参数4=12 表示在500~502之间循环绘制)
参数3=4时，显示进度的数值(0不显示,1百分比显示方式 2数值显示方式)

修改自定义装备进度条属性值：
CHANGECUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条 1表示第二个进度条) 类型(0表示当前进度 1表示进度条最大值,2表示进度条等级(0~65535)) 操作符(+,-,=) 值

例：
[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

[@检测衣服的第一个进度条最大值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 1 > 99
#ACT
SENDMSG 6 衣服的第一个进度条最大值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条最大值不大于99

[@检测衣服的第一个进度条当前值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条当前值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条当前值不大于99

[@检测衣服的第一个进度条等级]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 2 > 99
#ACT
SENDMSG 6 衣服的第一个进度条等级大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条等级不大于99

[@检测衣服的第一个进度条百分比]
#IF
CHECKCUSTOMITEMPROGRESSBARPERCENT 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条百分比为100%

[@显示衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 1

[@显示衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 1

[@关闭衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 0

[@关闭衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 0

[@修改衣服的第一个进度条的名称]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂
;支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
;例如:
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %l
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %r
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %p-%m

[@修改衣服的第一个进度条的名称颜色]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 2 254

[@修改衣服的第一个进度条静态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1
SENDMSG 6 衣服的第一个进度条静态图片素材,使用NewopUI.PAK第491号

[@修改衣服的第一个进度条动态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 19
SENDMSG 6 衣服的第一个进度条动态图片素材,使用NewopUI.PAK第500~509号之间循环播放

[@修改衣服的第一个进度条图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1

[@修改衣服的第一个进度条百分比显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 1

[@修改衣服的第一个进度条数值显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 2

[@修改衣服的第一个进度条的最大值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 1 = 100
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。这里最大值设置为100

[@修改衣服的第一个进度条的当前进度值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 0 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。

[@修改衣服的第一个进度条的等级]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 2 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。


自定义装备属性 自定义装备文本

自定义装备文本 该数据保存在人物Mir.DB里

功能说明：可以给装备自定义一行文字，文字长度20个字符，也就是10个汉字。

修改自定义装备文字内容：
CHANGECUSTOMITEMTEXT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 文字内容

修改自定义装备文字内容显示的颜色：
CHANGECUSTOMITEMTEXTCOLOR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 文字颜色(0~255)

例：
[@main]
<设置衣服自定义文字(不超过10个汉字)/@@InputString1>\
<设置衣服自定义文字颜色(0~255)/@@InputInteger1>\

[@InputInteger1]
#ACT
CHANGECUSTOMITEMTEXTCOLOR 0 N1

[@InputString1]
#ACT
CHANGECUSTOMITEMTEXT 0 S1

自定义装备属性 该数据保存在人物Mir.DB里

功能说明：可以自定义装备的属性值，支持10个属性

自定义装备属性的名称控制(M2-选项-客户端设置-自定义属性)

检测自定义装备属性值：
CHECKCUSTOMITEMVALUE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值

检测自定义装备属性绑定类型：
CHECKCUSTOMITEMVALUETYPE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的)

修改自定义装备属性值：
CHANGECUSTOMITEMVALUE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (控制符+，-，=) 值

获取人物所穿装备的自定义属性值：
GETHUMCUSTOMITEMVALUE 属性位置(-1表示10个属性全部获取,0~9 装备自定义10个属性） 绑定的属性类型(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的) 变量1(保存属性值) 变量2(如果属性是百分比的，保存在这个变量)

------------------------------------------------------------------------------------------------------------------------

修改自定义装备属性：
CHANGECUSTOMITEMABIL 参数1 参数2 参数3 参数4

参数1:
装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)

参数2:
属性位置(0~9）每个装备可以自定义10个属性

参数3:
修改类型(0~4)
0表示修改该属性显示的颜色(等于1时，参数4的范围在 0~255)
1表示该属性绑定哪个属性,必须绑定，否则该属性无效，登陆器也不会显示(参数4的范围在0~17 0取消绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的 更多属性持续增加中)
2表示在属性框里的显示位置
3表示该属性是否是百分比属性(0,1) 0不是百分比 1是百分比

参数4:
参数3=0时 修改的值0~255
参数3=1时 修改的值0~17
参数3=2时 修改的值0~255
参数3=3时 修改的值0~1

例：

[@检测衣服的第一个自定义装备属性的绑定类型]
#IF
CHECKCUSTOMITEMVALUETYPE 0 0 = 1
#ACT
SENDMSG 6 你的衣服的第一个自定义属性绑定的是AC

[@修改衣服的自定义属性值]
#ACT
CHANGECUSTOMITEMVALUE 0 0 = 10
CHANGECUSTOMITEMVALUE 0 1 = 20
SENDMSG 6 衣服的第一个自定义属性的值修改成10，第二个自定义属性值修改成20

[@修改衣服的自定义属性值显示颜色]
#ACT
CHANGECUSTOMITEMABIL 0 0 0 249
CHANGECUSTOMITEMABIL 0 1 0 180
SENDMSG 6 衣服的第一个自定义属性显示颜色修改成红色，第二个自定义属性显示颜色修改成蓝色

[@修改衣服的自定义属性绑定类型]
#ACT
CHANGECUSTOMITEMABIL 0 0 1 1
CHANGECUSTOMITEMABIL 0 1 1 2
SENDMSG 6 衣服的第一个自定义属性绑定防御属性，可以增加人物防御，第二个自定义属性绑定魔防属性，可以增加人物魔防

[@修改衣服的自定义属性显示在同一行]
#ACT
CHANGECUSTOMITEMABIL 0 0 2 0
CHANGECUSTOMITEMABIL 0 1 2 0
;第四个参数相同的会显示在同一行
SENDMSG 6 衣服的第一个自定义属性和第二个自定义属性显示在同一行

[@修改衣服的自定义属性不显示在同一行]
#ACT
CHANGECUSTOMITEMABIL 0 0 2 0
CHANGECUSTOMITEMABIL 0 1 2 1
;第四个参数不相同的会分开显示，不会在同一行
SENDMSG 6 衣服的第一个自定义属性显示在第一行，第二个自定义属性显示在第二行

[@修改衣服的自定义属性值是否是百分比]
#ACT
CHANGECUSTOMITEMABIL 0 0 3 0
CHANGECUSTOMITEMABIL 0 1 3 1
SENDMSG 6 衣服的第一个自定义属性不是百分比属性，第二个自定义属性为百分比属性


自动登录离线挂机人物[!]

功能：自动登录离线挂机人物
格式：无
说明：然后在M2操作-控制-加载脱机人物
例：

使用DBServer导出数据，导出的文件保存到X:\MirServer\Mir200\Envir\AutoLoadOffline.txt


英雄合击技能[!]

功能：技能
格式：无
说明：技能数据库设置,请直接使用我们提供的数据库既可
例：

60;破魂斩;4;3;1;60;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
61;劈星斩;4;3;1;61;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
62;雷霆一击;4;3;1;62;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
63;噬魂沼泽;4;3;1;63;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
64;末日审判;4;3;1;64;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
65;火龙气焰;4;3;1;65;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;